INTERGRAPH® |SOGEN I-Configure

Insider Blog Webinar

ISOGEN I|-Configure Webinar

The archived I-Configure webinar talks about the ISOGEN I-Configure graphic user interface
(GUI) features and the differences and similarities between I-Configure and Project Manager
(PipMan) applications. You learn how to setup, navigate, and edit Styles and how to
successfully migrate projects from ISOGEN Project Manager.

I-Configure Overview

ISOGEN is the industry de-facto standard supplied by all major plant design software vendors and
produces automatic isometrics from design systems. I-Configure uses ISOGEN to create Isometric
drawings and reports. I-Configure can create and manage Isometric Directories, Projects and Styles used
by Project Manager. The following is included with I-Configure:

=  Support for Projects and Styles created in Project Manager (PipMan).

= Object -based user interface used to configure ISOGEN control files.

=  Explorer windows to navigate the available Projects and Styles.

= Four Wizards to quickly set-up and configure Styles.

= XML files for storage of Project and Style information.

= Built-In drawing previewer for on-the-fly modifications to Styles.

= Password protection to avoid unauthorized alterations to Projects and Styles.
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[-Configure Installation

Click on the following links to install each product. Please read though the tips listed in this document
before creating or modifying any I-Configure Isometric Directory, Project or Style.

1. Install CADWorx Plant Professional 2010 September 4th build or later.
http://www.coade.com/uploads/cadworx/2010/

2. Install I-Configure
C:\CADWorx 2010\Plant\Isogen\I-Configure\setup.exe

3. Install Autodesk Volo View
http://images.autodesk.com/adsk/files/vv3setup.exe

4. Run Isogen Bat File
C:\CADWorx 2010\Plant\Support\iISOGEN.BAT

[-Configure Tips

The following is information on problems you may encounter. This information is to help you keep these
errors from occurring. If you have additional problems with the installation of I-Configure please email
support is at cadworx@intergraph.com.

Compatibility for CADWorx and CAESAR

I-Configure software will work with both CADWorx and CAESAR. To have this function a user will need to
install software on separate computers. One computer will need to run CADWorx + I-Configure and
second computer will need to run CAESAR + I-Configure.

One computer with CADWorx and CAESAR

To avoid issues, if you are using CADWorx and CAESAR on the same computer then you should install
CADWorx Plant Professional first and install CAESAR last. The following errors are displayed because
CAESAR was installed first. These errors will be resolved if CAESAR is uninstalled and I-Configure for
CADWorx is repaired. Remember to install CAESAR last or install it on a separate computer.

These errors also appear if you do not run the ISOGEN.BAT file. Refer to the following document for
more information: C:\CADWorx 2010\Plant\Isogen\l-Configure\ ReadMe.htm

ProjectManager x|

@ Error in I-Configure Form Load ( Prepare project manager )
Error creating ProjectManager
Error looking up version of sysconfig
Veersion of sysconfig does not match ProjectManager
Sysconfig Major.Minor = 3.0
ProjectManager Major.Minor = 2.9
Terminating application.
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i
'E Run-time error -2147199359 (80045681}
L

Error creating ProjectManager

Error lnoking up version of sysconfig

Version of sysconfig does not match ProjectManager
Sysconfig Major.Minor = 3.0

ProjectManager Major.Minor = 2.9

0K

The Drawing Setup Wizard
Object Enabler Error

The Drawing Setup Wizard inside I-Configure will have problems if the backing sheet (AutoCAD template)
contains custom ObjectARX objects. The following messages are displayed if custom objects are present.
To avoid having issues you should purge the title block of custom objects. You may also download the
correct object enabler from the Autodesk website.

waming x|

This drawing contains custom ObjectdFxB objects created by a different application. To enhance the
wiewing, orbit, and snap functionality of Yolo Yiew for this drawing, determing what application created
the ohjects and then download and install the appropriate ohject enabler. Until the carrect object
enableris installed, only proxy gragphics will be shown. Object enablers from Autodesk are available
far free from the following location:

hittp: autodesk comfenablers

[ Do not show this dialog again.

Alias Drawing Set Up Wizard [5__<|

’T Run-time error ‘13"
L

Type mismatch

Autodesk AutoCAD File Format Error

The Autodesk Volo View inside I-Configure can only preview an AutoCAD R12 DXF, AutoCAD 2000
DWG and AutoCAD 2004 DWG file. The Drawing Setup Wizard will NOT preview an AutoCAD 2007
DWG, AutoCAD 2010 DWG or anything later. The following error messages will appear if you are not
using the correct file format. If you get this error then update your drawing file type and restart I-
Configure. The Drawing Setup Wizard will not display correctly until you restart:
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Alias Drawing Set Up Wizard B|

'E Run-time error -21474 18101 (800100063
L3

Automation error
The client {caller) cannot marshal the parameter data - low memaory, ete,

Alias Drawing Set Up Wizard B‘

'E RUn-time error '440°;
-

Automaticon error

i m Wizard : : | . . , . B@

. i . '
UATERAL LT — FABRCATION
= | me . L3

D30 VA&l

UATENAL BT = EETEN

| &

Create an Isometric Directory
New Isometric Directory

Select File>New>Isometric Directory or, click the New Isometric Directory icon on the Toolbar. Once the
Isometric Directory is created, it is then necessary to create a Project.
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Browse For Folder @
Specify path to Isometric Direckory
@' Deskkop A
D Py Documents
= d My Computer
j}, 314 Floppey (A
e 05 (00 —
i DVD Drive (D)
i DYWD-RAM Drive (E:)
¥ Officejet Pro 8500 A909a (129,135,32.12
Contraol Panel
_ 2 B cotralPane "
< | =
[ Make Mew Falder ] [ oK | [ Cancel

Existing Isometric Directory

If you already have an Isometric Directory select the Project List Files by going to File>Connect to
Isometric Directory>ProjectList.xml. This helps users easily connect and disconnect to existing Isometric

directories on the network.

Create a Project and Styles

Select File>New>Project or, click the Create New Project icon on the Toolbar. On the Create New Project
dialogue, enter a name for the Project in the New Project Name field. Select the Styles required by
checking or un-checking those available. Click OK and the Project and Styles are created.

| Create New Project r5_<|

Current lzometnic Directany |

Mew Project Hame

Arvailable Styles

Optional [ ] FinalErection Final-Erection
Optional [ ] FinalFab Final-Fab
Optional Firnalweld-Box | Finalweld-Box

Type | |Mame | Template -

Application | Diefault j

Optiomal [ ] Overview Overview J

Optional |:| Spoal Spool

Optional Sypsham System

[ [P R | Q [ ) P Mla..l. ﬂ
k. | Cancel |
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Template Location

To help users get started with I-Configure, a set of template Styles are supplied. The templates can be
found at: C:\Program Files\Common Files\Alias\I-Configure\Templates. The Templates are stored in XML.

& Templates E‘ E| |Z|
File Edit ‘iew Faworites  Tools  Help ':,*'
@Back = 0 (T D search [ Folders [~

Address |ﬁ C:\Program FilesiCommon Files!alias)I-Configure) Templates| b | Go

. Mame -~ Size  Type Date Modified

File and Folder Tasks 2] Blank, xml 10KE %ML Docurment 7}3/2003 5:30 PM
2] Check. xml Z0KE =ML Daocurment 112212005 4:43 PM

Other Places = Check-Tablet.:ml 17KE %ML Document 2/3/2006 11:14 AM
= Final.=ml Z3IKE =ML Docurment 5/a/2005 6:39 PM

) || Final-Basic. xml 23KE =ML Docurment 11/22/2005 4:43 PM

HEG | Final-Cut-List.xml ZIKE XML Document 11/22{2005 4:53 PM

Templates || Final-Erection. xml 22KE =ML Document 11/22/2005 7:18 PM

File Folder 2| Final-Fab.xml ZZEE =ML Daocurment 112212005 4:53 PM

Date Modified: Friday, March 2] Final-Weld-Boo, ol 23KB =ML Docurment 11/22/2005 5:00 PM

03, 2010, 12:42 PM =] Full-Iso, om 24KB =ML Document 11/22/2005 7145 PM
= IsImport.zml 19KE =ML Document 5/9/2005 6:40 PM
= MTC, =l 12KE %ML Docurnent 3M6/2006 12:16 PM
2| MTO-Tablet, xml 19KE =ML Document 2/3/2006 11:13 AM
= Crverview. =ml 18KE =ML Document 10/24)2006 12:58 PM
= SGImport, xl 19KE %ML Document 5/9r2005 6:40 PM
12 Spool.=ml 23KB =ML Docurment 10/24)2006 12:57 PM
=] StyleEura.xml 1ZKE %ML Document 5/9/200% 6:41 PM
=] Skylels,xml 1ZKE =ML Document 5/9/200% 6:41 PM
|2 Syskermn, xml 18 KE %ML Document 10/24)2006 12:57 PM

XML Files Store Data

Each Style folder contains a Style.xml file, which is used to store the Style configuration data, e.g. Final-
Weld-Basic.xml. Before an application (CADWorx) can use a Style, it must first be exported.

Export Styles for use in CADWorx

In CADWorx users will see the following message displayed when attempting an ISOGENOUT:

ISOGEN Style Files Missing...

If this is an I-Configure projeck, werify that the style has been exported for use by ISOGER,
Direckary:
CAISOGEMOUT _T-COMFIG InkergraphiFinal-wWeld-Box ISOGEMN,. FLS

i ] Could not locate ISOGEN skyle files in the directory selected,

To resolve this issue, inside I-Configure you will need to Export the Style. Performing an export will
prepare the I-Configure Style for use inside CADWorx Plant Professional. To export a Style go to
File>Export, or click the Export Style icon on the toolbar.
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r

|-Configure

FIEW Edit ‘Wizards Tools Help
3 {
tew. I e+ | - [
Conneck to Isomeatric Direckary Property
Disconneck Isometric Directary Mame
) Path
Enable Project E xportBehaviour
Save StyleState
Expoark StyleType
|zoDirectaryManme

Exit Projecti ame

Ovwerview Eantafrite

Spoal CanExport

Syztem

Blank,

The export of the Style results in the creation of the various ISOGEN control files. The following files are
created when the export is performed: *.opl, *.pos, *.alt, *.fls etc. These control files are based on the
settings made for the Style in I-Configure. The following is an example of what the style directory contains
before the export:

& Final-Weld-Box EEX
-

File Edit Wiew Favorites Tools  Help

Qack ~ &) - F P seach [ Folders | -

Address |I':“} CAISOGEEMOUT_I-COMNFIG\Inkerar aph Final-wWeld-Box V| Go
: Mame Size | Twpe =~ [rate Modified
File and Folder Tasks [C)0rawings File Falder 4142010 5:12 PM
[CiMessages File Folder 4/14/20105:10 PM
Other Places [CiReports File Folder 4/14/2010 5:10 PM

22x17-WELD-BOX. dwg 303 KB AukaCAD Drawing 8/25/2004 2:45 PM

; Z3KE  RML Document 112212005 5;00 P
Details

Final-Weld-Box.xml
AML Document

Date Modified: Tuesday,
Movember 22, 2005, 5:00 PM

Size: 22,9 KB

After the export the following Control Files are created. Remember to do an export when you make a
change to your Style in I-Configure. If you don't export you will not see your Isometric drawing update.
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® Final-Weld-Box

B9[(=1[ES

File Edit Wiew Favortes Tools  Help ",'.
(JBack ~ T D search [ Folders [
Address |2 CAISOGENOUT_I-CONFIGHIntergraphiFinal-weld-Box v B Go
. | Name Size | Type = Date Modified
File and Folder Tasks ¥ 1 Siorawings File Falder 4142010 5:12 PM
|CiMessages File Folder 4/14/20105:10 PM
oOther Places [CReports File Folder 4/14/2010 5:10 PM
[ 2221 7-WELD-BOX. dwig 303KE  AutoCAD Drawing 5/25/2004 Z:45 PM
m— E ZIKE WML Document 11{22}2005 5:00 PM
o B 1KE ISOGENM ALT Fils 4/14/2010 5:15 PM
9 items selectad, 5 ZKE ISOGEM DDF File 4/14{2010 5:15 PM
5 = 1KB ISOGEM MLD Fil 4/14/2010 5:15 PM
Total File Size: 32.4 KB ¥ 4KE ISOGEM OPL File 4/14/2010 5:15 PM
LalFi ZEE ISOGEM POS Fils 4/14/2010 5:15 PM
B Fin 1KE ISOGEM WOF File 4/14/2010 5:15 PM
Ei-gen.fis ZKE ISOGEM FLS File 4/14{2010 5:15 PM
E¥lisogen.fis ZKB  ISOGEM FLS Fils 4/14/2010 515 PM

ISOGEN Control Files

DO NOT modify the following files in notepad. All modifications need to be done inside I-Configure.
Changes are saved to the XML style and updates are reflected in CADWorx by an Export in I-Configure.
To preview your control files go to: Tools>View Isogen Controls. Double click any of the files shown in the
dialogue and this opens for review in a text editor:

—| ISOGEN control files @

OPTION-SWITCHES-LONE>
IRAWING-DEFINITION
ALTERNAT IVE-TEXT

C:L ISOGENOUT I-CONFIG, Intergr aph"-, Final -Tleld-Fox' Final -W=14d-B
C:% IZ0EENOUT_I-CONFIG, Intaergraph! Final -Weld-Feox) Final -Wel 4-F
[N ISDG-EHEI'LTT_I—EDHPIG-"-. Intergr aph"-, Final -Teld-FEox' Final -W=14d-E
PO IT IOMED-TEXT C:% IZ0EENOUT_I-CONFIG, Intaergraph! Final -Weld-Feox) Final -Wel 4-F
MATERIAL-LIST-DEFIMIT ION C:% IZ0GENOUT_I-CONFIG, Intergraph! Final -Weld-Eeox), Final -Wel d-E
WELD INZ-DEFINITION C:% IZ0EENOUT_I-CONFIG, Intaergraph! Final -Weld-Feox) Final -Wel 4-F

C

C

C

C

C

MEZSZAGE s ISDG-EHEI'LTT_I—EDHPIG-"-. Inte:g'raph"-. Final-Tlel d—Box"-,!-Iessa.ges"-. Fin
PLOTFILE-FEETIX :% ISOGEROUT _I-CONFIGY Intergraph! Final -Weld-Eox' Drawings!
TELD-ZUTMMARY- APPEND s ISDG-EHEI'LTT_I—EDHPIG-"-. Intergr aph"-, Final-Te=14-E ox"-,Repo::ts"-, TIELD
DRAWING-TRAME 1% ISOGENOUT _I-CONFIG, Intergrapht Final -Weld-Fox\ AZ-WELD-E0X.
FONT- INFORMAT ION-TILE :"-.P::og'::a.m Fila=' Commor Filae=% 2l ia=\Data Pont=td. £fif

ok |

The following editor is displayed if you double click on any of the Control Files. This is for review only. Do
not make modifications in this text editor.
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Z] C:WISOGENOUT_I-CONFiG\Intergraph... [= |[B]fX]

File

Bwitch  Switch Switch ~

Nunher Setting Purpose T

1 2278

z a

3 o =

4 za

5 o

& 11z

7 o

g o

3 100

10 10

11 188

1z 10

13 50

14 &

15 o

18 o

17 1

18 1

13 a

z0 a

z1 a

zz 150150

z3 1200

z4 o

25 20 v
Options File

Options File: Search

Options File: The switches previously located in the Options Editor inside Project Manager are now easily
accessed by doing a search I-Configure. If you are looking for a known Options Switch then go-to, Tools>
Find. In this Find dialog you can query by a text string, an options switch number or a subject. You may
double click on the list shown and that item will be displayed in the Properties Panel.

| Find

Specify zearch

" Property |

f« Option Switch{zg  Position

" File Section | :‘

Drrawing. Contrals. PipeLineS plitting

Drrawing. Contrals. Pipet ameStyle
Drrawing. Controlz. ContinuationG raphice0ns pooll oz

© 2010 Intergraph Corporation

Page 9 of 11



ISOGEN I-Configure Webinar

The following is the Properties Panel:

|-Configure

Fle Edt ‘Wizards Tools Help

19|22l | B < 2 e+ | [ 12
(=14l Intergraph A fFroperty Walue
3 Check ~ |AppendStandardE st Falze
3| Final-Basic AutoDrawingSplt Tiue
=] Final-Cuit-List D ateFormat Biiitish
3| Final-Erection DateSource Systern
Diaghosticlevel Lot
Disconnectionkessage False
CirawingSize az
FouDigity ear Tiue
HeatTracingDptions
| ghiorel zerS plitPoints Falze
= = CASOGENTUTY [Pipman) o |lsometicType Combined
— JlsoScale 0
Overview Detail | IMindngleQffset 05
= I@ Style : Finalweld-Baox MoOfDrawings 1]
-] AlternativeTests NorthDirection Top Left
= Z] Dirawing DrawingsPerfile One per file
@] Cantent OutputFormat AutoCAD DixF [DF]
-l m OvenwriteFPlotFile False
] g] Drefinitions PipeLineScale i}
~[] Dimensions FipeLineSplitting i]
Z] Format FipeLineSpltinglnTube Mormal
] Layers Fipel amelnContieszages |
(]| DynamicFonts PipeNameStle
53 @] Welds PlotFileLenagth 128.937
[+ Q} DrawingFrame FlotFilePath FSTYLE$\Drawings's
[+ ﬁ M aterialList FostS criptSize A3
+- [ WeldList Printed0utputPagelen 1]
H CutList S etPipelineDisconnected True
[+ % Supplementary ShowlSOGENYer Falze
StartDrawingMumber o
Supportddditions\w eight
TrugScale False
Lnits tetric / Inch Bores
LlselD1TppeEsts False
W eightOutput MNane
Linearw/eightD enominator Mone
ContinuationGraphics0nS poollsos Falze
CAISOGEMOUT_I- | Intergraph Finalweld-Box | Empty

Webinar Audience Questions

Q: Is there a way to download this webinar?

Q: Where exactly does one find the insider blog?

Q: Is there an electronic version of the user guide available to download of I-Configure

Q: During the webinar changed the border to textl by cancelling when you were showing us.

Q: What's the use of the isoin/isoout command in the CADWorx as we have ISOGEN module of the
CADWorx to generate the isometrics?

© 2010 Intergraph Corporation
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Q: How can we show an equipment model in isometric drawing generated through ISOGEN?

A: Equipment can only be referenced in ISOGEN. When a CADWorx nozzle connects to an Equipment
nozzle the name is automatically referenced in ISOGEN. If any additional detail is need a detail sketch
can be used by using the CADWorx Isogen Data Dialog (ICEDIT).

Q: Can you export an I-Configure setup to project manager?

A: Going back to Project Manager is not as seamless as going to I-Configure. You will need to create the
Control Files and reconfigure the Project inside Project Manager. To recreate the Control Files you will
need to Export the Style inside I-Configure.

Q: Why do you have to export after you do a save in I-configure?

A:The Export command creates the Control Files that CADWorx needs to run a Isometric Drawing.

Q: Is the I-Configure install only available from the CADWorx 2010 CD-ROM or is there an install
available as a separate download?

A: I-Configure is available for CADWorx Plant Professional 2010 Users. Make sure you install September
4™ puild or later.

Q: If Cll and CADWorx Plant Pro is installed in the same system so which version of IConfigure to
be used?

A: 1-Configure will work for CADWorx or CAESAR on the same machine. I-Configure works with one
software per machine.

Q: I missed how to get I-Configure or where it might be located on install.

A: The install is located in the following location: C:ACADWorx 2010\Plant\Isogen\l-Configure\setup.exe

Q: Does I-Configure need to be installed on all workstations or just for the user that is
configuring?

A: I-Configure can be installed on one computer. Inside the CADWorx Configuration file you can control
what ISOGEN Styles users should use.
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