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 Introduction

Welcome to ETABS!

ETABS is a special purpose computer program developed spe-
cifically for building systems. The concept of special purpose
programs for building type structures was introduced more than
35 years ago [R. W. Clough, et al., 1963]. However, the need for
special purpose programs, such as ETABS, has never been more
evident as Structural Engineers put nonlinear static and dynamic
analysis into practice and use the greater computer power avail-
able today to create larger, more complex analytical models.

With ETABS, creating and modifying a model, executing the
analysis, design, and optimizing the design are all done through a
single interface that is completely integrated within Microsoft
Windows. Graphical displays of the results, including real-time
display of time-history displacements, are easily produced.
Printed output, to a printer or to a file, for selected elements or
for all elements, is also easily produced. This program provides a
quantum leap forward in the way models are created, modified,
analyzed and designed.
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The analytical capabilities of ETABS are just as powerful, repre-
senting the latest research in numerical techniques and solution
algorithms.

ETABS  is available in two versions, ETABS Plus and ETABS
Nonlinear. Both versions are comprised of the following mod-
ules integrated into and controlled by a single Windows-based
graphical user interface:

 Drafting module for model generation.

 Seismic and wind load generation module.

 Gravity load distribution module for the distribution of vertical
loads to columns and beams when plate bending floor ele-
ments are not provided as a part of the floor system.

 Output display and report generation module.

 Steel frame design module (column, beam and brace).

 Concrete frame design module (column and beam).

 Composite beam design module.

 Shear wall design module.

ETABS Plus also includes the finite-element-based linear static
and dynamic analysis module, while ETABS Nonlinear in-
cludes the finite-element-based nonlinear static and dynamic
analysis module.

Highlights of the ETABS Programs
The ETABS programs were the first to take into account the
unique properties inherent in a mathematical model of a build-
ing, allowing a computer representation to be constructed in the
same fashion as a real building:  floor by floor, story by story.
The terminology used in this program is column, beam, brace,
and wall, rather than nodes and finite elements.

Note:

Both ETABS
Plus and
ETABS Nonlin-
ear have no
limits set on the
allowable num-
ber of joints
and/or equa-
tions.

Note:

All of the
ETABS modules
are integrated
into a single,
user-friendly
graphical user
interface.
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For buildings, ETABS provides automation and specialized op-
tions to make the process of model creation, analysis, and design
fast and convenient. ETABS provides tools for laying out floor
framing, columns, frames and walls, in either concrete or steel,
as well as techniques for quickly generating gravity and lateral
loads. Seismic and wind loads are generated automatically ac-
cording to the requirements of the selected building code. All of
these modeling and analysis options are completely integrated
with a wide range of steel and concrete design features.

While easy to use, ETABS offers sophisticated analytical and
design capabilities. Full dynamic analysis is provided, including
nonlinear time-history capabilities for seismic base isolation and
viscous dampers, along with static nonlinear pushover features.
You can use powerful features to select and optimize vertical
framing members as well as identify key elements for lateral
drift control during the design cycle. In addition, the transfer of
data between analysis and design programs is eliminated because
ETABS accomplishes both tasks. This design integration, com-
bined with the ETABS capability to generate CAD output files,
means that production drawings can be generated faster and with
greater accuracy.

Organization of This Manual
This manual begins with general information about how to use
the program. This is followed by descriptions of the menu items,
interspersed with insights with respect to using the program to
maximum advantage.

 Chapter 1 describes the components of the graphical user in-
terface

 Chapters 2 and 3 provide a general overview of ETABS and
information helpful to creating models, respectively.

 Chapters 4 through 14 describe the program's primary menu
items and their associated submenus, forms, and command
buttons. In most cases, chapter headings that correspond to the
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menu items include the word command. Chapter headings that
do not include the word command are submenus, forms, com-
mand buttons, or general topics provided for informational
purposes.

Getting Help

Help with the program is available "on-line" within in the pro-
gram's Help menu, or through phone, fax and e-mail technical
support.

On-Line Help
The program includes extensive on-line help that is available any
time the graphical user interface is open. Access on-line help by
clicking on the Help menu and selecting Search For Help
On…, or by pressing the F1 function key on the keyboard. If you
press the F1 key while a form is open, context-sensitive help re-
lated to that form will be provided.

On-line help is focused to assist you with the graphic interface. It
can guide you through the process of entering data into the vari-
ous forms used in the program. On-line help also makes the
meaning of the data you enter into the forms more clear. For ex-
ample, if you want to find out how to assign gravity load to a
beam in the graphic interface, you can find the answer in the on-
line help. If you want to find out what a scale factor used in a re-
sponse spectrum load case actually scales, you can find it in the
on-line help.

The on-line help also includes a Documentation library. The
Documentation is provided in *.pdf format that can be viewed or
printed using Adobe Acrobat Reader.

Shortcut:

From within the
graphical user
interface, acti-
vate on-line
help at any time
by pressing the
F1 function key
on the key-
board.
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Phone, Fax and E-Mail Technical Support
Free technical support is available from CSI via phone, fax or e-
mail for 90 days after the software has been purchased. Techni-
cal support is available after 90 days if you have a current main-
tenance agreement with CSI. Maintenance agreements also pro-
vide for free or reduced cost upgrades to the program. Please call
CSI to inquire about a maintenance agreement.

Technical support is provided only according to the terms of the
Software License Agreement that comes with the program.

If you are experiencing problems with the software, please:

 Consult the documentation and other printed information in-
cluded with your product.

 Check the on-line help.

 If you cannot find a solution, contact us as described herein.

Telephone Support
Standard phone support is available in the United States, from
CSI support engineers, via a toll call between 8:30 A.M. and
5:00 P.M., Pacific Time, Monday through Friday, excluding
holidays.

You can contact CSI’s office via phone at (510) 845-2177. When
you call, please, if possible, be at your computer and have your
program manuals at hand.

7

Note:

Our phone
number is
(510) 845-217
Phone, Fax and E-Mail Technical Support Introduction - 5

Note that sometimes when you call us with a technical support
question, we will request that you e-mail us your input file ad-
dressed to support@csiberkeley.com so that we can better under-
stand and determine the cause of your problem.

mailto:support@csiberkeley.com
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Fax Support
You can fax CSI twenty-four hours a day at (510) 845-4096.
Structural engineers are available to review and respond to your
fax between 8:30 A.M. and 5:00 P.M., Pacific Time, Monday
through Friday, excluding traditional U.S. holidays.

When you send a fax with questions about your model, please
include a picture of your model if possible. This is often a con-6
Note:

Our fax
number is
(510) 845-409
ntroduction - 6 Phone, Fax and E-Mail Technical Support

siderable help to us in understanding your question.

When you send a fax, please be certain that you have provided
us with your fax number so that we have somewhere to send our
response. If your fax number is in your company letterhead in a
relatively small font, it is helpful if you repeat the fax number in
the body of your fax because often the small fax numbers in
company letterheads are difficult to read or completely indeci-
pherable when we receive the fax.

Note that it is generally more efficient for you to email your en-
tire model (*.edb and/or *.$et and/or *.e2k input file) than to fax
us pictures or descriptions of it.

E-Mail Support
You can e-mail CSI for technical support twenty-four hours a
day at support@csiberkeley.com. Structural engineers are avail-
able to review and respond to your e-mail between 8:30 A.M.
and 4:30 P.M., Pacific Time, Monday through Friday, excluding
traditional U.S. holidays.

If your question is about a specific model, it is always helpful
and sometimes necessary for you to include your model (*.edb
and/or *.$et and/or *.e2k input file) as an attachment to your e-
mail. When you send us a model as part of a technical support
question, we will not reveal that model to anyone outside the
company or use it in any advertising without first requesting and
obtaining your permission in writing. Note that many of the
models used in our advertising are actual models created by our
customers.

Note:

Our e-mail ad-
dress for tech-
nical support is
support@
csiberkeley.com
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Help Us to Provide You Technical Support
CSI takes pride in providing timely and effective technical sup-
port. If you send us a one word e-mail that says “Help,” we will
most certainly respond, perhaps with an equally wordy response
such as “How?”, but more likely with a response that asks you to
provide us with some or all of the information listed in the
bulleted items that follow. We recognize that much of the time
engineers requesting help are under tight deadline pressure and
thus would like to receive answers to their questions as quickly
as possible. In light of that, whenever you contact us with a tech-
nical support question, if you provide us with all or even some of
the following information, as appropriate to your circumstances,
we will be able to serve you better and faster.

 The name and the version number of the program you are us-
ing.

 If you are faxing us a description of your model, include a
picture of the model, if possible. E-mailing the entire model
(*.edb and/or *.$et and/or *.e2k input file) is generally more
efficient than faxing a description of it.

 A description of what problem occurred and what you were
doing when the problem occurred.

 The exact wording of any error messages that appeared on
your screen.

 Your computer configuration (make and model, processor, op-
erating system, hard disk size and RAM size).

 Your name, your company’s name and how we may contact
you (e.g., your phone number or e-mail address).

Shortcut:

For faster and
more effective
service when
requesting
technical sup-
port, please
provide us with
as much of the
information
listed in adja-
cent bulleted
items as possi-
ble.
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Chapter 1

The Graphical User Interface

The graphical user interface is shown in Figure 1-1. Several im-
portant features of the interface are shown. Those features in-
clude the main window, main title bar, display title bar, menu
bar, toolbars, display windows, status bar, mouse pointer posi-
tion coordinates and the current units. Each of these items is de-
scribed in this chapter.

Features

Main Window
The main window contains the entire graphical user interface.
This window may be moved, resized, maximized, minimized, or
closed using standard Windows operations. Refer to Windows
help, available on the Start menu, for additional information on
those items.
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1
Main Title Bar

Toolbars

Window 
Separator

Menu Bar

Display Title Bar
(Active Window)

Display Title Bar
(Inactive Window)

Status Bar
Current 

Units

Coordinate System used
for Mouse Coordinates

Mouse Pointer
Position
Coordinates

Plan View Drawing and
Assignments Options
(Similar Stories Feature)
Figure 1-1:
The ETABS graphical user interface
 - 2 Features

Main Title Bar
The main title bar, located at the top of the main window, in-
cludes the program name and the model name. The main title bar
is highlighted when the program is in use. You can move the
main window by left clicking in the main title bar and holding
down the mouse button as you drag the window around your
screen.

Menu Bar
The menu bar contains all of the program's menus, which acti-
vate available operations. To access a menu, left click on it. This
will activate a drop-down menu of commands. The individual
commands are described in other chapters of this manual.

Notice that some of the commands on the menus have three dots
after them, ..., and others have a filled triangular section adjacent
to the right-hand margin of the menu, . The three dots indicate
that a form will appear when you click on the menu item. The
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1triangle indicates that a submenu will appear when you click on
the menu item. The commands with neither of these items exe-
cute as soon as you click them. Those commands have no sub-
menus or forms.

Toolbars and Buttons
Toolbars are comprised of buttons. For example  and 

are familiar buttons for open and save commands. Virtually all
menu commands have a corresponding toolbar button.

Toolbar buttons provide "one-click" access to commonly used
commands, particularly file, viewing, and analysis output display
options. To execute an operation/command, left click on the ap-
propriate toolbar button.

Holding the mouse pointer over a toolbar button for a few sec-
onds without clicking or holding down any mouse buttons will
display a short description of the button's function in a small text
box.

The toolbars are customizable, which means you can show or
hide toolbar buttons as well as develop a toolbar of buttons that
fit your specific needs. To customize a toolbar, right click on an
existing toolbar. A form will appear that lists the toolbar buttons
and provides you with the options you need to select or deselect
buttons as well as "drag and drop" buttons to your custom-
designed toolbar.

Display Windows
A display window show the geometry of the model and may also
include display of properties, loading and analysis or design re-
sults. Up to four windows may display at any one time.

Each display window may have its own view orientation, type of
display, and display options. For example, the undeformed shape
could be displayed in one window, applied loads in another, an
animated deformed shape in a third, and design stress ratios in

Tip:

Some menu
items can be
accessed using
shortcut key-
strokes, which
are displayed
on the drop-
down menu.

Tip:

Hold your
mouse pointer
over a toolbar
button for a few
seconds and a
pop up box
describing the
button’s func-
tion will ap-
pear.
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1 the fourth window. Alternatively, the windows may provide four
different views of the undeformed shape or other type of display,
such as a plan view, two elevations, and a three-dimensional per-
spective view.

Only one display window is active at a time. Viewing and dis-
playing actions only affect the active window. To make a display
window active, click on its display title bar or anywhere within
the window. A highlighted title bar indicates that the display
window is active.

After performing certain operations, the display window may
Shortcut:

Clicking the
“X” in the up-
per right-hand
corner will
close the dis-
play window.
 - 4 Features

need to be redrawn. Normally the program automatically re-
draws the window. However, on some occasions, such as after
you have deleted some elements, the display may need to be
manually refreshed. Use the View menu > Refresh Window
command, or the Refresh Window  toolbar icon to redraw

the window.

Close a display window by left clicking the “X” button at the top
of the window to the right of the display title bar. At least one
display window must be open or the program will close.

Display Title Bar
The display title bar is located at the top of the display window.
The display title bar is highlighted when the associated display
window is active. The text in the display title bar typically in-
cludes the type and location of the view in the associated display
window. If you are displaying results on the model, the title bar
typically also tells you which results are being displayed.

Status Bar
The status bar is located at the bottom of the main window. Text
describing the current status of the program is displayed on the
left side of the status bar. Most of the time this text provides in-
formation about the type and location of the view in the active
display window. When you are displaying results on screen, the
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1text may tell you what you can do. For example, when the de-
formed shape is displayed, the status bar text prompts you to
"Right click on any point for displacement values."

The right side of the status bar includes the mouse pointer posi-
tion coordinates and the associated coordinate system, a drop-
down box with options for plan view drawing and assignment
options for the similar stories feature (only available when you
are in plan view), and a drop-down box for setting the current
units.

When you are displaying deformed shapes, including mode
shapes, animation controls are also available on the right-hand
side of the status bar. When displaying element forces for a par-
ticular load case, arrow buttons are available on the right-hand
side of the status bar that allow you to step the display forward
and backward through the available load cases.

Mouse Pointer Position Coordinates
The mouse pointer position coordinates are displayed on the
right-hand side of the status bar. The coordinates displayed here
are always in the coordinate system specified in the drop-down
box on the right-hand side of the status bar just to the left of the
current units drop-down box. Note that the Edit menu > Edit
Grid Data command can be used to define an alternate coordi-
nate system.

A window does not need to be active for the mouse pointer posi-
tion coordinates to be displayed. It is only necessary that the
mouse pointer be over the window.

In a two-dimensional plan or elevation view, the mouse pointer
position coordinates are always displayed. In a three-dimensional
view, the mouse pointer position coordinates are only displayed
when the mouse pointer snaps to a point or a grid line intersec-
tion.

Tip:

The status bar
provides useful
information and
messages.



Reference Manual

1 - 6 Features

1 Plan View Drawing and Assignment Options (Similar Sto-
ries Feature)

When drawing or making assignments while working in a plan
view, the Plan View Drawing and Assignment Options drop-
down box on the right side of the status bar controls the action.
The three options in that drop-down box are as follows:

 One Story: An object is applied only to the story level
on which it was drawn. An assignment is made only to
the selected elements.

 All Stories: An object drawn in the plan view is applied
to all story levels in the model at the same plan location.
An assignment is made to the selected elements and to
all other elements in the same plan location at all other
story levels.

 Similar Stories: An object drawn in plan view is ap-
plied to all similar story levels in the model at the same
plan location. An assignment is made to the selected
elements and to all other elements in the same plan loca-
tion at all similar story levels.

Similar stories are specified in the Story Data form,
which can be accessed by clicking the Edit menu > Edit
Story Data > Edit command.

The three options apply only at the time the object is drawn or
the assignment is made. The options do not apply retroactively.
For example, if you draw an element at one story level before
you change the Plan View Drawing and Assignment option to
"All Stories," the program will apply the element only to the
story level on which it was drawn, not to all stories.

Current Units
The current units are displayed in a drop-down box located on
the far right-hand side of the status bar. Change the current units
at any time by clicking on the drop-down box and selecting a
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1new set of units.  The units can also be changed using drop-down
boxes located inside some of the forms.

The Aerial View
The aerial view is a small window that can float over the main
window. If the main window is not fully maximized, the aerial
view can float outside the main window. An example of the aer-
ial view is shown in Figure 1-2. Toggle the aerial view on or off
using the Options menu > Show Aerial View command.

The aerial view window displays the entire drawing to help you
move around the active window of a larger model and use the
zoom feature to view smaller areas more easily. Also use the
aerial view to track which part of the model is displayed in the
active window. For example, assume that the active window is a
zoom of a small area of story level 4. In that case, the aerial view
will show the full view of story level 4, with a bounding box

Aerial View

Figure 1-2:
Example of the aerial view
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1 outlining the portion of story level 4 that is displayed in the ac-
tive window.

Each time the model is edited, the aerial view is updated.

To zoom into any area in the active display window, draw a
bounding box in the aerial view window to specify the area for
zooming. To draw the bounding box, put the mouse pointer in
the aerial view at one corner of the box that you want to draw,
then click the left mouse button and hold it down while you drag
the mouse to the diagonally opposite corner of your box; release
the mouse button. You will see the outline of the bounding box
as you drag the mouse.

Notice that in some instances, the bounding box will change
shape after it has been drawn. This occurs because the program
automatically adjusts the aspect ratio of the bounding box to
match the aspect ratio of the active display window. When
changing the aspect ratio of the bounding box, the program al-
ways maintains the longer dimension and changes only the
smaller dimension of the box.

To move the bounding box to a new location in the aerial view
window, click the right mouse button inside the bounding box
and hold the button down as you move to the desired location.
Release the right mouse button and the display in the active win-
dow will be updated accordingly.

Left clicking once in the aerial view window restores the full
view in both the active and aerial view windows and eliminates
the bounding box.

If you pan the view in the active display window, the bounding
box in the aerial view will move also. To pan the view in the ac-
tive display menu, choose the Pan feature from the View menu,
or click the Pan button on the toolbar and then left click in the
display window and hold down the mouse button while you drag
the mouse.

Tip:

If the aerial
view window is
not needed,
click the “X” in
the upper right-
hand corner of
the aerial view
window to close
it. Redisplay it
using the Op-
tions menu.
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1Using the Mouse
The seven mouse actions are (1) left click, (2) right click, (3)
hold down the Ctrl key on the keyboard and left click, (4) hold
down the Ctrl key on the keyboard and right click, (5) hold down
the Shift key on the keyboard and left click, (6) double click, and
(7) drag.

Left Click. Left click means to press down the left button on the
mouse and release it. In general, left click to select menu items,
activate toolbar buttons, and select objects in the model. If the
documentation reads "click on" an item, it means to left click.
The documentation will specify "right click" when appropriate.

Right Click. Right clicking means to press down the right button
on your mouse and release it. In general, right click on objects in
the model to display their assignments.

Ctrl Key. Sometimes you may have objects located one on top
of another in a model. In that case, if you want to select a spe-
cific object in the model, hold down the Ctrl key while left
clicking once on the objects. The left click will bring up a form
from which you can choose the object that you want to select. If
you want to see the assignments for one of the objects, hold
down the Ctrl key while right clicking once on the objects. This
will again bring up a form from which you can choose the object
whose assignments you want to see.

Within forms, use of the Ctrl key and the left mouse button will
select multiple items from a list box. Hold down the Ctrl key and
left click on an item to add that item to your selection. The se-
lected items do not need to be adjacent to one another. This fea-
ture is only available in the list boxes where multiple selections
are possible. An example of this type of list box will be dis-
played if you click Display menu > Set Output Table Mode
and then click the Select Loads button.

Shift Key. Also within forms, to select multiple adjacent items
from a list box, left click on the first item in the list box, hold
down the Shift key, and left click on the last item of the list. This

Tip:

"To click on"
something
means to posi-
tion the mouse
pointer over
that something
and click the
left mouse but-
ton.
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1 will select the two items that you clicked, plus all of the items in
between. This feature is only available in the list boxes where
multiple selections are possible.

Double Click. Double click means to click the left mouse button
twice in quick succession. Be careful not to move your mouse
while you are double clicking. Double clicking is used as one
method of completing some drawing operations.

Drag. Drag the mouse by clicking the left mouse button and
holding it down while you slide the mouse to another location
before releasing the button. Drawing a bounding box in the aerial
view window to zoom in on a model is one example of the
mouse dragging action. Another example is use of the Draw
menu > Reshape Object command.

Starting a Model
Start the graphical user interface by selecting the program from
the Windows Start menu or by clicking a shortcut on your desk-
top. After the graphical user interface has started, start a new
model by selecting File menu > New Model. Refer to Chapter 3
for more information on the modeling process. Refer to the sec-
tion entitled "Starting a New Model" in Chapter 4 for more in-
formation on starting a new model.

After a model has been started, if needed, get additional help by
clicking the Help menu > Search for Help On command. Al-
ternatively, press the F1 key on your keyboard at any time to ac-
cess online help. If you are in a form when you press the F1 key,
context sensitive help for that form will automatically appear.

Save your model often using the File menu > Save command or
the Save button  on the toolbar. No AutoSave feature exists

in this program so it is up to you to save your file on a regular
basis. Also, occasionally copy backup copies of your input file to
another location for safekeeping. The files to copy are the *.edb
file, which is your input file in a binary format (edb is short for

Note:

Refer to Chap-
ter 3 for more
information on
creating a
model.
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1ETABS database), and the *.$et or *.e2k file, which is a text
backup file of your input data.

Two Modes
The two distinct modes in this program are the draw mode and
the select mode. The draw mode allows you to draw objects. The
select mode allows you to select objects and is used for editing
operations, making assignments to objects, and viewing or
printing results. By default, the program is in select mode.

The draw mode automatically enables when you select one of the
submenu options of the following commands from the Draw
menu or click on the corresponding button(s) on the toolbar:

 Draw Point Objects 

 Draw Line Objects , , ,  or 

 Draw Area Objects , , ,  or 

 Draw Developed Elevation Definition 

 Draw Dimension Line 

 Draw Reference Point 

The draw mode remains enabled until you do one of the follow-
ing to return to the select mode:

 Click the Pointer button on the toolbar .

 Press the Esc key on the keyboard.

 Select a command from either the Select menu or the Display
menu.

The mouse pointer indicates which mode is enabled. The
mouse pointer is defined by the mouse pointer properties identi-
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1 fied in the Windows Control Panel for the Normal Select Pointer
and the Alternate Select pointer.

In select mode, the pointer is the Normal Select Pointer, and if
you are using the default settings, the mouse pointer will look
like this .

In draw mode, the mouse pointer is the Alternate Select pointer,
and if you are using the default settings, the mouse pointer will
look like this .

Note that while in draw mode if you run the mouse pointer over
the toolbar buttons or the menus, the pointer temporarily changes
to the selection pointer. If you do not click on one of the menus
or toolbar buttons, the mouse pointer reverts to the draw mode
pointer when you move back into the display window.

Typically, set the properties for the mouse by clicking on the
Windows Start menu, then Settings, then Control panel and
clicking on Mouse to bring up your Mouse properties form.

Other mouse properties used at various special times in the pro-
gram include Help Select, Busy, Text Select, Vertical Resize,
Horizontal Resize, and Move. The appearance of each of these
mouse pointers will also change depending on the mouse pointer
properties you specify.

Locking and Unlocking a Model
A toggle switch that allows a model to be locked or unlocked is

available on the Options menu and also as a toolbar button .
When a model is locked, no changes can be made to it. Unlock-
ing the model allows changes to be made.

After an analysis has been run, the program will automatically
save the results and lock the model to prevent any changes that
would invalidate the analysis results and subsequent design re-
Shortcut:

Use the 
Lock/Unlock
button  to
quickly lock or
unlock your
model.
1

Note:

If you edit the
mouse proper-
ties in the Win-
dows Control
Panel, the
change applies
to all of Win-
dows, not just
ETABS.
 - 12 Locking and Unlocking a Model

sults that may be obtained.
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1To make changes to a model after an analysis has been run, first
unlock the model. When you select the toggle switch to unlock
the model, the program will warn that the analysis results will be
deleted. If you do not want the analysis results to be deleted,
save the model under a new name before unlocking it, then make
any subsequent changes to the newly named model.

Undo Features
The Undo feature enables changes to model drawing (geometry
changes) for multiple steps, back to the last time you saved your
model. For example if you draw one or more objects and then
decide you do not want them, use the Edit menu > Undo com-
mand to remove them. If you then decide you want them back,
use the Edit menu > Redo command. The Undo and Redo
commands work sequentially. In other words, if you have just
finished the sixteenth operation since your last save, you can use
the Undo feature to undo the sixteenth operation, then the fif-
teenth operation, and so on. However, you could not, for exam-
ple, undo only the seventh operation.

The Undo and Redo features do not work for changes made in
forms. When an item is changed in a form, the change is not ac-
tually implemented until the OK button has been clicked. If the
Cancel button is clicked, the change is ignored and all original
values are restored. If you are working in a sub-form, which is
accessed through another form, the changes are not actually im-
plemented until the OK button is clicked in the topmost form;
that is, until the last form is closed by clicking the OK button.

Suppose for example that you are in a series of sub-forms that go
five levels deep. For changes made at the fifth level to be ac-
cepted and implemented, click the OK button at the fifth, fourth,
Shortcut:

Use the 
Redo button to
redo a previ-
ously undone
operation.
Shortcut:

Use the 
Undo button on
the toolbar to
undo a previous
operation.
Undo Features 1 - 13

third, second and topmost levels. Clicking the Cancel button at
any one of the levels cancels any of the changes made at that
level and at any lower level. Thus, if you click the Cancel button
in the topmost level of a form, no changes will be made at any
level.
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1 Tips for Using the Graphical User Interface
Following are tips for using the graphical user interface:

 Startup Tips appear when you first start the graphical interface.
Left clicking anywhere in the window closes the Tip of the
Day window. Clicking the OK button associated with the tip
or clicking the "X" button in the upper right-hand corner of the
tip window also closes the Tip window. Use the Options
menu > Show Tips at Startup command to turn off this fea-
ture.

 The graphical user interface works most efficiently with at
least a 17-inch monitor and at least 1024x768 resolution.

 Although up to four windows can be open, one or two win-
dows tiled vertically usually works best. Set the number of
windows using the Options menu > Windows command.

 Customize the graphical user interface display colors to suit
your individual preferences using the Options menu > Colors
command.

 Modify the maximum and minimum graphic font sizes used in
the display windows in the graphical user interface using the
Options menu > Preferences > Dimensions/Tolerances
command.

 The menus in the interface are intended to be organized logi-
cally so that you can easily locate any menu item. Ask your-
self, “What do I want to do?” When creating or modifying a
model, you typically edit the model, change the view of the
model, define properties or load cases, draw something new in
the model, or assign something to the model, such as proper-
ties or loads. Thus, one word can describe possible actions,
such as edit, view, define, draw, or assign. These action word
indicate which menu to use.

 Right clicking on an object brings up a form with information
about location, geometry and assignments for that object. This
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1information is for viewing only. You cannot edit the informa-
tion in this form.

 Save your model often.

 The Undo feature works for multiple steps, back to the last
time you saved your model.

 Do not overlook the extensive online help that is available at
the press of the F1 key on your keyboard. If you are in a form
when you press the F1 key, context sensitive help related to
that form will be displayed.

 Useful information about your model is displayed as text on
the left-hand side of the status bar at the bottom of the main
window.

 Try a few practice problems to get the hang of the graphical
user interface.

 If you have used an earlier version, you may want to import a
familiar file to see how it looks in this latest version.
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Chapter 2

Overview of a Model

A model developed using this program is different from models
produced in many other structural analysis programs for two
main reasons:

 This program is optimized for modeling building systems.
Thus, the modeling procedures and design capabilities are all
tailored to buildings.

 This program's model is object-based. It consists of area, line
and point objects. You make assignments to these objects to
define structural elements such as beams, columns, braces,
floors, walls, ramps and springs. You also make assignments
to those same objects to define loads.

When an analysis is run, the program automatically converts an
object-based model into an element-based model that is used for
analysis. We refer to this element-based model as the analysis
model. The analysis model consists of joints, frame elements,
link elements and shell elements in contrast to the point, line and

Note:

There are three
types of objects
in this program.
They are area,
line and point
objects.
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2
area objects in the object-based model that you create. The con-
version to the analysis model is internal to the program and es-
sentially transparent (not visible) to the user.

After the analysis is run, the results are reported with respect to
the object-based model, not the analysis model. See the section
titled “The Analysis Model” later in this chapter for additional
information on the analysis model.

The Concept of Objects
In its simplest form, developing a model requires three basic
steps. They are:

 Draw a series of area, line and point objects that represent your
building using the Draw menu drawing tools or their corre-
sponding toolbar buttons. See Chapter 8 for documentation of
the Draw menu commands and toolbar buttons.

Note that you could also create these objects directly from one
of the built-in templates. See the subsection entitled “Add
Structural Objects from a Template” in Chapter 4, and the sec-
tion entitled “Add to Model From Template Command” in
Chapter 5 for more information.

 Assign structural properties and loads to objects using the As-
sign menu options. See Chapter 10 for documentation of the

Tip:

Understanding
area, line and
point objects is
probably the
most important
key to success-
ful modeling in
this program.
A Note about Objects

The concept of objects in a structural model may be new to you. It is extremely im-
portant that you grasp this concept because it is the basis for creating a model in
this program. It is not a difficult concept, but because it is new, it may take some
time for you to become comfortable with it. After you understand the concept and
have worked with it for a little while, you should recognize the simplicity of the ob-
ject-based modeling, the ease with which you can create models using objects, and the
power of the concept for creating more complex models.
 - 2 The Concept of Objects
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Assign menu commands.

Note that you can also assign structural properties to objects as
you draw them using the floating Properties of Object box that
appears when you select a Draw menu command. This feature
is documented in Chapter 8.

 Manually mesh the area objects if they are not horizontal
membrane slab or deck sections that you are letting the pro-
gram fully, automatically mesh into the analysis model.

An understanding of these three steps is all you need to create a
model in this program.

It is extremely important that you become familiar with objects.
They are the basic building blocks for your model. If you are
new to this program, you should start by studying the area, line
and point objects.

Any single area, line or point object can have multiple assign-
ments made to it at the same time. We recommend that you
minimize the number of objects in your model by making multi-
ple assignments whenever possible.

For example, suppose you have a beam with three point loads
applied to it. You would draw a line object to represent the beam
and assign it a frame section (beam) property. You could, al-
though we do not recommend it, draw three point objects located
on the beam and assign point loads to those point objects to cre-
ate the point loads on the beam. Alternatively, you could apply
the point loads directly to the line object using the Assign menu
> Frame/Line Loads> Point command, thereby eliminating the
need for the three point objects. We strongly recommend that
you assign the point loads directly to the line object.

The Analysis Model
In general, it is not necessary that you concern yourself with the
particulars of the analysis model. Nevertheless, it may be helpful

Tip:

If you left click
any object, the
object is se-
lected. If you
right click any
object while
you are in an
undeformed
shape view,
information  is
displayed in a
pop-up form,
including exact
dimensions,
location, and
assignments.
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2
for you to know that when you run an analysis, the program uses
the data in your object-based model to create an element-based
analysis model (hereafter called the analysis model). All of this
happens internally in the program and is essentially transparent
(not visible) to the user.

The reason for converting from the object-based model to the
analysis model is to create a finite element representation of your
model that can be analyzed using standard finite element analy-
sis techniques.

The program transforms your object-based model that is based
on area, line and point objects into an analysis model that is
based on joints, frame elements and shell elements. In the proc-
ess of doing this, it internally meshes (divides) some frame ele-
ments, as necessary, to provide connectivity to other frame and
shell elements in the analysis model.

Also, if your model includes horizontal area objects that are as-
signed deck or slab properties with membrane behavior only, the
program can automatically mesh the floor into the analysis
model. You do not need to mesh those types of floors in your
object-based model.

All other types of floors, and all ramps and walls must be ade-
quately meshed in your object-based model because the program
does not automatically mesh those into the analysis model.

Link elements are never meshed in the analysis model. They al-
ways maintain a one-to-one correspondence with the object-
based model.

Structural properties are transferred directly from the structural
objects to the corresponding elements in the analysis model.
Spring stiffnesses for area and line support springs are trans-
ferred to spring elements at the analysis joints in a consistent
manner based on tributary area.

Tip:

If you are a
SAP2000 user,
you can export
your object-
based ETABS
model to a
SAP2000 .s2k
file. The
SAP2000 model
is the same as
the element-
based analysis
model. This is a
good way for
you to see an
ETABS analysis
model.
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Loads are transformed from the area, line and point objects in the
object-based model onto the frame elements and joints of the
analysis model.

After the analysis has been run, the results are typically reported
with respect to the objects in the object-based model, not the
elements in the analysis model.
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Chapter 3

Modeling Tips

This chapters outlines a basic modeling process and then pro-
vides some modeling tips.

Modeling Process
It is not necessary, or expected, that you exactly follow the gen-
eral process for creating a model described in this chapter.
Rather, the intent is to guide you in creating a model and running
an analysis.

To create a typical model:

1. Set the current units to those that you will want to use most
often in your model.
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2. Start your model by clicking the File menu > New Model
command or  button and choosing one of the file initiali-

zation methods. See the subsection entitled "Initialize a New
Model" in Chapter 4 File Menu for more information.

3. Set up your grid lines. See the subsection entitled "Grid Di-
mensions (Plan) - Define a Grid System" in Chapter 4 File
Menu for more information.

4. Define your story levels. See the subsection entitled "Story
Dimensions - Define Story Data" in Chapter 4 File Menu for
more information.

5. If desired, add structural objects from one of the built-in
templates. See the subsection entitled "Add to Model from
Template Command" in Chapter 5 Edit Menu for more in-
formation. In general, we recommend that you start your
model by adding objects from a template whenever possible.

6. Use the Options menu > Preferences command to modify
any of the default preferences if desired. See the section en-
titled "Preferences" in Chapter 14 Options Menu for more
information

7. Use the Define menu to define frame section properties,
wall, slab and deck section properties and link properties as
required. See Chapter 7 Define Menu for more information.

8. Use the Define menu > Static Load Cases command to de-
fine your static load cases. See the section entitled "Static
Load Cases Command" in Chapter 7 Define Menu for more
information.

9. If you are using mass in your model, use the Define menu >
Mass Source command or the  button to specify the

source of mass in your model. See the section entitled "Mass
Source Command" in Chapter 7 Define Menu for more in-
formation.

Tip:

In general, we
suggest that
when starting a
model you add
structural ob-
jects from a
template and
then edit them
as necessary.
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10. Use the commands available on the Draw menu to draw ad-
ditional area, line and point objects as needed. See Chapter 8
Draw Menu for documentation of the drawing features.

As you draw, we recommend that you assign structural
properties using the pop-up Properties of Object box.

The objects you draw may be assigned structural properties,
loads or masses. Also, the line objects might be used as
guidelines with the Snap To command (see Chapter 8 Draw
Menu), the Trim Lines at or Extend Lines to options for
extending or trimming other lines (see Chapter 5 Edit
Menu), or mesh lines for manual meshing.

Note that mass is required if you are doing a modal analysis
to determine mode shapes. It is also required for the non-
iterative method of considering P-Delta. It is also required to
convert static nonlinear force-deformation results into the
capacity spectrum ADRS format.

11. Use the Edit menu commands to modify, and in some cases,
tweak the geometry of your model as needed. See Chapter 5
Edit Menu for documentation of the various Edit menu fea-
tures.

12. Use the Assign menu commands to revise properties in your
template model, if necessary, and to make additional as-
signments to template members as well as to any other
members you might have drawn. See Chapter 10 Assign
Menu for documentation of the various Assign menu fea-
tures.

The types of assignments you make include section proper-
ties, loads, masses, moment releases, partial fixity, and so
forth.

To make an assignment to an object,  first select the object,
then click the appropriate Assign menu command.

Tip:

The similar
stories feature
is a useful and
powerful tool
that you can
use when
drawing, se-
lecting and
making assign-
ments to objects
in plan view.
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13. Use the Display menu > Show Loads command and the
Display menu > Set Input Table Mode command or 

button to review input. Both of those commands are docu-
mented in Chapter 12 Display Menu.

Another way to review your input is to right click on any
object. This brings up a form where you can review all as-
signments to the object.

You can also use the View menu > Set Building View Op-
tions command, or the Set Building View Options button

 to toggle on the display of various input items. Some

examples are section properties, member end releases, non-
linear hinges, diaphragm extent and the like.

14. If desired, use the File menu > Print Tables > Input com-
mand to print input data to a file or to the printer. See the
section entitled "Print Commands" in Chapter 4 File Menu
for more information.

Alternatively you can use the File menu > Export > Save
Input/Output as Access Database File command to save
the input data in a database file that can be reviewed, modi-
fied and printed using Microsoft Access.

15. Use the Analyze menu > Set Analysis Options to specify
various analysis parameters such as the building degrees of
freedom. See the section entitled "Set Analysis Options
Command" in Chapter 11 Analyze Menu for more informa-
tion.

16. If your model has floors, walls or ramps that require manual
meshing, use the manual meshing options available through
the Edit menu > Mesh Areas command.

Note that the program can automatically mesh floors that
have membrane properties only. All other floors and all
walls and ramps must be manually meshed by you. We rec-
ommend that you wait until just before you are ready to run
the analysis to perform this manual meshing.

Note:

Note that this
program can
automatically
mesh floors that
have membrane
properties only.
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17. Use the Analyze menu > Run Analysis command or the

 button to run your analysis. See the section entitled "Run

Analysis Command" in Chapter 11 Analyze Menu for more
information. When the analysis is complete, scroll through
the text in the Analysis Window to check for any warnings
or errors that might invalidate your analysis.

18. Use the display features available on the Display menu to
display analysis results on your model or on the screen in a
tabular format. See Chapter 12 Display Menu for documen-
tation of the Display menu features.

19. If desired, use the File menu > Print Tables > Analysis
Output command to print output to a file or to the printer.
See the section entitled "Print Commands" in Chapter 4 File
Menu for more information.

Alternatively you can use the File menu > Export > Save
Input/Output as Access Database File command to save
the analysis output data in a database file that can be re-
viewed, modified and printed using Microsoft Access.

20. If desired, use the features available on the Design menu to
run your building through one or more of the design post-
processors.

21. After you have run a design, save your model before exiting
the program. Otherwise your design is not saved.

Modeling Tips
1. Create a Default.edb file that contains standard preferences

for your company and use it as a starting point for each
model. See the subsection entitled "Initialize a New Model"
in Chapter 4 File Menu for more information.

2. Save your model often. It is also useful to occasionally save
a backup of your model under a different name.

Tip:

We recommend
that you run
large analyses
minimized.

Tip:

Design is an
iterative proc-
ess. Typically
you will rerun
your analysis
and design sev-
eral times until
your last used
analysis section
properties
match the de-
sign sections.



Reference Manual

3 - 6 Modeling Tips

3

3. With the program's powerful graphical interface, you can
easily and quickly create large, complex models. This does
not mean you should. Resist the temptation to model every-
thing in the building. Only model those elements that are an
essential part of the vertical or lateral load path.

4. You can get an overview of the options available in the pro-
gram by "surfing" through the various menus and thumbing
through this manual.

5. The Edit menu > Undo command or  button provides
powerful capabilities. Feel free to experiment with options
because you can always Undo them.

6. When you use auto select lists for your elements, resist the
temptation to put every possible steel section in the auto se-
lect list. Keep the auto select lists shorter, say 20 to 30 sec-
tions long, to significantly speed up the time it takes to de-
sign your model.

7. When creating a model, work in plan and elevation view as
much as possible. It is much easier to work in these 2D
views than it is to work in a 3D view.

Do not overlook the developed elevation feature. This fea-
ture provides a powerful way for you to work on multiple
faces of your building in the same 2D view. See the section
entitled "Draw Developed Elevation Definition Command"
in Chapter 8 Draw Menu for more information.

8. When creating or editing your model in plan view, consider
using the similar stories feature. If you use the  similar sto-
ries feature, however, keep track of when it is enabled (set to
Similar Stories or All Stories) or disabled (set to None) to
avoid adding or removing elements from the wrong story
level(s) or neglecting to add or remove them.

9. If you are working on a large steel frame building for which
you plan to use the Composite Beam Design or Steel Frame
Design postprocessor to design the floors and you also plan

Tip:

Try to keep
your models
less complex
rather than
more complex.
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to design the lateral system of the building, we suggest the
following.

a. Create a single story model for each floor level that is
different. Optimize the design of the floors in these sin-
gle story models.

b. Use the File menu > Import > ETABS8.edb File
command to import the single story floor framing into a
model of the complete building. Note that the similar
stories feature is available when you do this import.

c. Run the lateral analysis using the full building with the
floor levels imported from single story models.

For example, assume that you have a ten-story building.
Further assume that floor levels 3 through 10 are exactly
the same, and floor level 2 and the roof are unique. For
floor design, create three single story models: one single
story model for level 2, one for levels 3 through 10, and
one for the roof.

Perform your floor design in these three models and then
import the floors into a ten-story model for the lateral
analysis. Note that you can use the similar stories feature
when importing floors 3 through 10 so that you only
have to import the single story model once.

Alternatively, model everything in the ten-story build-
ing. The disadvantage to this is that when you do your
floor design, you will design floors 3 through 10 sepa-
rately. Thus, you will design 10 different story levels in-
stead of 3.

10. For a large building, or if you are working on a tight time
schedule, it may be advantageous to have multiple engineers
creating different story levels of your building. Those story
levels can then be combined into one building using the File
menu > Import > ETABS8.edb File command.

Tip:

In this pro-
gram, it is easy
for multiple
engineers to
work separately
on different
portions of a
large model
and then later
combine those
portions into a
single model.
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11. If you are working with a large multistory model, and you
want to concentrate on just one story level of that model, use
the File menu > Export > Save Story as ETABS8.edb File
command to export a story to another file as a single story
model.

12. The aerial view feature can be useful when you are doing a
lot of zooming into and out of regions of your model. See the
section entitled "The Aerial View" in Chapter 1 Graphical
User Interface for more information.

13. Your structure can be supported at any level. There is no
need for "dummy" levels to model nonstandard support con-
ditions.

14. Parking garages with sloping floors can be easily modeled
using ramp objects. Create your story levels as you would
for any building and connect them where appropriate with
Note:

The program
easily models
structures with
sloping floors
(ramps), such
as parking ga-
rages.
 - 8 Modeling Tips

ramp objects.

15. You can easily model flexible diaphragms. To do this, assign
slab or deck properties to the area object that represents the
floor. The membrane properties of the slab or deck model
the in-plane diaphragm flexibility. The program automati-
cally lumps the floor mass at the shell element corner points
on a tributary area basis.

16. If desired, you can use the Define menu > Mass Source
command to indicate that the mass of your building is to be
determined based on a specified load combination. See the
section entitled "Mass Source Command" in Chapter 7 De-
fine Menu for more information.

17. When creating a model, save the manual meshing of area
objects as the last thing you do before you run the analysis.
This allows you to take advantage of working with fewer
objects as you create your model.

18. The program automatically generates static lateral seismic
and wind loads based on building code requirements. See the
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section entitled "Static Load Cases Command" in Chapter 7
Define Menu for more information.

19. We recommend that as you draw objects, you assign struc-
tural properties to them using the floating Properties of Ob-
ject box. See the sections entitle "Draw Line Object Com-
mand" and "Draw Area Object Command" in  Chapter 8
Draw Menu for more information.

20. It is important that you draw your model accurately. The
snap options can help you do this. See the subsection entitled
"Snap To Commands" in Chapter 8 Draw Menu for more in-
formation.

If you do not draw your model accurately, the program may
not interpret the member connectivity in the way you intend.
For example, assume you draw a beam framing into a girder
but you stop the beam slightly short of the girder because
you did not have the snap options turned on. In that case, de-
pending on the tolerances set and how far the end of the
beam is from the girder, the program may not interpret the
beam as connecting to the girder. You can avoid this prob-
lem by using the snap options so that when the line object
representing the beam is drawn, it snaps onto the line object
representing the girder. The snap option that would do this is
the Snap to Lines and Edges option.

If you have already drawn objects that are slightly mislo-
cated, use Align features to fix the problem. See the section
entitled "Aligning Points/Lines/Edges Command" in Chapter
5 Edit Menu for more information.

21. Groups can be a great benefit when creating a model. You
can select elements by groups. Assume you have a braced
frame model and that you assign all of your braces to a
group. You can then select all of the braces at once by group
using the Select menu > Select by Groups command. After
the braces have been selected, make assignments to them as
a group or print input/output tables for them as a group. You
can also design elements as a group. In this case, all of the

Tip:

To help draw
objects in your
model accu-
rately, use the
snap options.
Reference
planes and ref-
erence lines
can assist you
when snapping.
See the section
entitled "Edit
Reference
Plans and Ref-
erence Lines"
in Chapter 5
Edit Menu for
more informa-
tion.

Tip:

Do not be shy
about defining
groups in your
model. You will
find many uses
for them as you
create your
model, use the
design postpro-
cessors and
review output
results.
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elements in the design group are given the same section
property by the design postprocessor.

See the section entitled "Group Name Command" in Chapter
10 Assign Menu for more information.

22. In general, given the choice, it is better to make rigid dia-
phragm assignments to horizontal area objects (floors) rather
than to point objects. This tip applies to loads assigned to
line objects. In general, where possible, we strongly recom-
mend that you assign line and point loads to line objects with
frame section properties (i.e., columns, beams and braces as-
signed to them) rather than simply assigning the loads to
null-type line objects located somewhere on an area object.
The transformation of loads from your object-based model
into the element-based analysis model is more easily pre-
dicted when the loads are assigned to a frame element.

23. Carefully review your input both graphically and in tables to
make sure you have modeled what you meant to model. One
of the most common problem areas is the frame member end
releases; check them carefully.

24. After you run your analysis and before clicking the OK
button in the Analysis Window, scroll through the messages
in the Analysis Window checking for any warnings or error
messages that might invalidate your analysis.

25. Carefully review your analysis output results to make sure
that your model is behaving as you expect. If it is not, inves-
tigate to find out why.
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Chapter 4

File Menu

General
The File menu provides basic file operations for creating new
models, opening existing models and saving models. It also pro-
vides options for printing input and output data as well as con-
trols for other miscellaneous features. This chapter describes the
features available on the File menu.

New Model Command
The File menu > New Model command is used to start/create a
new model. Alternatively, you can click the New Model button

 on the toolbar or use Ctrl+N (hold down the control key and

then type N). There are four distinct stages in creating a new
model:

 Initialize the model.
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 Define a grid system.

 Define story data.

 Add structural objects from a template.

Default values are provided for each of the stages, so with little
more than a few clicks of some OK buttons, you can create a
complete model using default dimensions and properties. More
typically, you will modify the default values provided for each of
the stages to specify the particular characteristics of your model.
The following four subsections describe each of the four stages
of creating a new model.

Initialize a New Model
When you execute the File menu > New Model command, a
form will display asking if you want to initialize your new model
using definitions and preferences from an existing .edb file.
(Note:  An .edb file is an ETABS model file.) You may select
one of three button:  the Choose.edb button, the Default.edb
button, or the No button. An explanation of these buttons fol-
lows.

 Choose.edb Button. If you select the Choose.edb button, you
will be asked to specify an ETABS file that has an .edb exten-
sion in any subdirectory on your computer system.  After you
have specified an .edb file, the program will start your new
model with the definitions and preferences from that .edb file.
In that case, the program essentially imports the entire speci-
fied .edb file into your new .edb file, except for the following
items:

 Grid lines

 Story data

 Objects

 Assignments to objects

Tip:

You can ini-
tialize a new
model based on
any .edb file.
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 Information on the number of windows and what is show-
ing in the windows.

 Default.edb Button. If you select the Default.edb button, the
program will start your new model using definitions and pref-
erences that are specified in the Default.edb file that is in the
same directory as the ETABS.exe file. If no Default.edb file
exists in the same directory as the ETABS.exe file, the pro-
gram will use built-in values for all of the definitions and pref-
erences in your new model.

 No Button. If you select the No button, the program will use
built-in values for all of the definitions and preferences in your
new model.

Creating .edb Files for Initializing Your Models
Create an .edb file for initializing your model by renaming an
existing .ebd (or model) file.

When creating a Default.edb file, it is most logical to select an
existing .edb file that uses most of the common practices of your
office with respect to how models should be set up (e.g., units,
section properties and the like). Store this file in the same direc-

Tip:

We recommend
that you create
your own cus-
tom Default.edb
file and place it
in the directory
that contains
the Etabs.exe
file.
Note:

The Default.edb
file is simply a
typical ETABS
.edb file that
has been re-
named De-
fault.edb.
New Model Command 4 - 3

tory as the ETABS.exe file.

If necessary, create other ETABS .edb files that may in certain
circumstances be useful for initializing your model. You may
want to store those .edbs in a location where all engineers have
access to them, or you may want them to be more personalized
and have limited access. Either way is functional for ETABS. It
works best if the files have names other than Default.edb so that
you do not confuse the files (i.e., you could have multiple De-
fault.edb files stored in separate subdirectories and use the
Choose.edb button to select a file name Default.edb, but this can
be confusing).
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Building Plan Grid System and Story Definition Form
After you have used the New Model command to initialize your
model, the Building Plan Grid System and Story Definition form
will appear. This form has four areas:

 Grid Dimensions (Plan), which is used to define a grid sys-
tem.

 Story Dimensions, which is used to define story data.

 Units, which is used to define the units to be used in the
model.

 Add Structural Objects, which is used to add structural ob-
jects from program templates.

With the exception of the Units area, which is assumed to be
self-explanatory, these areas are described in the following sub-
sections. The form also has OK and Cancel buttons, which are
used to accept or cancel the selections made on the form. You
must select the OK button for any changes you make to this
form to be accepted. Selecting the Cancel button cancels any
changes.

Grid Dimensions (Plan) - Define a Grid System
In the Grid Dimensions (Plan) area of the form, you can define a
grid line system. You can select from two options for defining
the grid line system:

 Uniform Grid Spacing: For this option, you specify the num-
ber of grid lines in the X and Y directions and a uniform spac-
ing for those lines. Note that the uniform spacing in the X and
Y directions can be different. This option defines a grid system
for the global coordinate system only. If necessary, you can
later edit this information using the Edit menu > Edit Grid
Data command. Refer to the section entitled "Edit Grid Data
Command" in Chapter  5 for more information. As noted in
Chapter 5, the default global coordinate/grid system is a Carte-
sian (rectangular) coordinate system. Thus, you will likely use

Tip:

The custom
grid spacing
item that is
available when
you start a new
model allows
you to immedi-
ately specify
nonuniformly
spaced grid
lines.
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the Edit > Edit Grid Data > Edit Cartesian/Cylindrical Sys-
tem command to modify the grid system.

 Custom Grid Spacing: This option allows you to label grid
lines and to define nonuniformly spaced grid lines in the X and
Y directions for the global coordinate system. After you have
chosen this option, click the Grid Label button to label grid
lines and click the Edit Grid button to edit the grid system. If
you want to make subsequent changes to your model grid sys-
tem, please refer to the explanation in Chapter 5 in the "Edit
Grid Data Command" section.

There are several reasons for defining a grid system for your
model, including:

 Default elevation views in the model occur at each defined
primary grid line in your model.

 Structural objects added to the model from a template are
added based on the grid line definitions in the model.

 Objects snap to grid lines when drawn in the model.

 Objects mesh at their intersections with grid lines.

 The grid lines in the model can be defined with the same
names as are used on the building plans. This may allow for
easier identification of specific locations in the model.

Story Dimensions - Define Story Data
Story data is defined from the Story Dimensions area of the
Building Plan Grid System and Story Definition form. You can
selected from two options for defining the story data:

 Simple Story Data:  With this option, you can define the
number of stories and a typical story height that is used for all
story levels. The program provides default names for each
story level and assumptions for story level similarity. (You can
later edit all of this information using the Edit menu > Edit
Story Data > Edit command. Refer to the section entitled
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"Edit Story Data Command" in Chapter 5 for more informa-
tion.)

 Custom Story Data: This option allows you to define your
own story names, story levels of non-uniform height and cus-
tomized story similarity. After you have chosen this option,
click the Edit Story Data button and the Story Data form will
appear. This form is the same one that appears when you exe-
cute the Edit menu > Edit Story Data > Edit command. Re-
fer to the section entitled "Edit Story Data Command" in
Chapter 5 for more information.

Add Structural Objects
While in the Building Plan Grid System and Story Definition
form, you can add structural objects to your model from one of
several built-in templates. It is not necessary that you add the
structural objects from a template. You can always draw, import,
copy or replicate structural objects later (see Chapter 5 Edit
Menu and Chapter 8 Draw Menu for more information). How-
ever, in many cases it is simplest, most convenient and quickest
to start your model with structural objects added from a tem-
plate.
Note:

You can create
steel and con-
crete building
models using
built-in tem-
plates. These
models can
then be edited
on screen to
satisfy specific
situations.
 - 6 New Model Command

The Add Structural Objects area of the Building Plan Grid Sys-
tem and Story Definition form is reproduced herein for refer-
ence:

Note that there is one steel building template called Steel Deck,
five concrete building templates, and a button for grids only
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where no structural objects are added to the model from a tem-
plate. You can always tell which option (button) has been se-
lected in the Add Structural Objects area because its name will
be highlighted. When the Building Plan Grid System and Story
Definition form opens, the Grid Only selection is highlighted,
thus indicating that unless you select another template, your
model will have only a grid system.

You can choose any of the templates by left clicking its associ-
ated button. When you choose one of the template buttons, a
form for that template will appear where you specify various
types of data for the template. Notice that each of the template
buttons has a pattern that suggests the type of template. This
pattern is repeated in a small area of the form that comes up after
the button has been selected. The six template forms (one steel
and five concrete) are described in the subsections that follow.

When you have finished specifying data for a template, click the
OK button to return to the Building Plan Grid System and Story
Definition form. As indicated previously, the button name for the
template that you just specified should be highlighted. If you
then decide you defined the wrong type of template, click an-
other template button and define data for it. When the program
creates the model, it adds structural objects based on the last
button clicked in the Add Structural Objects area; that is, the
highlighted button. You can select only one template on the
Building Plan Grid System and Story Definition form.

Note that when using concrete building templates in this pro-
gram, beams and slab ribs (joists) are normally modeled with
depths equal to the dimension from the top of the slab (not bot-
tom of slab) to the bottom of the beam or slab rib. Also note that
beams are modeled as line elements in this program. Thus, slabs
with out-of-plane bending capability span from center-of-beam
to center-of-beam in the program model.
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Steel Deck Button - Steel Floor System Form

Selecting the Steel Deck button on the Building Plan Grid Sys-
tem and Story Definition form brings up the Steel Floor System
form, which allows you to define a steel floor system. Following
are descriptions of each of the items on the Steel Floor System
form:

 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab/deck. These distances must be
greater than or equal to zero. They cannot be negative. Figure
4-1 illustrates the overhangs of a steel floor system.

   Left 
Overhang

  Right 
Overhang
Figure 4-1:
Steel Floor System
4 - 8 New Model Command

 Secondary Beams: Selecting the Secondary Beams check box
on the Steel Floor System form will include secondary (infill)
beams. If the check box is not checked, no secondary beams
are included. Secondary beams are the beams that do not frame
into columns. Secondary beams are shown in Figure 4-1 as
dotted lines. The direction of the beams can be X or Y. Direc-
tion X means the span of the beams is parallel to the X-axis.

  Top 
Overhang

  Bottom
Overhang
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Direction Y means the span of the beams is parallel to the Y-
axis.

You can specify the number of secondary beams using one of
two methods. You can either specify a maximum spacing, in
which case the program determines how many beams fit in the
bay, or you can specify a number of equally spaced beams.

Note that by default, moment is released at the ends of all sec-
ondary steel beams; that is, they are pinned.

 Structural System Type: There are three possible selections
for structural system type:

 No Moment Frame: Moment is released at all beam-to-
column connections; that is, those connections are pinned.

 Perimeter Moment Frame: Moment is not released at
beam-to-column connections for perimeter columns. Mo-
ment is released at beam-to-column connections for all in-
terior columns. In other words, beam column connections
are moment resistant at perimeter columns and pinned at
interior columns.

 Intersecting Moment Frame: Moment is not released at
any beam-to-column connections; that is, all beam-to-col-
umn connections are fully moment resisting.

 Restraints at Bottom: You can specify no restraints (sup-
ports) at the bottom of all columns, pinned restraints (UX, UY
and UZ restrained and RX, RY and RZ free), or fixed restraints
(UX, UY, UZ, RX, RY and RZ restrained).

 Structural System Properties: Here you specify frame sec-
tion properties to be assigned to columns and beams and a
deck section property for the deck/slab. The items in this area
include the following:

 Lateral Column: Column where the beam-to-column
connections are fully moment resisting.

Tip:

By default sec-
ondary steel
beams are
pinned.
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 Lateral Beam: Beam where the beam-to-column connec-
tions are fully moment resisting.

 Gravity Column: Column where the beam-to-column
connections are pinned; that is, not fully moment resisting.

 Gravity Beam: Beam where the beam-to-column connec-
tions are pinned; that is, not fully moment resisting.

 Secondary Beam: All secondary beams.

 Deck/Floor: The deck/slab.

 Load: The Dead Load Case drop down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box applies a rigid diaphragm con-
straint to the area object representing the slab/deck.

Staggered Truss Button - Stagger Truss System Form

Selecting the Staggered Truss button on the Building Plan Grid
System and Story Definition form brings up the Stagger Truss
System form, which allows you to define a staggered truss sys-
tem. This form consists of the following areas:
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 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab/deck in the X and Y directions.
These distances must be greater than or equal to zero. They
cannot be negative.

 Truss: Here the user can assign the truss in the X or the Y di-
rection as well as define the Typical Size of the Panel. Sections
can be assigned to Cords, Diagonals and Vertical Truss mem-
bers as desired.

 Restraints at Bottom: You can specify no restraints (sup-
ports), pinned restraints (UX, UY and UZ restrained and RX,
RY and RZ free), or fixed restraints (UX, UY, UZ, RX, RY
and RZ restrained)  at the bottom of all columns.

 Structural System Properties: Here you specify section
properties to be assigned to the framing members and a deck
section property for the deck/slab. The items in this area in-
clude the following:

 Column: This column supports the truss; that is, the col-
umn is beneath the truss.

 Spandrel: This beam spans between trusses.

 Brace (bottom):  This is the horizontal brace for the truss
bottom chord, where required.

 Hanger: This hanger is the vertical tension member that
supports the level below the hanger.

 Post:  This post is the vertical compression member that
supports the level above the post.

 Load: The Dead Load Case drop-down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
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multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box  applies a rigid diaphragm con-
straint to the area object representing the slab/deck.

Flat Slab Button - Flat Slab Form

Selecting the Flat Slab button on the Building Plan Grid System
and Story Definition form brings up the Flat Slab form, which
allows you to define a concrete flat slab floor system with drop
panels. No beams are included in this floor system. The form in-
cludes the following areas:

 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab. These distances must be greater
than or equal to zero. They cannot be negative.

 Drop Panels: Checking the Drop Panels check box adds drop
panels to the model. If the check box is unchecked, no drop
panels are included. Figure 4-2 illustrates a flat slab system
with a drop panel.

The drop panels are typically assumed to be square and cen-
tered on the columns, which are located at all grid line inter-
sections. The Size item for the drop panels is the length of one
side of the drop panel. If the drop panel occurs at a perimeter
column and the edge distance at that location is less than one-
half the drop panel size, the drop panel is truncated at the edge
of the slab.
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Note that the thickness (depth) of the drop panel is controlled
by the section property assigned to it in the Structural System
Properties area of the form.

 Restraints at Bottom: You can specify no restraints (sup-
ports), pinned restraints (UX, UY and UZ restrained and RX,
RY and RZ free), or fixed restraints (UX, UY, UZ, RX, RY
and RZ restrained) at the bottom of all columns.

 Structural System Properties: Here you specify a frame sec-
tion property to be assigned to the columns and slab section
properties to be assigned to the slab and drop panels. The items
in this area include the following:

 Column: Specify frame section properties for all of the
columns in the template model.

 Slab: Specify the slab section property for the floor slab,
excluding the drop panels.

 Drop: Specify the slab section properties for all of the
drop panels in the template model.

Figure 4-2:
Flat Slab System
Without Perimeter
Beams

Drop Panel  Size

11

Left
Overhang

Right 
Overhang

   Top
Overhang

  Bottom
Overhang

D r o p  P a n e l

S l a b

1 1



Reference Manual

4 - 14 New Model Command

4

 Load: The Dead Load Case drop down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box applies a rigid diaphragm con-
straint to the area object representing the slab and drop panels.

 Mesh Area for Analysis:  Checking the Mesh Area for
Analysis check box directs the program to mesh the slab im-
mediately. Because you are just beginning to develop your
model, it may be desirable to leave this check box unchecked,
at least in larger models. Meshing causes the program to slow
down, which on larger models, can mean make a significant
difference to your schedule. We recommend that you finish all
modeling input and then apply automatic meshing just before
running an analysis. Automatic meshing is described the
"Mesh Areas Command" section in Chapter 5 Edit Menu.

Flat Slab with Perimeter Beams Button - Flat Slab with Perime-
ter Beams Form

Selecting the Flat Slab with Perimeter Beams button on the
Building Plan Grid System and Story Definition form brings up
the Flat Slab with Perimeter Beams form, which allows you to
define a concrete flat slab floor system with drop panels and pe-
rimeter beams. The only difference between this template and
the Flat Slab template is that this template includes beams fram-
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ing between the perimeter columns. Note that the connection
between the beams and the columns is modeled as fully moment
resistant, as one would typically expect for a concrete structure.
The Flat Slab with Perimeter Beams form includes the following
areas:

 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab. These distances must be greater
than or equal to zero. They cannot be negative.

 Drop Panels: Checking the Drop Panels check box includes
drop panels in the model. If the check box is not checked no
drop panels are included. Figure 4-3 illustrates a flat slab with
drop panels and perimeter beams.

The drop panels are typically assumed to be square and cen-
tered on the columns, which are located at all grid line inter-
sections. The Size item for drop panels is the length of one side
of the drop panel. If the drop panel occurs at a perimeter col-
umn and the edge distance at that location is less than one-half
the drop panel size, the drop panel is truncated at the edge of
the slab.

Figure 4-3:
Flat Slab System
With Perimeter
Beams
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Note that the thickness (depth) of the drop panel is controlled
by the section property assigned to it in the Structural System
Properties area of the form.

 Restraints at Bottom: You can specify no restraints (sup-
ports), pinned restraints (UX, UY and UZ restrained and RX,
RY and RZ free), or fixed restraints (UX, UY, UZ, RX, RY
and RZ restrained) at the bottom of all columns.

 Structural System Properties: Here you specify frame sec-
tion properties to be assigned to the columns and perimeter
beams and you specify slab section properties to be assigned to
the slab and drop panels. The items in this area are:

 Column: Specify frame section properties for all of the
columns in the template model.

 Beam: Specify frame section properties for all perimeter
beams in the template model.

 Slab: Specify the slab section property for the floor slab,
excluding the drop panels.

 Drop: Specify the slab section properties for all of the
drop panels in the template model.

 Load: The Dead Load Case drop-down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
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cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box applies a rigid diaphragm con-
straint to the area object representing the slab and drop panels.

 Mesh Area for Analysis: Checking the Mesh Area for Analy-
sis check box directs the program to mesh the slab immedi-
ately. Because you are just beginning to develop your model, it
may be desirable to leave this check box unchecked,  at least in
larger models. Meshing causes the program to slow down,
which on larger models, can mean make a significant differ-
ence to speed of model development. We recommend that you
finish all modeling input and then apply automatic meshing
just before running an analysis. Automatic meshing is de-
scribed the "Mesh Areas Command" section in Chapter 5 Edit
Menu.

Waffle Slab Button - Waffle Slab Form

Clicking the Waffle Slab button on the Building Plan Grid Sys-
tem and Story Definition form brings up the Waffle Slab form,
which allows you to define a concrete waffle slab floor system
with drop panels (solid column heads) and perimeter beams.
Note that the connections between the ribs and either other ribs
or the columns are modeled as fully moment resistant, as one
would typically expect for a concrete structure. The Waffle Slab
form includes the following areas:

 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab. These distances must be greater
than or equal to zero. They cannot be negative.

 Drop Panels and Ribs: Checking the Drop Panels check box
means to include drop panels (solid heads) in the model. If the
check box is not checked, no drop panels will be included in
the model.

Note:

In waffle slabs,
the program
does not con-
sider the rec-
tangular space
between the
centerlines of
four adjacent
ribs (joists) to
be filled with a
drop panel un-
less the drop
panel size
specified fully
fills that space.
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The drop panels are typically assumed to be square and cen-
tered on the columns, which are located at all grid line inter-
sections. The Size item for drop panels is the length of one side
of the drop panel. If the drop panel occurs at a perimeter col-
umn and the edge distance at that location is less than one-half
the drop panel size, the drop panel is truncated at the edge of
the slab. Figure 4-4 illustrates a waffle slab system.
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The actual size of a drop panel included in a model may be less
than was input into the template. This happens because in waf-
fle slabs, the program does not consider the rectangular space
between the centerlines of four adjacent ribs (joists) to be filled
with a drop panel unless the drop panel size specified fully fills
that space. The drop panel is ignored in any rectangular space
between adjacent ribs that it does not fully fill.

Note that the thickness (depth) of the drop panel is controlled
by the section property assigned to it in the Structural System
Properties area of the form.

Checking the Ribs check box will include waffle slab ribs in
the model. If the check box is unchecked, no slab ribs will be
included.

Ribs are always provided interconnecting the columns. The rib
spacing specified is the typical center-of-rib to center-of-rib
spacing that applies to each bay of the structure. When the
specified rib spacing is not an exact multiple of the bay width,
the ribs are still typically spaced at the specified rib spacing.
Any required uneven spacing will occur between the ribs on
the grid lines interconnecting the columns and the first adja-
cent rib. This uneven space is always larger than the specified
rib spacing. We assume that you will manually adjust the
width of the ribs (beams) on the grid lines if necessary to
maintain a constant form size for your waffle slab.

An example of rib spacing is shown in the next subsection for
a one-way ribbed slab.

 Restraints at Bottom: You can specify no restraints (sup-
ports), pinned restraints (UX, UY and UZ restrained and RX,
RY and RZ free), or fixed restraints (UX, UY, UZ, RX, RY
and RZ restrained) at the bottom of all columns.

 Structural System Properties: Here you specify frame sec-
tion properties to be assigned to the columns and ribs and you
specify slab section properties to be assigned to the slab and
drop panels. The items in this area are:
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 Column: Specify frame section properties for all columns
in the template model.

 Ribs: Specify frame section properties for all waffle slab
ribs (in both the X and Y directions) in the template model.

 Slab: Specify slab section properties for the floor slab, ex-
cluding drop panels.

 Drop: Specify slab section properties for all drop panels in
the template model.

 Load: The Dead Load Case drop down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box applies a rigid diaphragm con-
straint to the area object representing the slab and drop panels.

 Mesh Area for Analysis: Checking the Mesh Area for Analy-
sis check box directs the program to mesh the slab immedi-
ately. Because you are just beginning to develop your model, it
may be desirable to leave this check box unchecked,  at least in
larger models. Meshing causes the program to slow down,
which on larger models, can mean make a significant differ-
ence to the speed of model development. We recommend that
you finish all modeling input and then apply automatic mesh-
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ing just before running an analysis. Automatic meshing is de-
scribed the "Mesh Areas Command" section in Chapter 5 Edit
Menu.

Two-Way or Ribbed Slab Button - Ribbed Slab Form

Clicking the Two Way or Ribbed Slab button on the Building
Plan Grid System and Story Definition form brings up the
Ribbed Slab form, which allows you to define a concrete flat
slab floor system with beams interconnecting all of the columns.
No drop panels are included in this template. Note that the con-
nection between the beams and the columns is modeled as fully
moment resistant, as one would typically expect for a concrete
structure. The Ribbed Slab form includes the following areas:

 Overhangs: These are the distances from the perimeter grid
line to the edge of the slab. These distances must be greater
than or equal to zero. They cannot be negative.

 Ribs: Checking the Ribs check box will include the one-way
slab ribs (joists) in the model. If the check box is unchecked,
no slab ribs are included in the model. The Rib Spacing must
be specified by the user. The Direction of Rib can be in either
the X or the Y direction. Figure 4-5 illustrates a ribbed slab
system. Figure 4-6 illustrates a two way slab system.

 Restraints at Bottom: You can specify no restraints (sup-
ports), pinned restraints (UX, UY and UZ restrained and RX,
RY and RZ free), or fixed restraints (UX, UY, UZ, RX, RY
and RZ restrained)  at the bottom of all columns.

 Structural System Properties: Here you specify frame sec-
tion properties to be assigned to the columns and beams and
you specify slab section properties to be assigned to the slab.
The items in this area include the follow:

 Column: Specific section properties for all columns in the
template model.
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 Beam X: Specific section properties for all beams in the
template model that span in a direction parallel to the X-
axis.

 Beam Y: Specific section properties for all beams in the
template model that span in a direction parallel to the Y-
axis.

 Slab: Specify slab section properties for the floor slab.

 Load: The Dead Load Case drop down box lists all defined
static loads that are type Dead. You can choose any one of
these load cases in the drop-down box (in most cases there will
probably be only one) and then define additional uniformly
distributed dead load for that case in the Dead Load (Addi-
tional) box. The word additional is used to indicate that it is in
addition to the self weight you specify using the self weight
multiplier when you define the static load case (see "Static
Load Cases Command" in Chapter 7 Define Menu for more in-
formation).

The Live Load Case drop-down box lists all defined static
loads that are type Live. You can choose any one of the load
cases in the drop-down box and then define uniformly distrib-
uted live load for that case in the Live Load box.

 Create Rigid Floor Diaphragm: Checking the Create Rigid
Floor Diaphragm check box applies a rigid diaphragm con-
straint to the area object representing the slab and drop panels.

 Mesh Area for Analysis: Checking the Mesh Area for Analy-
sis check box directs the program to mesh the slab immedi-
ately. Because you are just beginning to develop your model, it
may be desirable to leave this check box unchecked,  at least in
larger models. Meshing causes the program to slow down,
which on larger models, can mean make a significant differ-
ence to the speed of model development. We recommend that
you finish all modeling input and then apply automatic mesh-
ing just before running an analysis. Automatic meshing is de-
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scribed the "Mesh Areas Command" section in Chapter 5 Edit
Menu.

Grid Only Button

If you select the Grid Only button, a grid will be added to your
model without any structural objects. You can then:

 Use the commands from the Draw menu to draw objects (see
Chapter 8 Draw Menu for more information).

 Use the Edit menu > Add to Model from Template com-
mand to add objects to your model (see the "Add to Model
from Template Command" section in Chapter 5 for more in-
formation).

 Import stories from a SAFE .f2k file (see the "Import Com-
mand" section later in this chapter).

 Import stories from another ETABS .edb file (see the "Import
Command" section later in this chapter).

 Copy objects (geometry only) from another ETABS .edb file
(see the "Cut, Copy, Paste and Delete Command" section in
Chapter 5 for more information).

 Copy objects (geometry only) from a spreadsheet (see the
"Cut, Copy, Paste and Delete Command" section in Chapter 5
for more information).

 Use commands from the Edit menu to modify existing objects
(see Chapter 5 Edit Menu for more information).

Open Command
To open an existing version 7 or later model, click the File menu
> Open command or the Open .EDB File button  located on

the toolbar, or hold down the Ctrl key and type O to bring up the
Open Model File form. Find the name of the file you want to
open in this form and double click on it so that it appears in the
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File Name box. Alternatively, you can type the name of the file
into the File Name box, including the path if necessary. Then
click the Open button.

Another way to open an existing model is to select it from the
list of recently opened models that is displayed near the bottom
of the File menu. This list appears just below the Delete Analy-
sis Files command and just above the Exit command. If the
model you want to open appears in this list, click on its name to
open it. Note that this list is maintained in the ETABS.ini file
that is kept in your Windows or WinNT directory. If this file is
moved or lost, your list of recently used files disappears.

Backup Files
When you open an existing .edb file, the program always imme-
diately creates a backup of that file. The backup file has the same
name as your .edb file but it has a .ebk extension. The .ebk file is
not undated unless you close the .edb file and then reopen it. The
.ebk file is a binary file, not a text file. If your .edb file should
somehow become corrupted or lost, you always have a backup of
the file in the .ebk file, as it was when you last opened the .edb
file. If you need to access the .ebk file, simply change its exten-
sion to .edb and use it like a regular .edb file. Thus, in addition to
saving your .edb file frequently, it may also be advisable to close
and reopen it from time to time to update the .ebk backup file.

Important Note: There is not an AutoSave feature in this pro-
gram. Thus, it is fully your responsibility to save your model.

Save and Save As Commands
To save your model, click the File menu > Save command or
the Save Model button  the toolbar, or hold down the control

key and type S. If you have just created your model and this is
the first time you are saving it, the Save Model File As form ap-
pears where you can specify a location (directory) and name for

Tip:

Save your file
often!
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your model file. Specify the location and name in the form and
click the Save button to save your model.

If your model previously existed or has been previously saved,
clicking the File menu > Save command or the Save Model
button immediately saves your model in the previously specified
location, overwriting any earlier versions of the model.

Important Note: There is not an AutoSave feature in this pro-
gram. Thus, it is fully your responsibility to save your file. We
recommend that you make it a habit to save your model file early
and often. This helps minimize the lose of work that may result
from power failures, computer malfunctions or unforeseen soft-
ware behavior.

If you want to save your model in a new location or with a new
name, use the File menu > Save As command. The Save Model
File As form appears where you can specify a location (direc-
tory) and name for your model file.

If a File Becomes Corrupted
When you save a model file, the program actually saves two dif-
ferent files. First it saves a text file with the same name as your
.edb file but with a .$et extension. Then it saves your ETABS
database file for your model with a .edb extension.

The text file with the .$et extension is intended as a text backup
file of your .edb file, which is a binary file. If something happens
to the .edb file of your model, such as the file becomes corrupted
or it is otherwise lost, you can restore your model by importing
the .$et file. Use the File menu > Import > ETABS8.e2k Text
File command to import a .$et file. Specify the name of your .$et
file, including the .$et extension, in the resulting form.

Note that a .$et file is exactly the same as a .e2k file that you can
export using the File menu > Export > Save Model as
ETABS8.e2k Text File command. The .$et file is created (and
the previous .$et file is overwritten) every time you save your
model. The .e2k files are only created when you use the File
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menu > Export command, or when you copy a .$et file and give
it a .e2k extension, or when you create one from scratch. We do
not recommend that you try to create a text input file for
ETABS.

Also note the information about .ebk files (backup files) in the
previous "Save and Save As Commands" section.

Import Command
You can import certain types of files into the program using the
File menu > Import command. Following are the options avail-
able for this command.

 ETABS8.e2k Text File: This option is used to import
ETABS8 .e2k and .$et text input files. If another model is cur-
rently open, this option will close that model (prompting you
to save it if necessary) and open a new one for the imported
file.

 ETABS7 Text File: This option is used to import an ETABS7
text input file. ETABS7 Steeler, Conker and Waller input files
are not imported. If another model is currently open,  this op-
tion will close that model and open a new one for the imported
Note:

ETABS6 analy-
sis input files
can be im-
ported into
ETABS7.
ETABS6
Steeler, Conker
and Waller
input files can
not be imported
into ETABS7 or
later versions.
Import Command 4 - 27

file.

 DXF File:  This option is used to import a .DXF drawing file.

 CIS/2 Step File:  This option is used to import a file created
using the CIMsteel Integration Standard (CIS). CIS is a set of
formal computing specifications used in the steel industry to
make software applications mutually compatible. This file type
is often used by steel fabricators outside the United States.
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Export Command
You can export certain types of files using the File menu > Ex-
port command. Following are the options available for this
command.

Export files for Use in CSI Programs
 Save Model as ETABS8.e2k Text File: This option saves the
model as a .e2k text input file. You can later import this
file/model back into ETABS using the File menu > Import >
ETABS8.e2k Text File command if you wish.

 Save Model as SAP2000.s2k Text File: This option saves the
analysis model (an element-based model rather than the
ETABS object-based model) as a .s2k text input file. You can
later import this file/model into SAP2000 if you wish.

Because the model is converted into an element-based model,
you may not recognize the names of the elements. They may
be different from the names of the objects in your object-based
ETABS model.

This option can be useful if you want to see exactly what the
analysis model looks like for your structure. It is also useful if
you want to add certain other special purpose elements to your
model that are not available in ETABS, such as Solid ele-
ments. Note however that once you export your ETABS model
to SAP2000, you cannot then import that SAP2000 model
back into ETABS. Thus, you will no longer have access to the
specialized design features in ETABS.

 Save Story as SAFE.f2k Text File: This command saves the
specified story level as a SAFE.f2k text input file. You can
later import this file/model into SAFE if you wish.

The items exported in this case are:

 Structural objects and their assignments, assuming those
assignments are valid in SAFE.

Note:

You can export
the ETABS
analysis model
to a SAP2000
.s2k file. The
element-based
analysis model
is different from
the typical ob-
ject-based
ETABS model.
See Chapter 2
for additional
information
about the dif-
ferences.
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 Grid line definitions.

 Loads.

 Information regarding columns above and below.

This command can be useful if you want to use SAFE to per-
form a more refined analysis and design of the concrete floor
that is in your ETABS model. You cannot later import this re-
vised file back into your ETABS model.

 Save Story as ETABS8 .edb File: This command saves the
specified story level as an ETABS8 .edb. If the story you are
exporting is the bottom story of a structure, the restraints are
included in the exported one-story model. If the story level ex-
ported is not the bottom level of a structure, ETABS fixes the
base of all columns and walls in the exported one-story struc-
ture.

Export Files for Use in AutoCAD
 Save as .DXF File: This command is used to transfer full or
selected parts of the model into AutoCAD. It provides easy to
use features to customize the drawing before transferring to
.DXF by selecting appropriate attributes for various ob-
jects/elements and text. A full 3D model, including node sym-
bols and frame members, can be transferred. The program does
not export any analysis output results. All items that are ex-
ported must be showing in the currently active window when
the export operation is executed.

Note that plan views that occur either at story levels or at ref-
erence plane elevation can be exported to a .DXF file. Only the
elements that occur in the horizontal plane of the plan view are
exported. Other elements that are a part of the story level that
is associated with the plan view are not exported.

The types of items listed below can be exported to a .DXF file
in a plan view. A layer name can be specified for each of those
types of items. You can put several different types of items on

Tip:

When exporting
a plan view to a
.DXF file all
items that are
to be exported
must be visible
in a plan view
in the currently
active window.

Note:

The .DXF files
created by
ETABS are
compatible with
AutoCad 2000.
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the same layer if you wish. If you do not want to export a par-
ticular type of item even though it is showing in the plan view,
set its layer name to None.

 Grid lines: These are exported to the .DXF file as lines.
This item includes the grid line and the grid ID bubble if it
exists, but not the grid ID. The grid ID is exported with the
text.

 Walls: These are exported to the .DXF file as polylines so
that their width can be graphically shown.

 Beams: These are exported to the .DXF file as lines. You
can also specify a beam offset. This is the distance be-
tween the end of the beam and its supporting girder or col-
umn in the .DXF file.

 Moment connection block: This is exported to the .DXF
file as a block. It includes the moment connection symbols
for the beams. The moment connections will only export if
they are visible in the currently active window. Use the
Moment Connections check box in the Special Frame
Items area of the Set Building View Options form to tog-
gle the display of moment connection symbols on and off.
You can use the View menu > Set Building View Op-
tions command to access this form.

 Links: These are exported to the .DXF file as lines.

 Slab/deck perimeter: This is exported to the .DXF file as
a polyline.

 Column block: This is exported to the .DXF file as a
block. It shows the shapes of the columns as they appear in
the plan view.

 Dimension lines: These are exported to the .DXF file as
dimension lines.

Note:

ETABS does
not export
analysis results
to .DXF files.
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 Text: Text is exported to the .DXF file as text. Only text
that is visible in the currently active window is exported.
Text associated with analysis output is not exported.

 Grid lines: These are exported to the .DXF file as lines.
This item includes the grid line but not the grid ID bubble
or the grid ID text. Grid lines exported in this way are only
shown at the base of the building.

 Areas: Area objects are exported to the .DXF file as
polylines.

 Lines: Line objects are exported to the .DXF file as lines.
You cannot specify a beam offset for a 3D .DXF file like
you can for a plan view .DXF file.

Export Files for Use in Access
 Save Input/Output as an Access database file: This com-
mand exports all of the model input and analysis output as ta-
bles in a Microsoft Access database file (.mdb file) that is
compatible with Microsoft Access 97.

Export Files to an Enhanced Metafile
 Save Graphics as Enhanced Metafile: This command ex-
ports all that is graphically showing in the currently active
window to a Windows enhanced metafile (.*.emf file).

Export Files to a CIS/2 Step File
 CIS/2 STEP File: This command is used to export a file using
the CIMsteel Integration Standards (CIS). CIS is a set of for-
mal computing specifications used in the steel industry to
make software applications mutually compatible. This file type
is often used by steel fabricators outside the United States.
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Export Files to a Steel Detailing Neutral File
 Steel Detailing Neutral File: This command is used to export
a file using the Steel Detailing Neutral File computing specifi-
cation standards. This file type is often used by steel fabrica-
tors in the United States.

Create Video Command
You can create videos in the program showing the movement of
the structure during any time history analysis you have run. You
can also create videos showing animations of mode shapes and
other deformed shape plots of the structure. The videos are saved
as .avi files. They can be played back using the Window's media
player.

Time History Animation Command
Use the File menu > Create Video > Time History Animation
command to create videos of time histories. Note the following
for time history videos:

 The magnification factor controls how large the deformations
appear in the video.

 To record the time history file in real time animation, make
sure that the number of frames per second is equal to one over
the time increment. If you want to record the time history
video in slow or fast motion, the value of number of frames per
second may be adjusted up or down to speed the animation up
or slow it down.

The time increment controls how many different pictures
(frames) of the deformed shape of the structure are created. For
example, a time increment of 0.1 means a picture (frame) of
the deformed shape is created for every one-tenth second of
the time history. The Frames per Second item controls how
fast the time history is played back.

Tip:

You can create
videos of time
history re-
sponse in
ETABS (as .avi
files) and then
play back the
videos.
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 For best results make sure that all program windows are
showing undeformed views before attempting to create a time
history video.

Cyclic Animation Command
Use the File menu > Create Video > Cyclic Animation com-
mand to create videos of animated mode shapes and other de-
flected shapes. A mode shape or deformed shape must be show-
ing in the active window for this command to be available.

Print Setup Command
Clicking the File menu > Print Setup command brings up the
Print Page Setup form. This form has two selection areas:

 Lines Per Page area has a No Page Ejects check box and De-
fault and User Defined selections. If the No Page Ejects check
box is checked, the print out will be continuous. Use this check
box if your printer has continuous feed paper, which is often
referred to as "computer paper." The Default selection will
print 56 lines per page, which is the standard length for 8 1/2 x
11 inch paper. The User Defined selection allows you to enter
your own number of lines per page.

 Titles area allows you to add a Project Title and a Data Title to
your print out. Click in the edit box and type your desired title.
These titles will appear at the top of each page of the printout.

A Color Printer (Graphics) check box is also on the form;
checking this check box tells the printer to use colors in the print
out. Remember to use a printer capable of printing in color to
take advantage of this selection.

Click the OK button to accept the selection you have made on
the form. Clicking the Cancel button cancels any selection
made.
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The Setup button brings up the Print Setup form. This form al-
lows you to select the printer, the paper size and the paper ori-
entation for your print out.

Print Preview for Graphics Command
Clicking the File menu > Print Preview for Graphics com-
mand brings up the Print Preview form. This form provides a
snap shot of how the file will print in graphical format. The form
is equipped with zoom tools that enable you to zoom into the
snap shot for a closer look at your print out before printing.

The form has a drop-down box with various selections for sizing
your print out. For example, the Print to Page selection will print
your graphics to fit the size of paper defined for your printing
device. You can also select specific scaling for your printout,
such as 1 inch equals 1 foot, 1 inch equals 2 feet and so forth. A
User Scale selection is also available that allows you to pick
your own scaling for the output. This scaling applies only to the
print out and has no effect on the model file itself.

To close the Print Preview form, select either the Close button,
which will return you to your model without printing, or the
Print button, which will send your print to your printer.

Print Graphics
The File menu > Print Graphics command or  toolbar

button prints whatever graphics are displayed in the active win-
dow to the printer that is currently specified as active. The
printer used may be either a black and white printer or a color
printer. The gray scales or colors used for displaying various
objects in the print out are controlled in the Assign Display Col-
ors form, which is accessed using the Options menu > Colors
command.

The colors (grayscales) used for black and white printers are
those displayed in the Assign Display Colors form when the De-

Note:

The File menu
> Print Preview
for Graphics
command al-
lows you to
preview the
printed output
for graphics
before actually
printing it.
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vice Type option is set to Printer. The colors used for color
printers are those displayed in the Assign Display Colors form
when the Device Type option is set to Color Printer. The colors
used for display on the screen are those displayed in the Assign
Display Colors form when the Device Type option is set to
Screen. If the object display colors are set differently for screen
display and color printing, the objects' colors in print will be dif-
ferent from their colors displayed on screen.

Print Tables Command
You can use the File menu > Print Tables command to print
text tables either to a printer or to a text file. The following types
of tables can be printed using this command:

 Analysis input data

 Analysis output data

 Design input and output data for steel frame design, concrete
frame design, composite beam design and shear wall design.

When you use the File menu > Print Tables command, note the
following:

 If you select some objects before executing the File menu >
Print Tables command, the printed output will be for the se-
lected objects only.

 If you do not select some objects before executing the File
menu > Print Tables command, the printed output will be for
all objects in the model.

Input Command
Use the File menu > Print Tables > Input command to print
tables of analysis input data to a printer or to a text file. This
command brings up the Print Input Tables form where you can
specify the types of input data that you want to print.
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Note that you can use the Display menu > Set Input Table
Mode command to display similar data in a database format on
the screen. Data displayed in this manner cannot be printed.

Analysis Output Command
Use the File menu > Print Tables > Analysis Output command
to print tables of analysis output data to a printer or to a text file.
This command brings up the Print Output Tables form where
you can specify the types of output data that you want to print.

Note that you can use the Display menu > Set Output Table
Mode command to display similar data in a database format on
the screen. Data displayed in this manner cannot be printed.

Design Tables Commands
The program has the capability to generate output table files for
Steel Frame, Concrete Beam, Composite Beam and Shear Wall.
Use the File menu > Print Tables, and then the respective op-
tion command (Steel Frame Design command, Concrete
Frame Design command, Composite Beam Design command,
or Shear Wall Design command) to print tables of design output
data to a printer or to a text file.

User Comments and Session Log Command
The File menu > User Comments and Session Log command
brings up a text window where you can type in any comments
that you want to make. Those comments are saved with your
model and can be accessed and added to, modified or deleted at
any time using the File menu > User Comments and Session
Log command. Note that the program also occasionally adds
comments to this file. You can modify or delete those comments
as well.
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Last Analysis Run Log Option
Use the File> Last Analysis Run Log option to open and view
the analysis log file of the last analysis. The file is saved as plain
text with a .$og extension. It can be opened using any text
viewer/editor, including Notepad. The log file contains useful
overall information about the model, analysis and the output.
The information cover the statistics of the model (for example,
the total number of elements, nodes, supports, load cases, and
other similar data), solution sequences, number of equations,
storage space required and available solution status, errors,
warnings and successful completion of the analysis as well as
other pertinent information. The file also shows the number of
iterations and convergences obtained at each step for nonlinear
and Eigen value solutions. The user can open this file at any time
after the analysis has been run to identify and understand any
analysis problem such as instability, numerical errors, or the like.

Display Input/Output Text Files Command
The File menu > Display Input/Output Text Files command
provides a convenient way for you to view input and output text
files associated with this program. The input text files you might
want to view include those with the .$et and .e2k extensions and
perhaps any time history or response spectrum text files that you
are using. The output files that you might want to view are those
where you have printed output to a file rather than to a printer.
Typically, those files have a .txt extension.

When you click the File menu > Display Input/Output Text
Files command and select a file to be displayed, the program
opens the text file in the Windows WordPad program.

Delete Analysis Files Command
You can use the File menu > Delete Analysis File command to
delete temporary analysis files associated with the current model.
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After obtaining the results, use of this command will "free up"
hard drive capacity.

Exit Command
Use the File menu > Exit command to exit the program. Also
exit by clicking the X in the upper right-hand corner of the win-
dow, or right clicking the program button on your Windows
taskbar and choosing Close from the popup menu. If the model
has changed since it was last saved, the program will prompt you
to save your model before exiting.

Note that using these ways to exit the program not only closes
the model, but also closes the entire program. To close one
model and open another (or start a new one), click on the appro-
priate command in the File menu to open another model or to
start a new one. If you have made changes to your model since
you last saved it, the program will prompt you to save your
model before beginning work on the next file.
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Chapter 5

Edit Menu

General
The Edit menu provides basic tools for editing (modifying) the
geometry of your model. This chapter describes many of those
tools.

 Undo and Redo Commands
Clicking the Undo option or  button or holding down the Ctrl
key and typing Z deletes the last performed action. The Redo

option,  button, or Ctrl Y allows the user to restore the last
step that was undone. Some commands, such as Auto Relabel
All, cannot be undone.
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Cut, Copy and Paste Commands
In general, the cut, copy and paste commands are similar to the
standard cut, copy and paste Windows commands. However,
some behavior of the commands is specific to this program.

The cut, copy and paste commands are only active when the cur-
rently active window is in plan or plan perspective view.

 The Cut command,   button, or Ctrl X  deletes the se-

lected objects of the story level shown in plan view of the ac-
tive window. When the objects are deleted, all of their as-
signments are also deleted. The geometry of the objects are
copied to the Windows clipboard. Additionally, the names of
any frame section properties assigned to selected line objects
or the names of any wall/slab/deck section properties assigned
to selected area objects are copied to the clipboard along with
the geometry. No other assignments to the object are copied
to the clipboard. The geometry and section property names
associated with the cut objects can be pasted back into the
program, or they can be copied to a spreadsheet, such as Mi-
crosoft Excel, in a text format. Additional description of the
spreadsheet option is provided later in this section.

 The Copy command,  button, or Ctrl C copies to the

Windows clipboard; this command copies the geometry of the
selected objects of the story level shown in plan view of the
active window. The names of any frame section properties as-
signed to selected line objects or the names of any
wall/slab/deck section properties assigned to selected area
objects are copied to the clipboard along with the geometry.
The geometry and section property names associated with the
copied objects can be pasted back into the program, or they
can be copied to a spreadsheet, such as Microsoft Excel, in a
text format. Additional description of the spreadsheet option
is provided later in this section.

 The Paste command,  button, or Ctrl V copies geometry

and section property names from the Windows clipboard into

Tip:

The Cut and
Copy com-
mands copy
geometry and
property names
only. Use the
Edit menu >
Replicate com-
mand to copy
an object and
its assignments.
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the model on the story level shown in plan or plan perspective
view in the currently active window. The geometry and sec-
tion property names that are on the Windows clipboard may
have been copied to the clipboard from this program or from
a spreadsheet.

It is important to note that the Cut and Copy commands only
copy the geometry and property name of the selected object to
the Windows clipboard. Other assignments made to the selected
object are not copied using these commands.

Using a Spreadsheet to Create or Modify Model Geometry
and Section Properties

You can edit geometry in a spreadsheet and then copy and paste
it into the program. Again note that you can only create and/or
modify geometry and some section properties in this fashion.
You cannot make assignments (loads, supports, end offsets, or
the like) through spreadsheet input.

You can see the text format used when the program geometry is
copied to or from a spreadsheet by selecting a portion of a
model, clicking Edit menu > Copy to copy the selected geome-
try to the clipboard, and then opening a spreadsheet and using
the Paste command in the spreadsheet to paste the geometry data
into the spreadsheet. The appropriate toolbar buttons or the Ctrl
key strokes can also be used for these actions.

In the spreadsheet, each object is described in one line. Follow-
ing are descriptions of the column headings for each of the three
object types (point, line and area).

Point Object
The point object data copied from the model and into a spread-
sheet or copied from the spreadsheet into the model using the
Copy command is organized in the spreadsheet under the fol-
lowing column headings:

Note:

You can edit
geometry in a
spreadsheet
and then copy
and paste it into
the program.
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Heading Description - Point Objects

Type: This is always POINT for point objects.

X: This is the global X coordinate of the point object.

Y: This is the global Y coordinate of the point object.

DZ: This is the Z-direction distance from the story level
associated with the plan view where the object is
pasted into the program to the point object. DZ is 0
if the point object is at the associated story level.
Otherwise, it is a positive number measured from
the story level down.

Note that if the currently active plan view is show-
ing a reference plane, a DZ value of zero pastes
the object in at the story level associated with the
reference plane, not at the reference plane level.
See the section entitled "Edit Reference Planes
and Edit Reference Lines Commands" later in this
chapter for a description of reference planes.

Line Objects
The line object data copied from the model and into a spread-
sheet or copied from the spreadsheet into the model using the
Copy command is organized in the spreadsheet under the fol-
lowing column headings:

Heading Description - Line Objects

Type: This is always LINE for line objects.

Section: This is the name of the frame section property as-
signed to the line object. If no frame section prop-
erty is assigned to the line object, it is NONE.

If a line object has a frame section property name
in a spreadsheet and the frame section property
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Heading Description - Line Objects

has not already been defined in the model, when
spreadsheet data is pasted into the model, the pro-
gram sets the frame section property assignment
for that object to NONE. For example, assume a
line object has a frame section property name of
COL1 in a spreadsheet. Also assume that no pre-
viously defined frame section property named
COL1 is included in the model. In that case, when
the spreadsheet data is pasted into the model, the
program sets the property assignment for that line
object to NONE.

The following items are provided for each end point of the line
object:

XI (XJ): This is the global X coordinate of the considered
end point of the line object.

YI (YJ): This is the global Y coordinate of the considered
end point of the line object.

DZI
(DZJ):

This is the Z-direction distance from the story level
of the plan view where the line object is pasted into
the program at the considered end point of the line
object. DZ is 0 if the end point is at the associated
story level. Otherwise, it is a positive number
measured from the story level down.

Note that if the currently active plan view is show-
ing a reference plane, a DZ value of zero pastes
the object at the story level associated with the ref-
erence plane, not at the reference plane level. See
the section entitled "Edit Reference Planes and
Edit Reference Lines Commands" later in this
chapter for a description of reference planes.

BelowI This is a flag that indicates if the considered end
point of the line object is at the story level below the
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Heading Description - Line Objects

(BelowJ): story level associated with the plan view where the
line object is to be pasted into the model. This item
can either be Y for Yes or N for No. Y means it is at
the story level below where it is pasted; N means it
is not. When the item is Y, any value input for DZ is
ignored and the end point is simply placed at the
story level below where it is pasted into the model.

An example where this is used is for a column. The
bottom end point of a column typically has this flag
set to Y. This way a column can be pasted into a
story of any height and it will always span from
story level to story level.

Area Objects
The area data copied from the model and into a spreadsheet or
copied from the spreadsheet into the model using the Copy
command is organized in the spreadsheet under the following
column headings:

Heading Description - Area Objects

Type: This is always AREA for area objects.

Section: This is the name of the wall, slab or deck section
property assigned to the area object. If no section
property is assigned to the area object, it is NONE.

If an area object has a property name in a spread
sheet and the property has not already been de-
fined in the model, when the spreadsheet data is
pasted into the model, the program sets the prop-
erty assignment for that object to NONE. For ex-
ample, assume that an area object has a property
name of WALL1. Also assume that no previously
defined wall, slab or deck section property named



Chapter 5 - Edit Menu

Cut, Copy and Paste Commands 5 - 7

5

Heading Description - Area Objects

WALL1 is included in the model. In that case, when
the spreadsheet data is pasted into the model, the
program sets the property assignment for that area
object to NONE.

Points: This is the number of corner points in the area ob-
ject.

The following items are provided for each corner point, n, of the
area object where n represents a number 1 through the number
of corner points in the area object:

X-n: This is the global X coordinate of the considered
corner point of the area object.

Y-n: This is the global Y coordinate of the considered
corner point of the area object.

DZ-n: This is the Z-direction distance from the story level
associated with the plan view where the area object
is pasted into the model to the considered corner
point of the area object. DZ is 0 if the corner point
object is at the associated story level. Otherwise, it
is a positive number measured from the story level
down.

Note that if the active plan view is showing a refer-
ence plane, a DZ value of zero pastes the object in
at the story level associated with the reference
plane, not at the reference plane level. See the
section entitled "Edit Reference Planes and Edit
Reference Lines Command" later in this chapter for
description of reference planes.

Below-N: This is a flag that indicates if the considered corner
point of the area object is at the story level below
the story level associated with the plan view where
the area object is pasted into the model. This item
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Heading Description - Area Objects

can either be Y for Yes or N for No. Y means it is at
the story level below where it is pasted; N means it
is not. When the item is Y, any value input for DZ is
ignored and the corner point is simply placed at the
story level below where it is pasted into the model.

A wall is an example of where this feature is used.
The bottom corner points of a wall typically have
this flag set to Y. This way a wall can be pasted
into a story of any height and it will always span
from story level to story level.

Delete Command
In general, the Delete command or  toolbar button in this

program works like the standard Windows delete command. This
command deletes the selected object(s) and all of its assignments
(loads, properties, supports and the like). Alternatively, select the
object(s) and press the Delete key on the keyboard to delete the
selected object(s).

Add to Model from Template Command
Use the Edit menu > Add to Model from Template command
to add two-dimensional and three-dimensional frames to your
model.

The two-dimensional option can be used to locate planar frames
throughout a model. The three-dimensional option can assist in
modeling conditions where several towers rest on the same base
structure.
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Add to Model From Template > Add 2D Frame Command
Click the Add to Model From Template > Add 2D Frame
command to add a two-dimensional frame or wall to your model.
When the 2D Frame form appears, select wall or frame using the
Click Picture of Choice buttons. This brings up the Portal Fame
form, in which you specify the following data:

 Number of stories. The two-dimensional frames are always
assumed to start at the base of the building and extend up-
ward. This is different from the three-dimensional frame op-
tion.

 Number of bays and typical bay width.

 Typical properties for columns and beams in a frame or typi-
cal property for a wall.

 Location in plan. This is the location of one end of the frame
in global X and Y coordinates. You also specify a plan orien-
tation angle for the frame in degrees. The angle is measured
in the global X-Y plane from the positive global X-axis with
positive angles counterclockwise when you look down on the
model.

 The base restraints are specified as pinned, fixed or none.

Add to Model From Template > Add 3D Frame Command
Click the Add to Model From Template > Add 3D Frame
command to add a three-dimensional frame to your model. When
the Structural Floor System Type form appears, select the frame
type to be added to your model by clicking the appropriate but-
ton in the Click Picture of Choice area of the form. You may
recognize the buttons because they are the same as the buttons
used when you start a model from a template. With the exception
of the location data, which is described here for this command,
please refer to the subsection entitled "Add Structural Objects"
under the "New Model Command" section of Chapter 4 File
Menu for a description of these buttons and their functions.  The
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following information is provided to locate the three-
dimensional frame:

 A coordinate system (grid system) is specified. By default,
the added three-dimensional frame fills all of the specified
bays and story levels in this coordinate system (grid system).
If you want to fill only some of the bays or story levels in the
specified coordinate system (grid system), click the Ad-
vanced button and fill in the starting and ending grid line IDs
and the story levels at top and bottom of the frame.

Note that unlike an added two-dimensional frame, an added
three-dimensional frame can start at a story level above the base
level.

Replicate Command
To replicate one or more objects and most of their assignments,
select the object(s) and use the Edit menu > Replicate com-
mand or  toolbar button to specify the desired replication op-

tion. The selected objects, including their assignments, will be
replicated (copied) as specified.
Note:

Replication
copies objects
and their as-
signments.
 - 10 Replicate Command

Important note: When using the replication feature, if an object
to be replicated is targeted to occupy exactly the same location
as an existing object, the replication is not completed at that lo-
cation; the existing object remains. However, if other locations
are targeted and those locations do not contain objects, the repli-
cation is completed at those other locations.

Clicking the Edit menu > Replicate command or the  tool-

bar button brings up the Replicate form. This form has a tab for
each type of replication that is available: Linear, Radial, Mirror,
and Story. Each of these replication types is subsequently de-
scribed  in separate subsections.

Clicking the Options button on any of the tabs brings up the
Replicating Objects Assignment form, which consists of a series
of check boxes for each object type (point, line, and area). Use
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this form to control which assignments you want to replicate by
checking or unchecking the boxes. By default all assignments are
replicated, except for the following, which are never replicated:

 Rigid diaphragm assignments to point objects and area ob-
jects.

 Pier label assignments to line and area objects.

 Spandrel label assignments to line and area objects.

For area and line objects, some assignments are always repli-
cated and you have no control over them. Table 5-1 lists those
assignments.

Table 5-1: Area and Line Object Assignments That Are
Always Replicated

Line Object Assignments Area Object Assignments

Frame section property Section property

End releases (not partial fixity) Opening

Output stations Local axes

Local axes Automatic mesh/no mesh

Automatic mesh/no mesh

Table 5-2 lists the area, line and point object assignments for
which you can control replication.

Table 5-2: Object Assignments with Replication That Can be Controlled

Point Object Assignments Line Object Assignments Area Object Assignments

Panel zones Additional masses Additional masses

Restraints (supports) Line springs Area springs

Additional masses Partial fixities Stiffness modifiers

Point springs End and joint offsets Uniform loads
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Table 5-2: Object Assignments with Replication That Can be Controlled

Point Object Assignments Line Object Assignments Area Object Assignments

Link properties Link properties Temperature loads

Forces Nonlinear hinges (pushover)

Ground displacements Property modifiers

Temperatures Point loads

Distributed loads

Temperature loads

Linear Tab
For linear replication, specify a dx, dy and a number of times the
object is to be replicated on the Linear Tab of the Replicate
form. The object and its assignments are then copied the speci-
fied number of times, incrementing the global X and Y coordi-
nates by the specified dx and dy.

Radial Tab
For radial replication, specify on the Radial Tab a point to rotate
about (the rotation is in the global X-Y plane about the global Z-
axis), a rotation angle, and a number of times the object is to be
replicated. The object and its assignments are then copied the
specified number of times, incrementing the location of the ob-
jects by the specified rotation angle.

Two Rotate About Point options are available: rotate about the
center of the selected objects, or specify global X and Y coordi-
nates of a specific point to rotate about.

When the rotation occurs about the center of the selected objects,
the program calculates the location of that point as follows.
ETABS determines the maximum and minimum global X-
coordinate of all selected objects. The global X-coordinate of the
center of the selected objects is determined as the average of the
coordinates of the maximum and minimum X coordinates. The
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global Y-coordinate of the center of the selected objects is de-
termined in a similar manner.

The rotation angle is input in degrees. Angles are measured from
the positive global X-axis. Positive angles appear counterclock-
wise when you view them from above.

Figure 5-1 shows an example of radial replication. Figure 5-1a
shows a plan view of a frame that extends from the point (10,
20) to the point (30, 20) where the coordinates are given in the
global coordinate system. The frame is selected and radial repli-
cation is specified about the point (20, 30). The angle is set to 90
degrees and the number is set to 3. Figure 5-1b shows the result
of the replication.

Mirror Tab
For mirror replication, specify on the Mirror Tab a line in the
global X-Y plane to mirror about, or if you prefer, think of it as a
vertical plane to mirror about. The vertical plane is defined by
the specified line in the global X-Y plane and vertical line, par-
allel to the global Z-axis, that intersects the specified line.
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You specify the line in the X-Y plane by specifying two points
(X1, Y1) and (X2, Y2) in global coordinates. The program repli-
cates the selected objects by mirroring the objects and their as-
signments about the specified line/plane. Figure 5-2 illustrates
the mirroring process. Note that the projection lines used in the
mirroring process (shown dashed in the figure) are perpendicular
to the specified mirroring line/plane.

Story Tab
For story replication, specify on the Story Tab a story that the
selected objects are to be replicated on. The object and its as-
signments are then copied to that story level. If the story level
where you select the objects and the story level to which you
replicate the objects have different story heights,  be aware of the
following:

 Elements that extend from one story level to the next still ex-
tend from one story to the next when they are replicated, even
if the story heights are different. Figure 5-3a shows some ex-
amples.

 Distances are measured from the top of the story down. If an
object that is to be replicated to story level X is below the
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bottom of story level X, that object is placed at the bottom
story level X; that is, it is placed at story level (X - 1). This
can happen when you are replicating from a story level that is
taller than the story level you are replicating to.

Figure 5-3b shows some examples. Note that the height of the
lower replicated area object on the left side of Figure 5-3b is
reduced from 6 feet to 2 feet when it is replicated to fit into
the 4th story level. Also note that the line object is taken to
the bottom of the story level because the 12-foot dimension
that it is to be replicated to exceeds the story height. Notice
that the plan location of the bottom of the line object remains
the same at each level; thus the slope of the line object is dif-
ferent at the two levels. Similar to the line object, the point
object is placed at the bottom of the 4th story level.

Delete Original Check Box
If the Delete Original check box is checked, the program will
delete the object selected for replication as part of the replica-
tion operation, leaving only the replicated object(s).
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Edit Grid Data Command
The Edit menu > Edit Grid Data command is used to define
new coordinate systems, modify existing coordinate systems and
edit the grid line data associated with the coordinate systems.
The default global coordinate/grid system is a Cartesian (rectan-
gular) coordinate system. Additional coordinate/grid systems can
be defined that are either Cartesian or Cylindrical. Cylindrical
coordinate systems are based on a set of radial and circumferen-
tial grid lines. The following four options, described individu-
ally, are available when you select the Edit menu > Edit Grid
Data command:

Edit Grid Data > Edit Cartesian/Cylindrical System Com-
mand

Clicking the Edit menu > Edit Grid Data > Edit Carte-

sian/cylindrical System command or the  toolbar button
brings up the Coordinate System form, where you can add,
modify, or delete a coordinate system.

Add New System Button
Clicking the Add New System button on the Coordinate System
form will open the Coordinate System Definition form. There are
several areas in this form. The first frame offers a field for the
name of the system. Initially, a default name is given, which can
be changed.

You can specify the grid type as Cartesian or Cylindrical. If the
Cartesian option is selected, specify the number of grid lines and
the line spacing in the X and Y directions. The grids will be
drawn using this spacing in a uniform manner. If the Cylindrical
option is selected, input the grid spacing and number of grids in
the radial and theta directions. Here too the grids will be drawn
with uniform spacing.

Edit Grid Button. To specify non-uniform spacing or change
other default values, click the Edit Grid button. In the Coordi-

Note:

In ETABS you
can have Car-
tesian (rectan-
gular) and/or
cylindrical co-
ordinate/grid
systems.
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nate System form that appears, change the spacing in the X or Y
directions (or Radius and Theta) by first clicking the X Grid or Y
grid option (or Radius and Theta) in the Display area. The table
on the left-hand side of the form will display the selected grids
with their coordinates. If you choose to view the spacing rather
than the coordinates, select the Spacing option under the Display
Grid as area. The values that appear in the table are editable.

Add Primary or Secondary grid lines by selecting the appropriate
option under the area labeled Grid Line # 1. Also change display
settings of the grid such as color, bubble location and the like in
this area. The bubble size can also be edited. Each of these se-
lections is described as follows:

 Grid ID: This is an identifier for the grid line. It can be left
blank if desired.

 Coordinate/Spacing: This is the location of the grid line in
the specified coordinate system. Grid line locations can be
specified by their coordinate or by their spacing.

 Primary/Secondary Grid Lines: You can specify a grid
line as either a primary or a secondary line. Primary grid
lines are intended to represent the main architectural grid
lines of the building. Secondary grid lines are intended as
temporary reference lines for modeling. They do not have a
bubble assigned to them for the grid ID. You can use the
View menu > Set Display Options command to collec-
tively hide the secondary grid lines from view.

 Hide Grid Line: Checking this box for either primary or
secondary grid lines marks them as hidden and they are not
displayed, regardless of the setting specified in the View
menu > Set Display Options feature.

 Switch Bubble Location: Checking this box moves the
bubble location to the other end of the grid line.

 Color: Clicking on the Color box allows you to change the
color of the grid line.
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 Bubble Size: The grid line bubbles are drawn as hexagons.
The bubble size indicates the distance between two opposing
faces of the hexagon measured in the current units of the
model. This size applies to all bubbles in the coordinate/grid
system.

 Hide All Grid Lines: If this box is checked, all grid lines
(primary and secondary) in this coordinate/grid system only
are hidden. If you want to hide grid lines in all coordinate
systems, use the View menu > Set Building View Options
command. When using the View menu > Set Building
View Options command, be sure to turn off both primary
and secondary grid lines.

 Reset to Default Color: Clicking this button sets the color
of all grid lines in this coordinate/grid system back to their
default color. Note that you can use the Option menu >
Colors command to set the default color for grid lines.

 Locate System Origin: Clicking this button brings up a
form that allows you to specify the location of the origin of
the coordinate system relative to the global coordinate sys-
tem. Note that this button is not visible if you are editing the
global coordinate/grid system. In the Locate System Origin
form you specify the following:

 Global X: This is the global X coordinate of the origin
of the coordinate/grid system.

 Global Y: This is the global Y coordinate of the origin
of the coordinate/grid system.

 Rotation (deg): This angle, input in degrees, specifies
the orientation of the positive X-axis (or theta equals 0
degrees radial line in a cylindrical system) of the coordi-
nate system relative to the positive global X-axis. The
angle is measured from the positive global X-axis to the
coordinate system X-axis. Positive angles appear coun-
terclockwise when viewed from above.
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Figure 5-4 shows some examples. The figure shows the global
X-axis and the orientation of the X-axis for the added system.
Figure 5-4a shows an example where the rotation angle is speci-
fied as 30 degrees. Figure 5-4b shows an example where the ro-
tation angle could be specified as either 330 degrees or -30 de-
grees.

Grid Labels Button.  Clicking on the Grid Labels button of the
Coordinate System Definition form will open the Grid Labeling
Options form. All of the features on this form, which include the
starting ID of the grid in either direction and the direction of la-
beling (left to right, right to left, top to bottom or bottom to top),
are self-explanatory.

Modify/Show System Button
Clicking the Modify/Show System Button on the Coordinate
System form will bring up the Coordinate System form. Change
the spacing in the X or Y directions (or Radius and Theta) by
first clicking the X Grid or Y grid option (Radius or Theta) in the
Display area. The table on the left-hand side of the form will
display the selected grids with their coordinates. If you choose to
view the spacing rather than the coordinates, select the Spacing
option under the Display Grid as area. The values that appear on
the table are editable. You can also add Primary or Secondary
grid lines by selecting the appropriate option under the area la-
beled Grid Line # 1. You can also change display settings of the
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grid, such as color, bubble location, and the like in this area. The
bubble size can also be edited here. All of the options available
on this form are the same as those described in the previous sec-
tion entitled "Add New System Button."

Delete System Button
Any system, except the Global system, can be deleted by select-
ing the system and clicking the Delete System button.

Edit Grid Data > Edit General System Command
Clicking the Edit menu > Edit Grid Data > Edit General Sys-
tem command brings up the Grid System form. In the Grid Sys-
tems form, you can add a new system, add a copy of a system,
modify and show the list of systems, and delete a system by se-
lecting the appropriate button. Each of the buttons is described s
follows:

Add New System Button
Clicking the Add New System button on the Grid System form
will open the Grid System Data form. The form has the follow-
ing area:

 Grid System Name: Specifies the name of the grid system.
Accept the default name or specify a different one.

 Click to: Adds a new grid line or modifies or deletes an ex-
isting grid line. Clicking the Add New Grid Line button (or
Modify/Show Grid Line button if a grid line already exists)
will bring up the Grid Line form. Here you can specify the
Grid Line ID, Type of Grid (Straight or Arc) and its Plan
Coordinates. You can also select the story level at which the
grid line is to be included. Checking the Apply to All check
box will include the change in all the levels that lie between
the top and bottom story level selected. Other options avail-
able include:
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 Primary/Secondary Grid Lines: Specify a grid line as
either a primary or a secondary line. Primary grid lines
are intended to represent the main architectural grid lines
of the building. Secondary grid lines are intended as
temporary reference lines for modeling. They do not
have a bubble assigned to them for the grid ID.

 Hide Grid Line: Hides the primary or secondary grid
lines depending on which check box is checked.

 Switch Bubble Location: Moves the bubble location to
the other end of the grid line.

 Color: Changes the color of the grid line.

 Bubble Size: The grid line bubbles are drawn as hexa-
gons. The bubble size indicates the distance between two
opposing faces of the hexagon measured in the current
units of the model. This size applies to all bubbles in the
coordinate/grid system.

 System Origin: The System Origin portion of the Grid Sys-
tem Data form allows you to specify the location of the ori-
gin of the coordinate system relative to the global coordinate
system. Specify the following using the System Origin form:

 Global X: This is the global X coordinate of the origin
of the coordinate/grid system.

 Global Y: This is the global Y coordinate of the origin
of the coordinate/grid system.

 Rotation (deg): This angle, input in degrees, specifies
the orientation of the positive X-axis (or theta equals 0
degrees radial line in a cylindrical system) of the coordi-
nate system relative to the positive global X-axis. The
angle is measured from the positive global X-axis to the
coordinate system X-axis. Positive angles appear coun-
terclockwise when viewed from above.
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Add Copy to System Button
Before clicking the Add Copy to System button, select the sys-
tem you wish to copy from the Systems list box on the left-hand
side of the form. Clicking the Add Copy to System button
brings up the Grid System Data form. This form has options that
allow you to add a copy of the selected grid system to the model
without changing it (click the OK button), or to modify all or
portions of the system, such as adding to the system (click the
Add New Grid Line button) modifying grid lines (click the
Modify/Show Grid Line button), or deleting grid lines from the
system (click the Delete Grid Line button), before adding the
copy to your model.

The Add New Grid Line button works as described in the pre-
vious section entitled "Add New Grid Line Button." The Mod-
ify/Show Grid Line button works as described in the following
section entitled "Modify/Show System Button."  The Delete
Grid Line Button works as described in the subsequent section
entitled "Delete Grid Line Button."

Modify/Show System Button
Before clicking the Modify/Show System button, select the
system you wish to modify or show from the Systems list box on
the left-hand side of the form. Clicking the Modify/Show Sys-
tem button brings up the Grid System Data form. This form has
the following area:

 Grid System Name: Specifies the name of the grid system.
Accept the default name or specify a different one.

 Click to: Adds a new grid line or modifies or deletes an ex-
isting grid line. Clicking the Add New Grid Line button (or
Modify/Show Grid Line button if a grid line already exists)
brings up the Grid Line form. Here you can specify the Grid
Line ID, Type of Grid (Straight or Arc) and its Plan Coordi-
nates. You can also select the story level at which the grid
line is to be included. Checking the Apply to All check box
will include the change in all the levels that lie between the
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top and bottom story level selected. Other options available
include:

 Primary/Secondary Grid Lines: Specify a grid line as
either a primary or a secondary line. Primary grid lines
are intended to represent the main architectural grid lines
of the building. Secondary grid lines are intended as
temporary reference lines for modeling. They do not
have a bubble assigned to them for the grid ID.

 Hide Grid Line: Hides the primary or secondary grid
lines depending on which check box is checked.

 Switch Bubble Location: Moves the bubble location to
the other end of the grid line.

 Color: Changes the color of the grid line.

 Bubble Size: The grid line bubbles are drawn as hexa-
gons. The bubble size indicates the distance between two
opposing faces of the hexagon measured in the current
units of the model. This size applies to all bubbles in the
coordinate/grid system.

 System Origin: The System Origin portion of the Grid Sys-
tem Data form allows you to specify the location of the ori-
gin of the coordinate system relative to the global coordinate
system. Specify the following using the System Origin form:

 Global X: This is the global X coordinate of the origin
of the coordinate/grid system.

 Global Y: This is the global Y coordinate of the origin
of the coordinate/grid system.

 Rotation (deg): This angle, input in degrees, specifies
the orientation of the positive X-axis (or theta equals 0
degrees radial line in a cylindrical system) of the coordi-
nate system relative to the positive global X-axis. The
angle is measured from the positive global X-axis to the
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coordinate system X-axis. Positive angles appear coun-
terclockwise when viewed from above.

Delete System Button
Clicking the Delete System Button deletes the selected system. If
only one system is defined, this option is inactive.

Edit Grid Data > Convert System to General Command
Clicking the Edit Menu > Edit Grid Data > Grid Systems
command brings up the Convert Cartesian/Cylindrical System to
General form. This form enables you to convert previously de-
fined Cartesian/Cylindrical systems to a single General System.
Converting to the General System groups all previously defined
systems into one system.

Edit Grid Data > Glue Points to Grid Lines Command
The Edit Menu > Edit Grid Data > Glue Points to Grid Lines
command is a toggle switch. As the name suggests, when en-
abled, this command allows you to "glue" point objects that fall
directly on grid lines to those grid lines. When a point object is
glued to a grid line and the grid line is moved, the point object
moves with the grid line. Line and area objects that are attached
to the point object when it is moved remain attached to the point
object and thus move or resize as appropriate.

Edit Story Data Command
Use the Edit menu > Edit Story Data command or  toolbar

button to edit story information and to insert new story levels or
delete existing story levels. Clicking the Edit menu > Edit
Story Data command brings up three submenus:  Edit, Insert
Story and Delete Story.
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Edit Story Data > Edit Command
Clicking the Edit menu > Edit Story Data > Edit command
brings up the Story Data form. The items in this form are de-
scribed as follows.

 Label: Identifies the story level. Default values for this label
are STORY1, STORY2, and so forth. You can change the la-
bel for any story level; for example, you may want to label
your story levels 1st, 2nd, and so on. Note that the bottom of
the building is identified as story level BASE; you cannot
change this.

 Height: Defines the interstory height of the story level. It is
the distance from the considered story level to the story level
below. Note that by default, the story height of the BASE
level is zero; you cannot change this.

 Elevation: Identifies the elevation of the story level relative
to the base elevation. Note that you can specify the BASE
level elevation (the default is 0). The program automatically
calculates all other elevations and you cannot change them.
These story level elevations are provided for informational
purposes.

 Similar To: This is tag indicates that a story level is similar
to another story level for drawing, assignment and selection
purposes when working in plan view. See the section entitled
"Similar Story Levels" in Chapter 8 for more information.

 Splice Point: A Yes in this column indicates that the columns
will be spliced at this floor level.  A No in this column indi-
cates that the columns at this floor level are not to be spliced.

 Splice Height: If this floor level has been specified as a level
where the columns will be spliced, the dimension here indi-
cates the height above the top of steel at that level where the
column splice will occur.
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Cautionary Note: Once you change something in the story data
and close the form by clicking the OK button, you cannot undo
the change.

Edit Story Data > Insert Story Command
Clicking the Edit menu > Edit Story Data > Insert Story
command brings up the Insert New Story form. Specify the fol-
lowing items in this form:

 Story ID: Specify the name of the new story level.

 Story Height: Specify the inter-story height (not elevation
above the base level) of the new story level.

 Number of Stories: Specify the number of stories to be in-
serted.

 Insert Above Level: Specify the story level above which the
new story level is to be inserted. It can be any story level that
currently exists in the model.

 Replicate New Story: Specify an existing story level from
which the new story level is to be replicated. If you specify an
existing story level instead of None, all of the framing and all
of the assignments in the specified existing story level will be
copied to the new story level.

In the Replicate New Story area of the Insert New Story op-
tion,  note that specifying an existing story level (say Story
Level X) instead of None is equivalent to the following proc-
ess:

1. Create a new story level (call it Story Level Y) using the
None option in the Replicate New Story area of the Insert
New Story form.

2. Select all of the objects on Story Level X and click the
Edit menu > Replicate command to open the Replicate
form.

Note:

When a new
story level is
inserted, all
story levels
above it are
automatically
moved up.
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3. Select the Story tab and highlighting Story Level Y in the
Replicate on Stories area of the form.

4. Click the OK button.

Edit Story Data > Delete Story Command
Clicking the Edit menu > Edit Story Data > Delete Story
command brings up the Select Story to Delete form where you
can specify the story to be deleted. When a story level is deleted,
all story levels above it are automatically moved down.

Edit Reference Planes and Edit Reference Lines
Command

You can use the Edit menu to create, modify and delete reference
planes and reference lines. Use the Edit menu > Edit Reference
Planes and Edit menu > Edit Reference Lines commands to
complete these actions.

Reference planes are horizontal planes at user-specified Z-
ordinates. The main purpose of these planes is to provide a hori-
zontal plane/line that you can snap to when drawing objects in
elevation views. You can also view reference planes in a plan
view. This option can be useful for adding mezzanine-type
framing when you have not specified the mezzanine as a story
level in the story data.

Note the following about reference planes:

 If you draw vertical line objects or vertical area objects (col-
umns or walls) in plan on a reference plane level, the program
inserts one object from the reference plane to the story level
below and another object from the reference plane to the story
level above.

 When you draw vertical line or area objects (columns or
walls) in plan on a story level and there is a reference plane in

Note:

When drawing
objects, you can
snap to refer-
ence planes and
lines.

Note:

You can view
and draw on
reference
planes in plan
view.
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that story level, the program does not break the vertical object
at the reference plane. A single object is drawn from the story
level to the story level below.

Reference lines are vertical lines at user-specified global X and
Y coordinates. The main purpose of those lines is to be available
for snapping when drawing objects in elevation or plan view.
Reference lines appear as points in plan view.

Merge Points Command
Use the Edit menu > Merge Points command or  toolbar

button to merge any points in the model at any time. Note that
you can specify a tolerance distance for automatically merging
points using the Auto Merge Tolerance edit box on the Dimen-
sions/Tolerances form, which is accessed using the Options
menu > Preferences > Dimensions/Tolerances command.
Note that when points are created (drawn, moved, copied, or
replicated) such that the distance between them is smaller than
the specified Auto Merge Tolerance, the program will automati-
cally merge the new point into the existing point.

To use the Edit menu > Merge Points command,  first select
the points to be merged. Then execute the command and specify
a merge tolerance. The program uses the following logic to
merge the points:

1. The program organizes the selected points based first on the
number of grid lines that pass through them and then on the
order in which they were drawn.

2. The program merges all selected points that are within the
specified merge tolerance of the first point in the sorted list
(if any) with the first point in the selected list.

3. The sorted list is updated by deleting any point that has been
merged to the first point on the sorted list and by deleting the
first point on the sorted list. This creates a new first point on
the sorted list.
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4. Steps 2 and 3 are repeated until all points have been deleted
from the sorted list.

A couple of special cases exist for merging points, as follows:

 Suppose one point is exactly at a story level (call it Story
Level X) and a second point is a very short distance above the
first point. Thus, the second point is associated with Story
Level (X+1). In that case, the point above always merges into
the point located at Story Level X assuming, of course, that
the distance between the points is within the specified merge
tolerance.

 If one point is located just below a story level and another
point is located just above the same story level, and thus is
actually associated with the story level above, those two
points will never merge. This is true regardless of the speci-
fied merge tolerance.

Align Points/Lines/Edges Command
The Edit menu > Align Points/Lines/Edges command or 

toolbar button provides some powerful tools for aligning objects
in your model. To use this command, select the objects to be
aligned and then specify a coordinate system, align option and
align tolerance. These items are described in the subsections that
follow.

Important: Note the following about aligning points, lines and
edges:

 If a point object is moved using the Edit menu > Align
Points/Lines/Edges command, all objects connected to the
point object are reoriented. For example, if the point object at
the top of a column-type line object is aligned (moved) in
plan, the top of the column-type line object moves with the
point object. The bottom of the column-type line object does
not move. Note that in that case, because the column-type line

Tip:

Use the Edit
menu > Align
Points/Lines/
Edges com-
mand to align
objects in your
model and to
trim or extend
line objects.
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object is no longer vertical, the program automatically
changes it to a brace-type line object.

 Suppose a line object is selected but the points at the end of
the line object are not selected. Next suppose that the Edit
menu > Align Points/Lines/Edges command is used to align
(move) this line object. In that case, the line object moves but
the point objects at the end of the line object do not move.
New point objects are created at the ends of the line object in
its new position if necessary. Any other objects that were
connected to the point objects at the ends of the line object in
its original location remain where they were; they do not
move in any way. Similarly any assignments to the point ob-
jects at the ends of the line object in its original location re-
main where they were. If no other objects are connected to the
point objects at the ends of the line object in its original loca-
tion, and if there are no assignments made to these point ob-
jects, the program deletes them after the line object has been
moved.

 When the program aligns an edge of an area object, only the
edge of the area object being aligned actually moves. All
other edges of the area object remain in their original loca-
tion. Thus, when an area object is aligned, its shape changes.

 Suppose an area object is selected but the points at the corners
of the area object are not selected. Next suppose that the Edit
menu > Align Points/Lines/Edges command is used to align
(move) an edge of this area object. In that case, the edge of
the area object moves but the point objects at the ends of the
edge of the area object do not move. New point objects are
created at the ends of the edge of the area object in its new
position if necessary. Any other objects that were connected
to the point objects at the ends of the edge of the area object
in its original location remain where they were; they do not
move in any way. Similarly any assignments to the point ob-
jects at the ends of the edge of the area object in its original
location remain where they were. If no other objects are con-
nected to the point objects at the ends of the edge of the area
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object in its original location and if there are no assignments
made to these point objects, the program deletes them after
the edge of the area object has been moved.

Align Points/Lines/Edges Form
Clicking the Edit menu > Align Points/Lines/Edges command
brings up the Align Points/Lines/Edges form. The Coordinate
System specified on this form indicates which coordinate/grid
system is to be considered for the following align options:

 Align to X-coordinate

 Align to Y-coordinate

 Align to Z-coordinate

 Align to X grid lines

 Align to Y grid lines

Align Options to Selected Objects
Eight Align Options to Selected Objects are available on the
Align Selected Lines/Edges/Points form:

 Align Points to X-Coordinate

 Align Points to Y-Coordinate

 Align Points to Z-Coordinate

 Align Points to X Grid Line.

 Align Points to Y Grid Lines

 Trim Lines at

 Extend Lines to

 Align Points to
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These options are described in the subsections that follows.

Align to X, Y or Z Coordinate

For these options, specify the location of the coordinate that you
want to align to. Then if the appropriate coordinate of the se-
lected object is within the maximum move allowed of the speci-
fied coordinate, the appropriate coordinate of the selected object
is changed to the specified coordinate.

For example, assume that you choose to align to an X-coordinate
of 4 and assume that your maximum move allowed is 0.2. In that
case:

 Any selected point object that has an X-coordinate be-
tween 3.8 and 4.2 (in the specified coordinate system) is
moved such that it has an X-coordinate of 4. Selected point
objects with X-coordinates outside of the 3.8 to 4.2 range
are not moved.

 Any selected line object where each of the ends of the line
has an X-coordinate between 3.8 and 4.2 (in the specified
coordinate system) is moved such that each of its ends has
an X-coordinate of 4. Selected line objects with the X-
coordinates of one or both ends outside of the 3.8 to 4.2
range are not moved.

 Any selected area object where two adjacent corner points
each have an X-coordinate between 3.8 and 4.2 (in the
specified coordinate system) is resized such that two adja-
cent corner points have an X-coordinate of 4. Selected area
objects where there are not two adjacent corner points each
having an X-coordinate between 3.8 and 4.2 are not
resized. Note that the effect of changing the coordinates of
two adjacent corner points of the area object is to move
one of its edges.
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Align to X or Y Grid Lines

For these options, you specify which grid line you want to align
to. Then if the appropriate coordinate of the selected object is
within the maximum move allowed of the specified grid line, the
appropriate coordinate of the selected object is changed to be the
same as the specified grid line.

When you are aligning to X grid lines, the X-coordinate of the
selected object is examined, and if it is in the appropriate range,
it is modified. The Y and Z coordinates are not affected.

When you are aligning to Y grid lines, the Y-coordinate of the
selected object is examined, and if it is in the appropriate range,
it is modified. The X and Z coordinates are not affected.

For example, assume that you choose to align to an X grid line at
a coordinate of 4 and assume that your maximum move allowed
is 0.2. In that case:

 Any selected point object that has an X-coordinate be-
tween 3.8 and 4.2 (in the specified coordinate system) is
moved such that it has an X-coordinate of 4 to match the
grid line. Selected point objects with X-coordinates outside
of the 3.8 to 4.2 range are not moved.

 Any selected line object where each of the ends of the line
has an X-coordinate between 3.8 and 4.2 (in the specified
coordinate system) is moved such that each of its ends has
an X-coordinate of 4 to match the grid line. Selected line
objects with the X-coordinates of one or both ends outside
of the 3.8 to 4.2 range are not moved.

 Any selected area object where two adjacent corner points
each have an X-coordinate between 3.8 and 4.2 (in the
specified coordinate system) is resized such that two adja-
cent corner points have an X-coordinate of 4 to match the
grid line. Selected area objects where there are not two
adjacent corner points each having an X-coordinate be-
tween 3.8 and 4.2 are not resized. Note that the effect of
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changing the coordinates of two adjacent corner points of
the area object is to move one of its edges.

Trim or Extend Selected Lines

These options allow you to trim or extend line objects. Recall
that in the program, to ensure that a beam is connected to a
girder, the end of the beam should be exactly on the girder, not
some distance away, as it might be drawn in the building plans.
If you import a floor plan from a *.DXF file, it is likely that the
beams will be drawn such that they stop short of the girders.
Similarly, the girders will be drawn such that they stop short of
the columns. These commands allow you to fix such things in
your ETABS model.

For these options, specify at what point you want the selected
lines to be trimmed (or extended). Then, if the end of the se-
lected line object is within the maximum move allowed of the
specified trim (or extend) item, the line option is trimmed (or
extended) to that item.

Four different choices are available for the trim (extend) item.
They are:

 Any line object that has frame section properties assigned to
it.

 Any line object or any edge of an area object.

 Any line object.

 Any edge of an area object.

Note that the specified trim (extend) item need not be in the
same plane as the selected line objects. For example if you
choose line objects as your extend item and you select a girder as
the object to be extended, the girder can be extended to the line
object representing the column even though the girder is in a
horizontal plane and the column is in a vertical plane.
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Consider the example shown in Figure 5-5. Figure 5-5a shows a
floor plan as it might be drawn on your building plans. Note that
the beams stop short of the girder and the beams and girders stop
short of the columns. Also, in this example the beams stop short
of the wall.

If you select Beams 1, 2 and 3 and Girder 1 and execute the Edit
menu > Align Points/Lines/Edges command, you could then
use the "Extend selected lines to" align option to specify that the
lines be extended to "Line or Edge." This would give you the
model shown in Figure 5-5b as long as the maximum required
line extension is less than your specified maximum move al-
lowed. This would give your model the correct connectivity be-
tween the various elements.

The left side of Beams 1, 2 and 3 are extended to meet the top
edge of the vertical area object that represents the wall below.
The right side of Beam 1 is extended to meet the vertical line
object that represents Column 1. The right side of Beam 2 is ex-
tended to meet the horizontal line object that represents Girder 1.
The right side of Beam 3 is extended to meet the vertical line
object that represents Column 2. The top side of Girder 1 is ex-
tended to meet the vertical line object that represents Column 1.
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Figure 5-5:
Example of extend-
ing selected lines
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The bottom side of Girder 1 is extended to meet the vertical line
object that represents Column 2.

If you specified that the lines are to be extended to "Edge," only
the left side of Beams 1, 2 and 3 would be extended to meet the
top edge of the vertical area object that represents the wall be-
low. No other line extensions would be accomplished in that
case.

Assume that the beams, girder and column are all assigned frame
section properties. If you specified that the lines are to be ex-
tended to "Frame Sections," all of the extensions shown in Fig-
ure 5-5b would be accomplished, except that the left side of
Beams 1, 2 and 3 would not be extended to meet the top edge of
the vertical area object that represents the wall below.

Note the following about trimming and extending selected lines:

 If two or more specified trim (extend) items are within the
maximum allowed move distance to the end of the line, the
trim (extend) is done to the item that is closer to the end of the
line.

For example, assume that in Figure 5-5 the right end of Beam
2 is within the specified maximum allowed move distance to
both Girder 1 and the edge of the slab. If you select Beam 2
and specify that the lines are to be extended to "Line or
Edge," the right end of Beam 2 would be extended to Girder
1, not the edge of the slab, because the right end of the beam
is closer to Girder 1 than it is to the edge of the slab.

 Line objects are always trimmed (extended) along their lon-
gitudinal axis.

 Specified trim (extend) items (frame sections, line objects or
edges of area objects) are only considered if they are visible
in the active window. You can use this feature together with
the View menu > Show Selection Only command to get ad-
ditional control of the trimming (extending) of line objects.



Chapter 5 - Edit Menu

Align Points/Lines/Edges Command 5 - 37

5

Align Points To

You can align selected points to the following items:

 Any line object that has frame section properties assigned to
it.

 Any line object or any edge of an area object.

 Any line object.

 Any edge of an area object.

When you use this option, any selected point is aligned with the
closest specified item if that item is within the specified maxi-
mum move allowed. Specified items (frame sections, line objects
or edges of area objects) are only considered if they are visible in
the active window. You can use this feature together with the
View menu > Show Selection Only command to get additional
control for aligning points.

When checking for the closest specified item to a selected point,
the program measures the perpendicular distance to line and
edges of area objects. When a point is moved to align with an
item, it is either moved perpendicular to the line object or edge
of the area object.

Align Tolerance
The Align Tolerance area of the Align Selected Lines/Edges/
Points form displays the Maximum Move Allowed. This is a
distance that is you can specify in the current units. If the se-
lected object is within the align tolerance distance of whatever it
is specified to be aligned with, the selected object is moved. If it
is not within the align tolerance distance, it is not moved.

When aligning line objects to an X, Y or Z coordinate or to an X
or Y grid line, the line object is only moved if both of the end
points of the line object are within the specified maximum move
allowed. If you have instead, or in addition, selected the point
objects at the ends of the line object, it is possible to have one
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end of the line object move (align) and not the other. This hap-
pens if the alignment is based on the point object because the
line object connected to the point object is reoriented when the
point object moves.

Similarly, when aligning the edge of an area object to an X, Y or
Z coordinate or to an X or Y grid line, the edge of the area object
is only moved if both of its end points are within the specified
maximum move allowed. If you have instead, or in addition, se-
lected the point objects at the ends of the edge of the area object,
it is possible to have just one of the point objects move (align).

Move Point/Line/Areas Command
Selected objects can be moved in any direction by clicking the
Edit menu > Move Points/Lines/Areas command or 

toolbar button, which brings up the Move Points/Lines/Area
form. In this form, specify the distances that the object is to be
moved in the global X, Y and Z directions. One restriction on the
movement is that when you move objects in the Z direction, they
cannot cross a story level. See the subsequent subsection entitled
"Moving Objects in the Z Direction" for more information.

When you move a point object, all line and area objects attached
to the point are reoriented or resized to account for the move-
ment. For example, if you move a point object at the top of a
column, the column will become sloped. (Note that the program
would then consider this column to be a brace).

When you move a line object, the line object moves but the point
objects at the end of the line object do not move. New point ob-
jects are created at the ends of the line object in its new position
if necessary. Any other objects that were connected to the point
objects at the ends of the line object in its original location re-
main where they were; they do not move in any way. Similarly
any assignments to the point objects at the ends of the line object
in its original location remain where they were. If no other ob-
jects are connected to the point objects at the ends of the line

Tip:

Objects moved
in the Z direc-
tion cannot
cross a story
level.
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object in its original location and if there are no assignments
made to these point objects, the program deletes them after the
line object has been moved.

Similarly, when you move an area object, the area object moves
but the point objects at the corners of the area object do not
move. New point objects are created at the corners of the area
object in its new position if necessary. Any other objects that
were connected to the point objects at the corners of the area
object in its original location remain where they were; they do
not move in any way. Similarly any assignments to the point
objects at the corners of the area object in its original location
remain where they were. If no other objects are connected to the
point objects at the corners of the area object in its original loca-
tion and if there are no assignments made to those point objects,
the program deletes them after the area object has been moved.

Moving Objects in the Z Direction
You can only move objects in the Z-direction within their own
story level or to the story level below. You can not specify a
delta Z dimension that requires an object to move across a story
level.

For example, suppose you have a four-story building with 10-
foot high story heights at all levels. Thus the first story level is at
an elevation of 10 feet, the second story level is at 20 feet, the
third story level is at 30 feet and the fourth story level is at 40
feet. Further suppose that you are moving an area object corner
point that occurs at the mid-height of the third story level, that is,
at an elevation of 25 feet.

You can specify a delta Z dimension for this corner point be-
tween -5 feet and +5 feet inclusive, that is between the distances
of the second and third story levels. If you specify a delta Z di-
mension less than -5 feet, ETABS moves the point to the second
story level elevation. If you specify a Z coordinate greater than
+5 feet, ETABS moves the point to the third story level eleva-
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tion. If you specify a Z coordinate between -5 feet and +5 feet,
inclusive, then ETABS moves the point to the specified location.

Important Note: In some cases, moving a point object in the Z
direction would cause line and/or area objects that are attached to
the point object to cross story levels. In such cases ETABS does
not allow the move to take place.

Expand/Shrink Areas Command
Select an area object and use the Edit menu > Expand/Shrink

Areas command or  toolbar button to expand or shrink an
area object. When you specify an offset value in the Ex-
pand/Shrink Areas form, each edge of the area object is moved
that amount in a direction perpendicular to the edge.

Positive offset values cause the edges to move away from the
interior of the area object; that is, they expand the object. Nega-
tive offset values cause the edges to move toward the exterior of
the area object; that is, they shrink the object.

If you specify a negative offset value that causes the area object
to collapse on itself, the command is ignored and the object is
not shrunk. For example, assume that a rectangular area object
has dimensions of 40 inches by 60 inches. If you specify an off-
set value of -20 inches or less (e.g., -25 inches), the area object
would collapse on itself because when each of the sides that are
40 inches apart move toward each other by 20 inches, the two
sides are in the same location and the area object is invalid. If the
two sides that are 40 inches apart are each moved toward the
other more than 20 inches, the two sides would have to cross
(overlap) each other. This is not allowed.

Useful Feature: Typically, when you select an area object and
use the Edit menu > Expand/Shrink Areas command, all sides
of the area object are moved. It is possible to select one or more
sides of an area object individually and have the Edit menu >

Note:

Positive offset
values expand
an area object
and negative
offset values
shrink it.
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Expand/Shrink Areas command apply only to the selected
sides of the area object. Do this as follows:

 Press and release the E key on your keyboard to enter the
edge select mode. In this mode, when you click on the edge of
an area object, that edge is selected. You are not able to select
entire area objects by clicking inside them in this mode. Tap
the space bar to discontinue edge select mode.

 Click on the area object edge(s) that you want to select.

 Use the Edit menu > Expand/Shrink Areas command in the
normal fashion.

 When you have finished selecting area objects edges, press
and release the space bar on your keyboard to return to the
normal area object select mode where you select entire area
objects by clicking inside of them. Note that you do not
automatically return to the normal area object select mode.
You must specifically press and release the space bar or the
Esc key on your keyboard to return to normal select mode.

Figure 5-6 shows some examples of expanded and shrunken area
objects. In the figure, the dashed line represents the original
area object and the solid line represents the final area object
after it has expanded or shrunk. Note in Figure 5-6c that be-
cause only one edge of the area object was moved, the solid
line lies on top of the dashed line for all other edges.

Tip:

You can expand
or shrink se-
lected edges of
area objects.
Figure 5-6:
Example of expanded
and shrunken area
objects
Expand/Shrink Areas Command 5 - 41

a)  Expanded Area Object b)  Shrunken Area Object
c)  Area Object with

One Side Expanded
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Merge Areas Command
Selecting two area objects that have a common edge or overlap
and using the Edit menu > Merge Areas command or  tool-

bar button will merge the two area objects into one area object.
You cannot merge more than two area objects at a time in the
same command.

When you merge two area objects, the new area object takes on
the properties and assignments of the area object with the larger
area. If the two area objects have exactly the same area, the
property and assignments come from the first drawn area object.
Because you may not remember which area object was drawn
first, carefully check the assignments of the newly combined
area object. Figure 5-7 shows some examples of merged area
objects.

Figure 5-7:
Examples of merged
area objects

a)

b)

c)

d)

e)

f)
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Mesh Areas Command
Selected areas can be meshed using the Edit>Mesh Areas com-
mand or  toolbar button. Several options are available in the

Mesh Selected Areas form:

 Auto Mesh Area (Horiz): This option meshes the selected
area into smaller areas. The smaller areas are three-sided or
four-sided and must have beams on all sides.

 Cookie Cut at Selected Line Object (Horiz): This option
meshes the selected area at the selected lines. Select one or
multiple lines. If the selected line passes through more than
one area, all of the areas will be meshed. Note that this and
the Auto Mesh Area option only work in plan view.

 Cookie Cut at Selected Point at [Specified] Angle: Use this
option to mesh areas at a specified point and angle. The angle
will be measured in the counterclockwise direction for the x-
and y-axis. If the point lies in the overlapping region of two
areas, both of the areas will be meshed at the given angle.

 Mesh Quads/Triangles into [Specified Number] by [Speci-
fied Number] Areas: This option meshes the selected area in
the number of areas specified by the user. For example, speci-
fying a meshing of 2 by 8 means that the selected area will be
meshed into 2 areas along the x-axis and 8 areas along the y-
axis. The size of the meshed areas will be uniform along a
given direction. Only quads and triangles can be meshed us-
ing this option.

 Mesh Quads/Triangles at:

 Intersections with Visible Grid Lines: This option
meshes each selected area at any location where it inter-
sects a visible grid line, regardless of the coordinate sys-
tem associated with the grid line.

 Selected Point Objects on Edges: Selecting this option
will mesh the area (horizontally and vertically) using the
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selected point at the edge as reference. One more points
can be selected for this type of meshing.

 Interactions with Selected Line Objects: The areas se-
lected are meshed with the line intersecting the area. More
than one line can be selected to mesh a desired area.

Note the following about Meshing Area Objects.

 The property assignments to meshed area objects are the same
as the original area object.

 Load and mass assignments on the original area object are
appropriately broken up onto the meshed area objects.

 When this menu item is clicked, all edges of the currently se-
lected area will be split at their mid-points. If clicked again
for the same selected area, they will be divided in half again,
and so on.

Split Area Edge Command
The Edit menu > Split Area Edge command adds point objects
at the mid-point of each edge of an area object. To use this
command, select the area object and then click the command.

Join Lines Command
Select two or more collinear line objects with common end
points and the same type of property (frame section, link or
none) and use the Edit menu > Join Lines command  or 

toolbar button to combine the line objects into a single line ob-
ject. Note the following about combined line objects.

 Combined line objects must be collinear.

 Combined line objects must have a common end point.
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 Combined line objects must all have the same type of prop-
erty. In other words, they must all have frame section proper-
ties, or they must all have link properties or they must all
have no properties.

 When line objects with frame section properties are joined,
the section property assigned to the combined line object is
the one associated with the largest area. If two of the com-
bined frame sections have the same area, the property of the
first drawn object is used.

 Load and mass assignments from the unjoined line objects are
combined on the joined object.

 Assignments to the unjoined line objects that would be illegal
in the middle of the joined line object are ignored. For exam-
ple, frame member end releases, rigid end zones and joint off-
sets that would occur in the center of joined frame members
are ignored.

Figure 5-8 shows some examples of joined line objects. Figure
5-8(a) shows that two collinear line objects with a common end
point (and the same property type assignment) are joined into
one line object. Figure 5-8b shows that five collinear line objects
can be joined at the same time. Figures 5-8c and 5-8d show that
two sets of collinear line objects can be joined simultaneously.
The two sets of line objects can have different property type as-
signments but all of the property type assignments within either
set of line objects must be the same.

Figure 5-8e illustrates that the collinear line objects must have a
common end point, otherwise they are not joined. To join the ex-
ample shown in Figure 5-8e, move one of the center joints so
that it is coincident with the other center joint and then perform
the join.

Figure 5-8f illustrates that assignments to the unjoined line ob-
jects that would be illegal in middle of the joined line object are
ignored. In that case, a moment release that is in the center of the
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combined beam is ignored. If you want this moment release to
remain, you should not join the line objects.

Divide Lines Command
Select one or more line objects and use the Edit menu > Divide
Lines command or  toolbar button to divide the line object

into multiple line objects. Several options are available for di-
viding the line objects:

 Divide into [Specified Number of] Objects: This option di-
vides the selected line object(s) into the specified number of
line objects. The divided line objects are all the same length.

a)

b)

c)

d)

e)

Not a valid join. The two
line objects do not have
common end points.
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1 2 1

1 2 3 4 1 2

1 2 3

4
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f) 1 2 1

Moment
release

Figure 5-8:
Examples of joined
line objects
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 Break at Intersections with Selected Lines and Points:
This option breaks each selected line at any point where it
intersects another selected line or point. Figure 5-9 shows
some examples.

Figure 5-9a shows two crossing line objects. Initially the line
objects are not connected at their intersection. When the two
line objects are selected and the Break at Intersections with
Selected Lines and Points option is used to divide the lines,
each of the lines is broken into two objects at the intersection
point.

Figure 5-9b shows a common situation in a chevron-braced
frame. Notice that the line object representing the top beam
(labeled 5) spans from one column to the other and is not bro-
ken at the intersection with the braces. To break this beam at
the intersection with the braces, select the beam and one of
the braces (say you select the line objects labeled 2 and 5) and
use the Break at Intersections with Selected Lines and Points
option. Alternatively, select the point at the top of the braces
and the top beam (line object labeled 5) to achieve the same
result.

In either of the case shown in Figure 5-9, the program would
provide connectivity at the intersection points, regardless of
whether the line objects are divided or not, unless the inter-

a)

b)
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5 6

Figure 5-9:
Examples of break-
ing line objects at
intersections with
selected lines and
points
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secting line objects are indicated not to be meshed using the
Assign menu > Frame/Line > Automatic Frame Mesh/No
Mesh > Don't Mesh It command (refer to Chapter 10 Assign
Menu). In most cases, manual breaking up of intersecting line
objects as shown in Figure 5-9 is not necessary unless differ-
ent properties are to be assigned or a different label is re-
quired. The example in Figure 5-9 is merely intended to il-
lustrate the Break at Intersections with Selected Lines and
Points option for dividing lines.

 Break at Intersections with Visible Grid Lines: This option
breaks each selected line at any location where it intersects a
visible grid line, regardless of the coordinate system associ-
ated with the grid line.

Note the following about divided line objects.

 The property assignments to divided line objects are the same
as the original line object.

 Load and mass assignments on the original line object are ap-
propriately broken up onto the divided line objects.

 Assignments that occur at the ends of the original line object,
such as releases and rigid end zones, occur at the appropriate
ends of the two end line objects when the original object is
divided.

Extrude Points to Lines Command and Extrude Lines
to Areas Command

In many situations during model creation, it is very convenient to
generate objects of one kind by some transformation of another
type of object. These commands are useful in creating line ob-
jects from points and area objects from line objects. Figure 5-10
illustrates examples of object extrusion. Figure 5-11 illustrates
the Extrude Lines to Areas form that comes up when you click
the Extrude Lines to Area command or the  toolbar button.
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The process of extrusion increases the dimensional space of an
existing object by one. In other words, line objects are of one
dimension that can be generated from a dimensionless object, the
point object. In a similar manner, a two-dimensional object, area
or plate/shell can be generated from a one-dimensional object,
the line object. This feature is especially suited to creating

(c) Generation of an
area object from verti-
cal extrusion of an line
object

(d) Generation of an
area object from hori-
zontal extrusion of an
line object

Figure 5-10:
Examples of ob-
ject extrusion
(linear)

(a) Generation of a single
horizontal line object
from a point object

(b) Generation of a
single inclined line ob-
ject from a point ob-
ject

Figure 5-11:
Input for linear and
radial extrusion
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plate/shell elements from beams and beams/columns from
point/nodes.

The object can be extruded linearly or radially. The same two
options are available on the Extrude Points to Lines form and the
Extrude Lines to Areas form. They Linear and Radial and are de-
scribed as follows:

Linear Extrusion
For linear extrusion you must specify the increment distance
along the X-axis (dx), the increment distance along the Y-axis
(dy), and the number of times the object is to be extruded. The
object is then extruded the specified number of times, each time
incrementing the global X and Y coordinates by the specified dx
and dy.

A Delete Source check box is provided on the Extrude Lines to
Areas form. Checking this check box will delete the lines used to
create the area. Leaving the check box unchecked will keep the
lines as well as the area.

Radial Extrusion
A typical use of this type of extrusion is to generate a cylindrical
surface from radial extrusion of a single line about the central
axis of the cylinder. For radial extrusion, specify a point to rotate
about (the rotation is in the global X-Y plane about the global Z-
axis), a rotation angle, and a number of times the object is to be
extruded. The object is then extruded the specified number of
times, each time incrementing the location of the objects by the
specified rotation angle. The rotation angle is input in degrees.
Angles are measured from the positive global X-axis. Positive
angles appear counterclockwise when you view them from
above.

A Delete Source check box is provided on the Extrude Lines to
Areas form. Checking this check box will delete the lines used to
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create the area. Leaving the check box unchecked will keep the
lines as well as the area.

Auto Relabel All Command
You can relabel all objects of the current model using the Edit > Auto
Relabel All command. This is a one-way command and cannot be un-
done. You cannot selectively relabel objects. Unlike other commands on
the Edit menu, you do not need to select the objects before using this
command.

The program relabels the objects in the following order. working the
global coordinate system, the objects are first sorted by their global delta
Z from their story level, then by their global Y location, and finally by
their global X location. The advantage of relabeling is so that with this
relabeling scheme if you find area object labeled W2, for example, you
will know that you can typically find the area object labeled W3 nearby.
Without relabeling, the object labeling is in the order in which the ob-
jects were defined in the model, which often times is not necessarily an
orderly progression.

Typically, we recommend that you use the Auto Relabel All command
after you have finished creating your model to get optimum labeling for
the model. Keep in mind that if you add or subtract objects from your
model after you have used the Auto Relabel All command  and then use
the command again, what was once object W3, for example, may not
longer be area object W3.

Nudge Feature
The program includes a nudge feature that allows you to modify
the geometry of your model in a plan view. To use the nudge
feature, select the item(s) that you want to nudge and press the
Ctrl key and one of the arrow keys on your keyboard simultane-
ously. Note the following about the nudge feature:
Tip:

You can nudge
dimension
lines.
Auto Relabel All Command 5 - 51

 The nudge feature only works in plan view.
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 You can nudge any selected point, line or area object. You
can also select dimensions lines and nudge them.

 Pressing the Ctrl key plus the right arrow key nudges the ob-
ject in the positive global X direction.

 Pressing the Ctrl key plus the left arrow key nudges the object
in the negative global X direction.

 Pressing the Ctrl key plus the up arrow key nudges the object
in the positive global Y direction.

 Pressing the Ctrl key plus the down arrow key nudges the
object in the negative global Y direction.

 The distance that the object(s) is nudged (moved) when you
press the Ctrl and arrow keys is specified in the Dimen-
sion/Tolerance Preferences, which can be accessed using the
Option menu > Preferences > Dimensions/Tolerances
command. The name of the item that controls the movement
is Plan Nudge Value.

 You cannot nudge objects in the Z direction.

 Similar to the Edit menu > Move Points/Lines/Areas com-
mand, when you nudge an area object without having selected
the corner points of the object, the area object moves but the
point objects at the corners of the area object do not move.
New point objects are created at the corners of the area object
in its new position if necessary. Any other objects that were
connected to the point objects at the corners of the area object
in its original location remain where they were; they do not
move in any way. In other words, the area object is discon-
nected from other objects when it is nudged.

 Similar to the Edit menu > Move Points/Lines/Areas com-
mand, when you nudge a line object without having selected
the end points of the object, the line object moves but the
point objects at the ends of the line object do not move. New
point objects are created at the ends of the line object in its
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new position if necessary. Any other objects that were con-
nected to the point objects at the ends of the line object in its
original location remain where they were; they do not move
in any way. In other words, the line object is disconnected
from other objects when it is nudged.

 Similar to the Edit menu > Move Points/Lines/Areas com-
mand, when you nudge a point object all of the objects con-
nected to the point move too; they are either reoriented or
resized, or both. Unlike area and line objects, the point object
does not disconnect from the objects it is attached to when it
is nudged.
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Chapter 6

View Menu

General
The View menu provides basic options and tools for viewing a
model. This chapter describes those options and tools in the or-
der displayed in the menu drop-down box.

The viewing options available on the View menu should not be
confused with the display options available on the Display menu.
The View menu items control the type of view and the visibility
of objects. The Display menu items control the display of input
and output items. The Display menu is described in Chapter 12.

Set 3D View Command
Set a window to a three-dimensional (3D) view using the View
menu > Set 3D View command or by clicking the  toolbar

button. Use of the View menu > Set 3D View command will
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open the Set 3D View form where you can define the view di-
rection by specifying a plan angle, elevation angle and an aper-
ture angle.  Use of the  toolbar button gives you the default
3D view, with the plan, elevation and aperture angle as specified
in Figure 6-1.

All angles are specified in degrees. The view direction defines
the location where you would be standing if you were viewing
the building from the outside. Figure 6-1a shows a three-
dimensional view of a building using the default view direction
of plan angle = 225 degrees, elevation angle = 35 degrees and
aperture angle = 60 degrees. Figures 6-1b, 6-1c and 6-1d illus-
trate how the plan, elevation and aperture angles are defined
within the program. Following are explanations of the terms used
in Figure 6-1.

 Eye point: This is the location from which you are viewing the
building.

 Target point: This is the geometric center of the building.

 View direction: This is defined by a line drawn from the eye
point to the target point.

 Plan angle: This is the angle (in degrees) from the positive
global X-axis to the line defining the view direction measured
in the horizontal global XY plane. A positive angle appears
counterclockwise as you look down on the model. Any value
between -360 degrees and +360 degrees, inclusive, is allowed
for the plan angle.

 Elevation angle: This is the angle (in degrees) from the global
XY plane to the line defining the view direction. A positive
angle starts from the global XY plane and proceeds toward the
positive global Z-axis. A negative angle starts from the global
XY plane and proceeds toward the negative global Z-axis. Any
value between -360 degrees and +360 degrees, inclusive, is
allowed for the elevation angle.

Note:

The plan and
elevation an-
gles together
control the di-
rection from the
eye point to the
target point.
The aperture
angle controls
the distance
from the eye
point to the
target point.
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 Aperture angle: The plan angle and the elevation angle to-
gether define the direction from the eye point to the target
point. The aperture angle sets the distance from the eye point
to the target point. This distance is set as follows:

 The program constructs the view direction line from the
eye point to the target point.

 The program constructs a 3D bounding rectangular box
that just encloses the model.

 The program passes a plane through the target point and
perpendicular to the view direction line.

 The program projects the eight corner points of the
bounding box onto the plane. Those points are the "pro-
jected corner points."

 The program constructs lines from the eye point to the
projected corner points of the bounding box. Eight such
lines are constructed because there are eight corner points.
Those eight lines are the "corner point lines."

 The program locates the eye point along the view direction
line such that the largest angle between the view direction
line and any of the eight corner point lines is equal to one-
half of the specified aperture angle. This ensures that the
entire structure is included in the view.

Note that the program does not allow the eye point to be lo-
cated inside the structure.

Set 3D View Form
The 3D View form has four Fast View buttons labeled 3-d, xy,
xz and yz. The fast view buttons automatically set the plan, ele-
vation and aperture angle to give you the specified 3D view. The
fast view 3D view is as shown in Figure 6-1. The other fast
views give you 3D perspective views of the specified planes
(i.e., xy, xz, yz).
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Adjust the 3D View
When the active window is showing a 3D view, you can adjust
the 3D view using the Rotate 3D View  toolbar button. First

click the   button. Then left click the mouse in the window

with the 3D view; hold down the mouse left button while you
drag the mouse to adjust the view direction. Note that as soon as
you left click the mouse in the window, a bounding box (dashed
lines enclosing the model) appears, and as you drag the mouse,
the orientation of the bounding box changes, showing you the
new orientation of the model. When you release the left mouse
button, the entire model is redrawn in the new view direction.

Refer to the subsection in this chapter entitled "Perspective
Views" for additional information on three-dimensional views.

Set Plan View Command
Set a window to a plan view using the View menu > Set Plan

View command or the Plan View  toolbar button. Using the

menu item or clicking the toolbar button brings up the Select
Plan Level form. From this form, select the story level or refer-
ence plane that you want to show in plan view. Refer to the sec-
tion entitled "Set Reference Planes and Set Reference Lines
Commands" in Chapter 5 Edit Menu for additional information
on reference planes. Alternatively, use the Move Up in List 

and the Move Down in List  toolbar button to quickly

change views.

The following objects are visible in plan view if they have been
specified as visible in the Set Building View Options form,
which is accessed through the View menu > Set Building View
Options command (see subsequent section entitled "Set Building
View Options Command"):

 All area, line and point objects that lie in the horizontal plane
of the plan view. This horizontal plane occurs at the story level

Note:

You can create
plan views of
story levels and
reference
planes.
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elevation for plan views of story levels and at the reference
plane elevation for plan views of reference planes.

 All column-type line objects that have an end point in the con-
sidered plan view or pass through the considered plan view.
Note that column-type line objects cannot pass through plan
views at story levels. They can only pass through plan views at
reference plane levels.

 All wall-type area objects that have corner points in the con-
sidered plan view or pass through the considered plan view.
Note that wall-type area objects cannot pass through plan
views at story levels. They can only pass through plan views at
reference plane levels.

Note that braces and ramps are never visible in a plan view.
Braces are visible in elevation view and in any three-dimensional
view, including all perspective views. Ramps are visible in any
three-dimensional view, including all perspective views.

Refer to the subsection in this chapter entitled "Perspective
Views" for additional information on plan views. See Chapter 9
Select Menu for special selection rules when windowing in plan
view ("windowing" means to draw a window around one or
more objects to select them).

Set Elevation View Command
By default the program defines elevation views along each of the
defined primary grid lines in the model. Use the View menu >
Set Elevation View command or click the Elevation View 

toolbar button to display the Set Elevation View form. This form
allows you to add additional elevation views, modify or delete
existing elevation views, and select which elevation view to dis-
play.

Developed elevation views can be displayed but not defined
from the Set Elevation View form. Refer to the section entitled
"Draw Developed Elevation Definition Command" in Chapter 8
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for an explanation of developed elevations and information on
defining developed elevation views.

The Set Elevation View form includes a list of the defined ele-
vation names (including the names of defined developed eleva-
tions, if any) and several command buttons. To select an eleva-
tion for display, highlight the appropriate elevation name in the
Set Elevation View form and click the OK button. To delete a
defined elevation view, highlight the elevation in the Set Eleva-
tion View form and click the Delete Elevation Name button.

To define a new elevation view, click the Add New Elevation
button in the Set Elevation View form. (Note: The Add New
Elevation button is not used to define developed elevations. Use
the Draw menu > Draw Developed Elevation Definition
command to define a developed elevation.)

To modify an existing elevation view, highlight the elevation in
the Elevations list box on the Set Elevation View form and click
the Modify/Show Elevation button. Note that you cannot mod-
ify the default elevations along the grid lines that are created by
the program; however, you can delete them. Also you cannot
modify user-defined developed elevations; however, you can
delete them.

Both the Add New Elevation and the Modify/Show Elevation
commands bring up the Elevation Data form. This form allows
you to specify a name, coordinate system and location for the
elevation. The location is either an X or Y ordinate in the speci-
fied coordinate system. If you specify an X ordinate, the eleva-
tion is a view of the YZ plane in the specified coordinate system
at the specified X ordinate. Similarly, if you specify a Y ordi-
nate, the elevation is a view of the XZ plane in the specified co-
ordinate system at the specified Y ordinate.

With the active window in elevation view, use the Move Up in
List button  and the Move Down in List button  to

move quickly through the available elevation views.

Note:

Elevation views
are automati-
cally created
along primary
grid lines. They
are not auto-
matically cre-
ated along sec-
ondary grid
lines.
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Refer to the subsection in this chapter entitled "Perspective
Views" for additional information on elevation views.

Perspective Toggle Button
The Perspective Toggle  toolbar button is a useful tool that

has slightly different behavior, depending on whether it is used
in a plan, elevation or three-dimensional view.

Perspective Toggle in a Plan View
In plan view, clicking the Perspective Toggle button switches
the view to a 3D perspective view. If the plan view is of a story
level, the 3D perspective view only shows the objects that are as-
sociated with that story level. Objects associated with other story
levels are not shown. If the plan view is of a reference plane, the
perspective view shows only the objects of the story level asso-
ciated with that reference plane.

While in the perspective view, you can use the Rotate 3D View
 toolbar  button to adjust the view direction.

As the name implies, the Perspective Toggle button is a toggle
switch. Press it once to switch to a perspective view of a story
level. Press it again to switch back to your original plan view.

Perspective Toggle in an Elevation View
In an elevation view, clicking the Perspective Toggle button
switches the view to a 3D perspective view of the entire struc-
ture. The initial direction of the 3D perspective view is looking
directly at the elevation that was displayed, with the elevation
angle set to 0 degrees and the aperture angle set to 60 degrees. If
the elevation displayed is a developed elevation, the initial di-
rection of the 3D perspective view is looking directly at the first
segment of the developed elevation.

Note:

A perspective
view of a plan
view shows
only the objects
that are a part
of the story
level associated
with the plan
view.
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While in the perspective view, you can use the Rotate 3D View
 main toolbar button to adjust the view direction.

As the name implies, the Perspective Toggle button is a toggle
switch. Press it once in an elevation view to switch to a perspec-
tive view of a structure. Press it again to switch back to your
original elevation view.

Perspective Toggle in a Three-Dimensional View
Clicking the Perspective Toggle button in a three-dimensional
window switches the view from a perspective view to an isomet-
ric view. In other words, the aperture angle is toggled to 0 de-
grees.

As the name implies, the Perspective Toggle button is a toggle
switch. Press it once in a 3D view to switch to an isometric view
of structure. Press it again to switch back to your original per-
spective view.

Set Building View Limits Command
Setting building view limits allows only objects that are entirely
inside the view limits to be displayed. Use the View menu > Set
Building View Limits command and the Set Building View
Limits form to set the limits for a view. Note that view limits af-
fect only objects; the limits have no effect on the coordinate/grid
systems, which will display in their entirety.

The Set Limits form allows you to specify X-axis, Y-axis and
story level (Z-axis) limits. The story level limits are set by speci-
fying a top story level and a bottom story level.

Two methods are available for specifying the X- and Y-axis lim-
its. For the first method, type in the minimum and maximum X
and Y coordinates. For the second method, graphically set the
limits in the small plan view located in the Plan Limits area of
the form.
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With respect to the second method, in the Plan Limits area, a
dashed box with selection handles on the four sides is superim-
posed over a plan view of the structure. The dashed box defines
the view limits. Modify the size and location of the dashed box
as follows:

 Left click inside the dashed box, and while holding down the
left mouse button, drag the box to a new location.

 Left click on one of the selection handles on the sides of the
dashed box, and while holding down the left mouse button,
drag the mouse to resize the box.

Set Building View Options Command
The program allows you to enhance the display of a model in the
active window by changing colors, special effects and various
other aspects. These building view options are controlled using
the View menu > Set Building View Options command or by
clicking the Set Building View Options   toolbar button.

Clicking either the command or the button brings up the Set
Building View Options form. Note that the settings made in this
form affect only the active window.

The option categories on this form include the following:

 View by Colors of
Note:

The settings
made in the Set
Building View
Options form
affect only the
currently active
window.
 - 10 Set Building View Options Command

 Special Effects

 Object Present in View

 Object View Options

 Piers and Spandrels

 Visible in View

 Special Frame Items

 Other Special Items
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Each of the building display option categories is briefly de-
scribed in the following subsections.

View by Colors of
You can view your model by the colors of the following items:

 Objects: This option displays the model by the colors of the
objects as defined in the Assign Display Colors form which
you can access using the Options menu > Colors command.

 Sections: This option displays the model by the colors of the
frame and wall/slab/deck section properties. Any object that is
not assigned frame section properties or wall/slab/deck section
properties is displayed in a color that is the opposite of the
background color. Note that you assign display colors to frame
section properties and to wall/slab/deck section properties
when you define the section properties.

 Materials: This option displays the model by the colors of the
material properties assigned to the frame and wall/slab/deck
section properties. Any object that is not assigned frame sec-
tion properties or wall/slab/deck section properties is displayed
in a color that is the opposite of the background color. Note
that you assign display colors to material properties when you
define the material properties.

 Groups: This option displays the model by the colors of one
or more selected groups. When you select this option be sure
to click the associated Select button and select the groups. Any
objects that are not part of any of the specified groups are dis-
played in a color that is the opposite of the background color.
When an object is part of more than one specified group it is
displayed in the color of the first defined group that it is a part
of.

 Design Type:  This option displays the model with a different
color for each different member design type.  For example, all
members specified as LATCOLS will be one color, all mem-
bers specified as LATBMS will be another color, etc.
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 Typical Members:  This option displays all members on a
level specified as “Typical” in one color.

 White Background Black Objects:  This option displays all
model objects in black on a white background.  This option
can sometimes be useful when you are cutting and pasting
screen shots into a report that is done in black and white.

Special Effects
Four special effects features are available. They are:

 Object Shrink: This feature shrinks line objects and area ob-
jects. It is useful when you are trying to determine connectivity
in your model. Also if you actually want to see dots at point
object locations then you must shrink the area and line objects
using this feature.

Line objects are shrunk by a percentage that is controlled by
the Shrink Factor in the Preferences form that you access using
the Options menu > Preferences > Dimensions/Tolerances
command. See the subsection titled "Dimensions and Toler-
ances" under the section titled "Preferences" in Chapter 14 for
additional information.

The object shrink feature can also be toggled on and off using
the Object Shrink Toggle button, , that is available on the

main (top) toolbar.

 Object Fill: This feature fills the area objects, that is draws
them solid. The color used is controlled in the Assign display
Colors form that is accessed using the Options menu > Colors
> Display command. See the Object Edge item below for ad-
ditional information.

 Object Edge: This feature displays the edges (outline) of the
area objects. The color used is controlled in the Assign display
Colors form that is accessed using the Options menu > Colors
> Display command.
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Note if neither the object fill or the object edge feature is ac-
tive you will not be able to see the area objects, however, if
you click in the location where they are supposed to be you
will select them. If you want the area objects to be invisible
and not selectable then you should uncheck the appropriate
boxes in the Object Visibility area of the Set Building View
Options form.

 Extrusion: This feature shows the extruded shape of all line
objects with frame section properties assigned to them. Line
objects that do not have frame section properties assigned are
shown non-extruded. Only line objects are displayed when the
extrusions feature is activated. Area objects and point objects
are not displayed when extrusions are shown.

When line objects are assigned auto select list frame section
properties ETABS displays the extruded shape of the current
analysis section. Note that before you have run the first analy-
sis the current analysis section is the median (by weight) beam
in the auto select list.

Showing extruded shapes is a very powerful tool for verifying
the local axes orientation for frame members.

Object Present in View
The Object Present in View area of the Set Building View Op-
tions form provides controls for the visibility of area, line and
point objects. When a check box in this area is checked, the ob-
jects of that type are visible; when the box is not checked, ob-
jects are not visible. Note that when objects are not visible be-
cause the appropriate check box in the Object Visibility area is
not checked, you cannot select the object. Contrast this with the
information in the second paragraph describing the Object Edge
feature in the subsection above entitled "Special Effects."

Following are the items for which you can control the object
visibility:

Note:

If an object
does not have
its corre-
sponding check
box checked in
the Object Visi-
bility area of
the Set Building
View Options
form, then you
can not see or
select the ob-
ject.

Tip:

Showing extru-
sions is a con-
venient way of
checking the
local axes ori-
entation of
frame members.
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 Floor (Area): All floor-type area objects, that is, all horizontal
area objects with wall/slab/deck section property assignments.

 Wall (Area): All wall-type area objects, that is, all vertical
area objects with wall/slab/deck section property assignments.

 Ramp (Area): All ramp-type area objects, that is, all sloped
area objects (not vertical or horizontal area objects) with
wall/slab/deck section property assignments.

 Openings (Area): All area objects that are designated as
openings. Note that these are a subset of all null areas.

 All Null Areas: All null area objects, that is, all area objects
that do not have wall/slab/deck section property assignments.

 Column (Line): All column-type line objects. By default col-
umn-type line objects are those with frame section property as-
signments that are oriented vertically (length is oriented paral-
lel to the Z-axis).

 Beam (Line): All beam-type line objects. By default beam-
type line objects are those with frame section property assign-
ments that are oriented horizontally (fall in the XY plane).

 Brace (Line): All brace-type line objects. By default brace-
type line objects are those with frame section property assign-
ments that are sloped (not oriented vertically or horizontally).

 Link (Line): All line objects with link property assignments.
Note that it is possible for a line object to have both a frame
section property assignment and a link property assignment
simultaneously. In this case ETABS creates a frame member
and a link element in the same location in the analysis model.
The following two paragraphs describe how the ETABS object
visibility options affect this type of line object.

If a line object has a link property assignment and no frame
section assignment then it is classified as a null-type line ob-
ject. This line object is visible if either the Links (Line) box is
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checked or the All Null Lines box is checked, or both boxes
are checked.

If a line object simultaneously has a frame section property as-
signment and a link property assignment then the line object
type is either column, beam or brace depending on its orienta-
tion. Thus, for example, a vertical line object with both a
frame section property assignment and a link property assign-
ment (column-type) is visible if either the Column (Line) box
is checked or the Links (Line) box is checked, or both boxes or
checked. However it is not visible if the Column (Line) box
and the Links (Line) box are unchecked even if the All Null
Lines box is checked.

Note that this box does not control the visibility of zero-length
links that are assigned to point objects.

 All Null Lines: All null line objects, that is, all line objects
that do not have frame section property assignments. See the
discussion above for the Link (Line) check box for additional
information.

 Point Objects: This check box controls the visibility of point
objects. Note the following about this feature:

 When the Point Objects check box is not checked, point
objects are not visible in the model and point objects can-
not be selected in the model.

 When the Points Objects check box is checked and the as-
sociated Invisible check box is unchecked and the Object
Shrink check box is checked (see next bullet), point ob-
jects are visible and you can select them by clicking on
them or by windowing them. If the Invisible check box is
checked while the Points Objects check box is also
checked, the point objects are invisible in the model, but
you can select them by clicking on them or windowing
them.
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 This option works in conjunction with the Object Shrink
feature. That is, you only see a dot representing a point
object when point objects are visible (see previous bullet
item) and the Object Shrink feature is on (i.e., the Object
Shrink check box is checked in the Special Effects area of
the Set Building View Options form or you click the Ob-
ject Shrink Toggle  toolbar button).

 This option also works in conjunction with the Links
(Point) check box, the Supports check box, and the Springs
check box. The Point Objects check box must be checked
in order for links assigned to point objects, supports and
grounded springs to be visible. In other words, if the Links
(Point) check box is checked, the links assigned to point
objects are still not graphically visible unless the Point
Objects check box is also checked. Similarly, if the Sup-
ports check box is checked, the supports are still not
graphically visible unless the Point Objects check box is
also checked and if the Springs check box is checked, the
grounded point springs are still not graphically visible un-
less the Point Objects check box is also checked.

 Link (Point): All point objects with link property assignments.
Note that this box does not control the visibility of links that
are assigned to line objects. Also as noted previously, the
check box works in conjunction with the Point Objects check
box.

Object View Options
The Object View Options area of the Set Building View Options
form allows you to toggle the display of object labels, section
properties and local axes on and off. Following is a list of the
specific items you control in this area of the form:

 Area Labels: Labels (names) for all types of area objects
(floor, wall, ramp and null).
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 Line Labels: Labels (names) for all types of line objects (col-
umn, beam, brace and null).

 Point Labels: Labels (names) for all point objects.

 Area Sections: Wall/slab/deck section property names are dis-
played for all area objects with wall/slab/deck section property
assignments.

 Line Sections: Frame section property names are displayed for
all line objects with frame section property assignments.

 Link Sections: Link section property names are displayed for
all line objects with link section property assignments.

 Area Local Axes: Arrows indicating local axes orientation are
displayed for all area objects. Note that the local 1 axis is al-
ways shown with a red arrow, the local 2 axis is always shown
with a white arrow, and the local three axis is always shown
with a blue arrow.

 Line Local Axes: Arrows indicating local axes orientation are
displayed for all line objects. Note that the local 1 axis is al-
ways shown with a red arrow, the local 2 axis is always shown
with a white arrow and the local three axis is always shown
with a blue arrow.

Note that no control is provided for the point local axes. This is
the case because by default in ETABS, the point local axes al-
ways correspond to the global local axes. That is, for point ob-
jects, local axis 1 is the same as the global X-axis,  local axis 2 is
the same as the global Y-axis and local axis 3 is the same as the
global Z-axis.

Piers and Spandrels
The Piers and Spandrels area of the Set Building View Options
form allows you to toggle the display of pier and spandrel labels
and local axes on and off. Following is a list of the specific items
you control in this area of the form:

Tip:

One way to
remember the
colors associ-
ated with the
local axes is to
think of the
American flag
which is red,
white and blue.
Note that local
axis 1 is red,
local axis 2 is
white and local
axis 3 is blue.
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 Pier Labels: Labels (names) for all specified pier elements.
Recall that you specify one or more area objects as a pier by
selecting them and then clicking the Assign menu >
Shell/Area > Pier Label command.

 Spandrel Labels: Labels (names) for all specified spandrel
elements. Recall that you specify one or more area objects as a
spandrel by selecting them and then clicking the Assign menu
> Shell/Area > Spandrel Label command.

 Pier Axes: Arrows indicating local axes orientation are dis-
played for all specified piers. Note that the local 1 axis is al-
ways shown with a red arrow, the local 2 axis is always shown
with a white arrow and the local three axis is always shown
with a blue arrow.

 Spandrel Axes: Arrows indicating local axes orientation are
displayed for all specified spandrels. Note that the local 1 axis
is always shown with a red arrow, the local 2 axis is always
shown with a white arrow and the local three axis is always
shown with a blue arrow.

Visible in View
The Visible in View area of the Set Building View Options form
allows you to toggle the display of the following items:

 Story Labels: This item toggles the labels (names) for story
levels on and off in elevation views. Note that the program
does not display story level labels in three dimensional views
to avoid cluttering the view. Story label names can be edited
using the Edit menu > Edit Story Data > Edit command.

 Dimension Lines: This item toggles the display of dimension
lines on and off. Note that dimension lines are only displayed
in plan and elevation views, not three-dimensional views.

 Reference Lines: This item toggles the display of reference
lines on and off. See the section titled "Edit Reference Planes
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and Edit Reference Lines Commands" in Chapter 5 Edit Menu
for additional information.

 Reference Planes: This item toggles the display of reference
planes on and off. See the section entitled "Edit Reference
Planes and Edit Reference Lines Commands" in Chapter 5 Edit
Menu for additional information.

 Grid Lines: This item toggles the display of primary grid lines
on and off. It does not affect the display of secondary grid
lines. Use the Edit menu > Edit Grid Data command to con-
trol whether a grid line is a primary or secondary grid line.

 Secondary Grids: This item toggles the display of secondary
grid lines on and off. It does not affect the display of primary
grid lines.  Use the Edit menu > Edit Grid Data command to
control whether a grid line is a primary or secondary grid line.

 Global Axes: This item toggles the display of global axes on
and off. Note that you can use the View menu > Change Axes
Location command to modify the location of the global axes
in a view.

 Supports: This item toggles the display of supports (restraints)
on and off. Note that both this item and the Point Objects box
in the Object Visibility area of the Set Building View Options
form must be checked for the supports to be visible. The four
basic graphic symbols used for displaying supports in the
ETABS graphical interface are as follows:

Roller:

Pinned:

Fixed:

Other:

 Springs: This item toggles the graphical display of grounded
point springs (not links) on and off. Note that these are the
springs that are assigned using the Assign menu > Joint/Point
> Point Springs command. Also note that if the Springs check
box is checked, the grounded point springs are still not graphi-
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cally visible unless the Point Objects check box is also
checked.

Special Frame Items
The Special Frame Items area of the Set Building View Options
form allows you to toggle the display of various assignments
made to line objects. These assignments are only meaningful if
the line object is also assigned a frame section property. If the
line object is not checked to be visible in the Objects Present in
View area of the form, the special frame assignments are not
visible even if their box is checked. Following is a list of the
specific items you control in this area of the form:

 End Releases: This item toggles the display of dots near each
end of any line object with frame section properties that has an
end release assignment (with or without partial fixity). The
color of the dots is based on the default color specified for text
in the Options menu > Colors > Display command. The end
releases are assigned using the Assign menu > Frame/Line >
Frame Releases/Partial Fixity command.

 Partial Fixity: This item toggles the display of text saying
"FIX*" without the quotes for any line object with frame sec-
tion properties that has an end release assignment with partial
fixity specified at one or both ends. The asterisk has no specific
meaning but rather is a convenient method of minimizing any
confusion between this text and other labels that may be con-
currently displayed. The partial fixity is assigned using the As-
sign menu > Frame/Line > Frame Releases/Partial Fixity
command.

 Moment Connections: This item toggles the display of trian-
gles at the ends of frame members that are fully fixed. The
moment connection symbols are only displayed for beams and
braces. They are not displayed for columns.

The moment connection symbol only appears on beams and
braces that have no end releases of any type assigned to them.
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If a beam or brace has any type of end release assigned to it
(e.g., axial, shear, moment or torsion), the moment connection
symbol will not appear for that object.

 Property Modifiers: This item toggles the display of text
saying "PM*" without the quotes for any line object with
frame section properties that is assigned frame property modi-
fiers that are not all ones. The asterisk has no specific meaning
but rather is a convenient method of minimizing any confusion
between this text and other labels that may be concurrently
displayed. The frame property modifiers are assigned using the
Assign menu > Frame/Line > Frame Property Modifiers
command.

 Nonlinear Hinges: This item toggles the display of dots to-
gether with a text label at the location of each frame nonlinear
hinge (pushover) assigned to a line object with frame section
properties. The color of the dots is based on the default color
specified for text in the Options menu > Colors > Display
command. The frame nonlinear hinges are assigned using the
Assign menu > Frame/Line > Frame Nonlinear Hinge
command.

 Panel Zones:  This item toggles the display of a Panel Zone at
each joint assigned as a Panel Zone.

 End (Length) Offsets: This item toggles the display of thick-
ened lines at any end of a line object with frame section prop-
erties that has an end offset along the length of the beam as-
signed to it. The length of the thickened line is scaled to match
the specified length of the end offset. The color of the thick-
ened lines is based on the default color specified for text in the
Options menu > Colors > Display command. The end offset
is assigned using the Assign menu > End (Length) Offsets
command. This command brings up the Assign Frame End
Length Offsets form. See Chapter 10 Assign Menu for more
information.

 Joint Offsets: This item toggles the display of text saying
"OFF*" without the quotes  for any line object with frame sec-

Tip:

Do not confuse
end offsets and
joint offsets.
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tion properties that has a frame joint offset assigned to it. The
asterisk has no specific meaning but rather is a convenient
method of minimizing any confusion between this text and
other labels that may be concurrently displayed. The joint off-
set is assigned using the Assign menu > Frame/Line > Inser-
tion Point command. This command brings up the Frame In-
sertion Point form where you can specify the frame joint off-
sets from the Cardinal Point.

 Output Stations: This item toggles the display of text values
reporting either the maximum output station spacing or the
minimum number of output stations depending on how the
output stations are specified. If the text value is reported in pa-
renthesis, the value represents the minimum number of output
stations. If it is not reported in parenthesis, it is the maximum
spacing between output stations. The frame output stations are
assigned using the Assign menu > Frame/Line > Frame
Output Stations command.

The graphics or text displayed as a result of checking boxes in
this area of the Set Building View Options form alert you that a
particular type of assignment is made to a line object with frame
section properties, but the display does not tell you the particu-
lars of the assignment because of space limitations. You can al-
ways right click on the line object to review its assignments in
detail.

Other Special Items
The Other Special Items area of the Set Building View Options
form allows you to toggle the display of other miscellaneous
items. Following is a list of the specific items you control in this
area of the form:

 Diaphragm Extent: This item toggles the graphical display of
the extent of rigid diaphragms (if any). A large dot is displayed
at the center of mass associated with the rigid diaphragm.
Dashed lines are drawn from this center of mass point to each
point object that is a part of the rigid diaphragm constraint.
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Also, text is provided adjacent to the large dot identifying the
name of the rigid diaphragm.

Note that the rigid diaphragms are assigned using either the
Assign menu > Joint/Point > Rigid Diaphragm command or
the Assign menu > Shell/Area > Rigid Diaphragm com-
mand.

 Auto Floor Mesh: This item toggles the graphical display of
automatic meshing of area objects performed by the program.
This feature puts the model in a special display mode where
elements are shown rather than objects. In other words, the
shell elements in the analysis model are displayed. The model
is displayed with the elements shrunken so that you can clearly
see the meshing.

Note that when you select this item, all other items in the Set
Building View Options form are grayed out because they will
not be displayed on the analysis model.

 Additional Masses: This item toggles the display of text val-
ues of additional area, line and point masses. The additional
area masses are assigned using the Assign menu > Shell/Area
> Additional Area Mass command. The additional line
masses are assigned using the Assign menu > Frame/Line >
Additional Line Mass command. The additional point masses
are assigned using the Assign menu > Joint/Point > Addi-
tional Point Mass command.

Zoom Commands
There are five zoom features available in this program. Those
features allow you to zoom in or out on a view. Zooming in en-
larges a smaller area of the model to show more detail, and
zooming out decreases detail but shows more of the overall
model. All five zoom features are available using the View menu
command and the toolbar buttons. The zoom features and their
associated toolbar buttons are as follows:
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Rubber Band Zoom, 
This command allows you to zoom in on the model by window-
ing. To use the command, depress and hold down the left button
on your mouse. While keeping the left button depressed, drag the
mouse to "rubber band" a window around the portion of the view
that you want to zoom in on. The rubber band window that
shows the extent you have dragged the mouse appears as a
dashed line on your screen. When you release the mouse left
button, the new view is displayed.

Restore Full View, 
This command has two uses. First, if you have zoomed in or out
from the initial default view of a window, this command returns
you to the original default view where the entire structure just
fills the window.

The second use for this command occurs if you have used the
View menu > Pan command to change the view in the window.
In that case, the View menu > Restore Full View command re-
turns you to the view that you had before you executed the View
menu > Pan command.

When you use both zoom commands and pan commands to-
gether, the program behaves as follows, depending on the order
in which you performed the zoom and pan commands:

 If you first perform a zoom command and then a pan com-
mand, clicking the View menu > Restore Full View com-
mand once returns you to the view you had before executing
the pan command. Clicking the View menu > Restore Full
View command a second time returns you to the original de-
fault view for the window where the entire structure just fills
the window.

 If you first perform a pan command and then a zoom com-
mand, clicking the View menu > Restore Full View com-
mand returns you to the original default view for the window
where the entire structure just fills the window.
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Previous Zoom, 
This command takes you back to your immediately previous
zoom settings. If you use the View menu > Previous Zoom
command repeatedly without using other commands to change
the zoom in between, the effect is to toggle between two zoom
settings. You cannot use the View menu > Previous Zoom to go
back more than one zoom setting.

The View menu > Previous Zoom command has no effect in
the following circumstances:

 Immediately after you first display a view in a window.

 Immediately after you use the View menu > Pan command.

Zoom In One Step, 
This command zooms in on the model one step. The size of the
step is controlled by the Auto Zoom Step item in the Preferences
form, which can be accessed using the Options menu > Prefer-
ences > Dimensions/Tolerances command.

The program default value for the Auto Zoom Step is 10 percent.
This means that when you use the View menu > Zoom In One
Step command, the program increases the magnification of all
objects in the view by 10 percent.

Zoom Out One Step, 
This command zooms out on the model one step. The size of the
step is controlled by the Auto Zoom Step item in the Preferences
form, which can be accessed using the Options menu > Prefer-
ences > Dimensions/Tolerances command.

The program  default value for the Auto Zoom Step is 10 per-
cent. This means that when you use the View menu > Zoom
Out One Step command, the program decreases the magnifica-
tion of all objects in the view by 10 percent.
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Pan Feature
The pan feature allows you to move a view within the window
such that you can see beyond the original edges of the view. The
distance you can move beyond the original edge of the view is
controlled by the Pan Margin item that is set in the preferences.
The Options menu > Preferences > Dimensions/Tolerances
command gives you access to the Pan Margin preference item.
See the subsection entitled "Dimensions and Tolerances Com-
mand" under the section entitled "Preferences" in Chapter 14
Options Menu for more information on the Pan Margin item.

Click the View menu > Pan command or the Pan  button to

pan a view. After you have used the menu command or clicked
the button, click and hold down the left mouse button in the view
and drag the mouse (while still holding down the left mouse
button) to pan the view.

You must reuse the menu command or re-click the button every
time you pan. If you have panned a view one or more times,
clicking the View menu > Restore Full View command, or its
associated button returns you to the view you had before you
executed the first View menu > Pan command.

Measure Command
You can use the View menu > Measure command to make
measurements in your model. You can measure lines, areas and
angles. Each of these are described below.

 Lines: When you execute the View menu > Measure > Line
command, left click on two points to define the line you want
to measure and the program will report the length of the line in
the status bar at the bottom of the program window.

 Areas: When you execute the View menu > Measure > Area
command, left click on the corner points of an area you want to
measure and the program will report the area and perimeter of
the area in the status bar at the bottom of the program window.

Tip:

You can use the
Draw menu >
Draw Dimen-
sion Line
command to
draw dimension
lines that in-
clude dimen-
sion text
(measure-
ments).
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When defining the last point for the area, either double left
click, or single left click and press the Enter key (or Esc key)
on your keyboard.

 Angles: When you execute the View menu > Measure > An-
gle command, left click on three points to define two lines that
have one common endpoint. The program reports the angle
between these lines in the status bar at the bottom of the pro-
gram window. The angle is always reported in degrees and it is
always less than or equal to 180 degrees.

Note the following about using the View menu > Measure
command.

 After you have drawn the line, area or angle and reviewed the
measurement, click anywhere and the drawn line, area or angle
will be deleted.

 The measurements are always reported in the current units.

Change Axes Location Command
By default, the global axes are shown at the global origin. You
can use the View menu > Change Axes Location to display the
Axes Location form that allows you to specify a new location for
the global axes. The new location is specified by entering global
X, Y and Z coordinates.

Note the following about the global axes:

 A default view for a window is not scaled such that the global
axes fit in the window. Thus if you locate the global axes a
large distance from the rest of your structure, they may not be
visible in a default view. (The default view for a window is
scaled based on story levels, grid lines and area, line and point
objects.)
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 You can control the visibility of the global axes using the View
menu > Set Building View Options or the corresponding Set
Building View Options  button .

Show Selection Only and Show All Commands
Sometimes you may find that there are too many objects in a
view for you to see necessary details. In such cases, you may
want to select just a few of the objects in the view and use the
View menu > Show Selection Only command. This command
will refresh the view such that only the selected items are visible
in the window. If you change the view type in the window, say
from a plan view to a 3D view, the originally selected items
continue to be the only ones visible. Use the View menu > Show
All command to remove the effects of the View menu > Show
Selection Only command.

Save Custom View and Show Custom View Com-
mands

The View menu > Save Custom View command allows you to
give any view a name and then save it. You can then later use the
View menu > Show Custom View command to restore your
named custom view.

These commands can be useful if you are going to use a certain
view over and over again and it takes you significant time to cre-
ate the view. For example, if you have a view with special limits
set and selected objects only displayed and a special zoom set
and a special view angle set, you may want to save it as a custom
view so that you can easily recreate it at a later time.

Refresh Window and Review View Commands
The View menu > Refresh Window command and the corre-
sponding Refresh Window button   are used to refresh the
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view after drawing or editing objects. This command redraws
what is visible on the screen but does not rescale it in any way.

The View menu > Refresh View command is also used to re-
fresh the view after drawing or editing objects. This command
redraws what is visible on the screen and returns the view to its
default full view where the entire model is visible. Note that the
default view is scaled based on all grid lines, story levels, and
objects being included in the view. Thus if any new grid lines,
story levels, or objects have been added outside of the original
model boundaries, this command rescales the default full view
such that all grid lines, story levels, and objects fit into it.

The refresh view and refresh window commands are similar.
However, unlike the refresh view command, the refresh window
command does not rescale the window or return it to a default
view.

Show Rendered View
Clicking the View menu > Show Rendered View command
brings up the Model Viewer window. A rendering of your model
is displayed when you click the Reset and Refresh View button

 in the upper left-hand corner of the Model Viewer window.

The Model Viewer renders the view that is shown in the active
window (i.e., plan, elevation, or 3D) at the time the View menu
> Show Rendered View command is selected.

This command gives you a realistic, extruded view of the struc-
tural objects that you have defined in your model. You can
change the angle and position of the view by clicking on the ren-
dering in the Model Viewer window and holding the left button
down while you move the mouse. You can also zoom in or out of
the view by clicking and holding down the left or right mouse
button, respectively, and NOT moving the mouse.

The View menu > Show Rendered View command is a power-
ful tool for verifying the geometry of your model.

Tip:

Click the Reset
and Refresh

View 

button in the
Model Viewer
to display the
Rendered View.
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Chapter 7

Define Menu

General
The Define menu provides a means of defining section proper-
ties and load case definitions. This chapter describes the features
available on the Define menu.

Items related to ETABS nonlinear analysis are mentioned in
passing but elaboration on those items is beyond the scope of
this manual. Consult the Technical Notes for more in-depth de-
scriptions of items related to nonlinear analysis.

Material Properties Command
The material properties in this program are always linear elastic.
Use the Define menu > Material Properties command or 

button to define material properties. This command brings up the
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Define Materials form where the names of all defined material
properties are listed. In this form you can do the following:

 Click the Add New Material button to display the Material
Property Data form where you can define new material prop-
erties.

 Highlight a material property name and click the Mod-
ify/Show Material button to display the Material Property
Data form where you can review and/or modify the material
properties for the highlighted material property.

 Click the Delete Material button to delete an existing material
property. Note that you cannot delete two built-in material
properties that are named STEEL and CONC. You also can
not delete any material property that is currently specified in
the definition of a frame section property or a wall/slab/deck
section property. In other words, you cannot delete a material
property if it is in use.

Material Property Data Form
The Material Property Data form consists of six different areas.
They are:

 Material name: Specifies or modifies the name of a material
property. Note that you cannot change the name of the built-in
STEEL and CONC material properties.

 Type of material: Specifies the material to be isotropic or or-
thotropic. The option chosen here affects what is shown in the
Analysis Property Data area of the form.

The behavior of an isotropic material is independent of the di-
rection of loading. In addition, the shearing behavior is uncou-
pled from the extensional behavior and it is not affected by
temperature change. Isotropic behavior is usually assumed for
steel and concrete, although that is not always the case.

Note:

You can specify
isotropic or
orthotropic
material prop-
erties in
ETABS.
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The isotropic mechanical and thermal properties relate strain to
stress and temperature change as shown in Figure 7-1a. In the
figure, e1 is Young's modulus of elasticity, u12 is Poisson's
ratio, g12 is the shear modulus and a1 is the coefficient of
thermal expansion.

The shear modulus is not directly specified for an isotropic
material. Instead, the program derives it from the specified
Young's modulus and Poisson's ratio as shown in Equation 7-1.

( )u1212

e1
g12

+
= Eqn. 7-1

Note that in this program, Poisson's ratio must satisfy the con-
dition that 0 ≤ u12 < 0.5 and that Young's modulus must be
positive.

The behavior of an orthotropic material can be different in the
three local axis directions. However, like an isotropic material,
the shearing behavior is uncoupled from the extensional be-
havior and it is not affected by temperature change.

The orthotropic mechanical and thermal properties relate strain
to stress and temperature change as shown in Figure 7-1b. In
the figure e1, e2 and e3 are the moduli of elasticity, u12, u13
and u23 are the Poisson's ratios, g12, g13 and g23 are the shear
moduli and a1, a2 and a3 are the coefficients of thermal ex-
pansion.
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Note that in this program, for orthotropic materials, the elastic
moduli and the shear moduli must be positive. The Poisson's
ratios may take on any values, provided that the upper left 3x3
portion of the stress-strain matrix is positive definite (i.e., has a
positive determinant.) The check for this is made at analysis
runtime, not when the values are entered.

 Analysis Property Data: Specifies the mass per unit volume,
weight per unit volume, modulus of elasticity, Poisson's ratio,
coefficient of thermal expansion, and if you are specifying an
orthotropic material, the shear modulus.

The mass per unit volume is used in calculating the self-mass
of the structure if you have specified that mass is to be deter-
mined from element and additional masses. The weight per
unit volume is used in calculating the self-weight of the struc-
ture.

For isotropic materials, define one value for the modulus of
elasticity, Poisson's ratio and coefficient of thermal expansion.
The shear modulus is calculated as previously described for
Equation 7-1.

For orthotropic materials, define three values for the modulus
of elasticity (one for each local axis direction), the Poisson's
ratio, the coefficient of thermal expansion and the shear
modulus.

 Display Color: Assigns a color to the material property. If you
use the View menu > Set Building View Options command
or  button to display the Set Building View Options form,

you can then choose an option to view the model based on the
colors associated with the material properties. In that case,
each object appears in a color associated with its assigned ma-
terial property. See the section entitled "Set Building View
Options Command" in Chapter 6 View Menu for more infor-
mation. You can change the color associated with the material
by clicking in the color box.
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 Type of Design: Here you can specify the type of design as
Steel, Concrete or None. The option you specify here affects
what is shown in the Design Property Data area of the form.

The Steel Frame Design and Composite Beam Design postpro-
cessors do not design members unless (among other things) the
type of design specified for their associated material property
is Steel.

The Concrete Frame Design and Shear Wall Design postpro-
cessors do not design members unless (among other things) the
type of design specified for their associated material property
is Concrete.

 Design Property Data: The data specified in this area de-
pends on the design type specified in the Type of Design area
of the form. In general, the Design Property data specified in
the Material Property Data form is used only by the design
postprocessors. The one exception to this is that for any degree
of freedom in the frame nonlinear hinge properties that is
specified as default, the program calculates the hinge force-
deformation properties based on the Design Property data pro-
vided here.

If the type of design is Steel, the following items are specified:

 Minimum yield stress, Fy

 Minimum tensile stress, Fu

 Cost per unit weight

The cost per unit weight item is used in the Composite Beam
Design postprocessor when the optimum beam size may be
determined based on the cost of the beam, connectors and
camber, rather than just the area (weight) of the beam.

If the type of design is Concrete, the following items are
specified:

Note:

The shear
strength reduc-
tion factor
multiplies the
calculated con-
crete shear
strength. This
reduction factor
is used for all
shear calcula-
tions whenever
lightweight
concrete is
specified.
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 Specified Concrete Compressive Strength, f'c: This item
is used in all calculations.

 Bending Reinforcing Yield Stress, fy: This is the rein-
forcing steel yield stress used in the calculations for bend-
ing and axial load calculations.

 Shear Reinforcing Yield Stress, fys: This is the rein-
forcing steel yield stress used in the calculations for shear.

 Lightweight Concrete: Check this check box if you have
lightweight concrete. Checking this check box enables the
shear strength reduction factor edit box.

 Shear Strength Reduction Factor: If the lightweight
concrete check box is checked, then for all shear calcula-
tions, the calculated concrete shear strength is multiplied
by this factor. Typically, this reduction factor is between
0.75 and 0.85.

If the type of design is None, nothing is specified in the Design
Property Data area.

Frame Sections Command
Use the Define menu > Frame Sections command or  but-

ton to define frame section properties. This command brings up
the Define Frame Properties form. The Properties area of this
form lists the names of all the currently defined frame section
properties. The Click To area of the form allows you to define
new frame sections, modify existing frame section definitions
and delete existing frame sections. Note that you can only delete
frame sections if they are not currently assigned to any line ob-
jects in your model and if they are not used to define other frame
section properties, such as nonprismatic sections and auto select
section lists.
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Importing Sections from a Database
The drop-down box that initially reads "Import I/Wide Flange"
in the Click To area of the Frame Properties form allows you to
import many different types of frame section properties from one
of several section databases that are included with this program.
The types of section properties you can import are as follows:

 I-shaped members, including wide flange sections

 Channels

 Double channels

 Structural tees

 Single angles

 Double angles

 Structural box/tubes

 Pipe sections

 Rectangular sections

 Circular sections

 General sections

 Steel Joists

Note that the Rectangular, General and Circular sections in the
above list are not available in the section databases provided
with the program but could be in user-created section databases.

Typically, the sections in the database file have both section
properties (e.g., area, moment of inertia) and specified dimen-
sions. General sections have section properties associated with
them but no dimensions specified for them. Steel joists have
section properties specified, or total load and live load capacities
are specified for a range of joist spans, but no dimensions are
specified.

Shortcut:

Use the Assign
menu >
Frame/Line >
Frame Section
command to
simultaneously
define frame
sections and
assign them to
selected line
objects.
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To import a section from a database, click the Define menu >
Frame Sections command or  button, click on one of the

section types in the Import drop-down box and specify a data-
base file from which to choose the section, if necessary.

The default name for the frame sections database file is Sec-
tions.pro. Note that the steel joist sections are kept in a separate
database file with the default name of Joists.pro. Steel joist sec-
tion properties are described later in this chapter in the section
entitled "Steel Joist Section Properties."

The program then displays a list of all of the sections of the type
specified in the database. You can select one or more sections
from the list by clicking on them. Following are some possible
methods of multiple selection:

 Select one section by left clicking on it and continuing to hold
down the mouse button while dragging your mouse up or
down to select additional adjacent sections.

 Select one section by left clicking on it. Then hold down the
Shift key on your keyboard and select another section. The
second section is added to the selection as well as all sections
between the first and second section.

 Select one section by left clicking on it. Then hold down the
Ctrl key on your keyboard and select another adjacent or non-
adjacent section. That section is added to the selection. You
can continue holding down the Ctrl key and clicking on other
sections to add them to the selection.

Adding User-Defined Frame Section Properties
The drop-down box that initially reads "Add I/Wide Flange" in
the Click To area of the Frame Properties form allows you to
easily define section properties for many different types of frame
sections. The types of section properties you can define are as
follows:

 I-shaped members
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 Channels

 Double channels

 Structural tees

 Single angles

 Double angles

 Structural tubes

 Pipe sections

 Rectangular sections

 Circular sections

 General sections

 Steel joist sections

 Auto select section list

 Sections defined in the Section Designer utility

 Nonprismatic sections

For all but the last five items in the above list, simply specify
dimensions for the section and the program will automatically
calculate the section properties. For general sections, simply
specify the section properties (e.g., area, moment of inertia, shear
area). No dimensions are input for general sections. Figure 7-2 is
provided to help you determine the shear area for general sec-
tions of various shapes.

Steel joist section properties are described later in this chapter in
the section entitled "Steel Joist Section Properties."
Frame Sections Command 7 - 9
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Auto select section lists are simply lists of previously defined
steel sections. These are useful for Steel Frame Design and
Composite Floor Design because the program can pick the opti-
mal section for a steel frame element from an Auto Select Sec-
tion List. There must be at least two steel frame sections defined
before you are allowed to define an auto select section list.

You can use the Section Designer utility to graphically define
unusual sections. The program then calculates the section prop-
erties for that section. See the section entitled "Adding Frame
Section Properties using Section Designer" later in this chapter
for more information.

You can use the Add Nonprismatic feature to define nonpris-
matic frame sections where the section properties vary along the
length of the frame element. See the section entitled "Nonpris-
matic Sections" later in this chapter for more information.

When you specify concrete frame sections, you can also specify
some of the reinforcing information. See the section entitled
"Reinforcing for Concrete Frame Section Properties" later in this
chapter for more information.

Steel Joist Section Properties
The database file for joist sections includes the Steel Joist Insti-
tute (SJI) K-Series, KCS-Series, LH-Series and DLH-Series
joists. The capacities used for these items are those published by
the SJI.

The K-, LH- and DLH-Series joist capacities are all defined by
total load capacities and live load capacities that produce an
L/360 deflection specified for a range of joist spans. This is ref-
erenced in the program as Standard design capacities. The KCS-
Series joist capacity is specified by a moment capacity, a shear
capacity, a moment of inertia, and minimum and maximum
spans for which the joist can be used. This is referenced in the
program as Envelope design capacities

Tip:

Use the Section
Designer utility
to graphically
define frame
sections. Select
the Add SD
Section option
in the Define
Frame Proper-
ties form.
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In addition to the joist section properties that can be imported
from the database file, you can also define user joist section
properties. The capacities of the user joists can either be defined
as Standard design capacities (similar to the K-Series joists) or as
Envelope design capacities (similar to the KCS-Series joists).

Note that you can not directly modify the joist section properties
that are imported from the joist database file. However, upon
import, you can convert those imported sections to user sections
that can then be modified.

When you define steel joist properties, there is a moment of in-
ertia term called I33 for Analysis. This moment of inertia is used
in the analysis model. It is also used to calculate the joist deflec-
tion for joists with Envelope design (e.g., KCS-Series joists). In
addition, the Standard Design joists have an I33 specified for
each span at which capacity data is specified. This I33 value is
only used when displaying the deflection diagram that is avail-
able when performing Interactive Joist Design.

Adding Frame Section Properties Using Section
Designer

Select the Add SD Section option in the Define Frame Properties
form to define a frame section property using the Section De-
signer feature. This brings up the SD Section Data form. The
following areas are in this form:

 Section Name: You can specify or modify the name of the
frame section.

 Base Material: You can specify or modify a defined material
property. The options available in the Design Type area of the
form will depend on the type of material selected here.

 If the Base Material is Concrete, the Design Type options
available are No Check/Design and the Concrete Column
options.
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 If the Base Material is Other, the Design Type option
available is No Check/Design.

 If the Base Material is Steel, the Design Type options
available are No Check/Design and the General Steel Sec-
tion.

 Design Type: You can specify the section type, given the re-
strictions outlined in the previous bullet. If the Design Type is
No Check/Design (not designed), any frame section assigned
this property is not designed by any postprocessor. If the De-
sign Type is General Steel Section, any frame section assigned
this property is designed by the Steel Frame Design postpro-
cessor as a general section. If the Design Type is Concrete
Column, any frame section assigned this property is designed
by the Concrete Frame Design postprocessor.

 Concrete Column Check/Design: This area is only active if
the Concrete Column option is selected in the Design Type
area. Here you specify whether the concrete column is to have
its specified reinforcing checked or new longitudinal reinforc-
ing designed when it is run through the Concrete Frame De-
sign postprocessor.

 Define/Edit/Show Section: After you have appropriately
specified items in the other areas of the form, click the Section
Designer button in this area to go to the Section Designer util-
ity and draw the section. When you exit the Section Designer
utility, you return to the SD Section Data form. You can then
click the OK button to complete the definition of the frame
section property.

Nonprismatic Sections
Nonprismatic frame sections may be defined for which the prop-
erties vary along the element length. You may specify that the
element length be divided into any number of segments; they do
not need to be of equal length. Most common situations can be
modeled using from one to five segments.
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The variation of the bending stiffnesses may be linear, parabolic,
or cubic over each segment of length. The axial, shear, torsional,
mass, and weight properties all vary linearly over each segment.
Section properties may change discontinuously from one seg-
ment to the next.

See Figure 7-3 for examples of nonprismatic frame sections.
Figure 7-3a shows a steel beam with cover plates at the ends.
Section A is the section without cover plates and section B is the
section with cover plates. You might define section B by click-
ing the Define menu > Frame Sections command, selecting
"Add SD Section" from the Add drop-down box and drawing the
section in the Section Designer utility (separate instructional
documentation is available for the Section Designer utility).

After both section A and section B have been defined, you can
define the nonprismatic section using the Define menu > Frame
Sections command and selecting "Add Nonprismatic" from the
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30"
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b) Concrete Column with Flare at Top

Figure 7-3:
Nonprismatic frame
section examples

Note:

ETABS ana-
lyzes nonpris-
matic sections.
The Steel
Frame Design
and the Con-
crete Frame
Design post-
processor can
design non-
prismatic sec-
tions. The
Composite
Beam Design
postprocessors
do not currently
design non-
prismatic sec-
tions.



Chapter 7 - Define Menu

Nonprismatic Sections 7 - 15

7

Add drop-down box to display the Nonprismatic Section Defini-
tion form. Table 7-1 shows the assignments that would be en-
tered in the form. Note that the variation items grayed out in the
table are not used by the program because the start section and
the end section are the same.

In Table 7-1 note that segment 2 has a length type of variable
and a segment length of 1. See the subsection entitled "Segment
Lengths and Segment Type" for an explanation of these pa-
rameters.

Table 7-1: Input for Nonprismatic Frame Section Example in Figure 7-3a

Segment
Start

Section
End

Section Length
Length
Type

EI33
Variation

EI22
Variation

1 B B 24 Absolute

2 A A 1 Variable

3 B B 30 Absolute

Figure 7-3b shows a concrete column with a flare at the top.
Section A is the section at the lower portion of the column and
section B is the section at the top of the column. You might de-
fine both section A and B by clicking the Define menu > Frame
Sections command, and selecting "Add Rectangular" from the
Add drop-down box.

After both section A and section B have been defined, you can
define the nonprismatic section using the Define menu > Frame
Sections command and selecting "Add Nonprismatic" from the
Add drop-down box to display the Nonprismatic Section Defini-
tion form. Table 7-2 shows the assignments that would be en-
tered into the form. Note that the variation items grayed out in
the table are not used by the program because the start section
and the end section are the same.
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Table 7-2: Input for Nonprismatic Frame Section Example in Figure 7-3b

Segment
Start

Section
End

Section Length
Length
Type

EI33
Variation

EI22
Variation

1 A A 1 Variable

2 A B 50 Absolute Cubic Linear

Nonprismatic Section Definition Form Buttons
The following buttons appear on the Nonprismatic Section Defi-
nition form and complete the actions described when used with
the Start Section and End Section drop-down boxes and the
Length edit box.

 Add:  This button adds the selected parameters to your seg-
ment definition. First, highlight the name of the section where
you want to start your segment in the Start Section drop-down
box. Then highlight the name of the section where you want
your segment to end in the End Section drop-down box. Con-
tinue defining your segment by typing in the desired length in
the Length edit box; and the desired parameters from the drop-
down boxes for length type and variations. Click the Add
button to complete your definition.

Note that clicking the Add button again quickly repeats the
definition. Repeating the definition can be helpful if you want
to define a second segment that has only one parameter that
needs to be modified, such as the Start Section selection. See
the Modify bullet item for an explanation of how to modify a
parameter or segment definition.

 Insert: This button inserts a selection into your list of defined
segments. Assume you have already defined segments X and
Y and that you want to insert segment A after segment X and
before segment Y. To do this, highlight segment Y, define
segment A by selecting from the drop-down boxes and using
 - 16 Nonprismatic Sections

the edit boxes. When the segment is fully defined, click the In-
sert button. You can repeat the insertion by clicking the Insert
button.
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 Modify: To change any parameter, highlight the parameter
that you want to change in the list of defined segments. Then
click the pull down box and highlight the new selection or type
the new parameter in the edit box before clicking the Modify
button.

 Delete: To delete a segment, highlight the segment and then
click the Delete button.

Starting and Ending Sections
The properties for a segment of a nonprismatic section are de-
fined using the drop-down boxes on the Nonprismatic Section
Definition form. From these drop-down boxes, select the fol-
lowing:

 The section name of a previously defined prismatic section
that defines the properties at the start of the segment, i.e., at the
end closest to joint i.

 The section name of a previously defined prismatic section
that defines the properties at the end of the segment, i.e., at the
end closest to joint j. The starting and ending sections may be
the same if the properties are constant over the length of the
segment.

The material would normally be the same for both the starting
and ending sections and only the geometric properties would dif-
fer, but this is not required.

 Segment Lengths and Length Type
When a nonprismatic frame section is assigned to an element,
the actual lengths of each segment for that element are deter-
mined as follows:

 The clear length of the element, Lc, is first calculated as the
total length minus the end offsets: Lc = L - (ioff + joff). In this
equation L is the full length of the frame element and ioff and
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joff are the lengths of the end offsets along the length of the
frame element at the i and j ends of the element respectively.

 If the sum of the absolute lengths of the segments exceeds the
clear length, they are scaled down proportionately so that the
sum equals the clear length. Otherwise, the absolute lengths
are used as specified.

 The remaining length (the clear length minus the sum of the
absolute lengths) is divided among the segments having vari-
able lengths in the same proportion as their specified lengths.
For example, for two segments with variable lengths specified
as vl1 = 1 and vl2 = 2, one-third of the remaining length goes
to the first segment, and two-thirds to the second segment. See
the calculations to the left.

The length of a nonprismatic segment may be specified as either
a variable length or an absolute length.

Variation of Properties
Nonprismatic column/beam/brace section properties are inter-
polated along the length of each segment from the values at the
two ends. The variation of the bending stiffnesses, EI33 and EI22,
along the length of the segment is specified as linear, parabolic,
or cubic; the variation type can be changed using the drop-down
box on the Nonprismatic Section Definition form.

Specifically, the linear, parabolic or cubic variation for EI33 is
calculated by the program as follows:

 Linear: The value EI33 varies linearly along the length of the
segment.

 Parabolic: The value 2
33EI  varies linearly along the length

of the segment.

 Cubic: The value 3
33EI  varies linearly along the length of

the segment.

1st Segment:

3

1
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vl2vl1

vl1 =
+

=
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2nd Segment:
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+
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This usually corresponds to a linear variation in one of the sec-
tion dimensions. For example, a linear variation in the width of a
rectangular shape yields a linear variation for EI33. A linear
variation in the depth of a rectangular shape yields a cubic varia-
tion for EI33. Finally, a linear variation in the depth of an I-shape
yields a parabolic variation for EI33.

The interpolation of the bending stiffness in the 1-2 plane, EI22, is
defined in the same manner to that for the 1-3 plane.

The remaining stiffness properties, other than EI33 and EI22, are
always assumed to vary linearly between the ends of each seg-
ment. Similarly, the mass and weight densities are always as-
sumed to vary linearly between the ends of each segment.

If a shear area is zero at either end, it is taken to be zero along
the full segment, thus eliminating all shear deformation in the
corresponding bending plane for that segment.

Effect upon End Offsets Along the Length of Frame
Elements

Frame section properties vary only along the clear length of the
element. Section properties within the longitudinal end offset at
the i-end of the element are constant using the starting section of
the first segment. Section properties within the end offset at the
j-end of the element are constant using the ending section of the
last segment. Note that if a longitudinal end offset rigidity factor
is specified, the specified part of the end offset is rigid and the
rest has the section property described above.

Reinforcing for Concrete Frame Section Properties
When you specify frame section properties for rectangular or
circular concrete members you can also specify some of the rein-
forcing information for that member. When you use the Add
Rectangle or Add Circle option in the Click To area of the De-
fine Frame Properties form, the appropriate Rectangular Section
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or Circular Section form will appear. If the Material is set to
CONC (concrete) on the form, a Reinforcement button will ap-
pear. Clicking the Reinforcement button brings up the Rein-
forcement Data form. The Design Type on this form can be set
to Column or Beam.

Reinforcing Information for Columns
For columns the following areas are provided in the Reinforce-
ment Data form:

 Configuration of Reinforcement: Specifies rectangular or
circular reinforcement. You can, if desired, put circular rein-
forcement in a rectangular column or put rectangular rein-
forcement in a circular column.

 Lateral Reinforcement: If the Configuration of Reinforce-
ment is Rectangular, the Lateral Reinforcement can only be
Ties. If the Configuration of Reinforcement is Circular, the
Lateral Reinforcement can be Ties or Spiral (transverse).

 Rectangular Reinforcement: When the Configuration of
Reinforcement is Rectangular, the following options are avail-
able in this area.

 Cover to Rebar Center: This is the distance from the
edge of the column to the center of a longitudinal bar.

In the special case of rectangular reinforcement in a circu-
lar column, the cover is taken to be the minimum distance
from the edge of the column to the center of a corner bar
of the rectangular reinforcement pattern.

 Number of bars in 3-dir: This is the number of longitudi-
nal reinforcing bars (including corner rebar) on the two
faces of the column that are parallel to the local 3-axis of
the section.

 Number of bars in 2-dir: This is the number of longitudi-
nal reinforcing bars (including corner rebar) on the two

Note:

You can specify
reinforcing
information for
rectangular,
T-shaped and
L-shaped con-
crete beam
sections and for
circular and
rectangular
concrete col-
umn sections.
Reinforcing for
other column
sections can be
specified using
the Section De-
signer utility.

Note:

Cover is typi-
cally measured
from the near-
est edge of the
concrete sec-
tion to the cen-
troid of the
reinforcing
steel.
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faces of the column that are parallel to the local 2-axis of
the section.

 Bar size: This is the specified size of reinforcing steel for
the section. You can only specify one bar size for a given
concrete frame section property.

 Circular Reinforcement: This area is visible if you have cho-
sen a circular configuration of reinforcement. The following
options are available in this area.

 Cover to Rebar Center: This is the distance from the
edge of the column to the center of a longitudinal bar.

In the special case of circular reinforcement in a rectangu-
lar column, the cover is taken to be the minimum distance
from the edge of the column to a circle drawn through the
center of all the rebar in the circular reinforcement pattern.

 Number of bars: This is the number of longitudinal rein-
forcing bars in the section.

 Bar size: This is the specified size of reinforcing steel for
the section. You can only specify one bar size for a given
concrete frame section property.

 Check/Design: In this area you specify Reinforcement to be
Checked or Reinforcement to be Designed when a member
with this frame section property is run through the Concrete
Frame Design postprocessor. All information in the Rein-
forcement Data form is used in checking reinforcement. If the
reinforcement is to be designed, all information in the Rein-
forcement Data form is used, except the bar size, which is ig-
nored, and the total required steel area is calculated. For de-
sign, the configuration of reinforcement, lateral reinforcement
and cover are used.

If you specify reinforcing in a concrete column frame section
property that is assigned using the Section Designer utility, the
Concrete Frame Design postprocessor either checks the column
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for the specified reinforcing or designs new reinforcing, de-
pending on the option you selected when you specified the sec-
tion.

Reinforcing Information for Beams
For concrete beams, you specify two types of reinforcing infor-
mation:  Concrete Cover to Rebar Center and Reinforcement
Overrides for Ductile Beams.

Rebar cover is specified at the top and bottom of the beam. The
top cover is measured from the top of the beam to the centroid of
the top longitudinal reinforcing. The bottom cover is measured
from the bottom of the beam to the centroid of the bottom lon-
gitudinal reinforcing.

The reinforcement overrides are specified areas of longitudinal
reinforcing steel that occur at the top and bottom of the left and
right ends of the beam. These overrides are used by the program
as follows:

 In the Concrete Frame Design postprocessor, when the design
shear in a concrete beam is to be based on provided longitudi-
nal reinforcement (that is, the shear design is based on the
moment capacity of the beam), the program compares the cal-
culated required reinforcement with that specified in the rein-
forcement overrides and uses the larger value to determine the
moment capacity on which the shear design is based.

 In the Concrete Frame Design postprocessor, when the mini-
mum reinforcing in the middle of a beam is to be based on
some percentage of the reinforcing at the ends of the beam, the
program compares the calculated required reinforcement at the
ends of the beam with that specified in the reinforcement over-
rides and uses the larger value to determine the minimum rein-
forcing in the middle of the beam.

 In the Concrete Frame Design postprocessor, when the shear
design of columns is to be based on the maximum moment that
the beams can deliver to the columns, the program compares

Note:

The reinforcing
data specified
for concrete
frame sections
is used by the
Concrete
Frame Design
postprocessor.
It is also used
to determine
default nonlin-
ear hinge
(pushover)
properties for
concrete mem-
bers. It is not
used to modify
the analysis
properties of
the section.
They are based
on the gross
section proper-
ties.
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the calculated required reinforcement with that specified in the
reinforcement overrides and uses the larger value to determine
the moment capacity of the beam.

 For any degree of freedom in the frame nonlinear hinge prop-
erties assigned to a concrete member that is specified as de-
fault, the program calculates the hinge force-deformation
properties based on the larger of the calculated required rein-
forcement at the ends of the beam (assuming you have run the
design through the Concrete Frame Design postprocessor) and
the specified reinforcement overrides.

Wall/Slab/Deck Sections Command and Form
Use the Define menu > Wall/Slab/Deck Sections command or

 button to define wall, slab or deck section properties. The

command or button brings up the Define Wall/Slab/Deck Sec-
tions form. The Sections area of this form lists the names of all
the currently defined deck, slab, and wall section properties. The
Click To area of the form has a drop-down box that allows you
to Add New Deck, Add New Slab, or Add New Wall as well as
Modify/Show Section and Delete Section buttons. Note that
you can only delete deck, slab and wall sections if they are not
currently assigned to any area objects in your model.

Wall/Slab Sections Form
When you select Add New Slab or Add New Wall in the drop-
down box, or click the Modify/Show Section bottom and select a
wall or slab section in the Define Wall/Slab/Deck Sections form,
the Wall/Slab Section form appears. Following is a discussion of
each of the areas in that form.

 Section name: Specify the name of a wall or slab section. You
can modify this name if desired.

 Material: Here you can choose the material property for the
slab or wall from a list of all defined material properties.
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 Thickness: Two thicknesses are specified: membrane and
bending. Typically these thicknesses are the same but they can
be different. For instance, they may be different if you are
trying to model full shell behavior for a corrugated metal deck.

The membrane thickness is used for calculating:

 The membrane stiffness for full shell and pure membrane
sections.

 The element volume for element self-mass and self-weight
calculations.

The bending thickness is used for calculating the plate-bending
and transverse-shearing stiffnesses for full shell and pure plate
sections.

 Type: A wall or slab section can have Shell, Membrane or
Plate-type behavior. Membrane-type behavior means that only
in-plane membrane stiffness is provided for the section. Plate-
type behavior means that only out-of-plane plate bending stiff-
ness is provided for the section. Shell-type behavior means that
both in-plane membrane stiffness and out-of-plane plate
bending stiffness are provided for the section.

When a section has plate-type or shell-type behavior, you have
the option of including or not including Thick Plate behavior.
When thick plate behavior is included (i.e., the Thick Plate
check box is checked), out-of-plane shearing deformations are
considered in the analysis. When thick plate behavior is not in-
cluded (i.e., the Thick Plate check box is not checked), these
shearing deformations are not considered in the analysis.

We recommend that in this program, you typically do not use
the thick plate option, except perhaps when you are modeling
thick footings or mat foundations.

 Display Color: Here you assign a color to the wall or slab
section. If you use the View menu > Set Building View Op-
tions command to display the Set Building View Options

Shortcut:

Use the Assign
menu >
Shell/Area >
Wall/Slab/Deck
Section com-
mand to simul-
taneously de-
fine wall, slab
and deck sec-
tions and as-
sign them to
selected area
objects.



Chapter 7 - Define Menu

Wall/Slab/Deck Sections Command and Form 7 - 25

7

form, you can then choose an option to view the model based
on the colors associated with the section properties. In that
case, each object appears in a color associated with its as-
signed section property. See the section entitled "Set Building
View Options Command" in Chapter 6 View Menu for more
information. You can change the color associated with the
material by clicking in the Display Color box.

Deck Sections Form
When you select Add New Deck from the drop-down box or the
Modify/Show Section button and select at deck section in the
Define Wall/Slab/Deck Sections form, the Deck Section form
appears. Following is a discussion of each of the areas in this
form.

 Section name: Specifies the name of a deck section; you can
modify this name if desired.

 Type: The three options for the deck type are filled deck, un-
filled deck and solid slab. The type of deck section controls
which features are active in the rest of the form. Following is a
description of the three deck type options.

 Filled deck: If you select the filled deck option, all items
in the Geometry and Composite Deck Studs areas are ac-
tive and the Slab Material item in the Material area is ac-
tive.

 Unfilled deck: If you select the unfilled deck option, the
slab cover item in the Geometry area (Slab Depth) is set to
zero and grayed out (inactive), the entire Composite Deck
Studs area is grayed out and the Deck Material and Deck
Shear Thickness items in the Material area are active.

 Solid slab: If you select the solid slab option, the deck
depth, rib width and rib spacing items in the Geometry
area are set to zero and grayed out (inactive), the entire
Composite Deck Studs area is active and the Slab Material
item in the Material area is active.

Tip:

If you want to
use the Com-
posite Beam
Design post-
processor, you
must define the
slab using Deck
properties, not
slab properties,
even if you are
using a solid
slab over the
composite
beams.
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 Geometry: You specify the geometry of the slab and deck in
this area. The following items are specified:

 Slab Depth (tc): Depth of the slab, not including the
height of the metal deck.

 Deck Depth (hr): Depth (height) of the metal deck.

 Rib Width (wr): Average width of the metal deck ribs.

 Rib Spacing (Sr): Distance from the center of one down
flute of the metal deck to the center of an adjacent down
flute.

 Composite Deck Studs: You specify the design information
for the composite beam shear studs in this area. The following
items are specified:

 Diameter: Diameter of the shear studs.

 Height (hs): Height of the shear studs after welding.

 Tensile Strength, Fu: Fu value for the shear studs.

 Material: Specifies the material property used for determining
the deck shear stiffness (membrane stiffness) in this area. If the
deck is filled or there is a solid slab, specify a slab material
property. If the deck is unfilled, specify a deck material prop-
erty and a deck shear thickness. The following items are speci-
fied in this area:

 Slab Material: Name of the concrete material property as-
sociated with the slab.

 Deck Material: Name of the steel material property asso-
ciated with the deck. The mass and weight per unit volume
specified for the steel material property (using the Define
menu > Material Properties command) are not used for
the deck (unless the specified mass per unit volume is zero
and the deck is unfilled). See the upcoming Metal Deck
Unit Weight bullet item for more information.

Note:

Deck section
properties have
membrane be-
havior only. No
plate bending
behavior is
modeled for
deck sections.

Note:

The deck al-
ways spans in
the same direc-
tion as the local
1-axis of the
area object that
it is assigned
to. You can use
the Assign
menu > Shell/
Area > Local
Axes command
to change the
direction of the
area object
local 1-axis.

Note:

When you as-
sign deck sec-
tion properties,
the program
assumes that
the deck spans
in the same
direction as the
local 1-axis of
the area object
to which the
deck is as-
signed
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 Deck Shear Thick: Thickness of the deck used for calcu-
lating shear (membrane) stiffness when the deck type is
unfilled deck.

 Metal Deck Unit Weight: This is the unit weight of the deck
in force/length2 units. This unit weight is included when de-
termining the total self-weight of the floor system.

When determining the self-mass of the floor system, the metal
deck unit weight is converted to a unit mass. This unit mass is
added to the unit mass specified for the material property des-
ignated by you as the Deck Material or Slab Material (de-
pending on the deck type) in the Material area of the form.

A special case does exist for this mass. If the deck is a filled
deck and the mass per unit volume of the designated Slab Ma-
terial is zero, the program assumes the mass of the metal deck
is also zero. Similarly, if the deck is an unfilled deck and the
mass per unit volume of the designated Deck Material is zero,
the program assumes the mass of the metal deck is also zero.

 Display Color: Use this box to assign or change the color as-
signed to the deck section. If you use the View menu > Set
Building View Options command to display the Set Building
View Options form, you can choose an option to view the
model based on the colors associated with the section proper-
ties. In that case, each object appears in a color associated with
its assigned section property. See the section entitled "Set
Building View Options Command" in Chapter 6 View Menu
for more information.

The program has three built-in default area object properties.
They are DECK1, SLAB1 and WALL1. These are, as the names
suggest, metal deck, slab and wall properties. You can add addi-
tional properties as desired. You can also delete properties, in-
cluding the built-in ones if they are not currently assigned to ob-
jects. However, the program does not let you delete the last deck,
slab or wall property. In other words, you must always have at
least one deck property, one slab property and one wall property
defined, even if they are never assigned to anything.
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Link Properties Command
The different types of link properties available in the program
are as follows:

 Linear

 Damper

 Gap

 Hook

 Plastic1

 Isolator1

 Isolator2

Typically link elements can have two different sets of properties
assigned to them: linear properties and nonlinear dynamic prop-
erties that are used for nonlinear dynamic (time history) analysis.
Linear link elements can only have linear properties assigned to
them. Note that you must have the nonlinear version of ETABS
to use the nonlinear link properties.

The linear property that you specify for each of the six degrees
of freedom of a linear link element is an effective stiffness. This
is simply a spring stiffness.

The linear properties that you specify for each of the six degrees
of freedom of all other types of link elements are an effective
stiffness and effective damping. Again the effective stiffness is
simply a spring stiffness. The effective damping specifies dash-
pot-type damping; it is not a specification of percent critical
damping. In the advanced Nllink properties, the fraction of Mo-
ment to each end of the link to be transferred to the major and
minor axis can be specified.

In a linear analysis, the program converts the specified effective
damping for a link element to modal damping. It then adds the

Note:

In a linear
analysis, the
program con-
verts the speci-
fied effective
damping for
link elements
into equivalent
modal damping
and adds it to
the specified
modal damp-
ing.
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modal damping calculated for all link elements in the model that
have effective damping specified to any modal damping already
specified for the structure as a whole to get the final modal
damping. The program reports this final modal damping in the
printed analysis output for building modes. To get this output
click, the File menu > Print Tables > Analysis Output com-
mand and check the Building Modal Info check box.

Frame Nonlinear Hinge Properties Command
Nonlinear hinge properties are assigned to line objects with
frame section property assignments for use in nonlinear static
(pushover) analysis. The nonlinear hinge properties are defined
using the Define menu > Frame Nonlinear Hinge Properties
command. Note that you must have the nonlinear version of
ETABS to utilize the frame nonlinear hinge properties. Descrip-
tion of the frame nonlinear hinge properties is beyond the scope
of this manual.

Groups Command
Use the Define Menu > Groups command to define a new
group name, change a group name or delete a group name. Use
the Assign menu > Group Names command, described in
Chapter 10 Assign Menu, to designate the objects to be assigned
to the group name. Note that group names can be also be defined
during the assignment process.

On the Define Group form, which comes up when you click the
Define Menu > Groups command, the ALL group listed in the
Groups area is a default group to which all objects in the model
are automatically assigned. The ALL group name cannot be
changed nor can the ALL group be deleted.

Use the Add New Group, Change Group Name and Delete
Group buttons to add a new name, change a group name or
delete a group name. The Change Group Color button can be
used to change the color of objects assigned to a group.
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Note that when the program is set to display colors by group, if
an object is part of more than one group, it will be displayed us-
ing the color of the earliest defined group to which it is assigned.
This can sometimes make it difficult to tell which objects are as-
signed to a particular group. To determine which objects are as-
signed to a group, first view the entire model. Then click the Se-
lect menu > Select by Groups command and select the desired
group and click the View menu > Show Selection Only com-
mand to see only the objects that are part of the desired group.

 Section Cuts Command
Section cuts allow you to get resultant forces acting at section
cuts through your structure. You can define section cuts before
or after you run an analysis. Typically, you should not define
section cuts, and more importantly the groups used in the section
cut definition, until you have completed all manual meshing of
your model.  If you define these groups before manual meshing,
some of the point objects that should be in the group may not yet
be created. It is safest to wait until after you have run the analy-
sis to define the section cuts.

Use the Define menu > Section Cuts command to define section
cuts in this program. However, before you use this command,
you first should define the group that to be used to specify the
extent of the section cut. Groups are defined by selecting the
objects that are to be part of the group and using the Assign
menu > Group Names command, which is described in Chapter
10 Assign Menu.

Section Cuts Form
Clicking the Define menu > Section Cuts command brings up
the Section Cuts form. The Section Cuts area of this form lists
the names of all of the currently defined section cuts. The Click
To area of the form allows you to define new section cuts, mod-
ify existing section cut definitions and delete existing section
cuts.

Note:

You can get
resultant forces
reported at any
location for
section cuts
that you define
through all or a
portion of your
structure.
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When you click the Add Section Cut button in the Section Cuts
form or when you highlight an existing section cut name and
click the Modify/Show Section Cut button, the Section Cut
Data form appears. This form is broken into four areas that are
described below.

 Section cut name: Specifies the name of a section cut; use this
edit box to modify the name if desired.

 Group: Specifies the name of the group that defines the sec-
tion cut; use this edit box to modify the group if desired.

 Summation about this location: Defines the location (point)
about which section cut forces are summed. There are two op-
tions for specifying this point.

 Default: By default, the section cut forces are reported at a
location (point) that has coordinates equal to the average
of the coordinates of all of the point objects included in the
group that defines the section cut.

 User-Defined: You can specify any arbitrary point that
section cut forces are to be summed about by entering the
global X, Y and Z coordinates of that point.

Note that there does not need to be a Point object defined at the
point that you are summing the section cut forces about.

 Local 1-Axis Orientation: By default the positive local 1, 2
and 3 axes of the section cut correspond to the global X, Y and
Z axis respectively. You can rotate the local 1 and 2 axes about
the 3-axis (Z-axis).

The direction of the positive local 1-axes is specified by an an-
gle measured in degrees from the positive global X-axis. A
positive angle appears counterclockwise as you look down on
it from above. An angle of 0 degrees means the positive local
1-axis is in the same direction as the positive global X-axis. An
angle of 90 degrees means the positive local 1-axis is in the
same direction as the positive global Y-axis.

Global X

G
lo

ba
l Y
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ca

l 1

Positive
angle



Reference Manual

7 - 32 Response Spectrum Functions Command

7

The angle described in the paragraph above is entered in the
Local 1-Axis Orientation area of the Section Cut Data form.
Any value between -360 degrees and +360 degrees, inclusive
can be input.

Response Spectrum Functions Command
A response spectrum function is simply a list of period versus
spectral acceleration values. In this program, the acceleration
values in the function are assumed to be normalized; that is, the
functions themselves are not assumed to have units. Instead, the
units are associated with a scale factor that multiplies the func-
tion and is specified when you define the response spectrum
case. See the subsection entitled "Input Response Spectra" under
the section titled "Response Spectrum Cases" later in this chapter
for more information.

Click the Define menu > Response Spectrum Functions com-
mand or this  button to define response spectrum functions.

When you execute this command, the Define Response Spec-
trum Functions form appears. The Response Spectra area of this
form lists the names of all the currently defined response spec-
trum functions. The Click To area of the form allows you to add
a new spectrum from a text file, add a new user-defined response
spectrum function, add a new response spectrum function based
on one of several ETABS built-in code response spectra, modify
an existing response spectrum function definitions, and delete
existing response spectrum function definitions.

Add Response Spectrum from File Form
You can add a response spectrum definition to the program from
a text file. The text file should have period and spectral accelera-
tion values. One set of values (period and spectral acceleration)
should be provided on each line. Any line that has a $ symbol in
the first character space is treated as a comment line and ignored.
You can specify any number of header lines at the beginning of
the file that the program should ignore. Those header lines do not

Note:

In ETABS the
acceleration
values in a re-
sponse spec-
trum function
are assumed to
be normalized,
that is, the
functions them-
selves are not
assumed to
have units.
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need $ symbols at the beginning of them. The program quits
reading the file when it reaches the end of the file or when it
reaches a blank line. Note that the program considers a line with
the first character space blank, the second character space a $
symbol and anything beyond the $ symbol as a blank line.

Click the Add Spectrum from File button in the Click To area
of the Define Response Spectrum Functions form to add a new
response spectrum function definition from an existing text file.
This brings up the Response Spectrum Function Definition form.
The following areas exist in that form:

 Function name: Specifies the name of the response spectrum
function; use this edit box to modify the name if desired.

 Function file: Click on the Browse button in this area to bring
the Pick Function Data File form where you indicate the name
of the text file that includes your response spectrum data.

Typically the program does not import the file into its data-
base. It simply maintains a link to the file location. Thus, if
you move the response spectrum file, or if you move your .edb
file to another location, the program may suddenly be unable
to locate the response spectrum file. If you click the Convert
to User-Defined button, the program imports the response
spectrum into its database file and the data will always be
available to your model. Do not click the Convert to User-
Defined button until you have specified the file name and in-
dicated the number of header lines to skip.

Tip:

There are many
code-specific
response spec-
trum templates
built into this
program.
Response Spectrum Functions Command 7 - 33

Note that when reading the function file, the program skips the
number of lines at the top of the file indicated in the Header
Lines to Skip item.

 Value are: The function can be Frequency vs. Value or Period
vs. Value. No values appear in this area until you actually dis-
play the graph of the function.

 Function graph: This area displays a graph of the function.
First specify the text file name and the number of header lines



Reference Manual

7 - 34 Response Spectrum Functions Command

7

to skip in the Function File area of the form. Then click the
Display Graph button in the Function Graph area of the form
to display the graph of the function. This also fills in the values
in the Values are area of the graph.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the response spectrum.
The coordinates of the dot are reported in the box just below
the graph.

The program reads the response spectrum function file in the
following way:

 First, it skips the specified number of header lines.

 Next, it checks to see if a line has a $ symbol as the first char-
acter. If it does, the program skips to the next line.

 If there is not a $ symbol as the first character on the line, the
program reads the information on the line.

 If the line is blank or if the end of the file is reached, the pro-
gram stops reading and closes the file.

User-Defined Response Spectrum Functions
Click the drop down box just below the Add Spectrum from
File button in the Click To area of the Define Response Spec-
trum Functions form and click on Add User Spectrum to add a
new user-defined response spectrum. This brings up the Re-
sponse Spectrum Function Definition form. The following areas
exist in this form:

 Function name: Specifies the name of the response spectrum
function; use this edit box to modify the name if desired.

 Define Function: Input the period and spectral acceleration
values for the function in this area. Type the first set of period
and spectral acceleration values into the edit boxes at the top
of this area. Then click the Add button. Type in the next set of

Note:

Response spec-
tra in this pro-
gram are al-
ways defined as
period versus
spectral accel-
eration.
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period and spectral acceleration values and again click the
Add button. Continue this process until all sets of values have
been entered.

If you want to modify an existing set of values, first highlight
the appropriate values in the list box. Note that when you
highlight them, they appear in the edit boxes at the top of the
area. Modify the values in the edit boxes and then click the
Modify button.

If you want to delete an existing set of values, first highlight
the appropriate values in the list box. Note that when you
highlight them, they appear in the edit boxes at the top of the
area. Then click the Delete button.

 Function graph: This area displays a graph of the function. It
updates automatically as additional points are defined for the
function. If your computer has any problem with the automatic
update, click the Display Graph button located just below the
graph.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the response spectrum.
The coordinates of the dot are reported in the box just below
the graph.

Code-Specific Response Spectrum Functions
The program allows you to easily define code-specific response
spectrum functions for a variety of building codes.

Click the drop-down box just below the Add Spectrum from
File button in the Click To area of the Define Response Spec-
trum Functions form and click on one of the code-specific items.
For example, click on Add UBC97 Spectrum to add a new re-
sponse spectrum based on the 1997 UBC.

Clicking on one of the code-specific items brings up a code-
specific Response Spectrum Function Definition form. The fol-
lowing areas exist in this form:
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 Function name: Specifies the name of the response spectrum
function; use this edit box to modify the name if desired.

 Parameters: You specify the parameters that define the code-
specific response spectrum in this area. These parameters vary
from code to code. The parameters specified for each of the
codes included in this program are described in subsequent
subsections.

 Define Function: This area displays the period and spectral
acceleration values for the function. You can only view the
values in this area. You cannot edit these values unless you
convert the function to a user-defined function. The values
shown here update every time you redefine the spectrum pa-
rameters.

Note that you can click the Convert to User-Defined button at
any time to convert the function to a user-defined function.
Then you are able to edit values in the Define Function area.

 Function graph: This area displays a graph of the function. It
updates automatically as you redefine the spectrum parame-
ters. If your computer has any problem with the automatic up-
date, click the Display Graph button located just below the
graph.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the response spectrum.
The coordinates of the dot are reported in the box just below
the graph.

1994 UBC Parameters for a Response Spectrum Function
The 1994 UBC response spectrum function is based on Figure
16-3 in Chapter 16 of the 1994 UBC. The digitization of these
response spectra are based on Section C106.2.1 in the 1996
SEAOC Recommended Lateral Force Requirements and Com-
mentary (more commonly called the SEAOC Blue Book).
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The parameters you enter are a seismic zone factor, Z and a soil
type. Any positive, nonzero value can be specified for the seis-
mic zone factor; see Table 16-I in the 1994 UBC for typical val-
ues. The soil type can be input as 1, 2 or 3; see Table 16-J in the
1994 UBC for typical values.

1997 UBC Parameters for a Response Spectrum Function
The 1997 UBC response spectrum function is constructed as
shown in Figure 16-3 in Chapter 16 of the 1997 UBC. The pa-
rameters you enter are seismic coefficients Ca and Cv. Any posi-
tive, nonzero value can be specified for the seismic coefficients.
See Tables 16-Q and 16-R in the 1997 UBC for typical values of
these coefficients.

1996 BOCA Parameters for a Response Spectrum Function
The following parameters are input for the 1996 BOCA response
spectrum function. Any positive, nonzero value can be input for
these parameters.

Aa = Seismic coefficient representing the effective peak ac-
celeration as determined in 1996 BOCA Section
1610.1.3.

Av = Seismic coefficient representing the effective peak ve-
locity-related acceleration as determined in 1996
BOCA Section 1610.1.3.

R = The response modification factor determined from 1996
BOCA Table 1610.3.3.

S = The coefficient for the soil profile characteristics of the
site as determined by 1996 BOCA Table 1610.3.1.

The 1996 BOCA response spectrum function is based on 1996
BOCA Section 1610.5.5. The response spectrum is constructed
by plotting the modal seismic design coefficient, Csm, versus the
modal period of vibration, Tm. For a given period, Tm, the value
of Csm is determined using Equation 7-3.
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1995 NBCC Parameters for a Response Spectrum Function
The following parameters are input for the 1995 NBCC (Cana-
dian) response spectrum function.

v = Zonal velocity ratio.

Za = Acceleration-related seismic zone.

Za = Velocity-related seismic zone.

Values for these parameters can be found in Appendix C of the
1995 NBCC. Any positive, nonzero value can be input for the
zonal velocity ratio, v. Any positive integer, or zero, can be input
for the acceleration and velocity-related seismic zones.

The 1995 NBCC response spectrum function is based on item
44(a) in Commentary J of the 1995 NBCC.

IBC2000 Parameters for a Response Spectrum Function
The following parameters are input for the IBC2000 response
spectrum function. Any positive, nonzero value can be input for
these parameters.

SDS = The 5% damped design spectral response acceleration at
short periods as specified in IBC2000 Section
1613.2.1.3.

SD1 = The 5% damped design spectral response acceleration at
a one second period as specified in IBC2000 Section
1613.2.1.3.

The IBC2000 response spectrum function is based on the proce-
dure described in IBC2000 Section 1613.2.1.4.
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1997 NEHRP Parameters for a Response Spectrum Function
The following parameters are input for the 1997 NEHRP re-
sponse spectrum function. Any positive, nonzero value can be
input for these parameters.

SDS = The design earthquake spectral response acceleration at
short periods as specified in 1997 NEHRP Equation
4.1.2.5-1.

SD1 = The design earthquake spectral response acceleration at a
one second period as specified in 1997 NEHRP Equation
4.1.2.5-2.

The 1997 NEHRP response spectrum function is based on the
procedure described in 1997 NEHRP Section 4.1.2.6.

1998 Eurocode 8 Parameters for a Response Spectrum
Function

The 1998 Eurocode 8 response spectrum function is constructed
as described in 1998 Eurocode ENV 1998-1-1:1994 Section
4.2.2. The parameters you enter are the design ground accelera-
tion, ag, the subsoil class and the damping correction factor, η.
Any positive, nonzero value can be specified for the design
ground acceleration. The damping correction factor must satisfy
η ≥ 0.7. The subsoil class can be input as A, B or C.

The ordinates of the response spectrum are calculated using
Equations 4.1 through 4.4 in 1998 Eurocode ENV 1998-1-
1:1994 Section 4.2.2. The values of βo, TB, TC, TD, k1, k2 and S are
taken from Table 4.1 in 1998 Eurocode ENV 1998-1-1:1994
Section 4.2.2. Note that the value of these items depends on the
specified subsoil class.

1992 NZS 4203 Parameters for a Response Spectrum
Function

For the 1992 NZS4203 (New Zealand) response spectrum func-
tion you input a scaling factor and a site subsoil category. Any
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positive, nonzero value can be specified for the scaling factor.
The site subsoil category can be input as A, B or C.

The 1992 NZS4203 (New Zealand) response spectrum function
is constructed as specified in 1992 NZS4203 Section 4.6.

The ordinates of the response spectrum are calculated using 1992
NZS4203 Equations 4.6.3 and 4.6.4. If you are using Equation
4.6.3 then you input the scaling factor as Sp * R * Z * Ls. If you
are using Equation 4.6.4 then you input the scaling factor as
Sm * Sp * R * Z * Lu.

ETABS calculates the Ch(T, 1) term in Equations 4.6.3 and 4.6.4
based on the input site subsoil category and the values for µ=1.0
in Figures 4.6.1a, b and c and in Tables 4.6.1a, b and c. In Table
4.6.1a the coefficient values for periods of 0, 0.09 and 0.20 sec-
onds are taken as 0.40, 0.68 and 0.68, respectively. In Table
4.6.1b the coefficient values for periods of 0, 0.13 and 0.20 sec-
onds are taken as 0.42, 0.80 and 0.80, respectively. In Table
4.6.1c the coefficient values for periods of 0 and 0.10 seconds
are taken as 0.42 and 0.72, respectively.

Modifying and Deleting Response Spectrum Functions
In the Define Response Spectrum Functions form, highlight an
existing response spectrum name and then click on the Mod-
ify/Show Spectrum button to modify the spectrum. The same
form that appeared when you defined the function appears and
you can make any changes or modifications that you desire.

To delete an existing response spectrum function, highlight its
name in the Define Response Spectrum Functions form and click
the Delete Spectrum button.

Time History Functions Command
A time history function may be a list of time and function values
or just a list of function values that are assumed to occur at
equally spaced intervals. The function values in a time history
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function may be ground acceleration values or they may be mul-
tipliers for specified (force or displacement) load cases.

Click the Define menu > Time History Functions command or
this  button to define time history functions. When you exe-

cute this command or click the button, the Define Time History
Functions form appears. The Functions area of this form lists the
names of all the currently defined time history functions. The
Click To area of the form allows you to Add Function from
(text) File, Add User Function (a user-defined time history func-
tion), add a new time history function based on one of several
built-in function templates (Sine, Cosine, Ramp, Sawtooth, Tri-
angle), Modify/Show Function to modify an existing time his-
tory function definition and Delete Function to delete existing
time history function definitions.

Add Functions from File Button
You can add a time history definition to the program from a text
file. Any line that has a $ symbol in the first character space is
treated as a comment line and ignored. You can specify any
number of header lines at the beginning of the file that the pro-
gram should ignore. Those header lines do not need $ symbols at
the beginning of them. The program quits reading the file when
it reaches the end of the file or when it reaches a blank line. Note
that the program considers a line with the first character space
blank, the second character space a $ symbol and anything be-
yond the $ symbol as a blank line.

Click the Add Function from File button in the Click To area of
the Define Time History Functions form to add a new time his-
tory function definition from an existing text file. This brings up
the Time History Function Definition form. The following areas
exist in this form:

 Function name: Specify the name of the time history func-
tion; use this edit box to modify the name if desired.

Tip:

Define time
history func-
tions using one
of several built-
in time history
function tem-
plates.
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 Function file: Click on the Browse button in this area to bring
up the Pick Function Data File form where you select the name
of the text file that includes your time history function data.

Typically, the program does not import the file into its data-
base. It simply maintains a link to the file location. Thus, if
you move the time history function file, or if you move your
.edb file to another location, the program may be unable to lo-
cate the function file. If you click the Convert to User-
Defined button, the program imports the time history into its
database file and the data will always be available to your
model. Do not click the Convert to User-Defined button until
you have specified all information in the Function file, Values
are and Format type areas.

Note that when reading the function file, the program skips the
number of lines at the top of the file indicated in the Header
Lines to Skip item. It also skips the number of characters
specified in the Prefix Characters per Line  item at the begin-
ning of each line.

The Number of Points per Line item tells the program how
many function values or sets of time and function values are
specified on each line.

 Values are: Specifies whether the text file contains time and
function values or function values that are spaced at equal time
intervals. If the file contains function values that are spaced at
equal time intervals, also specify the time interval.

 Format type: The format type can be specified as either free
format or fixed format. In free format, items on the lines can
be separated by spaces or tabs. If you specify a fixed format
type, you also specify the number of characters per item. Each
item on a line is assigned the same number of character spaces.
The program begins counting the spaces after it skips the num-
ber of prefix characters specified in the Function File area.

 Function graph: This area displays a graph of the function.
First specify all of the data in the Function file, Values are and
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Format type areas. Then click the Display Graph button in the
Function Graph area of the form to display the graph of the
function.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the time history func-
tion. The coordinates of the dot are reported in the box just
below the graph.

The program reads the function file in the following way:

 First, the program skips the specified number of header lines.

 Next, the program checks to see if a line has a $ symbol as the
first character. If it does, the program skips to the next line.

 If there is not a $ symbol as the first character on the line, the
program reads the information on the line, skipping the speci-
fied number of characters at the beginning of the line.

 If the line is blank or if the end of the file is reached, the pro-
gram stops reading and closes the file.

Add User Function
Click the drop-down box just below the Add Function from
File button in the Click To area of the Define Time History
Functions form and click on Add User Function to add a new
user-defined history function. This brings up the Time History
Function Definition form. The following areas exist in this form:

 Function name: Specifies the name of the time history func-
tion; use this edit box to modify the name if desired.

 Define Function: Input the time and associated function value
for the function in this area. Type the first set of time and
function values in the edit boxes at the top of this area. Then
click the Add button. Type in the next set of time and function
values and again click the Add button. Continue this process
until all sets of values have been entered.
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If you want to modify a set of values after you have entered
them, first highlight the appropriate values in the list box. Note
that when you highlight them, they appear in the edit boxes at
the top of the area. Modify the values in the edit boxes and
then click the Modify button.

If you want to delete a set of values after you have entered
them, first highlight the appropriate values in the list box. Note
that when you highlight them, they appear in the edit boxes at
the top of the area. Then click the Delete button.

 Function graph: This area displays a graph of the function. It
updates automatically as additional points are defined for the
function. If your computer has any problem with the automatic
update, click the Display Graph button located just below the
graph.

You can run your mouse pointer over the function graph and a
dot will appear along the line representing the time history func-
tion. The coordinates of the dot are reported in the box just be-
low the graph.

Add (Template) Function - Sine, Cosine, Ramp, Sawtooth
and Triangular

The program allows you to easily define sine, cosine, ramp,
sawtooth and triangular time history functions using built-in pro-
gram time history function templates.

Click the drop down box just below the Add Function from
File button in the Click To area of the Define Time History
Functions form and click on one of the sine, cosine, ramp, saw-
tooth and triangular items. For example, click on Add Sine
Function to add a new time history function based on a sine
function.

Clicking on one of these time history function items brings up a
the Time History (template name) Function Definition form. The



Chapter 7 - Define Menu

Time History Functions Command 7 - 45

7

forms for all templates are the same except for the name in the
title of the form. Those areas include the following:

 Function name: Specifies the name of the time history func-
tion; use this edit box to modify the name if desired.

 Parameters: Specify the parameters that define the template
time history function in this area. Those parameters vary for
different templates. The parameters specified for each of the
templates are described in subsequent subsections.

 Define Function: This area displays the time and function
values for the time history function. You can only view the
values in this area. You cannot edit the values unless you con-
vert the function to a user-defined function. The values shown
here update every time you redefine the template parameters.

Note that you can click the Convert to User-Defined button at
any time to convert the function to a user-defined function.
Converting the template to a user-defined function would al-
low you to edit values in the Define Function area.

 Function graph: This area displays a graph of the function. It
updates automatically as you redefine the template parameters.
If your computer has any problem with the automatic update,
click the Display Graph button located just below the graph.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the time history func-
tion. The coordinates of the dot are reported in the box just
below the graph.

Sine Time History Function Template Parameters
The sine time history function is a periodic function. A sine
function cycle starts at a function value of 0, proceeds to its
positive maximum value (positive value of amplitude), continues
to a value of 0, progresses to its negative minimum value (nega-
tive value of amplitude), and returns to a value of 0 again. The
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following parameters are specified in the sine time history func-
tion template.

 Period: The time in seconds that it takes for the sine function
to complete one cycle.

 Number of Steps per Cycle: The number of steps (i.e., func-
tion value points) provided for each cycle of the function.

 Number of Cycles: The number of cycles in the function.

 Amplitude: The maximum function value of the sine function.

Cosine Time History Function Template Parameters
The cosine time history function is a periodic function. A cosine
function cycle starts at its positive maximum value (positive
value of amplitude), proceeds to a value of 0, continues to its
negative minimum value (negative value of amplitude), and re-
turns to a value of 0 again and finally returns to it positive
maximum value again. The following parameters are specified
for the cosine time history function template.

 Period: The time in seconds that it takes for the cosine func-
tion to complete one cycle..

 Number of Steps per Cycle: The number of steps (i.e., func-
tion value points) provided for each cycle of the function.

 Number of Cycles: The number of cycles in the function.

 Amplitude: The maximum function value of the cosine func-
tion.

Ramp Time History Function Template Parameters
A ramp function is defined by three (time, function value) points.
Those three points, in order, are (0, 0), (Ramp time, Amplitude)
and (Maximum time, Amplitude). The ramp time, amplitude and
maximum time parameters are described as follows.
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 Ramp Time: Time that it takes for the ramp function to ini-
tially reach its maximum value. It is usually set to one second.

 Amplitude: The maximum value of the ramp function. It is
usually set to 1.

 Maximum Time: The time at the end of the ramp function. It
is usually between 10 and 20 seconds.

Sawtooth Time History Function Template Parameters
The sawtooth time history function is a periodic function. A sin-
gle cycle of a sawtooth function is defined by seven (time, func-
tion value) points. Those seven points, in order, are (0, 0), (Ramp
time, Amplitude), (0.5 * Period - Ramp time, Amplitude), (0.5 *
Period, 0), (0.5 * Period + Ramp time, -Amplitude), (Period -
Ramp time, -Amplitude) and (Period, 0). Figure 7-4 illustrates a
single cycle of a sawtooth time history function and the seven
points.

The following parameters are specified in the sawtooth time
history function template.

 Period: The time in seconds that it takes for the sawtooth
function to complete one cycle.

 Ramp Time: The time that it takes for the sawtooth function
to ramp up from a function value of 0 to its maximum ampli-
tude.

Figure 7-4:
Points that define a
cycle of a sawtooth
time history function (0, 0)

(Ramp time, amplitude)

(Period / 2, 0)

(Period / 2 – ramp time, amplitude)

(Period, 0)

(Period – ramp time, –amplitude)(Period / 2 + ramp time, –amplitude)
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 Number of Cycles: The number of cycles in the function.

 Amplitude: The maximum function value of the sawtooth
function.

Triangular Time History Function Template Parameters
The triangular time history function is a periodic function. A
single cycle of a triangular function is defined by five (time,
function value) points. Those five points, in order, are (0, 0), ,
(0.25 * Period, Amplitude), (0.5 * Period, 0), (0.75 * Period,
-Amplitude) and (Period, 0). The following parameters are speci-
fied in the Triangular time history function template.

 Period: The time in seconds that it takes for the triangular
function to complete one cycle.

 Number of Cycles: The number of cycles in the function.

 Amplitude: The maximum function value of the triangular
function.

Add User Periodic Function
Click the drop down box just below the Add Function from
File button in the Click To area of the Define Time History
Functions form and click on Add User Periodic Function to add
a new user-defined periodic time history function. This brings up
the Time History User Periodic Function Definition form. The
following areas exist in this form:

 Function name: Specifies the name of the time history func-
tion; use this edit box to modify the name if desired.

 Number of Cycles: This is the number of cycles in the func-
tion.

 Define Function: Input the time and associated function value
for the function in this area. Type the time and function values



Chapter 7 - Define Menu

Static Load Cases Command 7 - 49

7

in the edit boxes at the top of this area. Then click the Add
button.

NOTE: For a user periodic function, specify the time and
function values for one cycle of the function and specify the
number of cycles. When the program uses the function, it con-
tinues for the specified number of cycles, even though you
only specified values for the first cycle.

If you want to modify the set of values you have entered, first
highlight the appropriate values in the list box. Note that when
you highlight them they appear in the edit boxes at the top of
the area. Modify the values in the edit boxes and then click the
Modify button.

If you want to delete the set of values you have entered, first
highlight the appropriate values in the list box. Note that when
you highlight them they appear in the edit boxes at the top of
the area. Then click the Delete button.

 Function graph: This area displays a graph of the function. It
updates automatically as additional points are defined for the
function. If your computer has any problem with the automatic
update then simply click the Display Graph button located
just below the graph.

You can run your mouse pointer over the function graph and a
dot appears along the line representing the time history func-
tion. The coordinates of the dot are reported in the box just
below the graph.

If you convert a user periodic function to a user function, values
are shown for all of the specified cycles.

Static Load Cases Command
In this program, you first define static load cases and then you
assign various types of loads to the static load cases using com-
mands available on the Assign menu, which is described in
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Chapter 10. There is no limit on the number of static load cases
that you can define.

As you will see in the ensuing description, you actually can as-
sign three types of loads to static load cases as you define them.
These three types of loads are self-weight, automatic static
earthquake loads and automatic static wind loads.

Click the Define menu > Static Load Cases command or the
 button to define static load cases. This brings up the Define

Static Load Case Names form. The form has two areas:  Loads
and Click to.

The Loads area has four separate items:

 Load: This is the name of the static load case.

 Type: This is the type of the static load case. The program
uses these values when automatically creating design load
combinations for the design postprocessors. The factors used
in the design load combinations are different for the various
types of loads. The choices for load types are:

 Dead: Dead load.

 Super Dead: Superimposed dead load. This is used in the
Composite Beam design postprocessor.

 Live: Live load.

 Reduce Live: Reducible live load. A live load that is
specified as reducible is reduced automatically by the pro-
gram for use in the design postprocessors. The live load
reduction parameters are specified using the Options
menu > Preferences > Live Load Reduction command.
See the subsection entitled "Preference > Live Load Re-
duction Command" in Chapter 14 Options Menu for more
information.

 Quake: Earthquake load.
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 Wind: Wind load.

 Snow: Snow load.

 Other: Other load that does not fit into one of the above
categories or that you do not want included in the design
load combinations automatically created by the program.

 Self-weight multiplier: The self-weight of the structure is de-
termined by multiplying the weight per unit volume of each
object that has structural properties times the volume of the
object. The weight per unit volume is specified in the material
properties.

You can specify that a portion of the self-weight be applied to
any static load case. The self-weight multiplier controls what
portion of the self-weight is included in a load case. A self-
weight multiplier of 1 means to include the full self-weight of
the structure in the load case. A self-weight multiplier of 0.5
means to include half of the self-weight of the structure in the
load case.

Normally you should specify a self-weight multiplier of 1 in
one static load case only, usually your dead load load case.
All other static load cases then have self-weight multipliers of
zero. Note that if you include a self-weight multiplier of 1 in
two different load cases, and then combine those two load
cases in a load combination, the results for the load combina-
tion are based on an analysis where double the self-weight of
the building has been applied as a load.

 Auto Lateral Load: The Auto Lateral Load item is inactive
unless the load type specified is Quake or Wind. When you
specify the load type as Quake or Wind, the Auto Lateral Load
drop-down box becomes active and you can choose None or
one of several different code-specified loads that are then
automatically created for the specified load case.

If you do not want to use the automatic lateral loads and in-
stead plan to assign your own loads using the commands avail-
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able on the Assign menu, choose None from this drop-down
box. Otherwise select the automatic load that you want to cre-
ate from the drop-down box. Initially default values are used
for the automatic lateral load. If you want to review and/or
modify those values, click the Modify Lateral Load button.

Define Static Load Case Names Form
Use the following procedure to add a new static load case in the
Define Static Load Case Names form:

 Type the name of the load case in the Load edit box. The pro-
gram does not allow you to use duplicate names.

 Select a load type from the Type drop-down box.

 Type a self-weight multiplier in the Self-Weight Multiplier
edit box (see Self-weight multiplier bullet in the previous
section for suggested values).

 If the load type specified is Quake or Wind, select an option
from the Auto Lateral Load drop-down box.

 Click the Add New Load button.

NOTE: If your selected an automatic lateral load in the Auto
Lateral Load drop-down box, click the Show Lateral Loads
button and review or modify the parameters for the automatic
lateral load in the resulting form. Then click the OK button to
return to the Define Static Load Case Names form.

Modify an Existing Static Load Case
Use the following procedure to modify an existing static load
case in the Define Static Load Case Names form:

 Highlight the the existing load case in the Loads area of the
form. Note that the data associated with that load case appears
in the edit and drop-down boxes at the top of the Loads area.

 Modify any of the data in the Loads area for the load case.
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 Click the Modify Load button. If necessary, click the Show
Lateral Loads button to modify the automatic lateral load pa-
rameters.

Delete an Existing Static Load Case
Use the following procedure to delete an existing static load case
in the Define Static Load Case Names form. Note that when you
delete a static load case here, all of the loads that have been as-
signed to the model as a part of that static load case are also de-
leted.

 Highlight the existing load case in the Loads area of the form.
Note that the data associated with that load case appears in the
edit and drop-down boxes at the top of the Loads area.

 Click the Delete Load button.

Response Spectrum Cases Command
Click the Define menu > Response Spectrum Cases command
or the  button to define a response spectrum case. This com-

mand brings up the Define Response Spectra form. Note that you
must have at least one response spectrum function defined for
this command to be active.

The Spectra area of the Define Response Spectrum form lists the
names of all the currently defined response spectrum cases. The
Click To area of the form allows you to define new response
spectrum cases, modify existing response spectrum cases and
delete existing response spectrum cases.

Response Spectrum Case Data Form
Clicking on the Add New Spectrum button or highlighting an
existing spectrum and clicking the Modify/Show Spectrum
button brings up the Response Spectrum Case Data form. The
following subsections describe each of the areas in this form.
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Spectrum Case Name
Here you can specify or modify the name of the response spec-
trum case.

Structural and Function Damping
It is important that you understand the structural and function
damping item. This item specifies modal damping that is present
for all modes in the response spectrum analysis. Also, the pro-
gram assumes that the response spectrum functions specified for
the response spectrum case are all specified for this particular
damping ratio.

For example, if you specify 2% damping for this term, you are
specifying that there is 2% modal damping in all modes for the
response spectrum analysis and you are also telling the pro-
gram that the response spectrum functions specified for this
response spectrum case are for 2% damping.

If you have link elements defined in your model and damping is
specified in the linear properties of the link element, the actual
damping for a mode may be larger than that specified in the
structural and function damping term because the program con-
verts the damping for the links into modal damping and adds that
modal damping to the specified modal damping to get the final
total modal damping. See the previous section in this chapter en-
titled "Link Properties Command" for additional information on
 - 54 Response Spectrum Cases Command

total modal damping.

In the cases where the final modal damping is different from the
damping specified in the structural and function damping edit
box (larger than because of added damping from link elements),
the program modifies the input response spectrum to match this
larger damping. The damping modification is based on the 50%
median values for velocity in Table 2 of N. M. Newark and W. J.
Hall (1981).

For all response spectra, the program reduces the entire spectrum
based on the velocity formula (2.31 - 0.41 lnβ) in Table 2 of N.



Chapter 7 - Define Menu

Response Spectrum Cases Command 7 - 55

7

M. Newark and W. J. Hall (1981). A maximum reduction of
50% is made.

For example, suppose that a response spectrum is specified as a
4% damped response spectrum and the actual final damping for a
mode is 6.3% (because of added link elements). The program
then modifies the specified 4% damped spectrum by the factor
determined in Equation 7-7.

89.0
742.1

555.1

4ln41.031.2

3.6ln41.031.2
==

−
−

Eqn. 7-7

Thus the spectral ordinate at the modal period in the 4% damped
response spectrum is multiplied by a factor of 0.89 to obtain the
spectral ordinate for 6.3% damping, which is the actual final
damping associated with the mode.

Note that unlike time history analysis, for response spectrum
analysis, you cannot override the modal damping specified for
all modes on a mode-by-mode basis.

Modal Combination
In this area, you specify the method that the program uses to
combine modal responses in the response spectrum analysis.
Here you also define a damping value.

The following options are available for modal combinations:

 CQC: This is the Complete Quadratic Combination method
described by E. L. Wilson, A. D. Kiureghian and E. Bayo
(1981). This modal combination technique takes into account
the statistical coupling between closely spaced modes caused
by modal damping. Increasing the modal damping increases
the coupling between closely spaced modes. If the modal
damping is 0 for all modes, the CQC method degenerates to
the SRSS method.

 SRSS: This is the Square Root of the Sum of the Squares
method. This modal combination technique does not take into

Note:

The program
defaults to the
CQC method of
modal combi-
nation.
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account any coupling of modes as do the CQC and GMC
methods.

 ABS: This is the Absolute method. This modal combination
technique simply combines the modal results by taking the
sum of their absolute values. This method is usually over-
conservative.

 GMC: This is the General Modal Combination method that is
also known as the Gupta method. This method is the same as
the complete modal combination procedure described in
Equation 3.31 in A. K. Gupta (1990). The GMC method takes
into account the statistical coupling between closely spaced
modes similar to the CQC method, and it also includes the cor-
relation between modes with rigid-response content.

The GMC method requires that you specify two frequencies, f1

and f2, that define the rigid-response content of the ground
motion. These must satisfy 0 < f1 < f2. The rigid-response parts
of all modes are assumed to be perfectly correlated.

The GMC method assumes no rigid response below frequency
f1, full rigid response above frequency f2 and an interpolated
amount of rigid response for frequencies between f1 and f2.

Frequencies f1 and f2 are properties of the seismic input, not of
the structure. Gupta defines f1 as shown in Equation 7-4.

Vmax

Amax
1 S2

S
f

π
= Eqn. 7-4

where SAmax is the maximum spectral acceleration and SVmax is
the maximum spectral velocity for the ground motion consid-
ered. The default value for f1 is unity.

Gupta defines f2 as shown in Equation 7-5.

r12 f
3

2
f

3

1
f += Eqn. 7-5
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where fr is the rigid frequency of the seismic input; that is, the
frequency above which the spectral acceleration is essentially
constant and equal to the value at zero period (infinite fre-
quency). Others have defined f2 as shown in Equation 7-6.

r2 ff = Eqn. 7-6

The default value for fr is zero, indicating infinite frequency.
For the default value of f2, the GMC method gives results
similar to the CQC method.

Directional Combination
For each displacement, force or stress quantity in the structure,
modal combination produces a single, positive result for each di-
rection of acceleration. These directional values for a given re-
sponse quantity are combined to produce a single positive result.
The two available choices for directional combination are:

 SRSS: Combines the directional results by taking the square
root of the sum of their squares. All other input items remain-
ing unchanged, the results obtained using this method do not
vary, regardless of the excitation angle that you specify. This is
the recommended method for directional combination and is
the default.

 ABS: This is the scaled absolute sum method. Here the direc-
tional results are combined by taking the maximum, over all
directions, of the sum of the absolute values of the response in
one direction plus a scale factor times the response in the other
directions.

For example, if the scale factor equals 0.3, the spectral re-
sponse, R, for a given displacement, force or stress would be:

( )321 R,R,RmaxR =

where,

( )3211 RR0.3RR ++=
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( )3122 RR0.3RR ++=

( )2133 RR0.3RR ++=

and R1, R2 and R3 are the modal combination values for each
direction.

All other input items remaining unchanged, the results ob-
tained using this method will vary depending on the excitation
angle you choose. Results using a scale factor of 0.3 are com-
parable to the SRSS method (for equal input spectra in each di-
rection) but may be as much as 8% unconservative or 4% over-
conservative, depending on the excitation angle chosen. Larger
scale factors tend to produce more conservative results.

Input Response Spectra
Here you can specify any defined response spectrum function for
each of the three local coordinate system directions of the re-
sponse spectrum case as defined by the excitation angle. See the
subsection below for discussion of the excitation angle. You can
also specify a scale factor along with each function.

Note that this scale factor has units of Length/seconds2 and that
its value will change as you change the units in your model. Es-
sentially the program assumes the response spectrum functions
are unitless (normalized) and that the scale factor converts them
into the appropriate units.

If you are scaling your response spectrum to match some static
analysis results (e.g., base shear) you may want to include that in
the scale factor specified for the response spectrum function in
the input response spectra area. In this case you would input a
scale factor equal to the product of the scale factor to covert the
spectrum to the appropriate units and the scale factor to scale the
response spectrum base shear to the appropriate level.
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Excitation Angle
The response spectrum case positive local 3-axis is always in the
same direction as the positive global Z-axis. The response spec-
trum case local 1 and 2 axes lie in the horizontal global XY
plane.

The excitation angle is an angle measured from the positive
global X-axis to the response spectrum case positive local 1-axis.
A positive angle appears counterclockwise as you look down on
the model.

Thus the direction of the response spectrum local 1-axis is de-
termined by the excitation angle, the local 3-axis is in the same
direction as the Z-axis, and the local 2-axis is determined from
the local 1 and 3 axes using the right hand rule.

Time History Cases Command
Click the Define menu > Time History Cases command or the

 button to define a time history case. This command brings

up the Define Time History Cases form. Note that you must have
at least one time history function defined for this command to be
active.

The History area of the Define Time History Cases form lists the
names of all the currently defined time history cases. The Click
To area of the form allows you to define new time history cases,
modify existing time history cases and delete existing time his-
tory cases.

Time History Case Data Form
Clicking on the Add New History button or highlighting an ex-
isting time history and clicking the Modify/Show History button
brings up the Time History Case Data form. The following sub-
sections describe each of the areas in this form:
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History Case Name
Specifies the name of the time history case. Use this edit box to
modify the name if desired.

Options
This area of the form has the following options that you specify
for the time history analysis:

 Analysis type: Specifies the type of time history analysis. The
possible choices are linear, periodic and nonlinear.

 Linear: In a linear time history analysis, all objects behave
linearly. Only the linear properties assigned to link ele-
ments are considered in a linear time history analysis.
Frame nonlinear (pushover) hinges assigned using the De-
fine menu > Frame Nonlinear Hinge Properties com-
mand have no effect on a linear time history analysis.

 Periodic: A periodic time history analysis is a linear
analysis. For this analysis, specify a single cycle of the pe-
riodic function, and then the program assumes that the
specified cycle continues indefinitely.

The program shows time history results for a single cycle
that are generated after the output has stabilized such that
the conditions at the beginning of the cycle are equal to
those at the end of the cycle.

In a periodic time history analysis, all objects behave line-
arly. Only the linear properties assigned to link elements
are considered in a periodic time history analysis. Frame
nonlinear (pushover) hinges assigned using the Define
menu > Frame Nonlinear Hinge Properties command
have no effect on a periodic time history analysis.

 Nonlinear: In a nonlinear time history analysis, the non-
linear dynamic properties assigned to link elements are
considered. The mode shapes obtained for the analysis are
based on linear properties only. Frame nonlinear (push-
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over) hinges assigned using the Define menu > Frame
Nonlinear Hinge Properties command have no effect on
a nonlinear time history analysis.

 Modal damping: Click the Modify/Show button adjacent to
the Modal Damping item to bring up the Modal Damping form
where you can specify or modify the modal damping. In this
form you can specify a damping that applies to all modes and
then, if desired, overwrite the damping for any mode(s). The
three bullet items that follow describe the three areas of the
Modal Damping form.

 Damping for All Modes: Enter the damping for all modes
in this form. This is a percent critical damping. A damping
that is 5% of critical damping is entered as 0.05.

 Damping Override Options: You can choose one of two
options in this area. If you choose the Specify Modal
Damping Overrides option, the Modal Damping Overrides
area becomes active and you can specify damping over-
rides for any mode(s). Use the overrides when modal
damping for some modes is different from the damping
that is specified for all modes.

If you choose the No Damping Overrides/Delete Overrides
option, the Modal Damping Overrides area becomes inac-
tive and any damping overrides that were specified are
deleted.

 Modal Damping Overrides: This area is only active if the
Specify Modal Damping Overrides option has been se-
lected in the Damping Override Options area. To override
a modal damping value type, select the mode number in
the Mode box and then type the damping value in the
damping box. (A damping that is 5% of critical damping is
entered as 0.05). Then click the Add button.

To modify an existing modal damping value, highlight the
existing damping value in the Modal Damping Overrides
area of the form. Note that the data associated with that

Note:

In this pro-
gram, enter 5%
of critical
damping as
0.05.
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load case appears in the edit and drop-down boxes at the
top of this area. Modify the mode number or damping as
desired. Then click the Modify button.

To delete an existing modal damping value, highlight the
existing damping value in the Modal Damping Overrides
area of the form. Note that the data associated with that
load case appears in the edit and drop-down boxes at the
top of this area. Then click the Delete button.

Important note: Do not forget to specify the number of
modes to be used for your analysis. To specify the number
of modes, click the Analyze menu > Set Analysis Op-
tions command to bring up the Analysis Options form.
Make sure that the Dynamic Analysis check box is
checked and click the Set Dynamic Parameters button to
bring up the Dynamic Analysis parameters form where
you can specify the number of modes that are used in the
analysis.

You can specify a modal damping override for any mode
number. If you specify a damping override for a mode that
is larger than the number of modes specified for the analy-
sis, this overly large damping override is simply ignored
when the analysis is run.

 Number of Output Time Steps: This is the number of equally
spaced steps at which the output results are reported. Do not
confuse this with the number of time steps in your input time
history function. The number of output time steps can be dif-
ferent from the number of time steps in your input time history
function. The number of output time steps multiplied by the
output time step size is equal to the length of time over which
output results are reported.

 Output Time Step Size: This is the time in seconds between
each of the equally spaced output time steps. Do not confuse
this with the time step size in your input time history function.
The output time step size can be different from the input time
step size in your input time history function. The number of

Note:

If you start a
time history
from the final
conditions of a
previous his-
tory, both histo-
ries must be of
the same type.
That is, they
must both be
linear or they
must both be
nonlinear.
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output time steps multiplied by the output time step size is
equal to the length of time over which output results are re-
ported.

 Start from Previous History: This option allows you to set
the initial conditions for the time history analysis to the condi-
tions that exist at the end of a previously run analysis (in the
same analysis run). This option is not available for periodic
time history analysis.

Note that in many cases you can accomplish the same thing
using the Arrival Time feature in the Load Assignment area.
The advantage of the Start from Previous History option is that
when you want to start several different time histories from the
final conditions of another time history, such as a gravity load
time history, you only have to run the other (gravity) time his-
tory once rather than multiple times.

Often you will want to run gravity load as a time history and
then start one or more lateral time histories from the final con-
ditions of the gravity load time history using the Start from
Previous History option. To run a gravity load time history, de-
fine the Load in the Load Assignments area as the load case
that contains your gravity load and create an input function
from the built-in Ramp time history function template. It is
Time History Cases Command 7 - 63

also helpful to set your modal damping high (say 0.99) for this
gravity load time history.

Load Assignments
You can add as many different load assignments to a time his-
tory case as you desire. To define a load assignment, fill in the
appropriate items in the Load, Function, Scale Factor, Arrival
Time and Angle boxes and then click the Add button.

To modify an existing load assignment, highlight the existing
load assignment in the Load Assignment area of the form. Note
that the data associated with that load assignment appears in the
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edit and drop-down boxes at the top of this area. Modify the load
assignment data as desired. Then click the Modify button.

To delete an existing load assignment, highlight the existing load
assignment in the Load Assignment area of the form. Note that
the data associated with that load assignment appears in the edit
and drop-down boxes at the top of this area. Then click the De-
lete button.

The following items are included in the Load Assignment area:

 Load: This can be defined as acc dir 1, acc dir 2, acc dir 3, or
acc dir Z, or a static load case (Dead, Live). The three accel-
erations (acc dir 1, acc dir 2, and acc dir Z) are ground accel-
erations in the local axes directions of the time history. Posi-
tive acc dir 3 always corresponds to the positive global Z di-
rection. See the description of the Angle item in this area for
information about acc dir 1 and acc dir 2. When you specify
one of the ground accelerations, your input function defines
how the ground acceleration varies with time.

The static load cases that you can specify in this area may be
either force loads or displacement loads. In that case, your in-
put function defines how this load or displacement varies with
time.

Note that you can perform multiple support excitation time
history analysis in this program using displacement time histo-
ries. To do this, define a static load case with a unit displace-
ment at one or more locations and also define a time history
function that defines how that unit displacement varies with
time. Repeat this as many times as required. Then, define a
time history case with multiple load assignments where each
load assignment consists of one of the unit displacement load
cases and its associated time history function.

When you create functions for time history displacement
analysis, the time step for the input function should typically
be smaller than that for a comparable acceleration time history.
The reason for this is that when acceleration varies linearly

Note:

You can per-
form multiple
support excita-
tion time his-
tory analysis in
this program
using displace-
ment time his-
tories.
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between two points, displacement varies as a cubic between
those same two points. Thus, between those two points, you
can define the acceleration just by defining the two points.
However, you will have to define the two points and several
more in between them to reasonably define the displacement.

 Function: This may be any defined time history function.

 Scale Factor: This item is a scale factor that is used as a mul-
tiplier on the input function values. The units for the scale
factor depend on the type of load specified in the Load drop-
down box. If the load is specified as a ground acceleration
(that is, acc dir 1, acc dir 2,  or acc dir Z), this scale factor has
units of Length/seconds2. If the load is a static load case, this
scale factor is unitless.

The scale factor can be any positive or negative number, or
zero.

 Arrival Time: The arrival time is the time at which a particu-
lar load assignment starts. Suppose that you want to apply the
same ground acceleration that lasts 30 seconds to your build-
ing in the global X and global Y directions. Further suppose
that you want the ground acceleration in the global Y direction
to start 10 seconds after the ground acceleration in the global
X direction begins. In that case, you could specify an arrival
time of 0 for the load assignment for the global X direction
shaking and an arrival time of 10 for the load assignment for
the global Y direction shaking.

The arrival time can be zero or any positive or negative time.
The time history analysis for a given time history case always
starts at time zero. Thus, if you specify a negative arrival time
for a load assignment, any portion of its associated input func-
tion that occurs before time zero is ignored. For example, sup-
pose a particular load assignment has an arrival time of -5 sec-
onds. In that case, the first 5 seconds of the input function as-
sociated with that load assignment is ignored by the program.
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 Angle: The local 1 and 2 axes of the time history case coordi-
nate system lie in the global XY plane. By default the local 1-
axis is in the same direction as the positive global X-axis, the
local 2-axis is in the same direction as the positive global Y-
axis and the local 3-axis is in the same direction as the positive
global Z-axis. You can rotate the local 1 and 2 axes of the time
history coordinate system about the local 3 (global Z) axis.
The Angle item specifies the angle in degrees measured from
the positive global X-axis to the positive local 1-axis of the
time history case coordinate system. Positive angles appear
counterclockwise as you look down on the model.

The Angle item is only considered if the Load item is either
acc dir 1 or acc dir 2. Otherwise, the angle item has no mean-
ing. Note that the angle is always measured to the local 1-axis,
even when the Load item is specified as acc dir 2. Thus, if the
Load item is specified as acc dir 2, and the angle is specified as
30 degrees, then acc dir 2 and local coordinate direction 2 are
oriented at an angle of 120 degrees (measured counterclock-
wise) from the positive global X-axis.

Load Combinations Command
Click the Define menu > Load Combinations command or the

 button to define load combinations. This command brings up

the Define Load Combinations form. The Combinations area of
this form lists the names of all the currently defined load combi-
nations. The Click To area of the form allows you to define new
load combinations, modify existing load combinations and delete
existing load combinations.

Clicking on the Add New Combo button or highlighting an ex-
isting load combination and clicking the Modify/Show Combo
button brings up the Load Combination Data form. The follow-
ing bullet items include brief discussions of each of the areas in
this form.



Chapter 7 - Define Menu

Mass Source Command 7 - 67

7

 Load combination name: Specifies the name of the load
combination; use this edit box to modify the name if desired.

 Load combination type: Specifies the type of load combina-
tion as ADD (Additive), ENVE (Envelope), ABS (Absolute)
or SRSS. The most common type of load combination is ADD.

 Define Combination: The actual load combination is created
by specifying one or more load cases, each with an associated
scale factor. To add a load case to the load combination defi-
nition, select the load case name from the Case Name drop-
down box, type in an appropriate scale factor in the Scale
Factor edit box and click the Add button.

To modify the scale factor for a load case already specified as
a part of the load combination definition, highlight the load
case name. Note that the load case name and associated scale
factor appear in the drop-down box and edit box at the top of
the Define Combination area. Type in the revised scale factor
in the Scale Factor edit box and click the Modify button.

To delete a load case from the load combination definition,
highlight the load case name. Note that the load case name and
associated scale factor appear in the drop-down box and edit
box at the top of the Define Combination area. Click the De-
lete button.

Mass Source Command
Click the Define menu > Mass Source command or the 

button, which brings up the Define Mass Source form. The fol-
lowing are bullet items describe each of the areas on this form.

 Mass Definition: Specifies whether the program determines
the building mass based on element/object self masses and any
additional masses that you specify, or based on a load combi-
nation that you specify. By default the program determines the
mass from element/object masses and additional specified
masses.
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 Define Mass Multiplier for Loads: This area is only active if
you select the From Loads option in the Mass Definition area.
When this area is active, you specify a load combination from
which the program determines the building mass. The mass
source load combination is created by specifying one or more
load cases, each with an associated scale factor. To add a load
case to the mass source load combination definition, select the
load case name from the Load drop-down box, type in an ap-
propriate scale factor in the Multiplier edit box and click the
Add button.

To modify the scale factor for a load case already specified as
a part of the mass source load combination definition, high-
light the load case name. Note that the load case name and as-
sociated scale factor appear in the drop-down box and edit box
at the top of the Define Mass Multiplier for Loads area. Type
in the revised scale factor in the Multiplier edit box and click
the Modify button.

To delete a load case from the mass source load combination
definition, highlight the load case name. Note that the load
case name and associated scale factor appear in the drop-down
box and edit box at the top of the Define Combination area.
Click the Delete button.

 Include Lateral Mass Only: If this check box is checked,
only assigned translational mass in the global X and Y axes di-
rections and assigned rotational mass moments of inertia about
the global Z-axis will be considered in the analysis. All other
assigned masses will be ignored for the analysis. Checking this
box is useful if you do not want to consider vertical dynamics
in your model. If you do want to consider vertical dynamics,
this box must be unchecked.

 Lump Lateral Mass at Story Levels: If this check box is se-
lected, all assigned translational mass in the global X and Y di-
rection and assigned rotational mass about the Global Z axis
will be lumped together for a given story level.
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Chapter 8

Draw Menu

This chapter describes the drawing tools and controls that are
available on the Draw menu.

Select Object Command
The Draw menu > Select Object command is used to switch
from a drawing mode where mouse clicks draw objects into a
selection mode where mouse clicks select objects. Alternative
methods of switching from a drawing mode to a selection mode
include pressing the Esc key on your keyboard, clicking the

 button, and executing one of the Select menu commands.

Note that your model must be unlocked in order to draw objects
in it. Typically your model is locked after you run an analysis. If
you need to unlock your model, use the Options menu > Lock
Model command or you can click the Lock/Unlock Model but-
ton, . Note that both the menu command and the toolbar

button act as toggle switches to lock and unlock the model.

Tip:

Most of the
tools available
on the Draw
menu are also
available on the
side toolbar.
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Typically when you enter a drawing mode, you remain in that
drawing mode until you do something to exit it. For example if
you are in a mode to draw point objects, you will draw a new
point object every time you click the left mouse button until you
do something to enter a different drawing mode (e.g., Draw
menu > Draw Line Objects > Draw Lines (plan, elev, 3D)) or
until you do something to enter the select mode (e.g., press the
Esc key on your keyboard).

The Similar Stories Feature
The Similar Stories feature is helpful when drawing objects in
plan view in this program. Similar story assignments are made in
the story level data (Edit menu > Edit Story Data > Edit com-
mand). The drop-down box located in the lower right-hand cor-
ner of the screen (just to the left of the drop-down box for the
coordinate system) is the similar stories feature drop-down box.
The selection made in this box controls what happens when an
object is drawn in this program.

The similar stories drop-down box can be set to One Story, All
Stories or Similar Stories. Each of these is described herein. Note
that the similar stories feature is only active in plan view. It
works in conjunction with drawing, assigning and selecting.

 One Story: This option means that the drawn object only oc-
curs at the story level on which it is drawn.

 All Stories: This option means that the drawn object occurs at
all story levels even though it is drawn at only one story level.

Note:

The similar
stories feature
is only active in
plan view. It
works for
drawing, as-
signing and
selecting.
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 Similar Stories: This option means that the drawn object oc-
curs at all story levels designated as similar in the story level
data. Suppose that Level XX is designated similar to Level
YY. Then, when this option is active, an object drawn on
Level XX also occurs in Level YY and an object drawn on
Level YY also occurs in Level XX.

Reshape Object Command
You can activate the reshaper tool by either clicking on the Re-
shaper button, , or by clicking Draw menu > Reshape Ob-

ject. When you activate the reshaper tool, you enter reshape
mode. When active, you remain in reshape mode until you do
one of the following:

 Click the Pointer button, .

 Press the Esc key on your keyboard.

 Choose one of the drawing options from the Draw menu or
clicking one of the Draw buttons.

 Click on one of the select items in the Select menu.

 Run an analysis.

While in reshape mode, click on an area, line or point object and
modify it in one of several ways. The ways you can modify each
of these objects are described in the subsections in this chapter.

Whether you are reshaping an area, line or point objects, be sure
to read the subsection entitled "Moving/Reshaping Objects in the
Z Direction."

Note that the drawing constraints described in the subsection en-
titled "Drawing Constraints" in this chapter are available when
you use the reshaper tool.

Tip:

When reshap-
ing objects, you
cannot move
them in the Z
direction such
that they cross
a story level.
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Reshaping Area Objects
When you are in reshape mode and you click on an area object, a
series of selection handles (squares that are the opposite color
from the background color) appear at all corners of the area ob-
ject. You can then do any of the following:

 Left click on the area object and while holding down the left
mouse button, drag it to a new location. The area object retains
its original shape; it is simply relocated. Note that when you
move the area object in this way, the corner points of the area
object are disconnected from any other objects they might have
been connected to. Thus reshaping the area object in this man-
ner only affects the area object, not any surrounding elements
that it may be connected to.

 Left click on one of the corner points of the area object and
while holding down the left mouse button, drag the corner
point to a new location. The other corner points remain in their
original locations; the area object takes on a different shape.
Note that when you move the corner point of an area object in
this way, the corner point is disconnected from any other ob-
jects it might have been connected to. Thus, reshaping the area
object in this manner only affects the area object, not any sur-
rounding elements that it may be connected to.

 Right click on one of the corner points of the area object. This
brings up a form where you can modify the global X and/or Y
and/or Z coordinates of the corner point. The other corner
points remain in their original locations; the area object takes
on a different shape. Note that when you move the corner point
of an area object in this way, the corner point is disconnected
from any other objects it might have been connected to. Thus
reshaping the area object in this manner only affects the area
object and not the surrounding elements that it may be con-
nected to. For more information, see the subsection in this
chapter entitled " Moving/Reshaping Objects in the Z Direc-
tion."

Note:

The drawing
constraints
described in the
subsection en-
titled "Drawing
Constraints"
are available
when you use
the reshaper
tool.
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Reshaping Line Objects
When you are in reshape mode and you click on a line object,
selection handles (squares that are the opposite color from the
background color) appear at the ends of the line object. You can
then do any of the following:

 Left click on the line object and while holding down the left
mouse button drag, it to a new location. The line object retains
its original length; it is simply relocated. Note that when you
move the line object in this way, the end points of the line ob-
ject are disconnected from any other objects they might have
been connected to. Thus reshaping the line object in this man-
ner only affects the line object and not the surrounding ele-
ments that it may be connected to.

 Left click on one of the end points of the line object and while
holding down the left mouse button drag the end point to a
new location. The other end point remains in its original loca-
tion; the length of the line object changes. Note that when you
move the end point of a line object in this way, the end point is
disconnected from any other objects it might have been con-
nected to. Thus reshaping the line object in this manner only
affects the line object and not the surrounding elements that it
may be connected to.

 Right click on one of the end points of the line object. This
brings up a form where you can modify the global X and/or Y
and/or Z coordinates of the end point. The other end point re-
mains in its original location; the length of the line object
changes. Note that when you move the end point of a line ob-
ject in this way, the end point is disconnected from any other
objects it might have been connected to. Thus reshaping the
line object in this manner only affects the line object and not
the surrounding elements that it may be connected to. For more
information, see the subsection in this chapter entitled " Mov-
ing/Reshaping Objects in the Z Direction."
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Reshaping Dimension Lines
Dimension lines are described in the subsection entitled "Dimen-
sion Lines" in this chapter. You can use the reshaper tool to
move a dimension line to a new location. You cannot lengthen or
shorten a dimension line, even by using the reshaper tool.

To relocate a dimension line, first click on the line so that the
selection handles (squares that are the opposite color from the
background color) appear at the ends of the dimension line. Then
left click on the dimension line and, while holding down the left
mouse button, drag it to a new location. The dimension line re-
tains its original length; it is simply relocated. The leader lines
are automatically adjusted as needed.

Reshaping Point Objects
When you are in reshape mode and you click on a point object, a
selection handle (square that is the opposite color from the back-
ground color) appears on the point object. You can then do any
of the following:

 Left click on the point object and, while holding down the left
mouse button, drag it to a new location. When you move the
point object in this way, all of the objects connected to the
point move too; they are either reoriented or resized, or both.
Unlike area and line objects, the point object does not gets dis-
connect from the objects it is attached to when it is re-
shaped/moved.

 Right click on the point object. This brings up a form where
you can modify the global X and/or Y and/or Z coordinates of
the point. When you move the point object in this way, all of
the objects connected to the point move too; they are either re-
oriented or resized, or both. Unlike area and line objects, the
point object does not disconnect from the objects it is attached
to when it is reshaped/moved. For more information, see the
subsection in this chapter entitled " Moving/Reshaping Objects
in the Z Direction."
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Moving/Reshaping Objects in the Z Direction
You can only move/reshape objects in the Z-direction within
their own story level or to the story level below. You cannot
specify a Z coordinate that requires an object to move across a
story level.

For example, suppose you have a four-story building with 10-
foot story heights at all levels. Thus, the first story level is at an
elevation of 10 feet, the second story level is at 20 feet, the third
story level is at 30 feet and the fourth story level is at 40 feet.
Further, suppose that you are relocating an area object corner
point that occurs at the mid-height of the third story level; that is,
at an elevation of 25 feet.

You can specify a new Z coordinate for this corner point be-
tween 20 feet and 30 feet inclusive; that is, between the eleva-
tions of the second and third story levels inclusive. If you specify
a Z coordinate less than the second story level elevation, the pro-
gram moves the point to the second story level elevation. If you
specify a Z coordinate greater than the third story level elevation,
the program moves the point to the third story level elevation. If
you specify a Z coordinate between the second and third story
elevations, inclusive, the program moves the point to the speci-
fied elevation.

Draw Point Objects Command
You can only draw point objects in plan view. You cannot draw
them in an elevation or three-dimensional view. To draw point
objects, click the Draw menu > Draw Point Objects command
or click the Draw Point Objects button . After you have ac-

tivated the Draw Point Objects command or button, there are two
ways you can draw the point objects. They are:

 Left click at any location in a plan view to draw a point object.

 Working in plan view, depress and hold down the left button
on your mouse. While keeping the left button depressed, drag
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your mouse to " band" a window around one or more grid line
intersections. Then release the left mouse button. Point objects
will automatically be placed at each grid line intersection in
the same coordinate/grid system included in the "rubber band"
window.

Draw Line Objects Command
To draw line objects, use the Draw menu > Draw Line Objects
command. A submenu will appear with five line object drawing
options. Alternatively, you can select one of the five line object
drawing options directly by clicking the appropriate button.
Those line object drawing options and their associated toolbar
buttons are described in the bullet items that follow. Note that
the items in parenthesis, such as (plan, elev, 3D), indicate the
types of views for which the line object drawing option can be
enabled.

Also note that if the Show Flowing Property Window toggle
switch under the Options menu is enabled and you click a menu
item or toolbar button to draw a line object, a Properties of Ob-
ject box will pop up. The  Properties of Object box provides
various definition parameters and drawing controls for line ob-
jects, depending on the drawing tool selected. Review the pa-
rameters and controls shown in this box before drawing your line
object to ensure that they are what you want. Change any entry
in the box by clicking on it and making a new selection from the
drop-down box or typing in new information into the edit box, as
appropriate.

 Draw Lines (plan, elev, 3D), : To draw a line object us-

ing this command, left click once at the beginning of the line
and then drag the mouse to the end location of the line and left
click again. Note that as you drag the mouse, a dashed line is
visible, indicating the current extent of the line object.

If you left click once on the end point of the line object, the
program assumes that you want to draw another line object

Tip:

To finish
drawing a line
object, either
double left click
on the end point
or single left
click and then
press the Enter
key (or the Esc
key) on your
keyboard.
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starting from that point. Thus when you left click on a third
point, a second line object is created spanning from the second
point clicked to the third point clicked. This process continues
indefinitely when you left click (single click) on the end point
of the line object. You can always tell if the program is ex-
pecting you to draw the second point of a line object because
you will see the dashed "rubber band" line indicating the cur-
rent extent of the line as you drag the mouse. You might think
of the single left click as finishing the line but not picking up
your pencil from the paper.

If you double left click on the end point of the line, the pro-
gram assumes that you do not want to draw another line start-
ing at that point. You might think of the double left click as
finishing the line and picking your pencil up from the paper.
When you double left click to finish drawing a line object,  the
line drawing mode is still enabled. In other words, you can
move your mouse pointer to a new location and start to draw a
new line.

If you single click to finish drawing a line object and then de-
cide that you did not want to draw another line object starting
from that point, press the Enter key on the keyboard. This will
terminate the drawing of the next line and you will notice that
the dashed "rubber band" line disappears. Single left clicking
to finish drawing a line object and then pressing the Enter key
on the keyboard is equivalent to double left clicking to finish
drawing a line object.

You can single click to finish drawing a line object and then
press the Esc key on your keyboard. This terminates the
drawing of the next line and takes you out of Draw mode and
into Select mode. See the section entitled "Two Modes" in
Chapter 1 for more information about the draw and select
modes.

When using this command in an elevation view or 3D view, if
you draw a line object that crosses story levels, the program
immediately breaks the object up at the story levels. For exam-
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ple, if you draw a line object that has its top at the 4th story
level and it bottom at the 2nd story level, the program immedi-
ately breaks the object up into two objects, with the break
point at the 3rd story level.

 Create Lines in Region or at Clicks (plan, elev, 3D), :

This command works in two different ways. You can click on
any grid line (in plan view only) and a line object is drawn on
that grid line between the two adjacent intersecting grid lines
from the same coordinate/grid system.

Alternatively, in all views, you can depress and hold down the
left button on your mouse. While keeping the left button de-
pressed, drag your mouse to "rubber band" a window around
one or more grid line segments. Then release the left mouse
button. Line objects are automatically placed at each grid line
segment included in the "rubber band" window. The term grid
line segment in this paragraph means that portion of a grid line
that is between the two adjacent intersecting grid lines from the
same coordinate/grid system.

 Create Columns in Region or at Clicks (plan), : After

you have activated the Create Columns in Region or at Clicks
(plan) command, you can draw the columns in two ways:

 Left click at any location in a plan view to draw a column
(vertical line object below).

 Working in plan view, depress and hold down the left
button on your mouse. While keeping the left button de-
pressed, drag your mouse to "rubber band" a window
around one or more grid line intersections. Then release
the left mouse button. Columns (vertical line objects be-
low) are automatically placed at each grid line intersection
of two grid lines in the same coordinate/grid system in-
cluded in the "rubber band" window.

The columns (vertical line objects) extend from the story
level that you draw them on to the story level below, and if

Note:

The spacing
and orientation
of secondary
beams are
controlled in
the floating
Properties of
Object window.
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you have the similar stories feature in the program status
bar activated, also to other story levels.

 Create Secondary Beams in Region or at Clicks (plan),
: This command allows you to draw typical infill (secon-

dary) beams for an entire grid line space (beam bay) in a single
click. The grid line space is defined by four adjacent inter-
secting grid lines. If there are existing beams already in the
grid line space, the spacing and extent (length) of the secon-
dary beams is based on the existing beams rather than the grid
lines. Figure 8-1 shows an example of a grid line space and
secondary beams. Note that secondary beams are not included
on the grid lines.

This command works in two different ways. You can click in-
side the space created by adjacent intersecting grid lines (from
the same coordinate/grid system), and secondary beams will be
drawn in that space.

Alternatively, you can depress and hold down the left button
on your mouse. While keeping the left button depressed, drag
your mouse to "rubber band" a window around one or more
grid line spaces. Then release the left mouse button. Secondary
beams are automatically placed in each grid line space within

Note:

The type of
brace created
(X, V, chevron,
eccentric, etc.)
is controlled in
the floating
Properties of
Object window.

2

1

Secondary beams (entered
by clicking at $) in a grid
line space (beam bay)

Secondary beams (entered
by clicking at *) trimmed by
already existing beams

Grid line space
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the region that is fully included in the "rubber band" window.
The term grid line space in this paragraph means the space cre-
ated by adjacent intersecting grid lines (from the same coordi-
nate/grid system).

 Create Braces in Region or at Clicks (elev), : This

command works in an elevation view. It allows you to quickly
draw brace elements in a space bounded by two adjacent grid
lines (from the same coordinate/grid system) and two adjacent
story levels.

This command works in two different ways. You can click in-
side the space created by the intersection of two adjacent grid
lines (from the same coordinate/grid system) and two adjacent
story levels.

Alternatively, you can depress and hold down the left button
on your mouse. While keeping the left button depressed, drag
your mouse to "rubber band" a window around one or more
grid line/story level spaces. Then release the left mouse button.
Braces are automatically placed in each grid line/story level
space within the region that is fully included in the "rubber
band" window. The term grid line/story level space in this
paragraph means the space created by the intersection of two
adjacent grid lines (from the same coordinate/grid system) and
two adjacent story levels.

Draw Area Objects Command
To draw area objects, use the Draw menu > Draw Area Ob-
jects command. A submenu will appear with five area object
drawing options. Alternatively, you can select one of the five
area object drawing options directly by clicking the appropriate
toolbar button. Those area drawing options and their associated
toolbar buttons are described in the bullet items that follow. Note
that the items in parenthesis, such as (plan, elev, 3D), indicate
the types of views for which the area object drawing option is
active.
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will pop up as soon as you click the menu item or toolbar button
to draw a line object.

Also note that if the Show Flowing Property Window toggle
switch under the Options menu is enabled and you click a menu
item or toolbar button to draw an area object, a Properties of
Object box will pop up. The  Properties of Object box provides
various definition parameters and drawing controls for area ob-
jects, depending on the drawing tool selected. Review the pa-
rameters and controls shown in this box before drawing your
area object to ensure that they are what you want. Change any
entry in the box by clicking on it and making a new selection
from the drop-down box or typing in new information into the
edit box, as appropriate.

 Draw Areas (plan, elev, 3D), : To draw an area object

using this command, left click once at the first corner point of
the area, drag the mouse to the next corner point and left click,
and so on to define each corner point of the area object. Note
that as you drag the mouse, a dashed line is visible indicating
the current extent of the area object.

When you reach the last corner point of the area object, double
left click or single left click and then press the Enter key on the
keyboard  to finish the object.

An area object drawn using this command must have at least
three corner points. Typically area objects are limited to no
more than four corner points; however, there is no limit on the
maximum number of corner points allowed for horizontal area
objects (in the global XY plane).

When using this command in a 3D view, the program does not
allow the area object drawn to cross a story level. For example,
you cannot draw a vertical area object in a 3D view that has its
top at the 4th story level and its bottom at the 2nd story level.
With the top at the 4th level, the bottom cannot be below the
3rd story level because this would cause the area object to
cross a story level.

Tip:

To finish
drawing an
area object,
double left click
on the last point
or single left
click and then
press the Enter
key on your
keyboard.
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 Draw Rectangular Areas (plan, elev), : This command

requires two left clicks to draw the rectangular area object.
Left click once to define the position of one corner point of the
area. Then drag the mouse and left click again to define the di-
agonally opposite corner point. Note that as you drag the
mouse, a dashed line is visible indicating the current extent of
the area object.

When using this command in an elevation view, if you draw an
area object that crosses story levels, the program immediately
breaks the object up at the story levels. For example, if you
draw an area object that has its top at the 4th story level and it
bottom at the 2nd story level, the program immediately breaks
the object up into two objects, with the break line at the 3rd
story level.

 Create Areas at Click (plan, elev), : This command al-

lows you to draw area objects in one or more grid line spaces
at a single click. The grid line space is defined by four adjacent
intersecting grid lines. Figure 8-1 shows an example of a grid
line space. To draw the area object simply left click in the grid
line space.

 Draw Walls (plan), : Once you have activated the Draw

Walls (plan) command working in plan view, left click once at
the beginning of the wall below and then drag the mouse to the
end of the wall below and left click again. Note that as you
drag the mouse, a dashed line is visible indicating the current
extent of the area object (wall below).

If you left click once on the end of the wall below, the program
assumes that you want to draw another area object (wall be-
low) starting from that point. Thus when you left click on a
third point, a second area object (wall below) is created ex-
tending from the second point clicked to the third point
clicked. This process continues indefinitely when you left click
(single click) on the end of the area object. You can always tell
if the program is expecting you to draw the end point of an
area object (wall below) because you will see the dashed "rub-



Chapter 8 - Draw Menu

Draw Area Objects Command 8 - 15

8

ber band" line indicating the current extent of the wall as you
drag the mouse. You might also think of the single left click as
finishing the wall but not picking up your pencil from the pa-
per.

If you double left click on the end of the wall below (area ob-
ject), the program assumes you do not want to draw another
wall starting at that point. You might think of the double left
click as finishing the wall and picking your pencil up from the
paper. When you double left click to finish drawing an area
object (wall below), you still remain in same area object
drawing mode. In other words, you can move your mouse
pointer to a new location and start to draw a new wall.

If you single click to finish drawing a wall below and then de-
cide that you did not want to draw another wall below starting
from that point, press the Enter key on the keyboard. This will
terminate the drawing of the next wall; notice that the dashed
"rubber band" line disappears. Single left clicking to finish
drawing an area object (wall below) and then pressing the En-
ter key on the keyboard is equivalent to double left clicking to
finish drawing an area object.

Note that area objects representing walls are broken at story
levels. They are also broken at turns in developed elevations;
that is, at locations where the plane displayed by the developed
elevation changes.

 Create Walls in Region or at Click (plan), : This com-

mand works in two different ways. You can click on any grid
line (in plan view) and a wall below (area object) is drawn on
that grid line between the two adjacent intersecting grid lines
from the same coordinate/grid system.

Alternatively, you can depress and hold down the left button
on your mouse. While keeping the left button depressed, drag
your mouse to "rubber band" a window around one or more
grid line segments. Then release the left mouse button. Area
objects (walls below) are automatically placed at each grid line
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segment included in the "rubber band" window. The term grid
line segment in this paragraph means that portion of a grid line
that is between the two adjacent intersecting grid lines from
the same coordinate/grid system.

Draw Developed Elevation Definition Command
Developed elevations are special user-defined elevations. These
elevations can simultaneously show multiple faces of the build-
ing in a single "unfolded" elevation view. Use the following
steps to define a developed elevation:

 Click the Draw menu > Draw Developed Elevation Defini-
tion command.

 The Elevation Views form appears. In this form, you can de-
fine names for developed elevations that you plan to draw,
modify the names of developed elevations after they have been
drawn, and delete names of existing developed elevations.
When finished defining or modifying developed elevation
names, highlight the name of the elevation that you first want
to work with and then click the OK button.

 The program windows then all switch to special plan views
used for creating and modifying developed elevation views.
Note the following about these special plan views:

 In the special plan views, you can only see and work with
one developed elevation definition at a time. You can use
the drop down box in the status bar (at the bottom of the
program window) that ordinarily displays the similar sto-
ries option to switch to plan views of different developed
elevations.

 When you click the OK button in the Elevation Views
-

Note:

A line defining
a developed
elevation can
not intersect
(cross) itself
and it also can
not close.
 - 16 Draw Developed Elevation Definition Command

form, you enter the special plan views to work on the de-
veloped elevation that was highlighted in the form. This
developed elevation may or may not currently be defined.
If it is not defined, you will see a blank plan view, other-
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wise you will see a plan view with the existing developed
elevation view shown in it.

When you initially enter the special plan view, you are in a
mode where you can start drawing the developed eleva-
tion. You do not need to click on any buttons or menu
commands to draw the line defining the developed eleva-
tion. Simply start left clicking to draw the line. The line
defining the developed elevation may be multi-segmented.
When you get to the last point defining the developed ele-
vation, double left click or single left click and then press
the Enter key on your keyboard to complete the definition.

Important Note: The line defining the developed elevation
can not intersect (cross) itself and it also cannot close with
itself.

After you have drawn a developed elevation or if the developed
elevation you highlighted in the Elevation Views form already
exists such that when the special plan view appears a developed
elevation definition is showing, you can modify the developed
elevation definition. To do this:

 Click on the Draw menu > Reshape Object command or the
Reshaper button, , on the side toolbar.

 Click on the line defining the developed elevation. Selection
handles squares that are the opposite color from the back-
ground color appear along the line at the points where you
clicked to define the line.

If you then left click on the line and hold down the mouse left
button, you can drag the entire line defining the developed ele-
vation to a new location. Note that the shape of the line does
not change.

Alternatively, you can left click on one of the selection han-
dles, hold down the mouse left button, and drag the selection
handle (point) to a new location, thus changing the shape of
the line defining the developed elevation.
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When you have finished reshaping a developed elevation defini-
tion, do one of the following:

 Right click in the program window (not on any objects) to
bring up a selection menu. Click Restore Views on this menu.
You return to the views you were in before you began to de-
fine/modify the developed elevations. Alternatively you could
select these views from the view menu or associated toolbar
buttons, but it is much easier to use the Restore Views com-
mand.

 If instead you want to work with another developed elevation,
select a developed elevation view name from the drop-down
box in the status bar (at the bottom of the program window)
that ordinarily displays the similar stories option. When you
click on a developed elevation view in this drop-down box,
you enter a mode where you are ready to draw a new elevation,
not reshape it. If you want to reshape/modify this developed
elevation, click on the Draw menu > Reshape Object com-
mand or the Reshaper button .

Note that when you have finished drawing a line that defines a
developed elevation you can then immediately exit the devel-
oped elevation view (we recommend using the Restore Views
command as described above to do this), reshape the line (as de-
scribed above), or click in the drop-down menu on the status bar
to work on another developed elevation (as described above).

Figure 8-2 shows three example developed elevations together
with their associated plan views. The elevations associated with
a particular plan are shown next to the plan. The heavy line in
the plan views shows the extent of each developed elevation.
The open circles on the heavy lines show the locations where left
mouse clicks are required to define the developed elevation.
Note that each of the left click locations is numbered in the order
the clicks occur.

Note that in Figure 8-2c the final mouse click (point 5) cannot
occur at grid intersection A-3 (the same location as point 1) be-
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cause this would close the line and developed elevations are not
allowed to be closed in this manner.

Also note that the three examples shown in Figure 8-2 all have
the mouse clicks occurring on grid intersections. It is not neces-
sary to click on grid intersections to define developed elevations.
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Figure 8-2:
Example definitions
of developed eleva-
tions
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You can click anywhere in plan when defining a developed ele-
vation and the elevation will be created at the point of your click.
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Draw Dimension Line Command
You can use the Draw menu > Draw Dimension Line com-
mand to draw dimension lines at any location in a plan or eleva-
tion view. You cannot draw dimension lines in a three-
dimensional view. After you have clicked the Draw menu >
Draw Dimension Line command, use the following steps to
draw the dimension line:

 Left click on the point that you want to dimension from.

 Left click on the point that you want to dimension to.

 The dimension line appears between the two points you
clicked on but you are not quite finished creating it. Now drag
the dimension line in a direction perpendicular to its original
location to the final location for the line. When you have
dragged the dimension line to its final location, left click the
mouse again and the dimension line is complete.

Note that three left clicks are required to completely draw a di-
mension line. A completed dimension line has arrow heads at
each end, dimension text displaying the length of the dimension
line, and leaders to the points being dimensioned if you dragged
the dimension line away from those points. You can specify the
units that the dimensions are to be displayed in by using the Op-
tions menu > Preferences > Output Decimals command. See
Chapter 14 Options Menu for more information.

Dimension lines are similar to other line objects in that they only
appear on the story level you draw them on unless you are using
the similar stories feature, which can be enabled using drop-
down box on the program status bar. The similar stories feature
works for dimension lines.

You can use the View menu > Set Building View Options
command or the Set Building View Options button  to tog-

gle the visibility of the dimension lines on or off.
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After you have drawn a dimension line, you can select it any
time you are in the select mode by clicking directly on it. You
cannot select a dimension line by windowing it. You might want
to select a grid line to relocate it. There are two features avail-
able for relocating grid lines. They are the nudge feature and the
reshaper tool.

The nudge feature is described in the section entitled "Nudge
Feature" in Chapter 5 View Menu. This feature works as de-
scribed there for dimension lines.

The reshaper tool is described earlier in this chapter. In addition,
the section entitled "Reshaping Dimension Lines" provides in-
formation on using the tool to relocate dimension lines.

Draw Reference Point Command
Reference points are drawn in plan view. They are useful be-
cause they allow you to snap to the same plan location at any
story level. Reference point function somewhat similar to verti-
cal grid lines but they have no identification and no line associ-
ated with them. To draw a reference point, use the Draw Menu
> Reference Point command.

Snap To Command
The snap features allow you to snap to various items when you
are drawing or editing. There are six separate snap features
available. You can toggle those six features on or off in any
combination for simultaneous action using the Draw menu >
Snap to command or by clicking one or more of the six snap
feature buttons. The six snap features and their associated but-
tons are as follows:

 Snap to Grid Intersections and Points, : This feature

snaps to points and grid line intersections of two grid lines in
the same coordinate/grid system. This feature works in plan,
elevation and three dimensional views.
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 Snap to Line Ends and Midpoints, : This feature snaps

to the midpoints and ends of line objects and to the midpoints
and ends of edges of area objects. Note that the end of an edge
of an area object is a corner point of the area object. This fea-
ture works in plan, elevation and three dimensional views.

 Snap to Intersections, : This feature snaps to the inter-

sections of line objects with other line objects and with the
edges of area objects. It does not snap to the intersection of the
edge of one area object with the edge of another area object.
This feature works in plan view only. It does not work in ele-
vation or three-dimensional views.

 Snap to Perpendicular Projections, : This feature works

as follows. First draw the first point for a line or area object.
Then, if this snap feature is active, place the mouse pointer
over another line object or edge of an area object and left click.
A line object or edge of an area object will then be drawn from
the first point perpendicular to the line object or edge of an
area object that the mouse pointer was over when the second
point was clicked. This feature works in plan view only. It
does not work in elevation or three dimensional views.

 Snap to Lines and Edges, : This feature snaps to grid

lines, line objects and edges of area objects. This feature works
in plan, elevation and three dimensional views.

 Snap to Fine Grid, : This feature snaps to an invisible

grid of points. The spacing of the points is controlled by the
Plan Fine Grid Spacing Item, which is accessed using the Op-
tions menu > Preferences > Dimensions/Tolerances com-
mand. This feature works in plan view only. It does not work
in elevation or three-dimensional views.

Use the following procedure when using the snap commands:

 If the appropriate snap tool is not already activated, select it or
use the Draw menu > Snap to command and select it from the
submenu.
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 Move the mouse pointer in the graphics window.

 When a snap location is found close to the mouse pointer, a dot
appears at the snap location as well as a text field describing
the snap location.

Note that the distance the pointer must be from a snap location
before it snaps to that location is controlled by the Screen Snap
to Tolerance item, which is accessed using the Options menu
> Preferences > Dimensions/Tolerances command.

 When the desired snap location has been found, click the left
mouse button to accept it.

 Modify the snap options if necessary and continue drawing or
editing objects.

The snap options are evaluated in the order they are listed above.
This order is repeated below for easier reference. If more than
one snap option is active and the mouse pointer is located such
that it is within the screen snap to tolerance of two different snap
features, it will snap to the snap feature that is first in the list
below. This is true even if the item associated with the other
snap feature is closer to the mouse pointer as long as both items
are still within the screen snap to tolerance.

 Snap to Grid Intersections and Points,  .

 Snap to Line Ends and Midpoints, .

 Snap to Intersections, .

 Snap to Perpendicular Projections, .

 Snap to Lines and Edges, .

 Snap to Fine Grid, .

As an example, suppose Snap to Intersections and Snap to Fine
Grid are both enabled. Assume that the mouse pointer is located
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such that it is within the screen snap to tolerance of both an in-
tersection of two line objects and one of the invisible grid points.
The snap will be to the intersection of the two line objects be-
cause this snap feature occurs first in the above list.

When two items from the same snap feature are within the
screen snap to tolerance of the mouse pointer, the snap occurs to
the first drawn item, which may or may not be the closest item.
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Select Menu

General
The Select menu provides basic options and tools for selecting
objects in your model. This chapter describes those options and
tools. Do not overlook the Note about Window Selections in
Plan View at the end of the "Window" bullet item in the next
section.

Note that the similar stories feature works for selections but only
in plan view.

Basic Methods of Selecting Objects
The three basic methods of selecting objects in this program are
the following:

• Left click: Left click on an object to select it. If there are
multiple objects, one on top of the other, hold down the
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Ctrl key on your keyboard as you left click on the ob-
jects. A form will appear that allows you to specify
which object you want to select.

• Window or "Windowing": Draw a window around one
or more objects to select them. To draw a window
around an object, first position your mouse pointer be-
yond the limits of the object; for example, above and to
the left of the object(s) you want to window. Then de-
press and hold down the left button on your mouse.
While keeping the left button depressed, drag your
mouse to a position below and to the right of the ob-
ject(s) you want to select. Release the left mouse button
to complete the selection. Note the following about win-
dow selection:

 As you drag your mouse, a "rubber band window"
appears. The rubber band window is a dashed rec-
tangle that changes shape as you drag the mouse.
One corner of the rubber band window is at the point
where you first depressed the left mouse button. The
diagonally opposite corner of the rubber band win-
dow is at the current mouse pointer position. Any
visible object that is completely inside the rubber
band window when you release the left mouse but-
ton is selected.

 As long as you are beyond the limits of the object(s)
you want to select, you can start the window at any
point; for example, above and to the right, below and
to the left or below and to the right of the object(s)
you want to select. In all cases, you would then drag
your mouse diagonally across the object(s) you want
to select.

An entire object must lie within the rubber band window
for the object to be selected.

Note about Window Selections in Plan View: When
selecting by window in a plan view (not a perspective

Note:

When selecting
by window in a
plan view (not a
perspective
plan view), only
the visible ob-
jects that lie
fully in the
plane of the
plan view are
selected.

Note:

An entire object
must lie within
the rubber band
window for the
object to be
selected.
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plan view) only the visible objects that lie fully in the
plane of the plan view are selected. In other words, only
the visible point objects, horizontal area objects and
horizontal line objects within the select window are se-
lected.

• Intersecting Line: Draw a line through one or more
objects to select them. To use this selection method,
click the Select menu > Select Using Intersecting Line
command or the Set Intersecting Line Select Mode
button, . Then position your mouse pointer to one

side of the object(s) you want to select. Depress and hold
down the left button on your mouse. While keeping the
left button depressed, drag your mouse across the ob-
ject(s) you want to select. Release the left mouse button
to complete the selection. Note the following about the
intersecting line selection method:

 As you drag your mouse a "rubber band line" ap-
pears. The rubber band line is a dashed line that
changes length and orientation as you drag the
mouse. It extends from the point where you first de-
pressed the left mouse button to the current mouse
pointer position. Any visible object that is inter-
sected (crossed) by the rubber band line when you
release the left mouse button is selected.

 After using this method to make a selection, the pro-
gram defaults to the window selection mode. Thus,
each time you want to use the Select Using Inter-
secting Line method, you must use the menu or click
the  button.

Tip:

Use the inter-
secting line
selection
method in a
perspective
view to select
all columns at a
story level.
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Menu Methods of Selecting Objects
Table 1 identifies the submenu commands and related actions
accessed using the Select menu command.

Table 1 Submenus of the Select Menu Command

Command Action

Select on XY plane Click on a single point and all objects
(point, line and area) that are in the
same XY plane as the selected point
are also selected. The object must lie
entirely in the associated plane to be
selected.

Select on XZ plane Click on a single point and all objects
(point, line and area) that are in the
same global XZ plane as the selected
point are also selected. The object
must lie entirely in the associated plane
to be selected.

Select on YZ plane Click on a single point and all objects
(point, line and area) that are in the
same global YZ plane as the selected
point are also selected. The object
must lie entirely in the associated plane
to be selected.

Select by groups Select the name of any collection of
objects that has been defined as a
group from the Select Group box and
that group will be selected.

Note:

These selection
methods also
work for dese-
lection.
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Table 1 Submenus of the Select Menu Command

Command Action

Select by frame
sections

Select a frame section property name
from the Select Sections box and all
line objects that have been assigned
that frame section property will be se-
lected.

Select by
wall/slab/deck
sections

Select a wall/slab/ deck section prop-
erty name from the Section Selections
box and all area objects that have been
assigned that wall/slab/deck section
property will be selected.

Select by link
properties

Select a link property name in the Se-
lect Properties box and all line objects
that have been assigned that link prop-
erty will be selected.

Select by line
object type

Select a line objects type from the Se-
lect Line Object Type box. The choices
for the types of line objects are column,
beam, brace, null or dimen lines (short
for dimension lines).

Select by area
object type

Select an area objects type from the
Select Area Object Type box. The
choices for the types of area objects
are floor, wall, ramp or null. Note that
openings are a subset of null area ob-
jects.

Selecting by PIER
ID

Select from the  in the Select Pier IDs
box the name of any Shell/Area that
has been assigned a Pier Label.
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Table 1 Submenus of the Select Menu Command

Command Action

Selecting By
Spandrel ID

Select from the Select Spandrel IDs
box any Shell/Area that has been as-
signed a Spandrel Label.

Select by story level Select a story level from the Story
Level box, and all objects (point, line
and area) associated with that story
level will be selected.

Select all Selects all objects in the model re-
gardless of whether they are visible or
not. Be careful using this command. It
does not just select what is showing in
a particular window, but rather it liter-
ally selects all objects in your model.
You can also use the Select All button

 to execute this command.

Select invert Changes the selection such that the
currently selected objects are no longer
selected and all objects that are not
currently selected are selected.

Deselect Command
You can deselect objects one at a time by left clicking on the se-
lected objects. Alternatively, use the Select menu > Deselect
command and its submenus for quicker and more specific dese-
lection actions. This command gives you access to submenu
items similar to those described in the previous section, except
that executing the Select menu > Deselect command and an as-
sociated submenu item deselects rather than selects an object(s).
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For example, assume that you want to select all of the objects in
your model except for those in a particular XZ plane. Do this
quickly and easily by first using the Select menu > Select All
command and then using the Select menu > Deselect > XZ
Plane command.

Get Previous Selection Command
As the name suggestions, the Select menu > Get Previous Se-
lection command, gets the previously selected object(s). For ex-
ample, assume you select some line objects by clicking on them
and you then assign them some frame section properties. Use the
Get Previous Selection command or the  button to select the

line objects again and assign something else to them, such as
member end releases.

Clear Selection Command
As the name suggests, the Select menu > Clear Selection com-
mand and its associated button  clear all currently selected

objects. It is an all or nothing command. You cannot selectively
clear a portion of a selection using this command.
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Assign Menu

General
The Assign menu provides basic options and tools for assigning
section properties, loads, and more to area, line and point objects
in your model. This chapter describes the Assign options and
tools. Note that before you make an assignment to an object us-
ing the Assign menu, you must first select the object. Commands
for selecting objects are described in Chapter 9 Select Menu.

Assign Joint/Point Commands
Use the Assign menu > Joint/Point command to make assign-
ments to point objects. The following subsections describe the
assignments that you can make to point objects.
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Joint Point > Rigid Diaphragm Command
Use the Assign menu > Joint/Point > Rigid Diaphragm com-
mand to designate that a selected point is a rigid diaphragm. This
command assigns a diaphragm constraint to all of the selected
points. The selected points should typically all lie in a plane
that is parallel to the global X-Y plane. No points other than
those actually selected are included in the diaphragm constraint.

When you select one or more point objects and click the Assign
menu > Joint/Point > Rigid Diaphragm command or the 

button, the Assign Diaphragms form appears. The Diaphragms
area of the Assign Diaphragms form lists the names of all the
currently defined rigid diaphragms. The Click To area of the
form allows you to define new rigid diaphragms, change an ex-
isting diaphragm name and delete an existing diaphragm.

To assign a new diaphragm, select the point object(s) to which
you want to assign the diaphragm designation and click the As-
sign menu > Joint/Point > Rigid Diaphragm command or the

  button.  In the Assign Diaphragm form, type a new dia-

phragm name in the edit box of the Diaphragms area, for exam-
ple D2.  Click the Add New Diaphragm button, and then click
the OK button to complete the assignment.

Now assume you want additional point objects to be rigid dia-
phragms and for those rigid diaphragms to have a D2 designa-
tion, the same as the point objects in the previous paragraph. To
do this, select the additional point objects and click the Assign
menu > Joint/Point > Rigid Diaphragm command or the 

button. Highlight the name D2 in the Diaphragms area of the As-
sign Diaphragm form; note that D2 appears in the edit box. Click
the OK button. Note that this gives the selected points the D2
designation, increasing the number of point objects that are des-
ignated as rigid diaphragms and identified with the D2 assign-
ment.

If you decide that some point objects previously identified as
rigid diaphragms should not have that assignment, make the

Note:

Rigid dia-
phragms can
only be hori-
zontal. Thus
when assigning
a rigid dia-
phragm con-
straint to point
objects, all of
the selected
points should
lie in a plane
that is parallel
to the global X-
Y plane.

Tip:

You can also
assign rigid
diaphragms to
area objects
using the As-
sign menu >
Shell/Area >
Rigid Dia-
phragm com-
mand.
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change as follows. Select the point objects to be changed. Click
the Assign menu > Joint/Point > Rigid Diaphragm command
or the   button. In the Diaphragms area of the Assign Dia-

phragm form, highlight None and click the OK button.

In the program a rigid diaphragm translates within its own plane
(global X-Y plane) and rotates about an axis perpendicular to its
own plane (global Z-axis) as a rigid body. Including point ob-
jects in a rigid diaphragm definition has no affect on the out-of-
plane behavior of the point objects.

If you check the Disconnect from All Diaphragms check box, the
point will be disconnected from all diaphragms, regardless of
whether it is included within an area object given a rigid dia-
phragm assignment.

Note that you can also apply a rigid diaphragm to an area object.
In most instances, it is better to assign the rigid diaphragm to an
area object.

Joint/Point > Panel Zone Command
A panel zone assignment to a point object allows differential ro-
tation and in some cases differential translation at beam-column,
beam-brace and column-brace connections. You specify a panel
zone assignment by selecting the point object and clicking the
Assign menu > Joint/Point > Panel Zone command. This pops
up the Assign Panel Zone form.

Making a panel zone assignment to a point object you indicates
the properties of the panel zone, the connectivity at the panel
zone, the local axes orientation for the panel zone and an as-
signment option for the panel zone. Each of those items is de-
scribed in the subsections that follow. The headings used for the
subsections correspond to the areas in the Assign Panel Zone
form which comes up when you use the Assign men >
Joint/Point > Panel Zone command or the  button.

You cannot assign multiple panel zones to the same point object.

Tip:

To delete spe-
cific point ob-
jects from a
diaphragm
definition, se-
lect those point
objects, enter
the Assign Dia-
phragm form,
highlight None
in the Dia-
phragms area
and click the
OK button.
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Properties
When you specify panel zone properties, you are actually speci-
fying the stiffness of the springs used to model the panel zone.
See the subsequent subsection entitled "Connectivity" for more
information. The following options are available for specifying
panel zone properties:

 Elastic Properties from Column: In this case, only rotational
properties for bending about the major axis (local 3-axis) and
minor axis (local 2-axis) are taken from the column. Those
rotational properties are assigned to the panel zone spring that
connects the two program-created internal joints at the panel
zone. For all other degrees of freedom, the internal joints at the
panel zone are assumed to be rigidly connected.

When you select this properties option, the only active option
for Connectivity is beam-column and the only active option for
the local 2-axis is From Column.

If you specify this option and there is no column connected to
the point object with the panel zone assignment, the program
ignores this panel zone assignment.

 Elastic Properties from Column and Doubler Plate: When
using this option, you specify a doubler plate thickness. The
program then changes the web thickness (local 2-axis direc-
tion) of the column to be equal to the original web thickness
plus the specified doubler plate thickness and calculates the
properties of this modified section. The rotational properties
for bending about the major axis (local 3-axis) and minor axis
(local 2-axis) are taken from the modified column section.
Those rotational properties are assigned to the panel zone
spring that connects the two program-created internal joints at
the panel zone. For all other degrees of freedom, the internal
joints at the panel zone are assumed to be rigidly connected.

When you select this properties option, the only active option
for Connectivity is beam-column and the only active option for
the local 2-axis is From Column.

Tip:

Assigning link
element prop-
erties to a panel
zone is a little
more compli-
cated, but it
provides the
most versatility.
If you want the
panel zone to
behave non-
linearly in a
nonlinear static
or dynamic
analysis, you
must specify the
panel zone
properties as a
link property.
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If you specify this option and there is no column connected to
the point object with the panel zone assignment, the program
ignores the panel zone assignment.

 Specified Spring Properties: When using this option, you
specify rotational spring stiffnesses for major axis bending
(about the local 3-axis of the column and panel zone) and mi-
nor axis bending (about the local 2-axis of the column and
panel zone). Those two rotational spring properties are as-
signed to the panel zone spring that connects the two program-
created internal joints at the panel zone. For all other degrees
of freedom, the internal joints at the panel zone are assumed to
be rigidly connected.

When you select this properties option, the only active option
for Connectivity is beam-column and the only active option for
the local 2-axis is From Column.

 Specified Link Property: When using this option, you specify
a link element property for the panel zone. The link element
properties are assigned to the spring that connects the two pro-
gram-created internal joints at the panel zone. In this case, this
spring may have properties for all six degrees of freedom if
nonzero link properties are defined for all six degrees of free-
dom. If the link element property has zero properties for a par-
ticular degree of freedom, the program assumes that the degree
of freedom is rigidly connected. Therefore, given this assump-
tion, if for some reason you want one of the degrees of free-
dom of the panel zone to have essentially zero stiffness, spec-
ify a small stiffness for that degree of freedom in the link
properties.

If you have nonlinear static properties defined for the link
property, those properties are considered when you run a static
nonlinear (pushover) analysis. Similarly, If you have nonlinear
dynamic properties defined for the link property, those proper-
ties are considered when you run a nonlinear time history
analysis. Thus, when you indicate that the panel zone proper-

Note:

A panel zone
assignment
allows relative
movement,
typically rota-
tion, between
beam and col-
umn, beam and
brace, or brace
and column
members.



Reference Manual

10 - 6 Assign Joint/Point Commands

10

ties are based on a specified link property, you can model non-
linear behavior in the panel zone.

When you select this properties option, all three options are
available and active in the Connectivity area and both options
are available and active in the Local Axis area.

Connectivity
The choices for panel zone connectivity are beam-column,
beam-brace and brace-column. Unless you choose the Specified
Link Property option in the Properties area, the only active panel
zone connectivity option is beam-column.

If you specify a type of panel zone connectivity for a point object
and the element type specified does not connect to the point ob-
ject, the program ignores the panel zone assignment. For exam-
ple, if you specify brace-column connectivity at a point object
and there are no braces at the point object, the panel zone as-
signment is ignored.

Following are descriptions of the three types of panel zone con-
nectivity:

 Beam - Column: For beam-column connectivity, two separate
joints are internally created by the program to model the panel
zone. All beam members are connected to one of the joints and
all column members are connected to the other joint. The two
joints are connected by a spring that has the properties speci-
fied for the panel zone.

Consider Figure 10-1a, which shows a beam-column joint.
Figure 10-1b shows the effect of assigning a panel zone with
beam-column connectivity to this joint. Joints 1 and 2 are cre-
ated internally by the program. They both actually occur at the
same location as the point object that is at the beam-column
intersection. They are only shown in different locations in the
figure for graphical explanation purposes. The column mem-
bers are connected to joint 1. The beam members are con-
nected to joint 2.
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properties based on the panel zone assignment. Note that the
relative movement in the panel zone is between the column
elements and the beam elements. There is no relative move-
ment between individual column elements or individual beam
elements.

 Beam - Brace: For beam-brace connectivity, two separate
joints are internally created by the program to model the panel
zone. All beam members are connected to one of the joints and
all brace members are connected to the other joint. The two
joints are connected by a spring that has the properties speci-
fied for the panel zone. See the description of Beam - Column
connectivity for additional information.

 Brace - Column: For brace-column connectivity, two separate
joints are internally created by the program to model the panel
zone. All brace members are connected to one of the joints and
all column members are connected to the other joint. The two
joints are connected by a spring that has the properties speci-
fied for the panel zone. See the description of Beam - Column
connectivity for additional information.

Local Axis
The positive local 1-axis is in the same direction as the positive
global Z-axis (upward), always.

On the form you specify the positive direction of the local 2-axis
as one of the following:

Column

Beam
Beam

Column

Beam
Beam

1

2

a) Beam-Column Connection b) Panel Zone Representation

Figure 10-1:
Panel zone connec-
tivity
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 From Column: The positive local 2-axis of the panel zone
is in the same direction as the positive local 2-axis of the
column connected to the panel zone. If columns are con-
nected to the panel zone from both above and below and
they have different local axes orientations, the positive lo-
cal 2-axis of the panel zone is in the same direction as the
positive local 2-axis of the column below (and connected
to) the panel zone.

If you specify that the local 2 axis is based on a column
and no column exists at the panel zone location, the posi-
tive local 2-axis is oriented in the same direction as the
positive global X-axis.

 Angle: The direction of the positive local 2-axis of the
panel zone is specified by an angle measured in degrees
from the positive global X-axis. A positive angle appears
counterclockwise as you look down on it from above. An
angle of 0 degrees means the positive local 2-axis is in the
same direction as the positive global X-axis. An angle of
90 degrees means the positive local 2-axis is in the same
direction as the positive global Y-axis.

The direction of the positive local 3-axis is determined from the
directions of the local 1 and 2 axes described above using the
right hand rule.

Unless you choose the Specified Link Property option in the
Properties area, the only active local axis option is From Col-
umn.

Options
Two assignment options are possible:

 Replace Existing Panel Zones: Replaces the currently speci-
fied panel zone (spring stiffness), if any, with the new panel
zone assignment. If there is not an existing assignment, the
new assignment is still made. This is the default option.

Global X

G
lo

ba
l Y

Lo
ca

l 2

Positive
angle
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 Delete Existing Panel Zones: Deletes the panel zone assign-
ment made to the selected point object(s).

Note that the default option is Replace and that the program
defaults to this every time the form is opened.

Joint/Point > Restraints (Support) Command
Use the Assign menu > Joint/Point > Restraints (Supports)
command or the  button to bring up the Assign Restraints

form where you can assign restraints (supports) to selected point
objects. Note that restraints are always specified in the global
coordinate system.

The six possible degrees of freedom available for a point object
are listed in the Restraints in Global Directions area of the form.
Place a check in the check box associated with any degree of
freedom that you want to be restrained. Any degree of freedom
whose associated box is not checked is assumed to be unre-
strained assuming, of course, that the degree of freedom has been
designated as active for the model. See the Section entitled "Set
Analysis Options Command" in Chapter 11 Analyze Menu for
additional information.

The Fast Supports area of the Assign Restraints form provides
four buttons that quickly set the restraint conditions for you by
checking and unchecking various check boxes in the Restraints
in Global Directions area. The four fast restraint buttons are:

 : This is the fast fixed base restraint button. All six de-

grees of freedom are restrained (boxes checked) when you
click on this button.

 : This is the fast pinned base button. All three translation

degrees of freedom are restrained (boxes checked) and all
three rotation degrees of freedom are unrestrained (boxes not
checked) when you click on this button.

Tip:

The fast re-
straint buttons
provide a quick
and easy way of
assigning typi-
cal restraint
conditions. For
unusual condi-
tions, the fast
restraint but-
tons may not be
appropriate.
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 : This is the fast roller support button. Only the Z transla-

tion is restrained (box checked) when you click on this button.
All other degrees of freedom are unrestrained (boxes not
checked).

 : This is the fast no support button. All degrees of free-

dom are unrestrained (boxes not checked) when you click on
this button.

Joint/Point > Point Springs Command
Use the Assign Menu > Joint/Point > Point Springs command
or the  button to open the Assign Springs form and assign

point springs that are oriented in the global axes directions to
point objects. Both translational and rotational springs can be as-
signed to a point object.

The following two areas appear in the Assign Springs form:

 Spring Stiffness in Global Directions: Specify the spring
stiffness for one to six of the degrees of freedom for the se-
lected point objects. Note that point spring stiffnesses are al-
ways specified in the global coordinate system. There is no
coupling of the six springs specified in this form.

 Options: The following three assignment options are avail-
able:

 Add to Existing Springs: Adds the specified spring stiff-
ness to the point object. If one or more point spring as-
signments have already been made, this option increases
the existing spring stiffness, assuming that you are speci-
fying a positive spring stiffness.

 Replace Existing Springs: Replaces the currently speci-
fied spring stiffness, if any, with the new spring stiffness
assignment. If there is not an existing assignment, the new
assignment is still made. This is the default option.

Tip:

Make sure that
the point ob-
jects with
spring assign-
ments are con-
nected, either
directly or indi-
rectly, to
structural ele-
ments such as
frames, shell
and links.
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 Delete Existing Springs: Deletes any and all point spring
assignments made to the selected point object(s).

Important Note: It is possible to assign negative spring stiffness
to a point object as long as the total stiffness at the point still re-
mains positive (or is zero). If you decide to assign some negative
spring stiffness to a point object, do it with great care because it
can terminate your analysis. Negative spring stiffness at a point
during the analysis causes your structure to be unstable and thus
the program terminates the analysis and provides an error mes-
sage that there is an instability. The program does not check for
negative spring stiffness before running the analysis.

Coupled Springs
There is no coupling of the spring stiffnesses that are specified in
the Spring Stiffness in Global Directions area of the form. That
is, for the spring stiffnesses specified in the Spring Stiffness in
Global Directions area, the deformation in one degree of free-
dom does not affect the deformation in another degree of free-
dom. It is also possible to specify point springs that have coupled
behavior. The spring forces that act on a point object are related
to the displacements of that point object by a 6x6 symmetric
matrix of spring stiffness coefficients. Specify this 6x6 matrix by
clicking the Assign Menu > Joint/Point > Point Springs com-
mand and then clicking the Advanced button on the Assign
Springs form to bring up the Coupled 6x6 Spring form. In that
form, define the 6x6 matrix for the coupled springs.

Figure 10-2 illustrates the 6x6 symmetric matrix of spring stiff-
ness coefficients. When coupling is present, all 21 terms in the
upper triangle of the matrix are specified. The other 15 terms are
known by symmetry. For springs that do not couple the degrees
of freedom, only the 6 diagonal terms are needed because the
off-diagonal terms are all zero. You are specifying the diagonal
terms for the spring stiffnesses when you use the Assign Menu >
Joint/Point > Point Springs command and assign the stiffnesses
in the Spring Stiffness in Global Directions area of the form
rather than clicking on the Advanced button.
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When link element properties are assigned to a point object, that
link element is grounded. That is, one end is connected to the
point object and the other end is connected to the ground. The
element has zero length and no additional point is required to
connect it to the ground. The local axes for the grounded, zero-
length link element are as follows:

 The positive local 1-axis is up, in the same direction as the
positive global Z-axis.

 The positive local 2-axis is in the same direction as the posi-
tive global X-axis.

 The positive local 3-axis is in the same direction as the posi-
tive global Y-axis.

You cannot modify the local axes directions for grounded, zero-
length link elements.

Use the Assign menu > Joint/Point > Link Properties com-
mand to assign link properties to a point object. This command
brings up the Assign Link Properties form. Simply highlight the
name of a defined link property in the form and then click the
OK button to assign a link property to the selected point ob-
ject(s). Note that link properties are defined using the Define
menu > Link Properties command; see Chapter 7 Define Menu
for more information about defining link properties.

Fx
Fy
Fz
Mx
My
Mz

ux
uy
uz
rx
ry
rz

ux uxuy uxuz uxrx uxry uxrz
uy uyuz uyrx uyry uyrz

uz uzrx uzry uzrz
rx rxry rxrz

symmetric ry ryrz
rz

=  –

Figure 10-2:
6x6 symmetric ma-
trix of spring stiff-
ness coefficients

Tip:

Use the Assign
menu >
Joint/Point >
Panel Zone
command to
assign panel
zones with link
properties to
point objects.
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If you want to remove a link property assignment from a point
object, select the point object, click the Assign menu >
Joint/Point > Link Properties command, highlight "None" in
the Link Properties area of the Assign Link Properties form and
click the OK button.

Note you cannot use the Assign menu > Joint/Point > Link
Properties command to assign panel zones to point objects even
if the properties of the panel zone are based on a specified link
Note:

You can assign
multiple link
properties
(elements) to
the same point
object.
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property. You must use the Assign menu > Joint/Point > Panel
Zone command to assign panel zones to point objects. See the
previous subsection in this chapter titled "Joint Point > Panel
Zone Command" for more information.

Joint Point > Additional Point Mass Command
Use the Assign menu > Joint/Point > Additional Point Mass
command to assign additional point mass to a point object. Note
that the additional point mass is only considered by the program
if you have specified that the mass source is to be based on ele-
ment masses and additional masses, not from a specified load
combination. See the section entitled "Mass Source Command"
in Chapter 7 Define Menu for more information.

Clicking the Assign menu > Joint/Point > Additional Point
Mass command or the  button brings up the Assign Masses

form. Following are descriptions of the three areas in this form.

 Masses in Global Directions: Specify the translational masses
in the global coordinate system direction in this area. The
masses are entered in Force-Second2/Length units.

 Mom. of Inertia in Global Directions: Specify the rotational
mass moments of inertia about the global axes in this area. The
rotational mass moments of inertia are entered in Force-
Length-Second2 units. Figure 10-3 is provided to assist you in
calculating rotational mass moments of inertia for various
shaped areas.
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Shape in
plan

Mass moment of inertia about vertical axis
(normal to paper) through center of mass

Formula

b

d
c.m.

Rectangular diaphragm:
Uniformly distributed mass per unit area
Total mass of diaphragm = M (or W/g)

MMICM =
M(b2 + d2)

12

Triangular diaphragm:
Uniformly distributed mass per unit area
Total mass of diaphragm = M (or W/g)

Use general
diaphragm formula

c.m.

d

Y

X

Y

X

Y

X

Y

X

c.m.

c.m.

Circular diaphragm:
Uniformly distributed mass per unit area
Total mass of diaphragm = M (or W/g)

MMICM =
Md2

8

MMICM =
M(IX + IY)

A

General diaphragm:
Uniformly distributed mass per unit area
Total mass of diaphragm = M (or W/g)

Area of diaphragm = A
Moment of inertia of area about X-X = IX
Moment of inertia of area about Y-Y = IY

Line mass:
Uniformly distributed mass per unit length

Total mass of line = M (or W/g)
MMICM =

Md2

12

Axis transformation for a mass:
If mass is a point mass, MMIO = 0

MMICM = MMIO + MD2

d
c.m.

c.m.

OD

Figure 10-3:
Mass moment of inertia for various areas
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 Options: The following three assignment options are avail-
able:

 Add to Existing Masses: Adds the specified mass to the
point object. If one or more mass assignments have already
been made, this option increases the existing mass, as-
suming that you are specifying a positive mass.

 Replace Existing Masses: Replaces the currently speci-
fied mass, if any, with the new mass assignment. If there is
not an existing assignment, the new assignment is still
made. This is the default option.

 Delete existing masses: Deletes any and all mass assign-
ments made to the selected point object(s).

Note that if you select the Include only Lateral Mass option
when defining the mass source (you do this on the Define Mass
form, which is accessed using the Define menu > Mass Source
command), only the Direction X mass, Direction Y mass and
the Rotation about Z moment of inertia are considered in the
analysis.

Important Note: It is possible to assign negative mass to a point
object as long as the total mass tributary to the point object still
remains positive (or is zero). If you decide to assign some nega-
tive mass to a point object, do it with great care because it can
terminate your analysis. If the program detects negative mass at
a point during the analysis, it will terminate the analysis and pro-
vide an error message about negative mass. The program does
not check for negative mass before running the analysis.

Frame/Line Commands
Use the Assign menu > Frame/Line command to make assign-
ments to line objects. The following subsections describe the as-
signments that you can make to line objects.
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Frame/Line > Frame Section Command
Use the Assign menu > Frame/Line > Frame Section com-
mand or the  button to open the Assign Frame Properties

form and assign frame section properties to line objects. To use
this command, select some line objects, then click the menu
command to open the Assign Frame Properties form, highlight a
frame section in the Properties area of the form and click the OK
button to make the assignment.

The frame section property that you highlight in the Properties
area can be a previously defined property or you can define it
while you are in the Assign Frame Properties form. For defining
frame section properties, the Assign Frame Properties form has
all of the functionality that the Define Frame Properties form
has. See the section titled "Frame Sections Command" in Chap-
ter 7 Define Menu for more information.

Frame/Line > Frame Releases/Partial Fixity Command
You can release any of the three translational and three rotational
degrees of freedom at either end of a line object. However, those
releases are meaningful only if a frame section property is as-
signed to the line object. It is possible to specify partial fixity at
the ends of the line object. This is performed by specifying a
spring stiffness when you assign the member end release.

The releases are always specified in the line object (frame sec-
tion) local coordinate system. End releases are always assumed
to occur at the support faces; that is, at the inside end of the end
offsets.

Use the Assign menu > Frame/Line > Frame Releases/Partial
Fixity command or  button to open the Assign Frame Re-

leases form and assign frame releases to line objects. To use this
command select some line objects, then click the menu com-
mand to open the form and do one of the following:

 Specify the desired end releases by checking the appropriate
check boxes. Alternatively you can specify partial fixity by

Note:

Variable end
releases that
can supply from
0% to 100%
fixity can be
specified as
spring stiff-
nesses to model
different fixity
conditions at
the ends of
frame elements.

Shortcut:

You can use the
Assign menu >
Frame/Line >
Frame Section
command to
simultaneously
define frame
sections and
assign them to
selected line
objects.
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entering a spring stiffness value for the frame partial fixity
springs. Then click the OK button.

 If you want to remove all of the currently specified end re-
leases, including partial fixity, from a member, check the No
Releases check box at the bottom of the form and click the OK
button.

Unstable End Releases
Any combination of end releases may be specified for a frame
element, provided that the element remains stable. This ensures
that all load applied to the element is transferred to the rest of the
structure. The following sets of releases are unstable, either
alone or in combination, and are not permitted. The program
checks for these conditions when you click the OK button in the
Assign Frame Releases form, and provides a message if unstable
releases have been specified:

 Releasing Axial (U1) at both ends.

 Releasing Shear Force 2, Major (U2) at both ends.

 Releasing Shear Force 3, Minor (U3) at both ends.

 Releasing Torsion (R1) at both ends.

 Releasing Moment 22, Minor (R2) at both ends and Shear
Force 3, Minor (U3)  at either end.

 Releasing R3 (moment 33, major) at both ends and U2 (shear
force 3, major) at either end.

Frame/Line > End (Length) Offsets Command
In this program, frame section properties are assigned to line
objects. However, actual structural members have finite cross
sectional dimensions. When two members, such as a beam and
column, are connected at a point, there is some overlap of the
cross sections. In many structures, the dimensions of the mem-
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bers are large and the length of the overlap can be a significant
fraction of the total length of the frame element. The program
provides the capability of defining end offsets along the length of
frame members to account for those finite dimensions of struc-
tural elements. See the subsequent subsection entitled "End Off-
sets Along the Length of Frame Elements" for more information.

Use the Assign menu > Frame/Line > End (Length) Offsets
command or the  button to open the Frame End Length Off-

sets form where you can define the end offsets along the length
of frame elements.

Any end offset assigned to a line object is ignored unless the line
object also has a frame section assigned to it.

End (Length) Offsets
End offsets along the length of frame members are defined in the
End Offset Along Length area of the Frame End Length Offsets
form. Use the Assign menu > Frame/Line > End (Length)
Offsets command or the  button to open this form.

In the End Offset Along Length area you have the choice of
having the program determine the end offset lengths automati-
cally or specifying them yourself. You also can specify the rigid-
zone factor. Descriptions of these items follow.

Automatically Calculated End Offset Lengths
The program automatically calculates offset lengths for beam-
and column-type frame elements when the Automatic from Con-
nectivity option is selected on the Frame End Length Offsets
form. It assumes the offset length for all brace-type frame ele-
ments to be zero. (You can define your own non-zero offset
lengths for brace elements if necessary.) Also, the dimensions of
brace elements that frame into the ends of column and beam
elements are not considered when calculating the end offset di-
mension for a column or a beam.

Note:

The rigid zone
factor for end
offsets along
the length of a
frame element
only applies to
bending and
shear deforma-
tions. It does
not apply to
axial and tor-
sional defor-
mations.
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When the program automatically calculates the end offsets along
the length of a beam, it bases the end offset length at an end of
the beam on the maximum section dimensions of all columns
that connect to that end of the beam. Similarly, when the pro-
gram automatically calculates the end offsets along the length of
a column, it bases the end offset length at an end of the column
on the maximum section dimensions of all beams that connect to
that end of the column.
Note:

The program
reports output
forces at the
inside face of
end length off-
sets.
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Note the following about the program's automatically calculated
end offsets along the length of frame members:

 When more than one beam frames into a column, the program
bases the end offset in the column on the deeper beam.

 End offsets in beams are controlled by the size of the column
below. The column above is not considered.

Rigid-Zone Factor
The rigid-zone factor specifies the fraction of each end offset as-
sumed to be rigid for bending and shear deformations. When a
fraction of the end offset is specified as rigid, the outside portion
of the end offset is assumed to be rigid; that is, the portion at the
end of the frame member. By default, the program assumes the
rigid end factor to be zero; that is, the end offsets are fully flexi-
ble and they have the same frame section properties as those as-
signed to the rest of the member.

The rigid zones of the end offsets never affect axial and torsional
deformations. The full element length is always assumed to be
flexible for those deformations.

Output forces for the end of a frame member are provided at the
inside face of the end offset along the length of the member. No
output forces are produced within the end offset.



Reference Manual

10 - 20 Frame/Line Commands

10

Frame/Line > Insertion Point Command
When a line object is used to model a frame section, the line ob-
ject is assumed to be located at the centroid of the column sec-
tion and the top center of beam sections.  Thus, when line objects
(frame section) intersect in a model, it means that the centroids
of the columns and the top center points of the beams intersect.
In a real structure, this in not always the case.  For example, it is
not unusual for one or more floor beams in a building to frame
eccentrically into a column.  The program provides the capability
to define Cardinal Points at different locations on the member
and to offset the Cardinal Points, where required.

Figure 10-4 defines the Cardinal Point Options available and
Figure 10-5 shows the default Cardinal Point location assumed
by the program.

Note:

When you
specify Inser-
tion Point joint
offsets, the lo-
cal axes of the
member are
always based
on the final
position of the
member after
the end joint
offsets have
been applied.

Figure 10-4:
Cardinal Point
options
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Column Beam
Column

Beam

Plan

Cardinal Point

Cardinal Point
Figure 10-5:
Program default
Cardinal Points

Note: For doubly symmetric members such as
this one, cardinal points 5, 10, and 11 are
the same.
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7. Top left
8. Top center
9. Top right
10. Centroid
11. Shear center

2 axis

3 axis



Chapter 10 - Assign Menu

10

Frame joint offsets from Cardinal Points are defined on the
Frame Insertion Point form. Use the Assign menu >
Frame/Line > Insertion Point command to open this form. In
the Frame Joint Offsets from Cardinal Point area, specify the
global X, Y and Z joint offsets at each end point of the frame
element.

This feature is useful for modeling beams and columns when the
beams do not frame into the center of the column. Frame mem-
ber joint offsets are always fully rigid.

Figure 10-6 shows an elevation and plan view of a common
framing arrangement where the exterior beams are offset from
the column center lines to be flush with the exterior of the
Note:

The locations of
loads assigned
to the line ob-
ject are based
on the final
length and lo-
cation of the
member after
the joint offsets
have been  ap-
plied.
Frame/Line Commands 10 - 21

building. Also shown in this figure are the Cardinal Points for
each member and the offset dimensions.

Figure 10-7 shows the Frame Insertion Point forms filled in for
each member shown in Figure 10-6.

Important Note: When you specify member joint offsets, the lo-
cal axes of the member are always based on the final position of
the member after the joint offsets have been applied. Similarly,
the location of loads assigned to the line object are based on the
final length and location of the member after the joint offsets
have been applied.

Consider the example sketch shown to the left. Sketch a) shows a
plan view of a beam that has the j-end joint offset. The end joint
is offset such that the beam extends from i to j' rather than from i
to j.

Sketch b) shows the local axes for the beam when it is in its
original position without the joint offset. Sketch c) shows the lo-
cal axes for the beam when it is in its final position with the joint
offset. In sketches b) and c), the local 2-axis points upward and
thus does not show in the plan view sketches. The program bases
the local axes of the beam on those shown in sketch c).

i j

j

i j

1

3

a) Beam with Joint Offset

b) Original Position of Beam

i

j

c) Final Position of Beam
3

1
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Figure 10-6:
Elevation and plan
views of a common
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Frame/Line > Frame Output Stations Command
Frame output stations are designated locations along a frame
element. They are used as locations to report output force and
perform design and as plotting points for graphic display of force
diagrams. When force diagrams are plotted, exact forces are
plotted at each output station and then those points are connected
by straight lines.

Important note: Output stations occur at user-specified locations
and at point load locations along a beam.

Use the Assign menu > Frame/Line > Frame Output Stations
command or the  button to designate the output stations for a

frame element. Two options are available for defining output
stations for a beam on the Assign Output Station Spacing form:

B1 B2 C1
Figure 10-7:
Frame Insertion Point form
associated with Figure 10-6
Note:

When frame
output stations
are assigned to
a line object, a
text value is
displayed on
the line object.
If the text value
is reported in
parenthesis, it
is the minimum
number of out-
put stations. If
it is not, it is the
maximum
spacing be-
tween output
stations.
Frame/Line Commands 10 - 23
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 Max Station Spacing: Specifies the maximum spacing be-
tween stations along the beam. With this option, the program
will first provide an output station at each point load location.
Then it will provide an equally spaced number of stations be-
tween each adjacent pair of point loads where the spacing does
not exceed the specified maximum spacing.

Note that the output station spacing between one set of point
loads may be different than that between another set.

 Min Number Stations: Specifies the minimum number of
output stations along the beam. With this option, the program
will first equally space the specified number of stations within
the clear length of the beam. Then a station is added for each
point load that does not fall at one of the previously defined
output station locations.

The minimum allowed number of equally spaced stations is
three. This provides a station at each end of the beam and one
at the center of the clear length. If there are end offsets speci-
fied for the beam, the stations at the end of the beam occur at
the face of the end offset, not at the center of the support.

Note that the program determines the location of output stations
in a different order, depending on whether you specify a mini-
mum number of stations or a maximum spacing of stations.

By default for beams, output stations are provided at a maximum
spacing of 2 feet for English units and 0.5 meter for metric units,
and at all point load locations. By default, a minimum of three
output stations are specified for columns and braces (the two
ends and the middle).

Frame/Line > Local Axes Command
By default, the local 1-axis of a line object extends from the i-
end of the element to the j-end. The default orientation of the lo-
cal 2- and 3-axes depends on the frame-type (column, beam or
brace) and in some instances, the orientation of the frame ele-
ment itself.

Note:

Use the View
menu > Set
Building View
Options com-
mand to toggle
the display of
frame element
output stations
on and off.
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You can redefine the orientation of the local 2- and 3-axes of a
line object by rotating them about the local 1-axis. To do this,
select the line object and use the Assign menu > Frame/Line >
Local Axes command or the  button to bring up the Axis

Orientation form. There are four options in this form:

 Angle: Rotates the local 2-axis by the specified angle (in de-
grees) from its default position. When the 1-axis is pointing
towards you, a positive rotation is counterclockwise; that is,
the right hand rule applies.

 Rotate by Angle: Rotates the local 2-axis by the specified an-
gle (in degrees) from its current location (not necessarily its
default position). When the 1-axis is pointing towards you, a
positive rotation is counterclockwise; that is, the right hand
rule applies.

 Column major direction is X (or Radial): This option has no
effect unless the selected element is a column. It sets the col-
umn major direction (the local 2-axis) as follows:

 If the column is at the intersection of two global coordinate
system grid lines, the major direction (local 2-axis) is the
same as the positive global X-axis.

 If the column is at the intersection of two grid lines from
an additional rectangular coordinate system, the major di-
rection (local 2-axis) is the same as the positive X-axis of
that additional coordinate system.

 If the column is at the intersection of two grid lines from
an additional cylindrical coordinate system, the major di-
rection (local 2-axis) is in the outward radial direction of
that additional coordinate system.

 If the column is not at the intersection of two grid lines
from the same coordinate system, the major direction (lo-
cal 2-axis) is the same as the positive global X-axis.

i-end j-end

1

2

3

Positive direction
of rotation

2

3

Global X

Global Y

2

3

Global X

Global Y

2
3

Alt X

Alt Y

2
3

Radial
grid line
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R
gr
Column Major Direction

The column major direction is the same as
the local 2-axis direction (which is also the

Local 2 axis
Minor axis
Major direction

Local 3 axis
Major axis
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 Column major direction is Y (or Tangential): This option
has no effect unless the selected element is a column. It sets
the column major direction (the local 2-axis) as follows:

 If the column is at the intersection of two global coordi-
nate system grid lines, the major direction (local 2-axis) is
the same as the positive global Y-axis.

 If the column is at the intersection of two grid lines from
an additional rectangular coordinate system, the major di-
rection (local 2-axis) is the same as the positive Y-axis of
that additional coordinate system.

 If the column is at the intersection of two grid lines from
an additional cylindrical coordinate system, the major di-
rection (local 2-axis) is in the tangential direction of that
additional coordinate system pointing counterclockwise.

 If the column is not at the intersection of two grid lines
from the same coordinate system, the major direction (lo-
cal 2-axis) is the same as the positive global Y-axis.

Frame/Line > Frame Property Modifiers Command
Use the Assign menu > Frame/Line > Frame Property Modi-
fiers command to bring up the Analysis Property Modification

same as the minor axis). Loads acting in the
major direction cause M3 bending and V2
shear. In a wide flange member this corre-
sponds to bending resisted by the flanges and
shear resisted by the web.         

Minor direction
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Factors form. Here you can specify modification factors for the
following frame analysis section properties in your model.

 Cross-section (axial) area

 Shear Area in 2 direction

 Shear Area in 3 direction

 Torsional Constant

 Moment of Inertia about the 2-axis

 Moment of Inertia about the 3-axis

The modification factors are multiplied by the section properties
specified for a frame element (see the Define menu > Frame
Sections command) to obtain the final analysis section properties
used for the frame element. Note that these modification factors
only affect the analysis properties. They do not affect the design
properties.

Frame/Line > Frame Line Type Command
Use the Assign menu > Frame/Line > Frame Line Type com-
mand to assign a frame line type to the selected line object.
There are four line type options available. The selected line can
be assigned as Beam, Column, Brace or Default. If the default
option is selected, the line type will be that as defined using the
Define menu > Frame Sections command (see the section enti-
tled "Frame Sections Command" in Chapter 7 Define Menu).

Frame/Line > Link Properties Command
Use the Assign menu > Frame/Line > Link Properties com-
mand to assign link properties to a line object. Select a line ob-
ject(s) and use this command to bring up the Assign Link Prop-
erties form. On that form, highlight the name of a defined link
property and click the OK button to assign a link property to the
selected line object(s). Link properties are described in the sec-

Note:

The frame
property modi-
fiers only affect
the analysis
properties.
They do not
affect the de-
sign properties.

Note:

You can assign
multiple link
properties
(elements) to
the same line
object.
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tion entitled "Link Properties Command" in Chapter 7 Define
Menu.

If you want to remove a link property assignment from a line
object, select the line object, click the Assign menu >
Frame/Line > Link Properties command, highlight "None" in
the Link Properties area of the Assign Link Properties form, and
click the OK button.

Frame/Line > Frame NonLinear Hinges Command
Use the Assign menu > Frame/Line > Frame Nonlinear
Hinges command to bring up the Assign Frame Hinges (Push-
over) form where you can assign nonlinear frame hinges (push-
over) to line objects with frame section properties. Note that
these hinge assignments are only used for static nonlinear analy-
sis. They are not considered in a nonlinear time history analysis.
Also note that nonlinear frame hinges are defined using the De-
fine menu > Frame Nonlinear Hinge Properties command
(see Chapter 7 Define Menu).

If you have selected a single element before implementing this
command, the form shows you the currently assigned hinges, if
any. If you have selected multiple elements before implementing
this command, note the following:

 If all elements have the same hinge assignments, the form
shows you those assignments.

 If the elements do not all have the same hinge assignments, the
form is unfilled when it comes up.

A hinge assignment consists of a hinge property and a location
for that hinge along the frame element. The location is specified
as a relative distance along the clear length of the element,
measured from the i-end. The relative distance is equal to the
distance from the inside face of the end offset at the i-end of the
element to the hinge location divided by the clear length of the
frame element. Relative distances of 0, 0.5 and 1 specify hinges
at the inside face of the end offset at the i-end, center of the clear

Note:

You can assign
multiple frame
nonlinear
hinges to the
same line ob-
ject. If desired,
you can assign
multiple hinges
at the same
location. This
however may
make it difficult
for you to in-
terpret some of
the results.
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length and the inside face of the end offset at the j-end of a frame
element, respectively.

To add a hinge assignment for the selected element(s), choose
one of the defined hinge properties in the Hinge Property drop-
down box, type in a distance in the relative distance box and
click the Add button.

To modify an existing hinge assignment for the selected ele-
ment(s), highlight the assignment in the Frame Hinge Data area.
Note that the information for the highlighted assignment appears
in the drop-down box and edit box at the top of the form. Modify
the hinge property and relative distance as desired, and when
finished, click the Modify button.

To delete an existing hinge assignment for the selected ele-
ment(s), highlight the assignment in the Frame Hinge Data area.
Note that the information for the highlighted assignment appears
in the drop-down box and edit box at the top of the form. Click
the Delete button.

When you have finished specifying the hinge property assign-
ments, click the OK button to exit the form.

Frame/Line > Pier Label Command
A wall pier can consist of a combination of both area objects
(shell elements) and line objects (frame elements). If you want to
get output forces reported for wall piers, or if you want to design
wall piers, you must first define them. You define a wall pier by
selecting all of the line and/or area objects that make up the pier
and assigning them the same pier label.

If a wall pier is made up of both line and area objects, assign the
pier label to the line and area objects separately. For example,
assume that a wall pier that is to be labeled P23 is made up of
both line and area objects. You would first select the line objects
and use the Assign menu > Frame/Line > Pier Label command
to assign pier label P23 to the line objects. Then select the area
objects and use the Assign menu > Shell/Area > Pier Label
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command to assign pier label P23 to the area objects. See the
Shear Wall Technical Notes for more information on wall pier
labeling.

Typically, to assign a new pier label to a line object, you select
the line object and click the Assign menu > Frame/Line > Pier
Label command to enter the Pier Names form. On the form,
highlight an existing pier name and click the OK button, or type
a new pier name in the edit box in the Wall Piers area, click the
Add New Name button and then click the OK button. When you
highlight an existing pier name and click the OK button, the se-
lected objects are added to the current objects that define the
pier. The selected objects do not replace the current objects.

If you want to delete objects from a pier definition, select the
objects to be deleted, enter the Pier Names form, highlight None
and click the OK button.

You can click the Assign menu > Frame/Line > Pier Label
command and enter the Pier Names form without first making a
selection if you wish (regardless of whether the model is locked
or unlocked). This is useful if you want to change a pier name or
delete a pier definition. In that case, enter the Pier Names form
without first making a selection, make the desired name changes
or deletions and then click the OK button. Because you entered
the form without first making a selection, the program knows not
to make any assignment to the highlighted pier when you click
the OK button. In the special case where you enter the form
without a selection, whatever pier is highlighted when you click
the OK button retains exactly the same definition it had before
you entered the form.

Frame/Line > Spandrel Label Command
A wall spandrel can be made up from a combination of both area
objects (shell elements) and line objects (frame elements). If you
want to get output forces reported for wall spandrels, or if you
want to design wall spandrels, you must first define them. You
define a wall spandrel by selecting all of the line and/or area ob-
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jects that make up the spandrel and assigning them the same
spandrel label.

If a wall spandrel is made up of both line and area objects, assign
the spandrel label to the line and area objects separately. For ex-
ample, assume that a wall spandrel that is to be labeled S23 is
made up of both line and area objects. First select the line objects
and use the Assign menu > Frame/Line > Spandrel Label
command to assign spandrel label S23 to the line objects. Then
select the area objects and use the Assign menu > Shell/Area >
Spandrel Label command to assign spandrel label S23 to the
area objects. See the Shear Wall Technical Notes for more in-
formation on wall spandrel labeling.

Typically, to assign a new spandrel label to a line object, select
the line object and click the Assign menu > Frame/Line >
Spandrel Label command to enter the Spandrel Names form.
On the form, highlight an existing spandrel name and click the
OK button, or type a new spandrel name in the edit box in the
Wall Spandrels area, click the Add New Name button and then
click the OK button. When you highlight an existing spandrel
name and click the OK button, the selected objects are added to
the current objects that define the spandrel. The selected objects
do not replace the current objects.

If you want to delete objects from a spandrel definition, select
the objects, enter the Spandrel Names form, highlight None and
click the OK button.

You can click the Assign menu > Frame/Line > Spandrel La-
bel command and enter the Spandrel Names form without first
making a selection if you wish (regardless of whether the model
is locked or unlocked). This is useful if you want to change a
spandrel name or delete a spandrel definition. In that case, enter
the Spandrel Names form without first making a selection, make
the desired name changes or deletions and then click the OK
button. Because you entered the form without first making a se-
lection, the program knows not to make any assignment to the
highlighted spandrel when you click the OK button. In the spe-
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cial case where you enter the form without a selection, whatever
spandrel is highlighted when you click the OK button retains ex-
actly the same definition it had before you entered the form.

Frame/Line > Line Springs Command
Use the Assign menu > Frame/Line > Line Springs command
or the  button to bring up the Assign Spring form where you

can assign line springs to line objects. Line springs can be as-
signed in any of the local axes directions of the line object. Line
springs are linear; that is, they support both tension and com-
pression. You cannot define tension-only or compression-only
line springs.

The program distributes the springs associated with the line ob-
ject to all of the nodes associated with the internal-to-the-
program (analysis model) representation of the line object. Note
that internally, the program may mesh (break up) a line object
into several elements with associated points between each ele-
ment.

If you are modeling a beam on elastic foundation with a line
spring, you may want to mesh the line object yourself to ensure
that internally in the program a sufficient number of springs are
used in the analysis model. The program will automatically de-
termine the required stiffness for each spring. This saves you a
considerable amount of time when the points where the springs
actually occur are not uniformly spaced.

There are two areas in the Assign Spring form. They are:

 Line spring: Specifies the direction of the springs as one of
the three local axes of the line object and specifies a stiffness
for the spring. The units for the stiffness are Force/Length2.

 Options: Three line spring assignment options are possible:

 Add to Existing Springs: Adds the specified spring stiff-
ness to the line object. If one or more spring stiffness as-
signments have already been made, this option increases

Tip:

The program
distributes the
springs associ-
ated with the
line object to
all of the nodes
associated with
the internal-to-
the-program
(analysis
model) repre-
sentation of the
line object. If
you are mod-
eling a beam on
elastic founda-
tion with a line
spring, you may
want to mesh
the line object
yourself to en-
sure that  a
sufficient num-
ber of springs
are used in the
analysis model.
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the existing spring stiffness, assuming that you specify a
positive stiffness.

 Replace Existing Springs: Replaces the currently speci-
fied spring stiffness, if any, with the new spring stiffness.
If there is not an existing assignment, the new assignment
is still made. This is the default option.

 Delete Existing Springs: Deletes any and all spring stiff-
ness assignments made to the selected line object(s). When
this option is selected, the items in the Line Spring area of
the form are ignored when you click the OK button.

Note that the default option is Replace and that the pro-
gram defaults to this every time the form is opened.

Important Note: It is possible to assign negative spring stiffness
to a line object as long as the total stiffness at any point still re-
mains positive (or zero). If you decide to assign some negative
spring stiffness to a line object, do it with great care because it
can terminate your analysis. If negative spring stiffness occurs at
any point in your model during the analysis, the program termi-
nates the analysis and provides an error message that there is an
instability. The program does not check for negative spring stiff-
ness before running the analysis.

Frame/Line > Additional Line Mass Command
Use the Assign menu > Frame/Line > Additional Line Mass
command or the  button to assign additional line mass to a

line object. Note that the additional line mass is only considered
by the program if you have specified that the mass source is to
be based on element masses and additional masses, not from a
specified load combination. See the section entitled "Mass
Source Command" in Chapter 7 Define Menu for more informa-
tion.

The additional line mass is only applied in the three translational
degrees of freedom. If you have specified that only lateral mass
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is to be considered (see the section entitled "Mass Source Com-
mand" in Chapter 7 Define Menu), the additional line mass is
only active in the global X and Y directions.

Clicking the Assign menu > Frame/Line > Additional Line
Mass command or the  button brings up the Assign Mass

form. Following are descriptions of the two areas in that form.

 Line Mass/Length: Specifies the translational mass per unit
length in this area. The masses are entered in Force-
Second2/Length2 units.

 Options: Three line mass assignment options are possible:

 Add to Existing Masses: Adds the specified line mass to
the line object. If one or more line mass assignments have
already been made, this option increases the existing line
Tip:

Additional line
mass is only
considered by
the program if
the mass is
specified to be
determined
from material
property
masses. Addi-
tional line mass
is ignored if the
mass is deter-
mined from a
load combina-
tion.
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mass, assuming that you are specifying a positive mass.

 Replace Existing Masses: Replaces the currently speci-
fied line mass, if any, with the new line mass. If there is
not an existing assignment, the new assignment is still
made. This is the default option.

 Delete Existing Masses: Deletes any and all line mass as-
signments made to the selected line object(s).

Note that the default option is Replace and that the program
defaults to this every time the form is opened.

Frame/Line > Automatic Frame Subdivide Command
The program automatically subdivides frame elements as neces-
sary in the analysis. In some cases, you may not want the pro-
gram to automatically subdivide a frame element.

For example, when you have intersecting X-braces, the program
would, by default, connect those braces at their intersection and
divide each brace element into two pieces at the intersection
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point. You may want to model it such that there is no connection
between the braces where they cross.

In such a case, you can select the braces and use the Assign
menu > Frame/Line > Automatic Frame Subdivide command
to tell the program not to automatically subdivide them. You can
also use this command again if you later decide that you want the
program to automatically subdivide the braces. When you exe-
cute this command, you have three options:

 Subdivide: This tags the frame element to be automatically
subdivide, as required, by the program. By default, all line ob-
jects have this tag when they are drawn.

 Don't Subdivide: This tags the frame element to not be auto-
matically subdivide by the program.

 Cancel: This gives you a way to get out of the command with-
out assigning a "subdivide it" or a "don't subdivide it" tag to
the frame element.

Frame Line > Use Lines for Floor Meshing
The program automatically meshes area objects that are assigned
deck properties or slab properties with membrane behavior only
into the analysis model as necessary. There are several options
available for auto meshing the area objects. One of those options
is to mesh the area objects that are intersected by meshing lines
or line objects with auto meshing option set to yes. In some
cases, you may not want the program to automatically mesh an
area object into the analysis model.

To tag a line object so that it is not used for auto meshing of area
objects, select the line object and click the Assign menu >
Frame/Line > Use Line for Floor Meshing > No command.
You can also use this command again if you later decide that you
want the program to use this line object to automatically mesh
the area objects. When you execute this command, you have
three options:
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 Yes: This tags the line object to be used for automatic meshing
of area objects intersected by the line object, as required, by
the program into the analysis model. By default, all line ob-
jects have this tag when they are created.

 Don't mesh it: This tags the line object so that it is not used
for the automatic meshing of area objects intersected by the
line object in program analysis model.

 Cancel: This gives you a way to get out of the command with-
out assigning one of the above options.

Shell/Area Commands
Use the Assign menu > Shell/Area command to make assign-
ments to area objects. The following subsections describe the as-
signments that you can make to area objects.

Shell/Area > Wall/Slab/Deck Section Command
Use the Assign menu > Shell/Area > Wall/Slab/Deck Section
command or the  button to open the Assign Wall/Slab/Deck

Sections form and assign section properties to area objects. To
use this command, select some area objects, then click the menu
command or the  button to open the form, highlight a wall,

slab or deck section name in the Sections area of the form and
click the OK button to make the assignment.

The wall, slab or deck section property that you highlight in the
Sections area can either be a previously defined property (see
Chapter 7 Define Menu) or you can define it while you are in
this form. For defining wall, slab and deck section properties, the
Wall/Slab/Deck Sections form has the same functionality as that
Shortcut:

You can use the
Assign menu >
Shell/Area >
Wall/Slab/Deck
Section com-
mand to simul-
taneously de-
fine wall, slab
and deck sec-
tions and as-
sign them to
selected area
objects.
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of the Define Wall/Slab/Deck Sections form. See the section en-
titled "Wall/Slab/Deck Section Command" in Chapter 7 Define
Menu for more information.
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Important note concerning decks: When you assign deck sec-
tion properties, the program assumes that the deck spans in the
same direction as the local 1-axis of the area object to which the
deck is assigned.

Shell/Area > Opening Command
Use the Assign menu > Shell/Area > Opening command or the

 button to bring up the Assign Openings form and designate a

selected area object as an opening. In the Assign openings form,
indicate that the area object is one of the following:

 Not an Opening: Use this to remove the designation of
“opening” from an area object.

 UnLoaded Opening: Any loads applied to (or on) an un-
loaded-type opening are ignored by the program.

 Loaded Opening: The program considers all loads that are as-
signed to loaded-type openings.

The main purpose of designating area objects as openings is re-
lated to meshing. Both the automatic meshing of floors per-
formed by the program and some of the manual meshing that
you can do are based on openings.

A second purpose of designating area objects as openings is to
allow area loads that are not directly supported by the structure
to still be considered in an analysis. For example, if you are
modeling a stair opening in a floor, you may want to consider the
opening area as supporting some uniform dead and live load.

Shell/Area > Rigid Diaphragm Command
Use the Assign menu > Shell/Area > Rigid Diaphragm com-
mand or the  button to designate a rigid diaphragm. Rigid

diaphragms can only be horizontal. Thus, rigid diaphragm as-
signments are not applicable to wall-type and ramp-type area

Tip:

You can assign
unloaded
openings to
area objects as
you draw them
by selecting the
Openings op-
tion in the
floating Prop-
erties of Object
form (see
Chapter 8
Draw Menue
for more infor-
mation).
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objects. They are only applicable to floor type area objects and to
null-type area objects that happen to be in a horizontal plane.

In this program, a rigid diaphragm translates within its own
plane (global X-Y plane) and rotates about an axis perpendicular
to its own plane (global Z-axis) as a rigid body. Designating an
area object as a rigid diaphragm has no affect on the out-of-plane
behavior of the area object. For example, if you specify a con-
crete floor slab to have plate-bending properties (i.e., out-of-
plane bending capability), applying a rigid diaphragm constraint
has no affect on the out-of-plane bending of the floor. It only ef-
fects in plane behavior of the floor.

Internal to this program, assigning a rigid diaphragm to an area
object provides a diaphragm constraint to all of the corner points
of the area object and to any additional point objects that are en-
closed within the boundaries of the area object. This includes
any points (joints) that are created as a result of the program's
automatically meshing the area object.

When you select one or more area objects and click the Assign
menu > Shell/Area > Rigid Diaphragm command or the 

button, the Assign Diaphragms form appears. Refer to the sub-
section entitled "Joint Point > Rigid Diaphragm Command" ear-
lier in this chapter for a full description of this form.

Note that you can also apply a rigid diaphragm constraint di-
rectly to point objects. In most instances, it is better to assign the
rigid diaphragm to an area object.

Shell/Area > Local Axes Command
By default, the local 3-axis of an area object is perpendicular to
the plane of the area object. The local 1- and 2-axes lie in the
plane of the object. The orientation of the 1- and 2-axes and the
positive direction of the 3-axis depend on the type (orientation)
of the area object.

Tip:

You can also
assign rigid
diaphragms to
point objects
using the As-
sign menu >
Joint/Area >
Rigid Point
command.

Note:

You can model
the "actual" in-
plane stiffness
of a diaphragm
by assigning
slab properties
to the floor and
not specifying it
as a rigid dia-
phragm. This is
sometimes (and
perhaps some-
what inappro-
priately) called
a “flexible”
diaphragm
analysis.
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You can rotate the area object local 1- and 2-axes about the local
3-axis. To do this, select an area object and use the Assign menu
> Shell/Area > Local Axes command or the  button to bring

up the Assign Local Axis form. In this form, specify in degrees
the angle from the default location of the local 2-axis (not neces-
sarily the current location) to the new location of the local 2-axis.
The angle is positive if it is counterclockwise when viewed from
the positive local 3-axis side of the object.

Important Note: Do not confuse the local axes of area objects
with those of pier and spandrel elements. They are different. You
cannot rotate the local axes of pier and spandrel elements.

Shell/Area > Shell Stiffness Modifiers Command
Use the Assign menu > Shell/Area > Shell Stiffness Modifiers
command to bring up the Analysis Stiffness Modification Fac-
tors form. Here you can specify Stiffness Modifiers for the fol-
lowing shell analysis section stiffnesses in your model.

 Membrane f11 Modifier

 Membrane f22 Modifier

 Membrane f12 Modifier

 Bending m11 Modifier

 Bending m22 Modifier

 Bending m12 Modifier

The stiffnesses for each of the items calculated based on the sec-
tion properties specified for a shell element (see the Define
menu > Wall/Slab/Deck Sections command) are multiplied by
the specified modifiers to obtain the final stiffness used for the
shell element in the analysis. Note that these modification factors
only affect the analysis properties. They do not affect any design
properties.

1 (Original)

1 (
Ne

w)

Positive
angle

2 (New)

2 
(O

rig
in

al
)

Note:

The shell stiff-
ness modifiers
only affect the
analysis prop-
erties. They do
not affect any
design proper-
ties.
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The f11, f22 and f12 modifiers are essentially equivalent to
modification factors on the thickness of the shell element. The
m11, m22 and m12 modifiers are essentially equivalent to modi-
fication factors on the thickness3 of the shell element.

Shell/Area > Pier Label Command
A wall pier can consist of a combination of both area objects
(shell elements) and line objects (frame elements). If you want to
get output forces reported for wall piers, or if you want to design
wall piers, you must first define them. Define a wall pier by se-
lecting all of the line and/or area objects that make up the pier
and assigning them the same pier label.

If a wall pier is made up of both line and area objects, assign the
pier label to the line and area objects separately. For example,
assume that a wall pier that is to be labeled P23 is made up of
both line and area objects. First select the line objects and use the
Assign menu > Frame/Line > Pier Label command to assign
pier label P23 to the line objects. Then select the area objects and
use the Assign menu > Shell/Area > Pier Label command or

 button to assign pier label P23 to the area objects. See the

Shear Wall Technical Notes for more information on wall pier
labeling.

Typically to assign a new pier label to an area object, select the
area object and click the Assign menu > Shell/Area > Pier La-
bel command or the  button to enter the Pier Names form. On

the form, highlight an existing pier name and click the OK but-
ton or type a new pier name in the edit box in the Wall Piers
area, click the Add New Name button and then click the OK
button. When you highlight an existing pier name and click the
OK button, the selected objects are added to the current objects
that define the pier. The selected objects do not replace the cur-
rent objects.

If you want to delete objects from a pier definition, select the
objects, enter the Pier Names form, highlight None, and click the
OK button.
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Shell/Area > Spandrel Label Command
A wall spandrel can consist of a combination of both area objects
(shell elements) and line objects (frame elements). If you want to
get output forces reported for wall spandrels, or if you want to
design wall spandrels, you must first define them. Define a wall
spandrel by selecting all of the line and/or area objects that make
up the spandrel and assigning them the same spandrel label.

If a wall spandrel is made up of both line and area objects, assign
the spandrel label to the line and area objects separately. For ex-
ample, assume that a wall spandrel that is to be labeled S23 is
made up of both line and area objects. First select the line objects
and use the Assign menu > Frame/Line > Spandrel Label
command to assign spandrel label S23 to the line objects. Then
select the area objects and use the Assign menu > Shell/Area >
Spandrel Label command or the  button to assign spandrel

label S23 to the area objects. See the Shear Wall Technical Notes
for more information on wall spandrel labeling.

To assign a new spandrel label to an area object, select the area
object and click the Assign menu > Shell/Area > Spandrel La-
bel command  or the  button to enter the Spandrel Names

form. In this form, highlight an existing spandrel name and click
the OK button or type a new spandrel name in the edit box in the
Wall Spandrels area, click the Add New Name button and then
click the OK button. When you highlight an existing spandrel
name and click the OK button, the selected objects are added to
the current objects that define the spandrel. The selected objects
do not replace the current objects.

If you want to delete objects from a spandrel definition, select
the objects, enter the Spandrel Names form, highlight None, and
click the OK button.

Shell/Area > Area Springs Command
Use the Assign menu > Shell/Area > Area Springs command
of the  button to bring up the Assign Spring form where you
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can assign area springs to area objects. Area springs can be as-
signed in any of the local axes directions of the area object. Area
springs are linear; that is, they support both tension and com-
pression. You can not define tension-only or compression-only
area springs.

The program distributes the springs associated with the area ob-
ject to all of the nodes associated with the internal-to-the-
program (analysis model) representation of the area object. Note
that in some cases, internally the program may mesh (break up)
an area object into several elements with associated points be-
tween each element.

If you are modeling a slab or mat on an elastic foundation with
area springs, you probably will want to mesh the area object
yourself to ensure that internal to the program a sufficient num-
ber of springs are used in the analysis model. The program will
automatically determine the required stiffness for each spring.
This saves you a considerable amount of time when the points
where the springs actually occur are not uniformly spaced.

There are two areas in the Assign Spring form. They are:

 Area Spring: Specifies the direction of the springs as one of
the three local axes of the area object, and specifies a stiffness
for the spring. The units for the stiffness are Force/Length3.

 Options: Three area spring assignment options are possible:

 Add to Existing Springs: Adds the specified spring stiff-
ness to the area object. If one or more spring stiffness as-
signments have already been made, this option increases
the existing spring stiffness, assuming that you are speci-
fying a positive stiffness.

 Replace Existing Springs: Replaces the currently speci-
fied spring stiffness, if any, with the new spring stiffness.
If there is not an existing assignment, the new assignment
is still made. This is the default option.

Tip:

The program
distributes the
springs associ-
ated with the
area object to
all of the nodes
associated with
the internal-to-
ETABS (analy-
sis model) rep-
resentation of
the area object.
If you are mod-
eling a slab or
mat on an elas-
tic foundation
with area
springs you
may want to
mesh the area
object yourself
to assure that
internally in
ETABS a suffi-
cient number of
springs are
used in the
analysis model.
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 Delete Existing Springs: Deletes any and all spring stiff-
ness assignments made to the selected area object(s).
When this option is selected, the Value item in the Area
Spring area of the form is ignored when you click the OK
button.

Note that the default option is Replace and that the program de-
faults to this every time the form is opened.

Important Note: It is possible to assign negative spring stiffness
to an area object as long as the total stiffness at any point still
remains positive (or zero). If you decide to assign some negative
spring stiffness to an area object, do it with great care because it
can terminate your analysis. If negative spring stiffness occurs at
any point in your model during the analysis, the program termi-
nates the analysis and provides an error message that there is an
instability. The program does not check for negative spring stiff-
ness before running the analysis.

Shell/Area > Additional Area Mass Command
Use the Assign menu > Shell/Area > Additional Area Mass
command or the  button to assign additional area mass to an

area object. Note that the additional area mass is only considered
by the program if you have specified that the mass source is to
be based on element masses and additional masses, not from a
specified load combination. See the section entitled "Mass
Source Command" in Chapter 7 for more information.

The additional area mass is only applied in the three translational
degrees of freedom. If you have specified that only lateral mass
is to be considered (see the section entitled "Mass Source Com-
mand" in Chapter 7), the additional area mass is only active in
the global X and Y directions.
Tip:

Additional area
mass is only
considered by
the program if
the mass is
specified to be
determined
from material
property
masses. Addi-
tional area
mass is ignored
if the mass is
determined
from a load
combination.
Shell/Area Commands 10 - 43

Clicking the Assign menu > Shell/Area > Additional Area
Mass command or the  button brings up the Assign Mass

form. Following are descriptions of the two areas in this form.
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 Mass/Area: Specifies the translational mass per unit area in
this region. The masses are entered in Force-Second2/Length3

units.

 Options: Three area mass assignment options are possible:

 Add to Existing Masses: Adds the specified area mass to
the area object. If one or more area mass assignments have
already been made, this option increases the existing area
mass, assuming that you are specifying a positive mass.

 Replace Existing Masses: Replaces the currently speci-
fied area mass, if any, with the new area mass. If there is
not an existing assignment, the new assignment is still
made. This is the default option.

 Delete Existing Masses: Deletes any and all area mass as-
signments made to the selected area object(s) when you
click the OK button.

Note that the default option is Replace and that the program
defaults to this every time the form is opened.

Load Commands
Use the Assign menu commands to make load assignments to
point, line, and area objects. The following subsections describe
the assignments that you can make to those objects.

Joint/Point Loads > Force Command
Use the Assign menu > Joint/Point Loads > Force command
or the  button to bring up the Point Forces form and assign

point loads to selected point objects. Note that the point loads are
specified in global coordinate system directions.

Assigning a force or moment to a point object is only meaningful
if the point object is in one of the following locations:
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 At the ends of structural line objects (beam, column, brace,
link).

 At the corner points of structural area objects (floor, ramp,
wall).

 Anywhere in the plane of a structural area object (floor, ramp,
and wall). Note that in some cases, ramps may be slightly
warped (four corners not coplanar) and thus it is difficult to
impossible to tell if a point object actually lies in the plane of a
ramp. Thus you should take great care in applying loads to
point objects that are in the plane of ramps. We do not in gen-
eral recommend that you apply point loads to ramps.

 Anywhere along the length of the line object with frame sec-
tion properties (beam, column, and brace), unless the line ob-
ject is tagged to not be automatically meshed. Note that the
point object must lie exactly on the line object. We do not rec-
ommend that you attempt to apply point loads to frame ele-
ments in this manner. Instead, use the Assign menu >
Frame/Line Loads > Point command to apply the point
loads.

The following bullet items discuss three areas on the Point
Forces form:

 Load Case Name: Select the name of a defined static load
case that the specified loads are to be assigned to. Note that
you use the Define menu > Static Load Cases command to
define load case names.

 Loads: Input the point loads in the global coordinate system
directions in this area. Positive directions of moments (shown
in the sketch to the left) are based on the right hand rule.

 Options: The following three assignment options are avail-
able:

 Add to Existing Loads: Adds the specified point loads to
the point object. If one or more point load assignments

Z

X

Y
+MZZ +MYY

+MXX



Reference Manual

10 - 46 Load Commands

10

have already been made, this option increases the total
point load on the point object, assuming that you are speci-
fying a positive load.

 Replace Existing Load: Replaces the currently specified
point load, if any, with the new point load assignment. If
there is not an existing assignment, the new assignment is
still made. This is the default option. Note that only the
loads in the load case that is specified above are replaced.

 Delete existing loads: Deletes any and all point load as-
signments made to the selected point object(s). Note that
only the loads in the load case that is specified above are
deleted.

Joint/Point Loads > Ground Displacement Command
Use the Assign menu > Joint/Point Loads > Ground Dis-
placement command to bring up the Ground Displacements
form and assign ground displacement loads to selected point ob-
jects. Note that the ground displacements are specified in global
coordinate system directions. Please read the Important Informa-
tion About Ground Displacement Assignments provided in the
shadow box carefully.

The following bullet items describe three areas on the Ground
Displacements form:

 Load Case Name: Select the name of a defined static load
case that the specified displacements are to be assigned to.
Note that you use the Define menu > Static Load Cases
command to define load case names.

 Displacements: Input the displacements in the global coordi-
nate system directions in this area. Positive directions of rota-
tions (shown in the sketch to the left) are based on the right-
hand rule.

 Options: The following three assignment options are avail-
able:

Z

X

Y
+RZZ +RYY

+RXX
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 Add to existing loads: Adds the specified displacements
to the point object. If one or more displacement assign-
ments have already been made then this option increases
the total displacement assigned to the point object assum-
ing, of course, you are specifying a positive displacement.

 Replace existing load: Replaces the currently specified
displacement, if any, with the new displacement assign-
ment. If there is not an existing assignment then the new
assignment is still made. This is the default option. Note
that only the loads in the load case that is specified above
are replaced.

 Delete existing loads: Deletes any and all displacement
assignments made to the selected point object(s). When
this option is selected the items in the Loads area of the
form are ignored when you click the OK button. Note that

Important Information about Ground Displacement Assignments

Point object ground displacements are only meaningful when they are applied to point
objects that are connected to the ground in the direction that the displacement is ap-
plied. Point objects are connected to the ground through one of the following:

 Restraints
 Springs
 Grounded link elements assigned to a single point object

When ground displacements are assigned to a point object that is restrained, the dis-
placement takes place at the point object.

When ground displacements are assigned to point objects that have springs or
grounded link elements assigned to them, the displacement takes place at the
grounded end of the spring or link, not at the point object. This is a subtle but very
important distinction.

If you apply a ground displacement to a point object that is not connected to the
ground through a restraint, spring or grounded link element, that displacement is ig-
nored by the program when the analysis is run.
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only the loads in the load case that is specified above are
deleted.

Note that the default option is Replace and that the pro-
gram defaults to this every time the form is opened.

Joint/Point Loads > Temperature Command
Use the Assign menu > Joint/Point Loads > Temperature
command or the  button to bring up the Point Temperatures
form and assign a point temperature change to selected point
objects. This temperature change in itself is not a temperature
load.

Temperature loads actually act on area and line objects (shell and
frame elements). One of the options available when you specify
a temperature load on an area object (shell element) is that the
value of the temperature load (change) is determined from previ-
ously specified point temperature changes at the points at the
corners of the element. Similarly, one of the options available
when you specify a temperature load on a line object (frame
element) is that the value of the temperature load (change) is
determined from previously specified point temperature changes
at the points at the ends of the element.

Thus, the purpose of applying temperature changes to point ob-
jects is to allow you to specify that temperature changes in area
and/or line objects (shell and/or frame elements) are to be deter-
mined from the temperature changes specified at the corner or
end points of the elements. When you apply a temperature
change directly to a shell or frame element, that temperature
change is uniform throughout the element. Applying the tem-
perature change based on the points allows you to have tem-
perature changes that vary linearly along the length of frame
elements and vary linearly over the surface area of shell ele-
ments. A positive temperature change corresponds to an increase
in the temperature of an object.

Note:

The purpose of
applying tem-
perature
changes to
point objects is
to allow you to
specify that
temperature
changes in area
and/or line ob-
jects (shell
and/or frame
elements) are to
be determined
from the tem-
perature
changes speci-
fied at the cor-
ner or end
points of the
elements.
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The following bullet items describe three areas in the Point
Temperatures form:

 Load Case Name: Select the name of a defined static load
case that the specified temperature changes are to be assigned
to. Note that you use the Define menu > Static Load Cases
command to define load case names.

 Temperature: Specify the temperature change in this area. If
you are working in English units, the temperature is specified
in degrees Fahrenheit, °F. If you are working in metric units,
the temperature is specified in degrees centigrade, °C.

 Options: The following three assignment options are avail-
able:

 Add to Existing Values: Adds the specified temperature
changes to the point object. If one or more temperature
change assignments have already been made, this option
increases the total temperature change on the point object,
assuming that you are specifying a positive temperature
change.

 Replace Existing Values: Replaces the currently specified
temperature change, if any, with the new temperature
change assignment. If there is not an existing assignment,
the new assignment is still made. This is the default option.
Note that only the loads in the load case that is specified
on this form are replaced.

Delete existing loads: Deletes any and all temperature change
assignments made to the selected point object(s).

Frame/Line Loads > Point Command
Use the Assign menu > Frame/Line Loads > Point command
or the  button to bring up the Frame Point Loads form and as-

sign point loads to selected line objects. The following bullet
items describe the four areas on the Frame Point Loads form:
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 Load Case Name: Select the name of a defined static load
case that the specified point loads are to be assigned to. Note
that you use the Define menu > Static Load Cases command
to define load case names (see Chapter 7 Define Menu).

 Load Type and Direction: Specifies loads as Forces or Mo-
ments. Also specifies the direction of the load. The following
directions are possible:

 Local-1

 Local-2

 Local-3

 Global-X

 Global-Y

 Gravity

Note that the Gravity direction is downward in the negative
global Z direction. Defining the direction as Gravity rather
than Global-Z allows you to put in your gravity loads with
positive signs (or more likely, no sign) rather than negative
signs.

 Point Loads: Here you can specify up to four point loads act-
ing on the line object (frame element) by indicating a location
and a load for the point load. The data for the first point load is
input in the first set of Distance and Load boxes (see sketch to
the left), the data for the second point load is entered in the
second set of Distance and Load boxes, and so on.

The Distance to the point load is always measured from the i-
end of the line object. You have the option to specify Relative
Distance from End-I or Absolute Distance from End-I. The
relative distance is equal to the distance from the left end of
the line object to the point where the load intensity is specified
divided by the length of the line object. The relative distance is
never larger than 1.0. An absolute distance is the actual dis-

Data for point load 1

Note:

The positive
directions for
point moments
are determined
using the right
hand rule. Note
that the positive
direction for
the moment in
the gravity di-
rection is de-
termined by
pointing your
right thumb in
the Gravity
(negative
global Z) di-
rection and
applying the
right hand rule.
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tance from the left end of the line object to the point where the
load intensity is specified.

If you want to specify more than four point loads, simply
specify the first four point loads and click the OK button to as-
sign them, then reselect the line object and click the Assign
menu > Frame/Line Loads > Point command or the 

button to again bring up the Frame Point Loads form and
specify additional point loads.

 Options: The following three assignment options are avail-
able:

 Add to Existing Loads: Adds the specified point loads to
the line object. If one or more point load assignments have
already been made at the same location on the line object,
this option increases the total point load on the line object
at that location, assuming that you are specifying a positive
load.

 Replace Existing Loads: Replaces the currently specified
point load, if any, with the new point load assignment. If
there is not an existing assignment, the new assignment is
still made. This is the default option. Note that only the
loads in the load case that is specified above are replaced.

 Delete Existing Loads: Deletes any and all point load as-
signments made to the selected line object(s). When this
option is selected, the items in the Point Loads areas of the
form are ignored when you click the OK button. Note that
only the loads in the load case that is specified in this form
are deleted.

Note that the default option is Replace and that the program
defaults to this every time the form is opened.

Frame/Line Loads > Distributed Command
Use the Assign menu > Frame/Line Loads > Distributed
command or the  button to bring up the Frame Distributed
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Loads form and assign distributed loads to selected line objects.
The distributed loads may be specified as uniform over the
length of the line object or they may be specified as trapezoidal
loads over any length of the line object. The following bullet
items describe the four areas in the Frame Distributed Loads
form:

 Load Case Name: Select the name of a defined static load
case that the specified distributed load is to be assigned to.
Note that you use the Define menu > Static Load Cases
command to define load case names (see Chapter 7 Define
Menu).

 Load Type and Direction: Specifies whether the loads are
Forces (line loads) or Moments (line moments). Also specifies
the direction of the load. The following directions are possible:

 Local-1

 Local-2

 Local-3

 Global-X

 Global-Y

 Gravity

 Global-X Projection (only applicable to forces, not mo-
ments)

 Global-Y Projection (only applicable to forces, not mo-
ments)

 Gravity Projection (only applicable to forces, not mo-
ments)

Note that the Gravity direction is downward in the negative
global Z direction. Defining the direction as Gravity rather
than Global-Z allows you to put in your gravity loads with

Note:

Distributed
loads can be
uniform or non-
uniform (trape-
zoidal) and they
can be full
length or par-
tial length.

Note:

Only forces can
be specified as
projected loads,
not moments.

Note:

The Gravity
direction for
loads is down-
ward in the
negative global
Z direction
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positive signs (or more likely, no sign) rather than negative
signs.

Also note that only forces can be specified as projected loads,
not moments. Figure 10-8 shows an example of how the pro-
gram considers projected loads on line objects. Figure 10-8a
illustrates a projected uniform distributed load of intensity w.
The direction of the load is the program gravity projection di-
rection. Note that this is equivalent to a force of w(cosθ) acting
along the entire length of the line object in the gravity direc-
tion, as shown in Figure 10-8b.

 Trapezoidal Loads: Specifies non-uniform distributed loads
acting on a line object. The distributed loads can be specified
over the full length of the line object or just over part of the
length. Distributed load that you specify in this area, if any, is
additive with that specified in the Uniform Load area.

The loaded length for a trapezoidal load may be specified us-
ing Relative Distance from End-I or Absolute Distances from
End-I. A relative distance is equal to the distance from the left
end of the line object to the point where the load intensity is
specified divided by the length of the line object. The relative
distance is never larger than 1.0. An absolute distance is the
actual distance from the left end of the line object to the point
where the load intensity is specified.

Figure 10-8:
Uniform load ,w,
acting on a line ob-
ject in the Gravity
projection direction

X

Z

2

1

2

1

w(cosθ)

w

a) Line load, w, applied to line object
in Gravity projection direction

b) How projected line load is
treated in ETABS

θ θ

Note:

The positive
directions for
distributed
moments are
determined
using the right
hand rule. Note
that the positive
direction for
the moment in
the gravity di-
rection is de-
termined by
pointing your
right thumb in
the Gravity
(negative
global Z) di-
rection and
applying the
right hand rule.
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Trapezoidal loads are defined by specifying up to four sets of
distances and loads. The Distance and Load sets are specified
at locations where the rate of change of the load intensity
changes; that is, at the corners of the loading intensity diagram.
Figure 10-9 shows some examples. All of the distances shown
in Figure 10-9 are relative distances.

Specify the Distance and Load set closest to the i-end of the
line object in box 1, the next set in box 2 and so on. For any
sets of boxes that you do not use, set the distance to 0. The
program ignores any boxes where the distance is smaller than
the distance in the previous box.

Figure 10-9:
Examples of trape-
zoidal loads

Set # 1 2 3 4
Distance 0.25 0.5 0 0
Load 1 1 0 0

Set # 1 2 3 4
Distance 0 1 0 0
Load 0 1 0 0

Set # 1 2 3 4
Distance 0 0.5 1 0
Load 0 1 1 0

Set # 1 2 3 4
Distance 0 0.33 0.67 1
Load 0 1 1.25 0

Set # 1 2 3 4
Distance 0 0.5 0.5 1
Load 1 1 2 2

1

1

1

1
1.25

2
1

Note:

Input partial
length uniform
loads as trape-
zoidal loads.
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 Uniform Load: Enter a uniform load value that applies over
the entire length of the beam. Any load that is entered in this
area is additive to any load specified in the Trapezoidal Loads
area.
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 Options: The following three assignment options are avail-
able:

 Add to Existing Loads: Adds the specified point loads to
the line object. If one or more point load assignments have
already been made at the same location on the line object,
this option increases the total point load on the point object
at that location, assuming that you are specifying a positive
load.

 Replace Existing Loads: Replaces the currently specified
point load, if any, with the new point load assignment. If
there is not an existing assignment, the new assignment is
still made. This is the default option. Note that only the
loads in the load case that is specified above are replaced.

 Delete Existing Loads: Deletes any and all point load as-
signments made to the selected line object(s). When this
option is selected, the items in the Trapezoidal Loads and
the Uniform Loads areas of the form are ignored when you
click the OK button. Note that only the loads in the load
case that is specified on this form are deleted.

Note that the default option is Replace and that the program de-
faults to this every time the form is opened.

Frame/Line Loads > Temperature Command
Use the Assign menu > Frame/Line Loads > Temperature
command or the  button to bring up the Line Object Tem-

peratures form and assign temperature loads to selected line ob-
jects. Note that temperature loads may be based on a uniform
temperature change you specify for the object, or they may be
based on previously specified point object temperature changes
at the point objects at the ends of the line object, or they may be
based on a combination of both. The following bullet items de-
scribe the four areas in the Line Object Temperatures form:

Note:

In the Frame
Distributed
Loads form,
trapezoidal and
uniform load
assignments are
additive.
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 Load Case Name: Select the name of a defined static load
case that the specified line object temperature loading is to be
assigned to. Note that you use the Define menu > Static Load
Cases command to define load case names (see Chapter 7 De-
fine Menu).

 Object Temperature: Specifies the uniform temperature
change, if any, for the object. If you are basing the temperature
load for the line object on the point temperatures at the end of
the object only, enter 0 for the uniform temperature change. A
positive temperature change corresponds to an increase in the
temperature of an object.

 End Point Temperature Option: If you check the Include Ef-
fect of Point Temperatures check box in this area, the program
considers the temperature change in the line object based on
previously specified point object temperature changes at the
point objects at the ends of the line object. The program as-
sumes that the temperature change varies linearly along the
length of the line object based on the specified changes at the
end points.

Checking this box has no affect on the uniform temperature
change specified in the Object Temperature area. You can si-
multaneously specify a uniform temperature change and a
temperature change based on specified end point temperatures
if desired. Alternatively, and probably more commonly, you
can specify one type of temperature change or the other. If you
do not want to include the effect of point temperatures, leave
the box unchecked.

Note that the effect of the end point temperatures is not addi-
tive to itself. Either the end point temperatures are considered
(check box is checked) or they are not (check box is un-
checked). Thus, none of the three Object Temperature Options
assignments (add, replace, or delete; described in the next bul-
let item) have an affect on this option.

 Object Temperature Options: It is very important to note
that these options only apply to the uniform temperature

Note:

Temperature
loads may be
based on a
uniform tem-
perature
change you
specify for the
object, previ-
ously specified
point object
temperature
changes at the
point objects at
the ends of the
line object, or
a combination
of both.
Note:

When end point
temperatures
are specified to
be included in
the line object
temperature
load, the pro-
gram assumes
that the tem-
perature
change varies
linearly along
the length of the
line object
based on the
specified
changes at the
end points.
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change in the Object Temperature area of the form. The fol-
lowing three assignment options are available:

 Add to Existing Temperatures: Adds the specified uni-
form temperature change to the line object. If one or more
uniform temperature change assignments have already
been made, this option increases the total uniform tem-
perature change on the line object, assuming that you are
specifying a positive uniform temperature change.

This option has no affect on the end point temperature op-
tion. See the End Point Temperature Option bullet item for
more information.

 Replace Existing Temperature: Replaces the currently
specified uniform temperature change, if any, with the new
uniform temperature change assignment. If there is not an
existing assignment, the new assignment is still made. This
is the default option. Note that only the temperature
changes in the load case specified in this form are re-
placed.

This option has no affect on the end point temperature op-
tion. See the End Point Temperature Option bullet item for
more information.

 Delete Existing Loads: Deletes any and all uniform tem-
perature change assignments made to the selected line ob-
ject(s). Note that only the temperature changes in the load
case that is specified on this form are deleted.

This option has no affect on the end point temperature op-
tion. See the End Point Temperature Option bullet item for
more information.

Note that the default option is Replace and that the program
defaults to this every time the form is opened.
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Shell/Area Loads > Uniform Command
Use the Assign menu > Shell/Area Loads > Uniform command
to bring up the Uniform Surface Loads form and assign uniform
loads to selected area objects. The following bullet items discuss
the four areas in the Frame Distributed Loads form:

 Load Case Name: Select the name of a defined static load
case that the specified uniform surface load is to be assigned
to. Note that you use the Define menu > Static Load Cases
command to define load case names (see Chapter 7 Define
Menu).

 Uniform Load: Specifies the uniform load value and the di-
rection of the load. The following directions are possible:

 Local-1

 Local-2

 Local-3

 Global-X

 Global-Y

 Gravity

 Global-X projection

 Global-Y projection

 Gravity projection

Note that the Gravity direction is downward in the negative
global Z direction. Defining the direction as Gravity rather
than Global-Z allows you to put in your gravity loads with
positive signs (or more likely, no sign) rather than negative
signs.

Figure 10-10 shows an example of how the program considers
Note:

The Gravity
direction for
loads is down-
ward in the
negative global
Z direction
0 - 58 Load Commands

projected loads on area objects. Figure 10-10a illustrates a
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projected uniform surface load of intensity w. The direction of
the load is the program gravity projection direction. Note that
this is equivalent to a force of w(cosθ) acting over the entire
surface of the area object in the gravity direction as shown in
Figure 10-10b.

 Options: The following options are available:

 Add to Existing Loads: Adds the specified uniform load
to the area object. If one or more uniform load assignments
have already been made to the area object, this option in-
creases the total uniform load on the area object, assuming
that you are specifying a positive load.

 Replace Existing Load: Replaces the currently specified
uniform load, if any, with the new uniform load assign-
ment. If there is not an existing assignment, the new as-
signment is still made. This is the default option. Note that
only the loads in the load case that is specified in this form
are replaced.

 Delete Existing Loads: Deletes any and all uniform load
assignments made to the selected area object(s). When this
option is selected, the items in the Uniform Load area of
the form are ignored when you click the OK button. Note
that only the loads in the load case that is specified in this
form are deleted.

X

Z 3

1

w

3

1
w(cosθ)

a) Area load, w, applied to area object
in Gravity projection direction

b) How projected area load
is treated in ETABS

θ θ

Figure 10-10:
Uniform surface
load ,w, acting on an
area object in the
Gravity projection
direction
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Note that the default option is Replace and that the pro-
gram defaults to this every time the form is opened.

Shell/Area Loads > Temperature Command
Use the Assign menu > Shell/Area Loads > Temperature
command to bring up the Area Object Temperatures form and
assign temperature loads to selected area objects. Note that tem-
perature loads may be based on a uniform temperature change
you specify for the object, or they may be based on previously
specified point object temperature changes at the point objects at
the corners of the area object, or they may be based on a combi-
nation of both. The following bullet items discuss the four areas
in the Area Object Temperatures form:

 Load Case Name: Select the name of a defined static load
case that the specified area object temperature loading is to be
assigned to. Note that you use the Define menu > Static Load
Cases command to define load case names (see Chapter 7 De-
fine Menu).

 Object Temperature: Specifies the uniform temperature
change, if any, for the object. If you are basing the temperature
load for the area object on the point temperatures at the corner
points of the object only, enter 0 (zero) for the uniform tem-
perature change. A positive temperature change corresponds to
an increase in the temperature of an object.

 Corner Point Temperature Option: If you check the Include
Effect of Point Temperatures check box in this area, the pro-
gram considers the temperature change in the area object based
on previously specified point object temperature changes at the
Note:

When end point
temperatures
are specified to
be included in
the area object
temperature
load, the pro-
gram assumes
that the tem-
perature
change varies
linearly over
the surface of
the area object
based on the
specified
changes at the
corner points.
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point objects at the corners of the area object. The program as-
sumes that the temperature change varies linearly over the sur-
face of the area object based on the specified changes at the
corner points.

Checking this box has no affect on the uniform temperature
change specified in the Object Temperature area. You can si-
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multaneously specify a uniform temperature change and a
temperature change based on specified corner point tempera-
tures if desired. Alternatively, and probably more commonly,
you can specify one type of temperature change or the other. If
you do not want to include the effect of point temperatures,
leave the box unchecked.

Note that the effect of the corner point temperatures is not ad-
ditive to itself. The corner point temperatures are considered or
they are not. You control this by either checking or unchecking
the box. Thus the options in the Object Temperature Options
area (add, replace, or delete) have no affect on the option to in-
clude the effect of the point temperatures.

 Object Temperature Options: It is very important to note
that these options only apply to the uniform temperature
change in the Object Temperature area of the form. The fol-
lowing three assignment options are available:

 Add to Existing Temperatures: Adds the specified uni-
form temperature change to the area object. If one or more
uniform temperature change assignments have already
been made, this option increases the total uniform tem-
perature change on the area object, assuming that you are
specifying a positive uniform temperature change.

This option has no affect on the corner point temperature
option. See the corner Point Temperature Option bullet
item for more information.

 Replace Existing Temperature: Replaces the currently
specified uniform temperature change, if any, with the new
uniform temperature change assignment. If there is not an
existing assignment, the new assignment is still made. This
is the default option. Note that only the temperature
changes in the load case that is specified on this form are
replaced.

Note:

The three Ob-
ject Tempera-
ture Options
have no affect
on the corner
point tempera-
ture option. The
effect of the
corner point
temperatures is
not additive to
itself. Corner
point tempera-
tures are con-
sidered or they
are not.
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This option has no affect on the corner point temperature
option. See the Corner Point Temperature Option bullet
item for more information.

 Delete existing loads: Deletes any and all uniform tem-
perature change assignments made to the selected area
object(s). When this option is selected, any value input in
the Object Temperature area of the form for a uniform
temperature change is ignored when you click the OK
button. Note that only the temperature changes in the load
case that is specified in this form are deleted.

This option has no affect on the corner point temperature
option. See the corner Point Temperature Option bullet
item for more information.

Note that the default option is Replace and that the program
defaults to this every time the form is opened.

Shell/Area Loads > Wind Pressure Coefficient
The Assign menu > Shell/Area Loads > Wind Pressure Coef-
ficient command allows you to assign wind pressure coefficients
to area objects. Those coefficients are used for automatic wind
loads that have been specified to receive their loads from area
objects. A static load case with an automatic wind load must be
defined for this command to be enabled.

A positive coefficient, Cp, acts in the positive local 3-axis direc-
tion of the area object. When the Windward option is chosen, the
wind pressure on the selected area objects is assumed to vary
over the height of the building. When the Other option is chosen,
the wind pressure on the selected area objects is assumed to be
constant over the height of the building.

Group Names Command
To define a group, first select the objects that you want to be part
of the group. Then click the Assign menu > Group Names
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command or the  button to bring up the Assign Group form.

Either highlight an existing group name in the form and click the
OK button or create a new group name, click the Add New
Group button and then click the OK button. The selected ob-
jects are assigned to whatever group name is highlighted when
the OK button is clicked. Any object can be assigned to an un-
limited number of groups.

Important note: If you highlight an existing group name, the
selected objects replace rather than add to any objects that
might have previously been defined for that group.

The Groups area of the Assign Group form lists the names of all
the currently defined groups. The Click To area of the form al-
lows you to define new group names, change an existing group
name, change the display color for a group and delete an existing
group.

To add a new group name, type in the name of the group in the
Note:

If the name of
the group ap-
pearing in the
edit box in the
Groups area of
the Assign
Groups form
does not match
any of the
group names
listed in that
area, the OK
button is not
active until you
click the Add
New Group
button to add
that group
name to the list
of groups.
edit box in the Groups area and then click the Add New Group
button.

To change a group name, highlight the group name in the Groups
area. Note that the group name then appears in the edit box at the
top of the Groups area. Edit the group name as desired and then
click the Change Group Name button.

To change the display color associated with a group, highlight
the group name in the Groups area and then click the Change
Group Color button. A color box appears from which you can
select any color for the group. Note that the display color associ-
ated with a group is used as the background color in the edit box
in the Groups area of the Assign Groups form when that group
name is highlighted in the form. See the subsection entitled
"View by Colors of" in Chapter 6 View Menu for additional in-
formation.
Tip:

Assignments
made to exist-
ing groups re-
place what is in
the group. They
do not add to it.
If you want to
add to an ex-
isting group,
first select the
group, next
select the ob-
jects you want
to assign to the
group, and then
make the as-
signment.
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To delete a group, highlight the group name in the Groups area.
Note that the group name then appears in the edit box at the top
of the Groups area. Click the Delete Group button to delete the
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group. Note that the objects associated with the group are not
deleted, the group definition is the only thing that is deleted.

You can click the Assign menu > Group Names command or
the  button and enter the Assign Group form without first

making a selection if you wish (regardless of whether the model
is locked or unlocked). This is useful if you want to change a
group name, change a group color or delete a group. In those
cases, enter the Assign Groups form without first making a se-
lection, make the desired name changes, color changes or dele-
tions and then click the OK button. Because you entered the
form without a selection, the program knows not to make any
group assignment to the highlighted group when you click the
OK button. In this special case where you enter the form without
a selection, whatever group name is highlighted when you click
the OK button retains exactly the same definition it had before
you entered the form.

Clear Display of Assigns Command
When you make assignments to objects, those assignments are
then displayed on the model. For example, if you assign a frame
section property to a line object, the frame section assignments
are displayed for all line objects in the model. Sometimes you
may not want to display these assignments. You can use the As-
sign menu > Clear Display of Assigns command to remove the
displays from the active window.

Note that you can also remove the display of assignments by
clicking the Show Undeformed Shape button  or by click-

ing the Display menu > Show Undeformed Shape command.

Copy Assigns Command
The Assign menu > Copy Assigns command works in conjunc-
tion with the Assign menu > Paste Assigns command. Use the
Assign menu > Copy Assigns command to indicate which ob-
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ject you want to copy from when you use the Assign menu >
Paste Assigns command.

For example, assume that you want to copy assignments from
Line Object 1 to Line Object 2. First select Line Object 1 and
click the Assign menu > Copy Assigns command. This tells the
program that you want to copy from Line Object 1. Then select
Line Object 2 and use the Assign menu > Paste Assigns >
Frame/Line command to complete the copy.

Paste Assigns Command
The Assign menu > Paste Assigns command works in conjunc-
tion with the Assign menu > Copy Assigns command to allow
you to copy assignments from one object to another. You can
copy from and paste assignments to point objects, line objects
and area objects.

For example, assume that you want to copy assignments from
Line Object 1 to Line Object 2. First select Line Object 1 and
click the Assign menu > Copy Assigns command. This tells the
program that you want to copy from Line Object 1. Then select
Line Object 2 and use the Assign menu > Paste Assigns >
Frame/Line command.

When you click the Assign menu > Paste  Assigns >
Frame/Line command, a form listing the possible assignments
to line objects appears. Check the check boxes for the assign-
ments you want to paste and click the OK button.

If the object you are copying from has a null assignment to it,
pasting that assignment to another object will delete the assign-
ment on the other object. For example, assume you paste a point
force assignment from Point Object 1, which does not have a
point force on it, to Point Object 2, which does have a point
force on it. This will delete the point force assignment on Point
Object 1. On the other hand, if you instead paste a point force as-
signment from Point Object 2 to Point Object 1, both points will
have point force assignments.
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Chapter 11

Analyze Menu

The Analyze menu provides basic features for starting and con-
trolling your building analysis. This chapter describes the com-
mands available on the Analyze menu.

Set Analysis Options Command
Click the Analyze menu > Set Analysis Options command to
bring up the Analysis Options form where you can set various
parameters for your analysis. In this form, specify the parameters
for building active degrees of freedom, dynamic analysis and P-
Delta analysis. Each of these items is described in the subsec-
tions of this chapter.

Building Active Degrees of Freedom
The possible degrees of freedom for your building are UX, UY,
UZ, RX, RY and RZ. In the Building Active Degrees of Free-
dom area of the Analysis Options form, specify which of those
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degrees of freedom are to be active for your model. A check in
the box associated with a degree of freedom means that degree
of freedom will be active. You can check or uncheck the degree
of freedom boxes as desired.

Four special buttons are provided in this area to allow you to
quickly set the degrees of freedom for all of the typical cases that
might arise. They are:

 Full 3D: This button sets all six degrees of freedom active.
The vast majority of your building models should be run using
this option.

 XZ Plane: This button sets the UX, UZ and RY degrees of
freedom active. It is intended for two-dimensional frames that
are modeled in the global XZ plane.

 YZ Plane: This button sets the UY, UZ and RX degrees of
freedom active. It is intended for two-dimensional frames that
are modeled in the global YZ plane.

 No Z Rotation: This button sets all degrees of freedom active
except for RZ. Often, to satisfy building code requirements,
engineers run lateral force analyses of their structure with vari-
ous positive and negative eccentricities of mass (lateral load)
from the calculated center of mass of the building and with all
six degrees of freedom active. In addition, analyses are run
with the mass (lateral load) located at the calculated center of
mass of the building and the Z-rotations locked. The design is
then based on the worst case of all the analyses. This No Z

Tip:

The degree of
freedom buttons
provide a fast
and easy way to
set the building
active degrees
of freedom for
your analysis.
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Rotation feature sets the degrees of freedom of your model ap-
propriately to run an analysis with Z-rotations locked.

Set Dynamic Parameters Button
To set the dynamic analysis parameters, click the Analyze menu
> Set Analysis Options command to bring up the Analysis Op-
tions form. Check the Dynamic Analysis check box, if it is not
already checked, and click the Set Dynamic Parameters button.
This opens the Dynamic Analysis Parameters form. The follow-
ing bullet items describe the various areas in this form:

 Number of Modes: Specifies the number of Eigen or Ritz
modes that you want the program to capture.

 Type of Analysis: Choose either eigenvector or ritz-vector
analysis in this area. If you are running response spectrum or
time history analysis, we strongly recommend that you use
ritz-vectors. It is especially important that you use ritz-vectors
when performing nonlinear time history analysis.

 EigenValue Parameters: This area of the form is only active
if you select "Eigenvector" in the Type of Analysis area. The
following parameters are specified in this area:

 Frequency Shift (Center): This is the center of the cyclic
frequency range, ƒ0.

 Cutoff Frequency (Radius): This is the radius of the cy-
clic frequency range, also known as the cutoff frequency,
ƒmax.

 Relative Tolerance: This is the relative convergence tol-

erance, ε.

 Include Residual-Mass Modes: If you check this box, the
program computes residual-mass (missing-mass modes).
Those modes are used to approximate high-frequency be-
havior when the mass participation ratio for a given direc-
tion of acceleration load is less than 100%.

Tip:

If you are run-
ning response
spectrum or
time history
analysis, we
strongly rec-
ommend that
you use ritz-
vectors. It is
especially im-
portant that
you use ritz-
vectors when
performing
nonlinear time
history analy-
sis.
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When this option is chosen, the number of eigenvector
modes recovered is 3 less than the number specified, and
up to 3 non-zero residual-mass modes are reported. Thus,
when you check the Include Residual-Mass Modes check
box, at least four modes need to be requested because the
last 3 modes are automatically reserved for the residual-
mass modes.

The default values for the Eigenvalue Parameters will be
sufficient for most analyses.

 Starting Ritz Vectors: This area of the form is only active if
you select "Ritz Vectors" in the Type of Analysis area. In this
area, specify the starting ritz vectors.

The possible ritz load vectors are the acceleration loads in the
global X, Y and Z directions and all of your defined static load
cases. You can use any of those loads as starting ritz-vectors.

A load is used as a starting ritz-vector if it is in the Ritz Load
Vectors list box in the Starting Ritz Vectors area of the Dy-
namic Analysis Parameters form. If the load is in the List of
Loads list box, it is not used as a starting ritz-vector. You can
use the Add and Remove buttons to shift loads into and out of
the Ritz Load Vectors list box, respectively.

The Include Nonlinear Link Vectors check box is visible if you
have assigned link properties in your model. The check box is
active if link properties have been assigned and the Ritz Vector
analysis type has been specified.

If you check the Include Nonlinear Link Vectors box, the pro-
gram automatically provides a starting load vector for each
nonlinear degree of freedom in each link element. When you
use this option, be sure to specify a sufficient number of modes
to allow the program to capture the modes associated with
those special starting vectors. The program does not add addi-
tional modes to the number you requested when you check the
Include Nonlinear Link Vectors check box.
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Set P-Delta Parameters Button
To set the P-Delta analysis parameters, click the Analyze menu
> Set Analysis Options command to bring up the Analysis Op-
tions form. Then check the Include P-Delta check box, if it is not
already checked and click the Set P-Delta Parameters button.
This opens the P-Delta Parameters form. The following bullet
items describe the various areas in this form:

 Method: Initial P-Delta analysis in the program considers the
P-Delta effect of a single loaded state upon the structure. There
are two ways to specify this load:

 Non-iterative Based on Mass: The load is computed
automatically from the mass at each level as a story-by-
story load upon the structure. This approach is approxi-
mate, but does not require an iterative solution.

This method essentially treats the building as a simplified
stick model to consider the P-Delta effect. It is much faster
than the iterative method. It does not capture local buck-
ling as well as the iterative method. This method works
best if you have a single rigid diaphragm at each floor
level, although it also works for other cases.

This method allows you to consider P-Delta in cases where
you have not specified gravity loads in your model. If you
have specified gravity loads in your model, in general, we
recommend that you use the Iterative Based on Load
Combination option.

 Iterative Based on Load Combination: The load is com-
puted from a specified combination of static load cases.
This is called the P-Delta load combination. For example,
the load may be the sum of a dead load case plus a fraction
of a live load case. This approach requires an iterative so-
lution to determine the P-Delta effect upon the structure.

This method considers the P-Delta effect on an element-
by-element basis. It captures local buckling effects better

Tip:

We recommend
that you use the
Iterative Based
on Load Cases
method for P-
Delta analysis
unless there are
no gravity
loads specified
in your model.
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than the non-iterative method. We recommend that you
use this iterative method in all cases, except those where
no gravity load is specified in your model.

 Iteration Controls: This area is active if you select the Itera-
tive Based on Load Cases option in the Method area of the
form. When you specify a P-Delta load combination, the fol-
lowing parameters may also be specified to control the itera-
tive solution:

 Maximum Number of Iterations: Specifies the maxi-
mum number of additional analyses after the first analysis
has been run. This is used to prevent excessive computa-
tional time, given that each iteration requires about as
much computational effort as a linear static analysis. The
default is one.

 Relative Displacement Convergence Tolerance: This
item measures convergence. The default value is 0.001. If
the relative change in displacement from one iteration to
the next is less than the tolerance, no further iterations are
performed. The relative change in displacement is defined
as the ratio of the maximum change in displacement to the
largest displacement in either iteration. Note that rotations
and translations are treated equally.

If convergence has not been obtained after the maximum
number of iterations has been performed, the results of the
analysis may be meaningless, and they should be viewed
with great skepticism. Failure to converge may be result
from several causes:

 Too few iterations were permitted. A reasonable num-
ber is usually 2 to 5, although more may be required,
depending on the particular problem at hand.

 A convergence tolerance that is too small is used. A
reasonable value depends on the particular problem.
Beware, however, that using a value that is too large
may result in convergence to meaningless results.

Note:

P-Delta analy-
sis based on
specified load
cases is an it-
erative analy-
sis. It may take
several itera-
tions to achieve
convergence.
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 The structure is near buckling. The structure should be
stiffened against buckling, or the magnitude of the P-
Delta load combination should be reduced.

 P-Delta Load Combination: This area is active if you select
the Iterative Based on Load Cases option in the Method area of
the form. In this area, specify the single load combination to be
used for the initial P-Delta analysis of the structure.

As an example, assume that the building code requires the
following load combinations to be considered for design:

(1)  1.4 dead load

(2)  1.2 dead load + 1.6 live load

(3)  1.2 dead load + 0.5 live load + 1.3 wind load

(4)  1.2 dead load + 0.5 live load - 1.3 wind load

(5)  0.9 dead load + 1.3 wind load

(6)  0.9 dead load - 1.3 wind load

For this case, the P-Delta effect from overall sway of the
structure can usually be accounted for, conservatively, by
specifying the P-Delta load combination to be 1.2 times dead
load plus 0.5 times live load. This will accurately account for
this effect in load combinations 3 and 4 above, and will con-
servatively account for this effect in load combinations 5 and
6. This P-Delta effect is not generally important in load com-
binations 1 and 2 because there is no lateral load.

It is also possible to accurately account for the P-Delta effect
from the deformation of the members between their ends in the
program analysis, but we do not recommend that you do this.
Instead, we recommend that you account for this effect using
factors in your design. The program design postprocessors as-
sume this is what you have done and includes those factors,
where appropriate, in the design.
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If you did want to account for the P-Delta effect from defor-
mation of the members between their ends in the program
analysis, first break up all of your columns into at least two
objects between story levels. Then, run each of the six load
cases described earlier separately with a different P-Delta load
combination for each. Again, it is recommended that this effect
be accounted for by using factors in your design, the same way
it is performed in the program design postprocessors.

Save Access DB File Button
This program has the ability to save all input and output data to
an Access Database file. Checking the Save Access DB File
check box brings up the Save Access Database File As form. The
program provides a filename and path, which you can accept or
change. Click the Save button on the Save Access Database File
As form to complete the save. Note that the name of the file,
complete with path, appears in the edit box on the Analysis Op-
tions form. Also note that the File Name button is enabled. Click
the File Name button to recall the Save Access Database File As
form and store the file under a different name or path, if desired.

Run Analysis Command
Run an analysis of your building by clicking the Analyze menu
> Run Analysis command or the Run Analysis button , or

by pressing the F5 function key on you keyboard. When you
execute this command, the Run Options form appears with the
following three choices:

 Run: This option opens the Analysis Window on top of the
main program window and runs the analysis. Information con-
cerning the analysis scrolls by in the Analysis Window as the
run progresses. See the subsequent subsection entitled "Analy-
sis Window" for more information.

This option runs your analysis in such a way that if you switch
away from this program  to another program while the analysis

Tip:

The Run Mini-
mized option
has the advan-
tage of provid-
ing a Cancel
button while the
analysis is run-
ning, which
would allow
you to easily
abort the
analysis at any
time.
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is running, you may not be able to switch back until the analy-
sis run is complete. Also, there is no way to cancel an analysis
run after you have started it using this option.

In general you should only use this option for smaller models
that run quickly.

 Run Minimized: This option prompts you for a file name to
save your analysis results and closes the main program win-
dow, leaving only the Analysis Window open. Information
concerning the analysis run scrolls by in the Analysis Window
as the run progresses. See the subsequent subsection below
entitled "Analysis Window" for more information.

This option runs your analysis in such a way that if you switch
away from this program to another program while the analysis
is running, you are able to switch back to this program and ob-
serve the information in the Analysis Window. Also, this op-
tion provides you with a Cancel button that allows you to can-
cel (stop) the analysis at any time.

 Cancel: This cancels the Run Analysis command. The analysis
is not run if you click this button.

Analysis Window
As your program analysis runs, information about the analysis
scrolls by in the Analysis Window. When the analysis is com-
plete, and before you have clicked the OK button in the Analysis
Window, use the scroll bar in the Analysis Window to scroll
through all of the information and check for any warnings or er-
rors that might invalidate your analysis. After you click the OK
button in the Analysis Window, the warnings or error messages
disappear. However, they are saved, in text form, in the .log file.

Note:

Use the scroll
bar in the
Analysis Win-
dow to scroll
through all of
the information
and check for
any warnings
or errors that
might invali-
date your
analysis.
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Calculate Diaphragm Centers of Rigidity
Clicking the Analyze menu > Calculate Diaphragm Centers of
Rigidity command computes the location of diaphragm centers
of rigidity automatically. This option is available only after an
analysis has been run.

To view the results of the analysis, click the Display menu > Set
Output Table Mode command, which brings up the Display
Output Tables form. On this form, click the Building Output
check box and the OK button. The Centroids of Cummulative
Mass and Centers of Rigidity form will display the analysis re-
sults.
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Chapter 12

Display Menu

General
The Display menu provides options for displaying input and out-
put information on the model and onscreen in a tabular form.
This chapter describes those options.

Show Undeformed Shape Command
Clicking the Display menu > Show Undeformed Shape com-
mand or the Show Undeformed Shape button  does the

following:

 If you are creating your model, it clears the display of any as-
signments that are still showing on the model. It essentially
functions the same as the Assign menu > Clear Display of
Assigns command in this case.
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 If you are currently looking at onscreen output results of any
type that are plotted on the model, using this command clears
the display of the results and returns the view to an unde-
formed shape view.

Note that this command only affects the active window.

Show Loads Command
Click the Display menu > Show Loads command to display
loads that you have input for the model using the Assign menu >
Joint/Point Loads, Assign menu > Frame/Line Loads and As-
sign menu > Shell/Area Loads commands. Clicking the Dis-
play menu > Show Loads command brings up a submenu where
you can choose to display joint/point loads, frame/line loads or
shell/area loads. Each of these options is described in a subse-
quent subsection. The loads that you specify are only displayed
in the currently active window.

Note that alternatively you can right click on any object and then
select the Loads tab to see what loads are assigned to that object.

Show Loads > Joint/Point Command
Click the Display menu > Show Loads > Joint/Point command
of the  button  to bring up the Show Joint/Point Loads form.

The following bullet items describe the various areas in this
form.

 Load Case: From the drop-down box choose the static load
case  for which you want to display the joint/point loads. Note
that static load cases are defined using the Define menu >
Static Load Cases command (see Chapter 7 Define Menu).

 Load Type: Choose the type of load that you want to display.
The choices are forces, displacements or temperature values.
You can display one of these types of loads at a time. Note that
if the Load Type has not been assigned to the specified load

Tip:

You can right
click on any
object and se-
lect the Loads
tab as an alter-
native for
viewing the
loads on an
object.
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case (see Chapter 10 Assign Menu), the Load Type option is
grayed out and inactive.

 Show Loading Values: When the Show Loading Values
check box is unchecked, forces and displacements are indi-
cated by arrows in the appropriate direction only. When the
Show Loading Values check box is checked, forces and dis-
placements are indicated by arrows in the appropriate direction
together with loading values (text).

Loading values are always shown when you choose the Tem-
perature Values option in the Load Type area regardless of
whether the Show Loading Values check box is checked or
unchecked.

Show Loads > Frame/Line Command
Click the Display menu > Show Loads > Frame/Line com-
mand of the  button to bring up the Show Frame/Line Loads

form. The following bullet items describe the various areas in
this form.

 Load Case: From the drop-down box choose the static load
case  for which you want to display frame/line loads. Note that
static load cases are defined using the Define menu > Static
Load Cases command (see Chapter 7 Define Menu).

 Load type: Choose the type of load that you want to display
from this area. Note that you can only display one of these
types of loads at a time. Also note that if the Load Type has
not been assigned to the specified load case (see Chapter 10
Assign Menu), the Load Type option is grayed out and inac-
tive. The choices are:

 Span Loading (Forces): This includes all of the point,
uniform and trapezoidal force loads (not moment loads)
applied to the line object.

Note:

The values dis-
played for line
object tem-
perature loads
include the ef-
fect of point
temperatures at
the end points
of the line ob-
ject if you
specified this
when you as-
signed the tem-
perature load.
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 Span Loading (Moments): This includes all of the point,
uniform and trapezoidal moment loads applied to the line
object.

 Temperature Values: This includes all of the temperature
loads applied to the line object.

Important Note: When temperature loads are displayed, two
numbers are shown for each line object. Those two numbers
correspond to the temperatures at the ends of the object. If
upon assigning the temperature load you indicated that the ef-
fects of point temperature were not to be included, the two dis-
played temperatures for the line object are the same and are
equal to the temperature you assigned to the object. This is true
regardless of any point object temperatures that may be as-
signed to the point objects at the end of the line object.

If upon assigning the temperature load you indicated that the
effects of point temperature were to be included, the two dis-
played temperatures for the line object are equal to the tem-
perature you assigned to the object plus the temperature as-
signed to the point object at the considered end of the line ob-
ject. In that case, the two displayed temperatures for a line ob-
ject may be different.

 Include Point Object Loads: This check box toggles on and
off whether point object loads are shown together with the line
object loads. When this box is checked, both force and mo-
ment point object loads are displayed along with the selected
type of line object loads.

 Show Loading Values: When the Show Loading Values
check box is unchecked, forces and moments are indicated by
arrows in the appropriate direction only. When the Show
Loading Values check box is checked, forces and moments are
indicated by arrows in the appropriate direction together with
loading values (text).

Loading values are always shown when you choose the Tem-
perature Values option in the Load Type area, regardless of
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whether the Show Loading Values check box is checked or
unchecked.

Show Loads > Shell/Area Command
Click the Display menu > Show Loads > Shell/Area command
of the  button to bring up the Show Shell/Area Loads form.

The following bullet items describe the various areas in this
form.

 Load Case: From the drop-down box choose the static load
case  for which you want to display shell/area loads. Note that
static load cases are defined using the Define menu > Static
Load Cases command (see Chapter 7 Define Menu).

 Load type: Choose the type of load that you want to display
from this area. Note that you can only display one of these
types of loads at a time. Also note that if the Load Type has
not been assigned to the specified load case (see Chapter 10
Assign Menu), the Load Type option is grayed out and inac-
tive.  The choices are:

 Uniform Load Values: This is a uniform surface load on
an area object. If you choose this option, also specify the
loading direction for which you want the loads displayed
by choosing a direction from the associated Direction
drop-down box.

 Temperature values: This includes all of the temperature
loads applied to the area object.

Important Note: When temperature loads are displayed,
numbers are shown at each corner of the area object.
Those numbers correspond to the temperatures at the cor-
ners of the object. If upon assigning the temperature load
you indicated that the effects of point temperature were not
to be included (see "Shell/Area Loads > Temperatures
Command" in Chapter 10 Assign Menu), the displayed
temperatures for the area object are the same and are equal

Note:

The values dis-
played for area
object tem-
perature loads
include the ef-
fect of point
temperatures at
the corner
points of the
area object if
you specified
this when you
assigned the
temperature
load.
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to the temperature you assigned to the object. This is true
regardless of any point object temperatures that may be as-
signed to the point objects at the corners of the area object.

If upon assigning the temperature load you indicated that
the effects of point temperature were to be included, the
displayed temperatures for the area object are equal to the
temperature you assigned to the object plus the tempera-
ture assigned to the point object at the considered corner of
the area object. In that case, the displayed temperatures for
an area object may be different at each corner.

Set Input Table Mode Command
Use the Display menu > Set Input Table Mode command or

 button to display input data on screen. Use of this command

provides you with the opportunity to complete an onscreen re-
view of the input parameters you used in building your model.

Clicking the Display menu > Set Input Table Mode command
or its associated button  brings up the Data Tables Input form.

This form has two tabs:

 Definitions Tab - The Definitions tab has three areas:  Build-
ing Data, Properties, and Load Definitions. Each of those areas
lists a series of data types that can be used in building a model
using in this program. Include a data type in the onscreen dis-
play by checking its associated check box and clicking the Ok
button. Note that if an option is grayed out or inactive, the data
type is not used in the current model. The Check/Uncheck All
button in this area simultaneously toggles all of the check
boxes to be check or unchecked.

 Assignments Tab: The Assignments tab has three areas:
Point Assignments, Line Assignments and Area Assignments.
Each of those areas lists a series of data types that can be used
in building a model using in this program. Include a data type
in the onscreen display by checking its associated check box
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and clicking the Ok button. Note that if an option is grayed out
or inactive, the data type is not used in the current model. The
Check/Uncheck All button in this area simultaneously tog-
gles all of the check boxes to be check or unchecked.

Selection Only Check Box
When the Selection Only check box near the bottom of the Data-
base Input Tables form is checked, the program will display only
those data that have been selected by checking the check box in
the six areas of the Definitions and Assignments tabs. This is the
program default.

When the Selection Only check box is unchecked, the program
will display all data types used in the model even though no
check boxes have been checked on the Definitions and Assign-
ments tabs.

Select Loads Button
Clicking the Select Loads button near the bottom of the Data-
base Input Tables form brings up the Select Load Conditions
form. Select the load condition(s) you want to display by high-
lighting it in the Select area of this form and clicking the Ok
button. You can highlight one or more load cases in the list at the
same time.

Note that the form also displays the number of loads selected
relative to the number of loads available (e.g., 1 of 3 Loads Se-
lected).

Check/Uncheck All Button
The Check/Uncheck All button near the bottom of the Database
Input Tables form is similar to the Check/Uncheck All buttons
found in each area of the Definitions and Assignments tabs.
However, clicking this button selects/deselects all data types in
all areas of both the Definitions and the Assignments tabs.
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Show Deformed Shape Command
After an analysis has been run, clicking the Display menu >
Show Deformed Shape command or the Display Static De-
formed Shape button  brings up the Deformed Shape form.

Use this form to specify the load case for which you want to plot
the deformed shape. The following bullet items describe the
various areas in the Deformed Shape form.

 Load: From the drop-down box choose the load case for
which you want to plot the deformed shape. Note that you can
plot a deformed shape for any static load case, response spec-
trum case, time history case, static nonlinear case, or load
combination. Following is a description of what is plotted for
each of these items.

 Static load case (linear): The deformed shape multiplied
by a scale factor is plotted. When a deformed shape is dis-
played for a static load case, use the left and right arrow
keys on the status bar,  , to quickly display de-

formed shapes for other static load cases.

 Response spectrum case: A deformed shape multiplied
by a scale factor is plotted. In that case, the deformed
shape has little meaning because the response spectrum
analysis causes all results (deformations) to be positive,
and the displacements at each point are the maximum dis-
placement at that point that may not occur at the same time
in an earthquake as the maximum displacement at another
point.

It can be useful to compare the deformed shape plot for a
response spectrum with the undeformed shape to see
which parts of the structure are experiencing the most dis-
placement.

When a deformed shape is displayed for a response spec-
trum case, use the left and right arrow keys on the status
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bar,  , to quickly display deformed shapes for

other response spectrum cases.

 Time history case: When you choose a time history case,
a box appears where you specify the time step in the time
history analysis for which you want to display the de-
formed shape. Choose a time before clicking the OK but-
ton to plot the deformed shape.

If you specify a time that is before the time history starts,
the first step of the time history is displayed. If you specify
a time that is after the time history finishes, the last step of
the time history is displayed. If you specify a time during
the time history that is not exactly the same as one of the
output time step times, the nearest time step is displayed.

A deformed shape multiplied by a scale factor is plotted
for the chosen time of the time analysis. When a deformed
shape is displayed, use the left arrow key on the status bar,

, to display the previous time step in the analysis and

the right arrow key on the status bar, , to display the

next time step in the analysis.

 Static nonlinear case: When you choose a static nonlinear
case, a box appears where you specify the step in the static
nonlinear analysis for which you want to display the de-
formed shape. Choose a step number before clicking the
OK button to plot the deformed shape. To get an idea of
the force and deformation associated with any step in the
pushover, click the Display menu > Show Static Push-
over Curve command, click the File menu at the top of the
resulting form and click the Display Tables command.
This displays a table that, among other things, includes the
force and deformation for each step of the nonlinear static
analysis.

A deformed shape multiplied by a scale factor is plotted
for the chosen step of the static nonlinear analysis. When a
deformed shape is displayed you can use the left arrow key
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on the status bar, , to display the previous step in the

analysis and the right arrow key on the status bar, , to

display the next step in the analysis. In this manner you
can easily step through deformed shape views of the entire
pushover analysis if desired.

See the discussion of contours in the subsection entitled
"Colors > Output Command" in Chapter 14 for additional
information on deformed shapes for static nonlinear analy-
ses.

 Load combination: A deformed shape multiplied by a
scale factor is plotted. In this case the deformed shape may
or may not have much meaning depending on what is in
the load combination.

If the load combination is a single-valued load combina-
tion, the displayed results are meaningful. If the load com-
bination is multi-valued, the displayed results have little
meaning. In that case the value with the largest absolute
value is displayed. For example, if the minimum value at
point 1 is -3 and the maximum value is +2, the -3 value is
displayed. If an adjacent point has a minimum value of -1
and a maximum value of +2, then +2 is displayed at that
point. This process continues on for every point. It can
lead to some unusual looking deformed shape plots.

When a deformed shape is displayed for a load combina-
tion, use the left and right arrow keys on the status bar,

 , to quickly display deformed shapes for other

load combinations.

 Scaling: Specifies the scaling that is used to scale the plotted
deformations. If you specify a scaling factor of 100, all defor-
mations are plotted to scale at 100 times their actual value. For
example, a deformation of 1 inch is plotted to scale as if it is a
100-inch deformation.

By default the program automatically determines a scaling
factor for the deformed shape plot. If you want the program to
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automatically determine a scaling factor, leave the Auto option
selected. Otherwise, select the Scale Factor option and specify
your own scale factor.

The program calculates the scale factor as a multiple of the de-
fault font size, which itself is determined as a multiple of the
average story height. The advantage to determining the scale
factor as a multiple of the default font size is that the default
font size is limited by a specified minimum and maximum size
that is specified in the preferences. This helps keep the auto-
matically determined scale factor within a reasonable range
most, but not all, of the time. If the automatic scale factor
seems to cause a display problem, specify your own factor.

 Cubic Curve: Specify if the cubic curve function should be
used when plotting the deformed shape. Cubic curves affect
how the line objects with frame section properties appear in
the deformed shape plot.

The program only saves point/joint displacements from an
analysis. Thus, when it prepares to plot a deformed shape, the
only deformations it has available are the point/joint deforma-
tions. No deformations internal to the line objects are avail-
able.

When the deformed shape is plotted, the point/joints are put in
their correct locations. If you specify that the cubic curves are
not to be considered, the frame elements are simply drawn as
straight lines connecting the appropriate points/joints.

If you specify that cubic curves are to be considered, the pro-
gram does the following:

 Calculate an approximate deflection (translation and rota-
tion) at the center of the beam.

 Draw a cubic curve from the left end of the beam to the
center of the beam based on the actual translation and ro-
tation at the left end and the approximate translation and
rotation at the center.

Note:

The cubic curve
feature only
affects line ob-
jects with frame
section proper-
ties.
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 Draw a cubic curve from the center of the beam to the
right end of the beam based on the approximate translation
and rotation at the center and the actual translation and ro-
tation at the left end.

Note that drawing a single cubic curve from the left end to
the right end of the beam does not give a very good repre-
sentation of a loaded beam, but using two curves, as is per-
formed in this program, gives a pretty good plot. Never-
theless, when plotting a deformed shape, keep in mind that
the displacements at the joints are exact, whereas defor-
mation shown for the frame members is approximate, even
when the cubic curve option is activated.

When you are viewing a deformed shape, right click on any
point object to bring up the Joint Displacements form that dis-
plays the displacements (translation and rotations) for that point
object in the global coordinate system and in the current units. In
this form, click on the Lateral Drifts button to display dis-
placements at all story levels where a point object exists in the
same plan location as the selected point object. Also, drifts are
displayed for all story levels where a point object exists at the
top and bottom of the story level in the same plan location as the
selected point object. The drifts are calculated as the displace-
ment at the top of the story level minus the displacement at the
bottom of the story level divided by the story level height.

Important Note: When an analysis is run the program automati-
cally creates a point object at the center of mass of all rigid dia-
phragms. This point object is restrained against translation in the
Z-direction and against rotation about the global X- and Y-axes
to be compatible with the rigid diaphragm. You can right click
on this point to see displacements at the center of mass of the
diaphragm.

Note that the Z translation and X and Y rotations for those center
of mass points are zero because the points are restrained. Also
note that you can use the Point Objects item in the Object Visi-
bility area of the Set Building View Options form to toggle those

Note:

You can ani-
mate deformed
shapes in this
program.
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center of mass joints on and off. Use the Set Building View Op-
tions button  to access the form.

Finally, when a deformed shape is displayed in the active win-
dow, click on the Start Animation button on the status bar to
animate the deformed shape. Sometimes this makes it easier to
recognize the deformed shape. Click the Stop Animation button
on the status bar to stop the animation. Note that the program in-
cludes sound with the animation. You can use the Options menu
> Sound command to toggle this sound on and off.

Show Mode Shape Command
Click the Display menu > Show Mode Shape command or the
Show Mode Shape button   to bring up the Mode Shape

form. In this form, specify the mode for which you want to plot
the deformed shape. The following bullet items describe the
various areas in the Mode Shape form.

 Mode number: Specifies the mode number for which you
want to plot the deformed shape. Use the scroll buttons to
scroll to the desired mode shape or simply type in the mode
number you would like to display. If you type in a mode num-
ber larger than the number of modes used in the analysis, the
program defaults to the highest mode number in the analysis.

 Scaling: Specify the scaling that is used to scale the plotted
mode shapes. By default the program automatically determines
the scaling factor for the mode shape plot. If you want the pro-
gram to automatically determine a scaling factor, leave the
Auto option selected. Otherwise, select the Scale Factor option
and specify your own scale factor. When you select your own
scaling factor, a factor of 1 gives the same plot as the auto-
matic scaling. A factor of 2 gives twice the apparent deforma-
tion and so on.

The program calculates the default deformation (scale factor of
1 deformation) as a multiple of the default font size, which it-
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self is determined as a multiple of the average story height.
The advantage to determining the scale factor as a multiple of
the default font size is that the default font size is limited by a
specified minimum and maximum size that is specified in the
preferences. This helps keep the automatically determined de-
formations for the mode shapes within a reasonable range
most, but not necessarily all, of the time. If the automatic scale
factor seems to cause a display problem, specify your own
factor.

 Cubic Curve: Refer to the bullet item entitled "Cubic Curve"
in the previous "Deformed Shape" subsection for a description
of the cubic curve item.

When a mode shape is displayed, click on the Start Animation
button on the status bar to animate the mode shape. Sometimes
this makes it easier to recognize the deformed shape. Click the
Stop Animation button on the status bar to stop the animation.
Note that the program includes sound with the animation. You
can use the Options menu > Sound command to toggle this
sound on and off.

Also, when a mode shape is displayed, use the left arrow key on
the status bar, , to display the previous mode shape and the

right arrow key on the status bar, , to display the next mode

shape.

Show Member Forces/Stress Diagram Command
Click the Display menu > Show Member Forces/Stress Dia-
gram command or click the Display Member Force Diagram
button  to display Support/Spring Reactions; Frame/Pier/

Spandrel Forces; Shell Stresses/Forces; and Link Forces. These
items are described in detail in subsequent subsections.

Note:

You can ani-
mate mode
shapes in this
program.
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Show Member Forces/Stress Diagram > Support/Spring
Reactions Command

Display support and spring reactions directly on the program
model by clicking the Display menu > Show Member
Forces/Stress Diagram > Support/Spring Reactions com-
mand. Using this command brings up the Point Reaction Forces
form. The following bullet items describe the areas in this form:

 Load: From the drop-down box choose the load case for
which you want to display support or spring reactions. Note
that you can plot support or spring reactions for any static load
case, response spectrum case, time history case, static nonlin-
ear case, or load combination. For time history cases, also
specify a time for which you want to see the reactions. For
static nonlinear cases, also specify a step at which you want to
see the reactions.

Following is a description of what is plotted for each of those
cases.

 Static load case (linear): The force values are displayed
along with arrows showing the direction of the force. The
arrows indicate the direction of the force acting from the
support (spring) onto the elements connected to the sup-
port (spring). When reactions are displayed for a static
load case, use the left and right arrow keys on the status
bar,  , to quickly display reactions for other static

load cases.

 Response spectrum case: The reaction values are dis-
played along with arrows showing the direction of the
force. The arrows indicate the direction of the force acting
from the support (spring) onto the elements connected to
the support (spring). Note that the response spectrum reac-
tions show the maximum value obtained for each compo-
nent of each reaction and also note that the values may not
occur at the same time in an earthquake.
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When reactions are displayed for a response spectrum
case, use the left and right arrow keys on the status bar,

 , to quickly display reactions for other response

spectrum cases.

 Time history case: When you choose a time history case,
a box appears where you specify the time step in the time
history analysis for which you want to display the reac-
tions. Choose a time before clicking the OK button to plot
the reactions.

If you specify a time that is before the time history starts,
the first step of the time history is displayed. If you specify
a time that is after the time history finishes, the last step of
the time history is displayed. If you specify a time during
the time history that is not exactly the same as one of the
output time step times, the nearest time step is displayed.

The reaction values are displayed along with arrows
showing the direction of the force. The arrows indicate the
direction of the force acting from the support (spring) onto
the elements connected to the support (spring).

When reactions are displayed, use the left arrow key on the
status bar, , to display the reactions for the previous

time step in the analysis and the right arrow key on the
status bar, , to display the reactions for the next time

step in the analysis.

 Static nonlinear case: When you choose a static nonlinear
case, a box appears where you specify the step in the static
nonlinear analysis for which you want to display the reac-
tions. Choose a step number before clicking the OK button
to plot the deformed shape. To get an idea of the force and
deformation associated with any step in the pushover, click
the Display menu > Show Static Pushover Curve com-
mand, click the File menu at the top of the resulting form
and click the Display Tables command. This displays a
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table that among other things includes the force and de-
formation for each step of the nonlinear static analysis.

The reaction values are displayed along with arrows
showing the direction of the force. The arrows indicate the
direction of the force acting from the support (spring) onto
the elements connected to the support (spring).

When reactions are displayed, use the left arrow key on the
status bar, , to display the previous step in the analysis

and the right arrow key on the status bar, , to display

the next step in the analysis. In this manner, you can easily
step through the support or spring reactions for the entire
pushover analysis if desired.

 Load combination: The reaction values are displayed
along with arrows showing the direction of the force. The
arrows indicate the direction of the force acting from the
support (spring) on to the elements connected to the sup-
port (spring).

If a load combination is a single-valued load combination,
its reaction values are displayed. If a load combination is
multi-valued, the displayed results are those with the larg-
est absolute value. For example, if the minimum value at
point 1 is -3 and the maximum value is +2, the -3 value is
displayed. If an adjacent point has a minimum value of -1
and a maximum value of +2, then +2 is displayed at that
point. This process continues for every component at every
reaction point.

When reactions are displayed for a load combination, use
the left and right arrow keys on the status bar,  , to

quickly display reactions for other load combinations.

 Type: Indicate whether to display support reactions or spring
forces.
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When support or spring reactions are displayed, right click on
any point object to see its support or spring forces in a tabular
form. Sometimes it is easier to read the values using this method.

Show Member Forces/Stress Diagram > Frame/Pier/ Span-
drel Forces Command

Display column, beam, brace, pier and spandrel forces directly
on your program model by clicking the Display menu > Show
Member Forces/Stress Diagram > Frame/Pier/Spandrel
Forces command. Using this command brings up the Member
Force Diagram for Frames form. The following bullet items de-
scribe the areas in that form:

 Load: From the drop-down box, choose the load case for
which you want to display the member forces. Note that you
can plot member forces for any static load case, response
spectrum case, time history case, static nonlinear case, or load
combination. For time history cases, also specify a time for
which you want to see the forces. For static nonlinear cases,
also specify a step at which you want to see the forces.

 Component Type: Specify which component of force you
want to see. You can choose any one (at a time) of the follow-
ing:

 Axial Force

 Shear 2-2

 Shear 3-3

 In-Plane Shear

 Torsion

 Moment 2-2

 Moment 3-3

 In-Plane Moment
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The in-plane moment and shear items are only available if
the currently active window (the one where the forces are
going to be displayed) is a 2-D view. This view is useful
for looking at two-dimensional frames when the local 2-
axis of the columns is in the plane of the frame.

If the local axes of a member are rotated such that neither
the local 2- nor 3-axis is in the 2-D plane, the force dis-
played when the in-plane option is chosen is made up of
appropriate components from the local 2 and 3 axes.

 Scaling: By default the program automatically determines a
scaling factor for the plotted forces. If you want the program to
automatically determine a scaling factor, leave the Auto option
selected. Otherwise, select the Scale Factor option and specify
your own scale factor.

The program calculates the scale factor as a multiple of the de-
fault font size, which itself is determined as a multiple of the
average story height. The advantage to determining the scale
factor as a multiple of the default font size is that the default
font size is limited by a specified minimum and maximum size
that is specified in the preferences. This helps keep the auto-
matically determined scale factor within a reasonable range
most, but not all, of the time. If the automatic scale factor
seems to cause a display problem, specify your own factor.

 Fill diagram and Show Values on Diagram Check Boxes:
You can display the force diagrams filled with no text values,
unfilled with no text values or unfilled with text values.

 To display force diagrams filled with no text values:
Check the Fill Diagram check box. Note that if the Show
Values on Diagram check box is currently checked, you
must uncheck it before you can check the Fill Diagram
check box.

 To display force diagrams unfilled with no text values:
Leave both diagrams' check boxes unchecked.

Note:

The column,
beam, brace,
pier and span-
drel forces are
all displayed at
the same time.
If you want to
see forces for
just one of
those types of
objects, make
the other ob-
jects invisible
using the View
menu > Set
Building View
Options com-
mand.
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 To display force diagrams unfilled with text values:
Check the Show Values on Diagram check box. Note that
if the Fill Diagram check box is currently checked, you
must uncheck it before you can check the Show Values on
Diagram check box.

When forces are displayed on the model note the following:

 You can right click on a frame element, wall pier or wall span-
drel to pop up a window where you can run your mouse
pointer over the element and see the force value at any loca-
tion.

 When forces are displayed, use the left and right arrow keys on
the status bar,  , to quickly display forces for other

load cases.

 If you are currently viewing a static load case (linear), the
arrow keys step you through all of the other static load
cases (linear).

 If you are currently viewing a response spectrum case, the
arrow keys step you through all of the other response
spectrum cases.

 If you are currently viewing a time step in a time history
case, the arrow keys step you through all of the other time
steps in the time history case.

 If you are currently viewing a step in a static nonlinear
case, the arrow keys take you through all of the other steps
in the static nonlinear case.

 If you are currently viewing a load combination, the arrow
keys step you through all of the other load combinations.

 Multi-valued load combinations plot a range of values. See the
subsection titled "Color > Output Command" in Chapter 14 for
more information.

Tip:

When forces
are displayed
on the model,
right click on
any column,
beam, brace,
pier or span-
drel to pop up a
window where
you can run
your mouse
pointer over the
element and see
the force value
at any location.
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 For frame elements, exact force values are plotted at all output
station locations. Those exact force values are then connected
by straight-line segments to complete the force diagram. See
the section entitled "Frame/Line > Frame Output Stations
Command" in Chapter 10 Assign Menu for more information.

 For wall pier and spandrel elements, exact force values are
plotted at the ends of the element. Those exact force values are
then connected by a straight-line segment to complete the force
diagram.

Note that because of the above described method of reporting
pier and spandrel forces, the forces reported for spandrel ele-
ments may not be refined enough if your design is governed by
gravity load. In cases where your design is governed by gravity
load, we recommend that you model the spandrels with frame
elements.

Show Member Forces/Stress Diagram > Shell Stresses/
Forces Command

Display internal shell element forces and stresses directly on
your the program model by clicking the Display menu > Show
Member Forces/Stress Diagram > Shell Stresses/ Forces
command. Using this command brings up the Element
Force/Stress Contours for Shells form.

Important note: The internal shell element forces are forces per
unit length acting along the midsurface of the shell element (area
object). The internal shell element stresses are stresses acting on
the edges (not positive 3-axis face and negative 3-axis face) of
the shell element (area object).

The following bullet items describe the areas in the Element
Force/Stress Contours for Shells form:

 Load - From the drop-down box, choose the load case for
which you want to display shell element forces or stresses.
Note that you can plot shell element forces or stresses for any

Note:

Shell element
internal forces
are reported at
the element
midsurface in
force per unit
length. Shell
element inter-
nal stresses are
reported at
both the top
and bottom of
the element in
force per unit
area.



Reference Manual

12 - 22 Show Member Forces/Stress Diagram Command

12

static load case, response spectrum case, time history case,
static nonlinear case, or load combination. For time history
cases, also specify a time for which you want to see the forces
or stresses. For static nonlinear cases, also specify a step at
which you want to see the forces or stresses.

 Component Type - Specify whether you want to see the shell
element internal Forces or the internal Stresses.

 Forces -  For shell element internal forces, the possible
components are as follows:

 F11: Direct force per unit length acting at the mid-
surface of the element on the positive and negative 1
faces in the 1-axis direction.

 F22: Direct force per unit length acting at the mid-
surface of the element on the positive and negative 2
faces in the 2-axis direction.

 F12: Shearing force per unit length acting at the mid-
surface of the element on the positive and negative 1
faces in the 2-axis direction, and acting on the positive
and negative 2 faces in the 1-axis direction.

 FMAX: Maximum principal force per unit length
acting at the mid-surface of the element. Note that by
definition, principal forces are oriented such that the
associated shearing force per unit length is zero.

 FMIN: Minimum principal force per unit length act-
ing at the mid-surface of the element. Note that by
definition, principal forces are oriented such that the
associated shearing force per unit length is zero.

 M11: Direct moment per unit length acting at the mi-
surface of the element on the positive and negative 1
faces about the 2-axis.

Axis 1

Axis 3

Axis 2

Po
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Positive 2 Face

Positive 3 Face is
on front of element
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1 
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Negative 2 Face

Negative 3 Face is
on back of element
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 M22: Direct moment per unit length acting at the mid-
surface of the element on the positive and negative 2
faces about the 1-axis.

 M12: Twisting moment per unit length acting at the
mid-surface of the element on the positive and nega-
tive 1 faces about the 1-axis, and acting on the positive
and negative 2 faces about the 2-axis.

 MMAX: Maximum principal moment per unit length
acting at the mid-surface of the element. Note that by
definition, principal moments are oriented such that
the associated twisting moment per unit length is zero.

 MMIN: Minimum principal moment per unit length
acting at the mid-surface of the element. Note that by
definition, principal moments are oriented such that
the associated twisting moment per unit length is zero.

 V13: Out-of-plane shear per unit length acting at the
mid-surface of the element on the positive and nega-
tive 1 faces in the 3-axis direction.

 V23: Out-of-plane shear per unit length acting at the
mid-surface of the element on the positive and nega-
tive 2 faces in the 3-axis direction.

 VMAX: Maximum principal shear per unit length
acting at the mid-surface of the element. Note that by
definition, principal shears are oriented on faces of the
element such that the associated shears per unit length
on perpendicular faces are zero.

 Stresses - For shell element internal stresses, the possible
components are the following:

 S11: Direct stress (force per unit area) acting on the
positive and negative 1 faces in the 1-axis direction.

 S22: Direct stress (force per unit area) acting on the
positive and negative 2 faces in the 2-axis direction.
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 S12: Shearing stress (force per unit area) acting on the
positive and negative 1 faces in the 2-axis direction
and acting on the positive and negative 2 faces in the
1-axis direction.

 SMAX: Maximum principal stress (force per unit
area). Note that by definition, principal stresses are
oriented such that the associated shearing stress is
zero.

 SMIN: Minimum principal stress (force per unit area).
Note that by definition, principal stresses are oriented
such that the associated shearing stress is zero.

 S13: Out-of-plane shearing stress (force per unit area)
acting on the positive and negative 1 faces in the 3-
axis direction.

 S23: Out-of-plane shearing stress (force per unit area)
acting on the positive and negative 2 faces in the 3-
axis direction.

 SMAXV: Maximum principal shearing stress (force
per unit area). Note that by definition principal shear-
ing stresses are oriented on faces of the element such
that the associated shears per unit length on perpen-
dicular faces are zero.

 Contour Range - The shell element internal forces and
stresses are displayed on your screen as colored contours. Ten
different contour colors are used. Specify the actual colors
used by clicking the Options menu > Colors > Output com-
mand and editing the colors in the Contours area of the Assign
Output Colors form.

In the Contour Range area of the Element Force/Stress Con-
tours for Shells form, you can specify two values:

 Min: Any element with a force or stress less than the value
shown here is displayed in the color associated with Min in
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the Contours area of the Assign Output Colors form. Note
that the color associated with Min is the top color in the
form.

 Max: Any element with a force or stress greater than or
equal to the value shown here is displayed in the color as-
sociated with Max in the Contours area of the Assign Out-
put Colors form. Note that the color associated with Max
is the bottom color in the form.

When you specify the Min and the Max values, the program
spaces the intermediate range values equally between the
specified Min and Max values.

If you set both the Min and the Max values to zero, the pro-
gram creates its own range. In that case, the program creates a
stress range with rounded off (even) values within which the
actual maximum and minimum stresses fit. Note that setting
Min and Max to zero is the default.

 Stress Averaging - Specifies if stress averaging is to be used
when displaying the shell element forces or stresses. Consider
the four shell elements labeled A, B, C and D shown in the
sketch to the left. Those four shell elements all have a common
point, labeled 1, in the sketch.

Each of the shell elements has an associated internal force or
stress at joint 1. Typically, the forces or stresses at common
points in different shell elements are different. The finer your
mesh, the closer those values become.

If the force or stress contours are plotted with no stress aver-
aging at the common points, you will typically see abrupt
changes in force or stress from element to element. Stress av-
eraging tends to get rid of those abrupt changes in the plot and
smoothes the contours.

The program averages the stresses at a point by averaging the
stresses from all shell elements that both connect to the point
and are visible in the active window. Then when the program

BA

DC

1
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plots the stress for a particular shell element, it plots that aver-
age stress at the point considered, instead of the actual stress
calculated for that shell element at the point.

Do not overlook the implications of the italicized text in the
previous paragraph. Assume you are looking at stresses in a
location where a wall intersects a floor. Further assume that
you are looking at averaged stresses in the floor. If you are
viewing the averaged stresses in the floor in a 2D plan view of
the floor, only the shell elements that are in the floor, and thus
visible in the window, are included in the stress averaging.

If you view the same averaged stresses in a 3D view, where
both the wall and the floor are visible, the shell elements from
both the floor and the wall are included in the stress averaging.
Thus the averaged stresses in the floor at the intersection of the
floor and the wall will appear differently, depending on
whether you are looking at them in a 2D plan view or in a 3D
view.

 Stress Averaging - In this program, you have the following
Stress Averaging option: None, no stress averaging; at All
Joints, stress averaging at all joints; or at Selected Joints, stress
averaging at specific points you have selected just before plot-
ting the shell forces or stresses.

 Display on Deformed Shape - If this check box is checked,
the program will display the results on the deformed shape. If
it is unchecked, it will not.

Miscellaneous Notes about Shell Element Forces and Stresses
Note that shell element stresses (not forces) actually have differ-
ent values at the top and bottom of the shell elements (area ob-
jects). Thus, depending on which side of the object you are
looking at you may see different stresses. Two-dimensional
views always look at area objects from the same side. If you
want to see stresses on the other side of the area object, view
them in a 3D view.
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Finally, when shell element forces and stresses are plotted for
multi-valued load combinations, the program displays the maxi-
mum or minimum value that has the largest absolute value.

Show Member Forces/Stress Diagram > Link Forces
Display link forces directly on your program model by clicking
the Display menu > Show Member Forces/Stress Diagram >
Link Forces command. This command brings up the Member
Force Diagram form. This form works as described in the previ-
ous subsection entitled "Show Member Forces/Stress Diagram
> Frame/Pier/Spandrel Forces Command."

Note the following about displayed link element forces:

 When multiple link elements are defined at the same location,
the force value displayed on the model is the sum of the forces
in all the link elements that exist at that location.

 When link forces are displayed on the model, you can right
click on a link element to bring up a tabular display of the
forces on that element. When multiple elements are defined in
the same location, the tabular display shows the forces for each
element separately.

 When forces are plotted on link elements for multi-valued load
combinations, the program displays the maximum or minimum
values that has the largest absolute value.

Show Energy/Virtual Work Diagram Command
Click the Display menu > Show Energy/Virtual Work Dia-
gram command or the  button to display energy/virtual work

diagrams that can be used as an aid to determine which elements
should be stiffened to most efficiently control the lateral dis-
placements of your structure. Following is a little background in-
formation.
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Consider the two story structure shown in Figure 12-1a that has
lateral loads P1 and P2 at the Roof and Second story levels, re-
spectively. Also note the displaced shape, ∆, associated with this
structure and loading, which is shown by a dashed line.

Now consider the same structure, shown in Figure 12-1b, with a
single load P (typically a unit load) applied to it and a resulting
displaced shape, δ, shown as a dashed line. Maxwell's Reciprocal
Theorem states that:

P∆ = P1δroof + P2δsecond Eqn. 12-1

See a structural analysis textbook for details on Maxwell's Re-
ciprocal Theorem.

In this very simple example, Equation 12-1 could be reduced to
an element level where the elements are illustrated in Figure 12-
1c as shown in Equation 12-2.

P∆ = [P1δroof - P1δsecond] +

                           [(P1 + P2)δsecond - (P1 + P2)δbase] Eqn. 12-2

Noting that δbase is equal to zero, Equation 12-2 reduces to that
shown in Equation 12-3.

P∆ = [P1δroof - P1δsecond] + [(P1 + P2)δsecond] Eqn. 12-3

In Equation 12-3 the first term in brackets is the energy in the
top element and the second term is the energy in the bottom ele-

Figure 12-1:
Example of the the-
ory used for energy
diagrams

Roof

Second

P1

P2

∆
Roof

Second

P1

P2

δroof

δsecond

Roof

Second

P1

P1 + P2
P1

P1 + P2

a) b) c)

Note:

The energy
diagram is an
aid to help you
determine
which elements
should be stiff-
ened to most
efficiently con-
trol the lateral
displacements
of your struc-
ture.
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ment. The energy in both of these elements sums to the total P∆
energy.

When you request that the program shows the energy/virtual
work diagram, it reports the equivalent of the values shown in
brackets in Equation 12-3 for each element in the structure. Note
the following about the energy values that the program reports:

 The energy/virtual work values that the program reports are
based on all six degrees of freedom of the element, not just the
one degree of freedom described in Figure 12-1 and Equations
12-1 through 12-3.

 The energy/virtual work values that the program reports are
determined as follows:

 The program determines the energy/virtual work per unit
volume associated with each element in the structure.

 The program normalizes all of the calculated en-
ergy/virtual work values such that the largest one has a
value of 100.

As previously stated, the energy/virtual work diagrams are help-
ful as an aid to determine which elements should be stiffened to
control lateral displacements in your structure. When you request
that the program shows an energy diagram, the Energy Diagram
form appears. In this form, input a load case associated with
forces and one associated with displacements.

The load case associated with forces is the load case for which
you want to control displacements. In the previous discussion, it
is the load case shown in Figure 12-1a. The load case associated
with displacements is the one associated with Figure 12-1b in the
previous example. Typically, this load case consists of one or
more unit loads.

Note:

Energy
diagrams are
normalized.
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displacement load cases. Figure 12-2a shows a load case that is
appropriate if you are interested in controlling the roof displace-
ment. Figure 12-2b shows a load case that is appropriate if you
are interested in controlling the interstory displacement between
the roof and the second story level.

Show Response Spectrum Curves Command
After running a time history analysis, select one or more point
objects and click the Display menu > Show Response Spec-
trum Curves command or the  button to bring up the Re-

sponse Spectrum Generation form. In this form, specify the ap-
propriate data to plot various response spectra.

Important Note: The response spectrum curve that you plot us-
ing this command is based on a time history that you have previ-
ously run. It has nothing to do with any response spectrum
analysis that you may have run.

The Response Spectrum Generation form has five separate tabs
and two buttons. The two buttons are described first, followed by
an explanation of the tabs.

 Display button:  Click this button to display the plot you have
defined in this form.

Roof

Second

1

a)

Roof

Second

1

1

b)

Figure 12-2:
Example displace-
ment load cases for
energy diagram
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 Done button:  Click this button to close the Response Spec-
trum Generation form.

Define Tab
The Define tab on the Response Spectrum Generation form has
the following three areas:

 Time History Case: This is the name of a previously run time
history case for which you want to create the response spec-
trum.

 Choose a Point: This area displays the labels of the point ob-
jects you had selected when you clicked the Display menu >
Show Response Spectrum Curves command. Highlight a
point in this area. The response spectrum is generated based on
the time history absolute acceleration response at this high-
lighted point.

 Vector Direction: This is the direction associated with the re-
sponse spectrum. The choices are X, Y or Z, which are the
global axes directions. The response spectrum is based on time
history absolute acceleration response in the specified vector
direction at the point that is highlighted in the Choose a Point
area of the Define tab.

Axes Tab
Te Axes tab of the Response Spectrum Generation form has the
following areas:

 Abscissa: This is the horizontal axis of the response spectrum.
It can be frequency, f, or period, T, where f = 1/ T.

 Ordinate: This is the vertical axis of the response spectrum. It
can be SD (spectral displacement), SV (spectral velocity), PSV
(pseudo-spectral velocity), SA (spectral acceleration) or PSA
(pseudo-spectral acceleration).
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SD, SV and SA for a given period (frequency) are calculated
as the displacement, velocity and acceleration, respectively, of
a single degree of freedom system subjected to the output time
history acceleration at the highlighted joint (on the Define tab)
in the specified vector direction (on the Define tab).

PSV and PSA are defined by Equations 12-4a and 12-4b, re-
spectively.

SD
T

2
PSV

π= Eqn. 12-4a

SD
T

2
PSA

2






= π

Eqn. 12-4b

Options Tab
The Options tab of the Response Spectrum Generation form has
the following areas:

 Abscissa: This is the horizontal axis of the response spectrum.
It can be plotted with either an Arithmetic scale or a Log scale.

The Spectrum Widening item widens the plotted peaks of the
spectrum. When you specify a percentage value for spectrum
widening, each peak in the response spectrum is widened by
the specified percentage of the frequency at the peak on both
sides of the peak value.

Important note: The spectrum widening is based on a percent-
age of the frequency at the peak regardless of whether your ab-
scissa is frequency or period.

As an example, consider the response spectrum plot shown in
Figure 12-3a. Note that this is a plot of period versus spectral
acceleration. Note that a peak occurs at 2 seconds in the plot.
Now suppose that you create the same response spectrum but
this time specify 10% spectrum widening. In that case, the
program would artificially widen the peak such that there
would be a constant peak value from 1.82 seconds to 2.22 sec-
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onds. The response spectrum with spectrum widening is shown
in Figure 12-3b. The calculations are shown in the figure.

 Ordinate: This is the vertical axis of the response spectrum.  It
can be plotted with either an Arithmetic scale or a Log scale.

The Scale Factor item linearly scales the ordinates of the re-
sponse spectrum. This scale factor can be useful if, for exam-
ple, you have run your analysis in kip and inch units and you
want to see a PSA response spectrum with the acceleration in g
(acceleration of gravity) instead of inches/second2. If this were
the case, you would specify the scale factor as 1 / 386.4 =
0.002588.

 Grid Overlay: This check box toggles on and off the display
of gridlines on the response spectrum plot.

Frequency/Period Tab
The name of this tab is either Frequency or Period, depending on
which option is chosen in the Abscissa area of the Axes tab. The
following bullet items describe the two areas on this tab.

 Include Frequencies/Periods: There are three choices for in-
cluded frequencies/periods. You can choose any combination
of these three choices. The choices are:

1.50 2.00 2.50

Period (sec)

PS
A

1.50 2.00 2.50

Period (sec)

PS
A

Calculation for widened spectrum range shown in (b)
T = 2.00 sec, therefore f = 1 / T = 1 / 2.00 = 0.5 Hz
Calculate 10% spectrum widening frequency: 0.10 f = 0.10 * 0.5 = 0.05 Hz
Calculate frequency range: fmax = 0.5 + 0.05 = 0.55 Hz,  fmin = 0.5 - 0.05 = 0.45 Hz
Calculate period range: Tmin = 1/  fmax = 1/ 0.55 = 1.82 sec,  Tmax = 1/  fmin = 1/ 0.45 = 2.22 sec

1.
82

2.
22

a) b)

Figure 12-3:
Example of spectrum
widening
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 Default: The default frequencies in Hz are: 0.2, 0.3, 0.4,
0.5, 0.6, 0.7, 0.8, 0.9, 1, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.8, 2,
2.2, 2.4, 2.6, 2.8, 3, 3.3, 3.6, 4, 4.4, 4.7, 5, 5.5, 6, 6.5, 7,
7.5, 8, 8.5, 9, 10, 11, 12, 13, 14, 15, 16.5, 18, 20, 22, 25,
28 and 33. The default periods are equal to one divided by
the default frequencies.

The default frequencies range from 0.2 Hz to 33 Hz. The
default periods range from 0.0303 seconds to 5 seconds.

 Structural: The structural periods and frequencies are
those calculated by the program for your building.

 User: The user periods and frequencies are those specified
by you in the User Frequencies/Periods area of the tab.

 User Frequencies/Periods: Specifies user frequencies or peri-
ods. To add a user frequency/period, type it in the edit box and
click the Add Value button.

To change the value of an existing user frequency/period,
highlight it in the list box. Note that it appears in the edit box
when you highlight it. Change its value in the edit box and
click the Change Value button.

To delete an existing user frequency/period, highlight it in the
list box. Note that it appears in the edit box when you highlight
it. Click the Delete Value button.

Damping Tab
On the Damping Tab, specify as many different levels of damp-
ing as you want. One response spectrum curve is then created for
each value of damping. To add a damping level, type it in the
edit box and click the Add Value button.

To change the value of an existing damping level, highlight it in
the list box. Note that it appears in the edit box when you high-
light it. Change its value in the edit box and click the Change
Value button.
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To delete an existing damping level, highlight it in the list box.
Note that it appears in the edit box when you highlight it. Click
the Delete Value button.

Show Time History Traces Command
After running a time history analysis, click the Display menu >
Show Time History Traces command or the  button to bring

up the Time History Display Definition form. In this form spec-
ify the appropriate data to plot various time history curves.

A time history trace is simply a plot of a vertical time history
function versus a horizontal time history function. The vertical
time history function can be any defined time history function.
Although the horizontal time history function defaults to Time, it
can be any defined time history function.

You can define the following types of time history functions: in-
put functions, various types of energy functions, base reaction
functions, point displacement functions, frame element force
functions, link element force or deformation functions and sec-
tion cut force functions. The time history curves can be plotted
as a function versus time (e.g., displacement versus time) or as a
function versus another function (e.g., force versus displace-
ment).

Important note: Do not confuse the terminology of time history
function implied in the Time History Display Definition form
and used in this description with the time history function that is
defined using the Define menu > Time History Function com-
mand. The Define menu command defines a time history input
function that is simply one of the types of functions (see previ-
ous paragraph) referred to here as a time history function.

When you click the Display menu > Show Time History
Traces command, the program automatically creates time his-
tory display functions for all selected objects. When inside the
Time History Display Definition form, you can define additional

Tip:

You can use the
File menu >
Create Video
command to
create videos
(movies) of
your building's
real-time de-
formations in
an earthquake.
The video is
saved as a
Windows .avi
file.
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time history display functions as desired. Often, if you want to
see a time history trace for, say a particular point, it is easiest to
select that joint before clicking the command. The program cre-
ates the time history display function automatically for the point.
You can easily modify the component of displacement displayed
if the program did not default to the one you want.

The following bullet items describe various items in the Time
History Display Definition form:

 Time History Case: This is the name of the time history case
for which you want to display a time history trace.

 Choose Functions: Specify the vertical and horizontal time
history functions that make up your time history trace. A time
history trace is simply a plot of a vertical function versus a
horizontal function. You can specify multiple vertical func-
tions for a trace but only one horizontal function.

This area has a number of buttons and list and edit boxes that
are described as follows:

 Define Functions button: This button brings up the Time
History Functions form where add new functions, delete
existing functions, or modify the components of existing
functions.

Most of the definitions and component information you
encounter using this button are self-explanatory. Standard
energy formulas are used for the program energy meas-
ures. All energies are integrated over the full structure.
Following are equations describing each type of energy
available in the program that can be plotted as a time his-
tory function:

dtv(t)F(t)IE ∫= Eqn. 12-5a

dtv(t)a(t)mKE ∫= Eqn. 12-5b
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dtv(t)u(t)kPE ∫= Eqn. 12-5c

dt(t)vcMDE 2∫= Eqn. 12-5d

∫ −= dtv(t)]u(t)D(t)v[DNDE stiffavgforce Eqn. 12-5e

∫ −= dtv(t)]u(t)L(t)v[LLE stiffavgforce Eqn. 12-5f

EE = IE - KE - PE - MDE - NDE - LE Eqn. 12-5g

where,

IE = Input energy

KE = Kinetic energy

PE = Potential energy

MDE = Modal damping energy

NDE = Nonlinear damping energy from link elements
that are dampers. Note that this excludes the
potential energy already accounted for in PE
(the subtracted term).

LE = Link element energy (not including dampers).
Note that this excludes the potential energy al-
ready accounted for in PE (the subtracted
term).

EE = Energy error

a = Acceleration

c = Modal damping

Dforce = Force in link elements that are dampers

Dstiff = Stiffness of link elements that are dampers
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F = External force

k = Stiffness

Lforce = Force in link elements (not including dampers)

Lstiff = Stiffness of link elements (not including
dampers)

m = mass

t = time

u = displacement

v = Velocity

vavg = Average velocity over a time step

Note that for ground-acceleration input, all displacements,
velocities and accelerations above are relative to the
ground motion. The external force is the ground accelera-
tion times the mass of the structure.

 List of Functions - The list box entitled List of Functions
lists all of the currently defined time history functions.
Highlight a function in this list box and click the Add
button to move the function into the Vertical Functions list
box.

 Vertical Functions - The Vertical Functions list box lists
all of the time history functions that will be plotted versus
the single specified horizontal function in the current time
history trace. To remove a function from the Vertical
Functions list box, highlight the function and click the
Remove button.

 Horizontal Function - The horizontal time history func-
tion is selected from the Horizontal Function drop-down
box. This box includes all defined time history functions
and Time. The default is Time.
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 Selected Function Line Options: The individual line func-
tions apply separately to each vertical function that is defined.
To specify individual line options for a function, first highlight
the function in the Choose Functions area and then specify the
line options.

The vertical scale factor is a scale factor for the vertical func-
tion only. It does not scale the horizontal function in any way.

 Time Range: Specifies any time range to be plotted. This can
be useful if you only want to plot a portion of a full time his-
tory. This item applies whether you are plotting a function ver-
sus time or a function versus another function.

 Axes Range Override: This area allows you to change the
range plotted for both axes. If you are plotting function versus
time, the horizontal axis range override overrides the specified
Time Range.

For example, assume you have 10 seconds of earthquake out-
put. Further assume that you have adjusted the time range to be
from 0 to 5 seconds. Now if you override the horizontal axis to
be from 0 to 3, only three seconds of the time history output
plots. If you instead override the horizontal axis to be from 0 to
10, the time history plots from 0 to 5, as specified from in the
Time Range area, but the horizontal axis plots from 0 to 10
seconds. Thus, the earthquake plot fills half of the horizontal
axis length.

 Axes Labels: The axes labels that you type here appear on the
screen plots and on printed plots.

 Grid Overlay: This check box toggles on and off the display
of gridlines on the time history plot.

 Display button:  Click this button to display the plot you have
defined in this form.

 Done button:  Click this button to close the Time History Dis-
play Definition form.

Note:

The Selected
Function Line
Options can be
different for
each vertical
function
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 File Menu - There is a File menu at the top of the window that
displays the traces. This File menu allows you to print graphics
of the plot or to print tables either to a file or to a printer.
Printing time history functions to a file is useful if you then
want to take the data in the file and plot it in another program,
for example, a spreadsheet.

Set Output Table Mode Command
Click the Display menu > Set Output Table Mode command or
the  button to open the Display Output Tables form. In this

form, select the type of information you want to include in the
output tables. The options available are self-explanatory. Se-
lecting an option will include it in the output table.

Note that some of the options may be inactive. This is because
the current model type does not include those options. For ex-
ample, the Spring Forces option will be inactive if no springs
have been  defined in the model.

Select Loads Button
Click the Select Loads button to indicate for which load case you
want to display or print the output data. You can select one or
more load cases at the same time.

Section Cut Button
You can select the type of Section Cuts that have been defined
previously using the Define menu> Section Cuts command to
be included in the output tables. This can be accomplished by
clicking the Section Cut button. This will open the Select Section
Cuts dialogue box. Click on the Section Cuts to be included in
the output and click the OK button.
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Chapter 13

Design Menu

Overview
The Design menu serves as your gateway to the integrated de-
sign postprocessors that are a part of your program package. The
design postprocessors available are:

 Steel Frame Design

 Concrete Frame Design

 Composite Beam Design

 Steel Joist Design

 Shear Wall Design

For each of the design postprocessors, you can access the fol-
lowing types of commands from the Design menu.

 Review and/or select design load combinations.

 Review and/or select overwrites.
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 Start the design or check of the structure.

 Perform interactive design.

 Display input and output design information on the model.

 Perform various other tasks specific to the various design post-
processors.

Note that you use the File menu > Print Tables command to
print design output from the various design postprocessors in a
tabular form.

Background
The frame design procedure identifies the design post processor
that will design a particular line object. The design procedure is
reported in the Line Information form, which appears when you
right click on a line object.

The design procedure is always one of the following four items:

 Steel Frame Design

 Concrete Frame Design

 Composite Beam Design

 Null (no design)

 See the subsequent section entitled "Overwrite Frame Design
Procedure Command" for more information.

Default Design Procedure Assignments
The default design procedure assignments are determined by the
program as follows:

 Null: If the line object is not assigned a frame section prop-
erty, its default design procedure is Null.

 Concrete Frame Design: If the line object is assigned a frame
section property that has a concrete material property, its de-
fault design procedure is Concrete Frame Design.
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 Composite Beam Design: If the line object is assigned a
frame section property that has a steel material property and it
meets all of the criteria listed in the bullets that follow, its de-
fault design procedure is Composite Beam Design.

 The line type is Beam; that is, the line object is horizon-
tal.

 The frame element is oriented with its positive local 2-
axis in the same direction as the positive global Z-axis
(vertical upward).

 The frame element has I-section or channel section
properties.

 The M3 (major) moment is released at each end of the
frame element; that is, it is pinned.

 A deck property (not slab property) is assigned to an
area object located on top of the beam. The beam and the
area object must be in the same plane.

 Steel Joist Design: If the line object is assigned a frame sec-
tion property that has a steel material property and it meets all
of the criteria listed in the bullets that follow, its default design
procedure is Steel Joist Design.

 The line type is Beam; that is, the line object is horizon-
tal.

 The frame element is oriented with its positive local 2-
axis in the same direction as the positive global Z-axis
(vertical upward).

 The frame element has joist section properties.

 The M3 (major) moment is released at each end of the
frame element; that is, it is pinned.

 Steel Frame Design: If the line object is assigned a frame
section property that has a steel material property and it does
not qualify to have its design procedure set to Composite
Beam Design, its default design procedure is Steel Frame De-
sign.

Tip:

If you have
modeled a floor
or roof with
slightly sloping
beams and you
want to design
the beams using
the Composite
Beam Design
postprocessor,
first make all of
the beams hori-
zontal. Do this
using the Edit
menu > Align
Points/ Lines/
Edges com-
mand and se-
lecting the
"Align to Z Co-
ordinate of"
option.
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Steel Frame Design Command
Clicking the Design menu > Steel Frame Design command or
the  button activates a drop-down menu of the commands that
control the Steel Frame Design postprocessor. This section de-
scribes those menu commands.

Steel Frame Design > Select Design Group Command
In steel frame design, you have the option of grouping elements
for design. When you specify a group for design, all elements in
the group are given the same section. Note the following infor-
mation related to using groups for steel frame design.

 Define the groups in the usual way; that is, by selecting the
frame elements and clicking the Assign menu > Group
Names command.

 After the group has been defined, use the Design menu > Steel
Frame Design > Select Design Group command to designate
that the group is to be used as a design group.

 Designing with groups only works if you have assigned auto
select sections to the frame elements. Typically, you would as-
sign the same auto select section to each frame element in the
group, although this is not absolutely necessary. Any frame
elements in a design group not assigned an auto select section
are ignored for group design and are designed individually.

Steel Frame Design > Select Design Combo Command
Click the Design menu > Steel Frame Design > Select Design
Combo command to open the Design Load Combinations Se-
lection form. Here you can review the default steel frame design
load combinations defined by the program, or you can designate
your own design load combinations.

In the form all of the available design load combinations are
listed in the List of Combos list box. The design load combina-
tions actually used in the design are listed in the Design Combos
list box. You can use the Add button and the Remove button to
move load combinations into and out of the Design Combos list
box. Use the Show button to see the definition of a design load

Tip:

Frame elements
designed as a
part of a group
must be as-
signed auto
select section
lists.

Note:

Frame elements
designed as a
group are all
given the same
section size
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combination. All three buttons act on the highlighted design load
combination. You can use the Ctrl and Shift keys to make multi-
ple selections in this form for use with the Add and Remove
buttons, if desired.

The default steel frame design load combinations have names
such as DSTL1.

Steel Frame Design > View/Revise Overwrites Command
Use the Design menu > Steel Frame Design > View/Revise
Overwrites command to review or change the steel frame over-
writes. You may not need to assign any steel frame overwrites;
however, the option is available.

The steel frame design overwrites are basic properties that apply
only to the frame elements to which they are specifically as-
signed. Some of the default overwrite values are based on steel
frame preferences. Thus, you should define the preferences be-
fore defining the overwrites (and, of course, before designing or
checking any steel frame members).

Select one or more frame elements for which you want to specify
overwrites. To change an overwrite, check the check box to the
left of the overwrite name and then click in the cell to the right of
the overwrite name to change the overwrite.

You must check the box to the left of an overwrite item for that
item to be changed in the overwrites. If the check box for an item
is not checked when you click the OK button to exit the over-
writes form, no changes are made to the item. This is true
whether you have one frame element selected or multiple frame
elements selected.

Steel Frame Design > Set Lateral Displacement Targets
Command

Click the Design menu > Steel Frame Design > Set Lateral
Displacement Targets command to open the Lateral Displace-
ment Targets form where you can specify displacement targets
for various load cases. Our intent is that you pick a point, typi-
cally at the roof level of your building, and specify a maximum
displacement target (in any direction) for one or more load cases.

Tip:

The steel frame
design over-
writes only ap-
ply to the frame
elements to
which they are
specifically
assigned.
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In the Loads area of the form, specify the Load Case for which
you want to optimize the displacement, the location where you
are specifying the displacement (by point ID and story level) and
the target displacement. When those parameters have been speci-
fied to your satisfaction in the Loads area, click the Add button.
Specify as many load cases and displacements as you want.

If you want to modify an existing displacement target specifica-
tion, highlight it in the Loads area. Note that the data for the
specification appears in the edit boxes at the top of the Loads
area. Modify the data in the boxes as desired. Then click the
Modify button.

If you want to delete an existing displacement target specifica-
tion, highlight it in the Loads area. Note that the data for the
specification appears in the edit boxes at the top of the Loads
area. Then click the Delete button.

Note the following about the displacement optimization per-
formed by the program:

 The program predicts which members should be increased in
size to control the displacements based on the energy per unit
volume in the members. The members with more energy per
unit volume are increased in size a larger percentage than those
with smaller energies per unit volume. Some members with
small energy per unit volume may be decreased in size if they
are still acceptable for strength considerations.

 You must have auto select lists assigned to the frame elements
for the displacement optimization to do anything. When the
program goes to increase or decrease a section size, it uses the
available sizes in the auto select list.

 There is no guarantee that you will reach your displacement
target just because you specified this option. You always need
to rerun your analysis with the new section sizes to see what
your new displacements are. Displacement optimization is an
iterative process that typically requires you to rerun the analy-
sis and design multiple times.

 If the appropriate sections are not in your auto select lists, you
may never reach your displacement target, regardless of how
many times you iterate by rerunning the analysis and design.

Tip:

Frame elements
must have auto
select list as-
signments to be
designed using
displacement
optimization.
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Steel Frame Design > Start Design/Check of Structure
Command

To run a steel frame design, click Design menu > Steel Frame
Design > Start Design/Check of Structure. This option will not
be available if you have not first run a building analysis. It will
also be unavailable if no frame elements with the Steel Frame
design procedure are in the model.

If you have selected frame elements when you click this com-
mand, only the selected frame elements are designed. If no frame
elements are selected when you click this command, all steel
frame elements with the Steel Frame design procedure are de-
signed. The results are displayed on screen in the active window.

Steel Frame Design > Interactive Steel Frame Design
Command

Interactive steel frame design allows you to review the design re-
sults for any frame element and to interactively change the de-
sign overwrites and immediately view the results again.

Right click on a frame element while the design results are dis-
played on it to enter the interactive design mode and interac-
tively design the element. If you are not currently displaying de-
sign results, click the Design menu > Steel Frame Design > In-
teractive Steel Frame Design command and then right click a
frame element to enter the interactive design mode for that ele-
ment.

Steel Frame Design > Display Design Info Command
You can review some of the results of the steel frame design di-
rectly on the program model using the Design menu > Steel
Frame Design > Display Design Info command. The types of
things you can display include design sections, unbraced lengths,
effective length factors, allowable stresses, and stress ratio in-
formation. Clicking this command brings up the Display Design
Results form, which allows you to choose Design Output or De-
sign Input data types.
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Steel Frame Design > Make Auto Select Section Null Com-
mand

The Design menu > Steel Frame Design > Make Auto Select
Section Null command is used to remove auto select section lists
from selected frame elements. Typically you should remove auto
select lists from all frame elements near the end of the iterative
design process so that your final design iteration is performed
using the actual frame sections assigned, not auto select sections.

Setting the auto select section to null does not change the current
design section for the frame element.

The Make Auto Select Section Null command only works on a
selection that you make. Thus you should select the elements for
which you want to make the auto select sections null before exe-
cuting this command. If you do not select any elements, this
command will not be available. Often you may want to select all
elements before executing this command.

The Make Auto Select Section Null command is not active until
the first design has been run. If you have not yet run a design and
you want to remove the auto select property, use the Assign
menu > Frame/Line > Frame Section command to change the
section property.

Steel Frame Design > Change Design Section Command
After you have run a steel frame design, you may want to change
the design section property assigned to one or more frame ele-
ments and then rerun the design without first rerunning the
analysis. You can use the Design menu > Steel Frame Design >
Change Design Section command to change the design section
property, and then use the Design menu > Steel Frame Design
> Start Design/Check of Structure to rerun the design.

The Change Design Section command only works on a selec-
tion that you make. Thus you should select the elements for
which you want to change the design sections before executing
this command. If you do not select any elements, this command
will not be available.

The Change Design Section command only changes the design
section for the frame element. The forces used in the design are

Tip:

You normally
use the Make
Auto Select
Section Null
feature near the
end of the it-
erative design
process.

Note:

You can change
the element
design sections
and rerun the
design as many
times as you
want without
rerunning the
analysis.
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not based on this new section size but are instead based on what-
ever section was used in the last analysis.

Recall, however, that the design section property is used for the
next analysis section property. Thus changing the design section
property also changes the next analysis section property. If an
auto select section is assigned to a frame element, you can con-
trol the section property used for that frame element in the next
analysis by setting the design section property to the desired sec-
tion using the Change Design Section command and then re-
running the analysis.

Steel Frame Design >  Reset Design Section to Last Analy-
sis Command

In some instances you may change your design section several
times and then decide that you want to set the design section for
one or more frame elements back to the last used analysis sec-
tion. The Design menu > Steel Frame Design > Reset Design
Section to Last Analysis command gives you a quick and easy
way of doing this.

The Reset Design Section to Last Analysis command only
works on a selection that you make. Thus, before implementing
this command, select the elements for which you want to reset
the design sections. If you do not select any elements, this com-
mand will not be available.

Steel Frame Design > Verify Analysis vs Design Section
Command

When the iterative design process is complete, the last used
analysis section property for a frame element and the current de-
sign section property for that frame element should be the same.
If this is not the case, the frame element may not have been de-
signed for the correct forces. The Design menu > Steel Frame
Design > Verify Analysis vs Design Section command is useful
for verifying that the last used analysis section and the current
design section are the same for all steel frame elements in the
model.
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When you execute the Verify Analysis vs Design Section com-
mand, the program tells you how many frame elements with the
Steel Frame design procedure have different analysis and design
sections, and then selects those frame elements if you tell it to do
so. Typically you might use this command after you have run
what you believe is your last design iteration just to verify that
the analysis and design properties used are consistent.

It is not necessary to make a selection before using the Verify
Analysis vs Design Section command. This command automati-
cally checks all frame sections with the Steel Frame design pro-
cedure.

Steel Frame Design > Verify All Members Passed Command
The Verify All Members Passed command works in conjunc-
tion with the Start Design/Check of Structure command. Thus,
you must first run an analysis and use the Start Design/Check
of Structure command before using the Verify All Members
Passed command. When this command is used, the program re-
ports if structural members have passed the stress/capacity
check.

Steel Frame Design > Reset All Steel Overwrites Com-
mands

The Design menu > Steel Frame Design > Reset All Steel
Overwrites command resets the overwrites for all frame sections
with the Steel Frame design procedure to their default values. It
is not necessary to make a selection before using the Reset All
Steel Overwrites command. This command automatically ap-
plies to all frame sections with the Steel Frame design procedure.

Resetting your overwrites will reduce the size of your program
database (*.edb) file.

Steel Frame Design > Delete Steel Design Results Com-
mand

The Design menu > Steel Frame Design > Delete Steel Design
Results command deletes all of the steel frame design results. It
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is not necessary to make a selection before using the Delete
Steel Design Results command. This command automatically
applies to all frame sections with the Steel Frame design proce-
dure.

Deleting your steel frame design results will reduce the size of
your program database (*.edb) file. Note that deleting your steel
design results does not delete your current design section (next
analysis section).

Concrete Frame Design Command
Clicking the Design menu > Concrete Frame Design command
or the  button activates a drop-down menu of the commands
that control the Concrete Frame Design postprocessor. This sec-
tion describes those menu commands.

Concrete Frame Design > Select Design Combo Command
Click the Design menu > Concrete Frame Design > Select De-
sign Combo command to open the Design Load Combinations
Selection form. In this form you can review the default concrete
frame design load combinations defined by the program or you
can designate your own design load combinations.

In the form all of the available design load combinations are
listed in the List of Combos list box. The design load combina-
tions actually used in the design are listed in the Design Combos
list box. Use the Add button and the Remove button to move
load combinations into and out of the Design Combos list box.
Use the Show button to see the definition of a design load com-
bination. All three buttons act on the highlighted design load
combination. Use the Ctrl and Shift keys to make multiple selec-
tions in this form for use with the Add and Remove buttons, if
desired.

The default concrete frame design load combinations have
names such as DCON1.
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Concrete Frame Design > View/Revise Overwrites Com-
mand

Use the Design menu > Concrete Frame Design > View/ Re-
vise Overwrites command to review or change the concrete
frame overwrites. You may not need to assign any concrete
frame overwrites; however, the option is available.

The concrete frame design overwrites are basic properties that
apply only to the frame elements to which they are specifically
assigned. Some of the default overwrite values are based on con-
crete frame preferences. Thus, you should define the preferences
before defining the overwrites (and, of course, before designing
or checking any concrete frame members).

Select one or more frame elements for which you want to specify
overwrites. To change an overwrite, check the check box to the
left of the overwrite name and then click in the cell to the right of
the overwrite name to change the overwrite.

You must check the box to the left of an overwrite item for that
item to be changed in the overwrites. If the check box for an item
is not checked when you click the OK button to exit the over-
writes form, no changes are made to the item. This is true
whether you have one frame element selected or multiple frame
elements selected.

Concrete Frame Design > Start Design/Check of Structure
Command

To run a concrete frame design simply click Design menu >
Concrete Frame Design > Start Design/Check of Structure.
This option will not be available if you have not first run a
building analysis. It will also be unavailable if there are no frame
elements with the Concrete Frame design procedure in the
model.

If you have selected frame elements when you click this com-
mand, only the selected frame elements are designed. If no frame
elements are selected when you click this command, all concrete
frame elements with the Concrete Frame design procedure are
designed.

Tip:

The concrete
frame design
overwrites only
apply to the
frame elements
to which they
are specifically
assigned.
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Concrete Frame Design > Interactive Concrete Frame De-
sign Command

Interactive concrete frame design allows you to review the de-
sign results for any frame element and to interactively change the
design overwrites and immediately view the results.

Right click on a frame element while the design results are dis-
played on it to enter the interactive design mode and interac-
tively design the element. If you are not currently displaying de-
sign results, click the Design menu > Concrete Frame Design
> Interactive Concrete Frame Design command and then right
click a frame element to enter the interactive design mode for
that element.

Concrete Frame Design > Display Design Info
You can review some of the results of the concrete frame design
directly on the program model using the Design menu > Con-
crete Frame Design > Display Design Info command. The
types of things you can display include design sections, unbraced
lengths and longitudinal reinforcing.

Concrete Frame Design > Change Design Section
After you have run a concrete frame design, you may want to
change the design section property assigned to one or more
frame elements and then rerun the design without first rerunning
the analysis. You can use the Design menu > Concrete Frame
Design > Change Design Section command to change the de-
sign section property and then use the Design menu > Concrete
Frame Design > Start Design/Check of Structure to rerun the
design.

The Change Design Section command only works on a selec-
tion that you make. Thus you should select the elements for
which you want to change the design sections before executing
this command. If you do not select any elements, this command
will not be available.

The Change Design Section command only changes the design
section for the frame element. The forces used in the design are

Note:

You can change
the element
design sections
and rerun the
design as many
times as you
want without
rerunning the
analysis.
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not based on this new section size but are instead based on the
section used in the last analysis.

Recall, however, that the design section property is used for the
next analysis section property. Thus changing the design section
property also changes the next analysis section property. If an
auto select section is assigned to a frame element, control the
section property used for that frame element in the next analysis
by setting the design section property to the desired section using
the Change Design Section command and then rerunning the
analysis.

Concrete Frame Design > Reset Design Section to Last
Analysis Command

In some instances you may change your design section several
times and then decide that you want to set the design section for
one or more frame elements back to the last used analysis sec-
tion. The Design menu > Concrete Frame Design > Reset De-
sign Section to Last Analysis command gives you a quick and
easy way of doing this.

The Reset Design Section to Last Analysis command only
works on a selection that you make. Thus, before implementing
this command, select the elements for which you want to reset
the design sections. If you do not select any elements, this com-
mand will not be available.

Concrete Frame Design > Verify Analysis vs Design Section
Command

When the iterative design process is complete, the last used
analysis section property for a frame element and the current de-
sign section property for that frame element should be the same.
If this is not the case, the frame element may not have been de-
signed for the correct forces. The Design menu > Concrete
Frame Design > Verify Analysis vs Design Section command
is useful for verifying that the last used analysis section and the
current design section are the same for all concrete frame ele-
ments in the model.
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When you execute the Verify Analysis vs Design Section com-
mand the program tells you how many frame elements with the
Concrete Frame design procedure have different analysis and de-
sign sections and then selects those frame elements, if you ask it
to do so. Typically you might use this command after you have
run what you believe is your last design iteration to verify that
the analysis and design properties used are consistent.

It is not necessary to make a selection before using the Verify
Analysis vs Design Section command. This command automati-
cally checks all frame sections with the Concrete Frame design
procedure.

Concrete Frame Design > Reset All Concrete Overwrites
Command

The Design menu > Concrete Frame Design > Reset All Con-
crete Overwrites command resets the overwrites for all frame
sections with the Concrete Frame design procedure to their de-
fault values. It is not necessary to make a selection before using
the Reset All Concrete Overwrites command. This command
automatically applies to all frame sections with the Concrete
Frame design procedure.

Resetting your overwrites will reduce the size of your program
database (*.edb) file.

Concrete Frame Design > Delete Concrete Design Results
Command

The Design menu > Concrete Frame Design > Delete Con-
crete Design Results command deletes all of the concrete frame
design results. It is not necessary to make a selection before us-
ing the Delete Concrete Design Results command. This com-
mand automatically applies to all frame sections with the Con-
crete Frame design procedure.

Deleting your concrete frame design results will reduce the size
of your program database (*.edb) file. Note that deleting your
concrete design results does not delete your current design sec-
tion (next analysis section).
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Composite Beam Design Command
Clicking the Design menu > Composite Beam Design com-
mand or the  button activates a drop-down menu of the
commands that control the Composite Beam Design
postprocessor. This section describes those menu commands.

Composite Beam Design > Select Design Group Command
In composite beam design, you have the option of grouping ele-
ments for design. When you specify a group for design, all ele-
ments in the group are given the same beam size. Note the fol-
lowing information related to using groups for design of com-
posite beams.

 Define the groups in the usual way; that is, by selecting the
beam elements and clicking the Assign menu > Group
Names command.

 After the group has been defined, use the Design menu >
Composite Beam Design > Select Design Group command
to designate that the group is to be used as a design group.

 Designing with groups only works if you have assigned auto
select sections to the beams. Typically you would assign the
same auto select section to each beam in the group, although
this is not absolutely necessary. Any beams in a design group
not assigned an auto select section are ignored for group de-
sign and are designed individually.

Note that when beams are designed in a group, they will all have
the same beam size, but the shear connectors and camber may be
different.

Composite Beam Design > Select Design Combo Com-
mand

Clicking the Design menu > Composite Beam Design > Select
Design Combo command brings up the Design Load Combina-
tions Selection form. In this form, review the default composite
beam design load combinations defined by the program or des-
ignate your own design load combinations. Note that for com-

Tip:

Beams designed
as a part of a
group must be
assigned auto
select section
lists.

Note:

Beams designed
as a group are
all given the
same beam
size; however,
each beam in
the group may
have a different
number of
shear connec-
tors and differ-
ent camber.
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posite beam design, separate design load combinations are speci-
fied for construction loading, final loading considering strength,
and final loading considering deflection. Each of those types of
design load combinations is specified on a separate tab of the
form.

In the form, all of the available design load combinations are
listed in the List of Combos list box. The design load combina-
tions actually used in the design are listed in the Design Combos
list box. You can use the Add button and the Remove button to
move load combinations into and out of the Design Combos list
box. Use the Show button to see the definition of a design load
combination. All three buttons act on the highlighted design load
combination. Use the Ctrl and Shift keys to make multiple selec-
tions in this form for use with the Add and Remove buttons, if
desired.

The default composite beam design load combinations have
names such as DCMPC1. The naming conventions is described
as follows:

 DCMPCn: The D stands for Design. The CMP stands for
composite. The last C stands for construction. The n item is a
number. Design load combinations with this type of designa-
tion are the program default for construction loading in com-
posite design.

 DCMPSn: The D stands for Design. The CMP stands for
composite. The S stands for strength. The n item is a number.
Design load combinations with this type of designation are the
program default for strength considerations under final loading
in composite design.

 DCMPDn: The D stands for Design. The CMP stands for
composite. The last D stands for deflection. The n item is a
number. Design load combinations with this type of designa-
tion are the program default for deflection considerations un-
der final loading in composite design.
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Composite Beam Design > View/Revise Overwrites Com-
mand

Use the Design menu > Composite Beam Design >
View/Revise Overwrites command to review or change the
composite beam overwrites. You may not need to assign any
composite beam overwrites; however, the option is available. If
you are using cover plates or user-defined shear connector pat-
terns, you must assign them through the overwrites. This is the
only place available to assign those items.

The composite beam design overwrites are basic properties that
apply only to the beams to which they are specifically assigned.
Some of the default overwrite values are based on composite
beam preferences. Thus define the preferences before defining
the overwrites (and before designing or checking any composite
beam).

Select one or more beams for which you want to specify over-
writes. To change an overwrite, check the check box to the left
of the overwrite name and then click in the cell to the right of the
overwrite name. When you click in the cell, you activate a drop
down box where you can select a choice or you are able to type
data into the cell. Note that information about each item in the
overwrites is provided at the bottom of the form when you click
on the item.

You must check the box to the left of an overwrite item for that
item to be changed in the overwrites. If the check box for an item
is not checked when you click the OK button to exit the over-
writes form, no changes are made to the item. This is true
whether you have one beam selected or multiple beams selected.

Composite Beam Design > Start Design Using Similarity
Command

If you are designing using similarity, the program assumes that if
a composite beam is located at a story designated as similar to a
master story, then that composite beam has the same composite
beam size as the composite beams of the master story (set a story
Similar To a master story in the Story Data; see the Edit menu >
Edit Story Data > Edit Story command). Thus, the program de-
signs the composite beam at the master story and then copies that

Tip:

The composite
beam design
overwrites only
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cifically as-
signed.
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design to the other stories designated as similar to the master
story. Note that in the composite beam overwrites, you can
specify that similarity be ignored for a composite beam; in which
case the composite beam will be designed, not copied from a
master story level.

To run a composite beam design and take advantage of similar-
ity, click the Design menu > Composite Beam Design > Start
Design Using Similarity command. It is not necessary to run
the full building analysis (i.e., use the Analyze menu > Run
Analysis command) before using the Start Design Using Simi-
larity command. However, if a full building analysis has not
been run when the Start Design Using Similarity command is
used, the program will run an analysis on a story-by-story basis,
analyzing only those stories for which analysis is needed to per-
form the design.

The story-by-story analysis is much quicker than the full build-
ing analysis. However, if, for example, columns from one story
frame down onto beams in another story, the loads in those col-
umns will not be accounted for in a single-story analysis.

Note that the final design should always be based on a full
building analysis, not single-story analyses. Also, final design
should use the Design menu > Composite Beam Design >
Composite Beam Design Command 13 - 19

Start Design Without Similarity command.

Composite Beam Design > Start Design Without Similarity
Command

To run a composite beam design that excludes the similarity
features described in the previous section, click the Design
menu > Composite Beam Design > Start Design Without
Similarity command. Note that for this option to be available,
you must first use the Analyze menu > Run Analysis command
to run a full building analysis.

If composite beams have been selected when you click this
command, only the selected beams are designed. If no beams are
selected when you click this command, all composite beams are
designed.
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Composite Beam Design > Interactive Composite Beam
Design Command

Interactive composite beam design is a powerful feature that al-
lows you to review the design results for any composite beam
and to interactively change the design assumptions and immedi-
ately view the results.

Right click on a beam while the design results are displayed on it
to enter the interactive design mode and interactively design the
beam. If you are not currently displaying design results you can
click the Design menu > Composite Beam Design > Interac-
tive Composite Beam Design command and then right click a
beam to enter the interactive design mode for that beam.

Composite Beam Design > Display Design Info Command
Review some of the results of the composite beam design di-
rectly on the program model using the Design menu > Com-
posite Beam Design > Display Design Info command. The
types of things you can display are beam labels and associated
design group names; design sections together with connector
layout, camber and end reactions; and stress ratio information.

Composite Beam Design > Make Auto Select Section Null
Command

The Design menu > Composite Beam Design > Make Auto
Select Section Null command is used to remove auto select sec-
tion lists from selected beams. Typically you should remove auto
select lists from all beams near the end of the iterative design
process so that your final design iteration is performed using ac-
tual beam sections assigned, not auto select sections.

Setting the auto select section to null does not change the current
design section for the beam.

The Make Auto Select Section Null command only works on a
selection that you make. Thus, select the elements for which you
wan to make the auto select sections null before executing this
command. If you do not select any elements, this command will
not be available. Often you may want to select all elements be-
fore executing this command.

Tip:

You normally
use the Make
Auto Select
Section Null
feature near the
end of the it-
erative design
process.
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The Make Auto Select Section Null command is not active until
the first design has been run. If you have not yet run a design and
you want to remove the auto select property, use the Assign
menu > Frame/Line > Frame Section command to change the
section property.

Composite Beam Design > Change Design Section Com-
mand

After you have run a composite beam design, you may want to
change the design section property assigned to one or more
beams and then rerun the design without first rerunning the
analysis. You can use the Design menu > Composite Beam De-
sign > Change Design Section command to change the design
section property and then rerun the design.

The Change Design Section command only works on a selec-
tion that you make. Thus you should select the elements for
which you want to change the design sections before executing
this command. If you do not select any elements, this command
will not be available.

The Change Design Section command only changes the design
section for the beam. The forces used in the design are not based
on this new section size but are instead based on the section used
in the last analysis.

Recall, however, that the design section property is used for the
next analysis section property. Thus, changing the design section
property also changes the next analysis section property. If an
auto select section is assigned to a beam, control the section
property used for that beam in the next analysis by setting the
design section property to the desired beam size using the
Change Design Section command and then rerunning the analy-
sis.

Composite Beam Design > Reset Design Section to Last
Analysis Command

In some instances you may change your design section several
times and then decide that you want to set the design section for
one or more beams back to the last used analysis section. The

Note:

You can change
the element
design sections
and rerun the
design as many
times as you
want without
rerunning the
analysis.
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Design menu > Composite Beam Design > Reset Design Sec-
tion to Last Analysis command gives you a quick and easy way
of doing this.

The Reset Design Section to Last Analysis command only
works on a selection that you make. Thus, before implementing
this command, select the elements for which you want to reset
the design sections. If you do not select any elements, this com-
mand will not be available.

Composite Beam Design > Verify Analysis vs Design Sec-
tion Command

When the iterative design process is complete, the last used
analysis section property for a beam and the current design sec-
tion property for a beam should be the same. If this is not the
case, the beam may not have been designed for the correct
forces. The Design menu > Composite Beam Design > Verify
Analysis vs Design Section command is useful for verifying that
the last used analysis section and the current design section are
the same for all composite beams in the model.

When you execute the Verify Analysis vs Design Section com-
mand, the program tells you how many beams have different
analysis and design sections and then selects those beams, if you
tell it to do so. Typically you might use this command after you
have run what you believe is your last design iteration to verify
that the analysis and design properties used are consistent.

It is not necessary to make a selection before using the Verify
Analysis vs Design Section command. This command automati-
cally checks all composite beam sections.

Composite Beam Design > Verify All Members Passed
Command

The Verify All Members Passed command reports how many
structural members have passed the stress/capacity check.
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Composite Beam Design > Reset All Composite Beam
Overwrites Command

The Design menu > Composite Beam Design > Reset All
Composite Beam Overwrites command resets the composite
beam overwrites for all composite beam sections back to their
default values. It is not necessary to make a selection before us-
ing the Reset All Composite Beam Overwrites command. This
command automatically applies to all composite beam sections.

Resetting your composite beam overwrites will reduce the size
of your program database (*.edb) file.

Composite Beam Design > Delete Composite Beam Design
Results Command

The Design menu > Composite Beam Design > Delete Com-
posite Beam Design Results command deletes all of the com-
posite beam results. It is not necessary to make a selection before
using the Delete Composite Beam Design Results command.
This command automatically applies to all composite beam sec-
tions.

Deleting your composite beam results will reduce the size of
your program database (*.edb) file. Note that deleting your com-
posite beam design results does not delete your current design
section (next analysis section).

Steel Joist Design Command
Clicking the Design menu > Steel Joist Design command or the

 button activates a drop-down menu of the commands that
control the Steel Joist Design postprocessor. This section de-
scribes those menu commands.

Steel Joist Design > Select Design Group Command
In steel joist design, you have the option of grouping elements
for design. When you specify a group for design, all elements in
the group are given the same joist size. Note the following in-
formation related to using groups for design of steel joists.
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 Define the groups in the usual way; that is, by selecting the
joist elements and clicking the Assign menu > Group Names
command.

 After the group has been defined, use the Design menu > Steel
Joist Design > Select Design Group command to designate
that the group is to be used as a design group.

 Designing with groups only works if you have assigned auto
select sections to the joists. Typically, you would assign the
same auto select section to each joist in the group, although
this is not absolutely necessary. Any joists in a design group
not assigned an auto select section are ignored for group de-
sign and are designed individually.

Steel Joist Design > Select Design Combo Command
Clicking the Design menu > Steel Joist Design > Select Design
Combo command brings up the Design Load Combinations Se-
lection form. In this form, review the default steel joist design
load combinations defined by the program or designate your own
design load combinations.

In the form, all of the available design load combinations are
listed in the List of Combos list box. The design load combina-
tions actually used in the design are listed in the Design Combos
list box. You can use the Add button and the Remove button to
move load combinations into and out of the Design Combos list
box. Use the Show button to see the definition of a design load
combination. All three buttons act on the highlighted design load
combination. Use the Ctrl and Shift keys to make multiple selec-
tions in this form for use with the Add and Remove buttons.

Steel Joist Design > View/Revise Overwrites Command
Use the Design menu > Steel Joist Design > View/Revise
Overwrites command to review or change the steel joist over-
writes. You may not need to assign any steel joist overwrites;
however, the option is available.

Select one or more beams for which you want to specify over-
writes. To change an overwrite, check the check box to the left
of the overwrite name and then click in the cell to the right of the

Tip:

Joists designed
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overwrite name. When you click in the cell, a drop-down box is
activated where you can select a choice or type data into the cell.
Note that information about each item in the overwrites is pro-
vided at the bottom of the form when you click on the item.

You must check the box to the left of an overwrite item for that
item to be changed in the overwrites. If the check box for an item
is not checked when you click the OK button to exit the over-
writes form, no changes are made to the item. This is true
whether you have one joist selected or multiple joists selected.

Steel Joist Design > Start Design Using Similarity Com-
mand

When you design using similarity, the program assumes that if a
joist is located at a story designated as similar to a master story,
that joist has the same joist size as the joists of the master story
(set a story Similar To a master story in the Story Data; see the
Edit menu > Edit Story Data > Edit Story command). Thus,
the programs designs the joist at the master story and then copies
that design to the other stories designated as similar to the master
story. Note that in the steel joist overwrites, you can specify that
similarity be ignored for a joist, in which case the joist will be
designed, not copied from a master story level.

To run a steel joist design and take advantage of similarity, click
the Design menu > Steel Joist Design > Start Design Using
Similarity command. It is not necessary to run a full building
analysis (i.e., use the Analyze menu > Run Analysis command)
before using the Start Design Using Similarity command.
However, if a full building analysis has not been run when the
Start Design Using Similarity command is used, the program
will run the analysis on a story-by-story basis, analyzing only
those stories for which analysis is needed to perform the design.

The story-by-story analysis is much quicker than the full build-
ing analysis. However, if, for example, columns from one story
frame down onto beams in another story, the loads in those col-
umns will not be accounted for in the single-story analysis.

Note that final design should always be based on a full building
analysis, not single-story analyses. Also, final design should use
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the Design menu > Steel Joist Design > Start Design Without
Similarity command.

Steel Joist Design > Start Design Without Similarity Com-
mand

To run a steel joist design that excludes the similarity features
described in the previous section, click the Design menu > Steel
Joist Design > Start Design Without Similarity command.
Note that for this option to be available,  you must first run a full
building analysis using the Analyze menu > Run Analysis
command.

If steel joists have been selected when you click this command,
only the selected joists are designed. If no joists are selected
when you click this command, all steel joists are designed.

Steel Joist Design > Interactive Steel Joist Design Com-
mand

Interactive steel joist design is a powerful feature that allows you
to review the design results for any steel joist and to interactively
change the design assumptions and immediately view the results.

Right click on a joist while the design results are displayed on it
to enter the interactive design mode and interactively design the
beam. If you are not currently displaying design results click the
Design menu > Steel Joist Design > Interactive Steel Joist De-
sign command and then right click a joist to enter the interactive
design mode for that joist.

Steel Joist Design > Display Design Info Command
Review some of the results of the composite beam design di-
rectly on the program model using the Design menu > Steel
Joist Design > Display Design Info command. The types of
things you can display are beam labels and associated design
group names; design sections together with end reactions; and
design ratio information.
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Steel Joist Design > Make Auto Select Section Null Com-
mand

The Design menu > Steel Joist Design > Make Auto Select
Section Null command is used to remove auto select section lists
from selected joists. Typically, you should remove auto select
lists from all joists near the end of the iterative design process so
that your final design iteration is performed using actual joist
sections assigned, not auto select sections.

Setting the auto select section to null does not change the current
design section for the beam.

The Make Auto Select Section Null command only works on a
selection that you make. Thus, select the elements for which you
want to make the auto select sections null before executing this
command. If you do not select any elements, this command will
not be available. Often you may want to select all elements be-
fore executing this command.

The Make Auto Select Section Null command is not active until
the first design has been run. If you have not yet run a design and
you want to remove the auto select property, use the Assign
menu > Frame/Line > Frame Section command to change the
section property.

Steel Joist Design > Change Design Section Command
After you have run a steel joist design, you may want to change
the design section property assigned to one or more joists and
then rerun the design without first rerunning the analysis. Use
the Design menu > Steel Joist Design > Change Design Sec-
tion command to change the design section property and then re-
run the design.

The Change Design Section command only works on a selec-
tion that you make. Thus you should select the elements for
which you want to change the design sections before executing
this command. If you do not select any elements, this command
will not be available.

The Change Design Section command only changes the design
section for the joist. The forces used in the design are not based
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on this new section size but are instead based on the section used
in the last analysis.

Recall, however, that the design section property is used for the
next analysis section property. Thus, changing the design section
property also changes the next analysis section property. If an
auto select section is assigned to a joist, control the section prop-
erty used for that joist in the next analysis by setting the design
section property to the desired beam size using the Change De-
sign Section command and then rerunning the analysis.

Steel Joist Design > Verify Analysis vs Design Section
Command

When the iterative design process is complete, the last used
analysis section property for a joist and the current design sec-
tion property for a joist should be the same. If this is not the case,
the joist may not have been designed for the correct forces. The
Design menu > Steel Joist Design > Verify Analysis vs Design
Section command is useful for verifying that the last used analy-
sis section and the current design section are the same for all
steel joists in the model.

When you execute the Verify Analysis vs Design Section com-
mand, the program tells you how many joists have different
analysis and design sections and then selects those joists, if you
tell it to do so. Typically you might use this command after you
have run what you believe is your last design iteration to verify
that the analysis and design properties used are consistent.

It is not necessary to make a selection before using the Verify
Analysis vs Design Section command. This command automati-
cally checks all steel joist sections.

Steel Joist Design > Verify All Members Passed Command
The Design menu > Steel Joist Design > Verify All Members
Passed command reports how many of the steel joists have
passed the design check.
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Steel Joist Design > Reset All Steel Joist Overwrites Com-
mand

The Design menu > Steel Joist Design > Reset All Steel Joist
Overwrites command resets the steel joist overwrites for all
steel joist sections back to their default values. It is not necessary
to make a selection before using the Reset All Steel Joist
Overwrites command. This command automatically applies to
all steel joist sections.

Resetting your composite beam overwrites will reduce the size
of your program database (*.edb) file.

Steel Joist Design > Delete Steel Joist Design Results
Command

The Design menu > Steel Joist Design > Delete Steel Joist De-
sign Results command deletes all of the steel joist results. It is
not necessary to make a selection before using the Delete Steel
Joist Design Results command. This command automatically
applies to all steel joist sections.

Deleting your steel joist results will reduce the size of your pro-
gram database (*.edb) file. Note that deleting your steel joist de-
sign results does not delete your current design section (next
analysis section).

Shear Wall Design Command
Clicking the Design menu > Shear Wall Design command or
the  button activates a drop-down menu of the commands that
control the Shear Wall Design postprocessor. This section de-
scribes those menu commands.

Shear Wall Design > Select Design Combo Command
Clicking the Design menu > Shear Wall Design > Select De-
sign Combo command brings up the Design Load Combinations
Selection form. In this form, review the default shear wall design
load combinations defined by the program or designate your own
design load combinations.
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In the form all of the available design load combinations are
listed in the List of Combos list box. The design load combina-
tions actually used in the design are listed in the Design Combos
list box. You can use the Add button and the Remove button to
move load combinations into and out of the Design Combos list
box. Use the Show button to see the definition of a design load
combination. All three buttons act on the highlighted design load
combination. Use the Ctrl and Shift keys to make multiple selec-
tions in this form for use with the Add and Remove buttons, if
desired.

The default shear wall design load combinations have names
such as DWAL1.

Shear Wall Design > View/Revise Pier Overwrites Command
Use the Design menu > Shear Wall Design > View/Revise Pier
Overwrites command to review or change the wall pier over-
writes. You may not need to assign any wall pier overwrites;
however, the option is available.

The wall pier design overwrites are basic properties that apply
only to the piers to which they are specifically assigned. Note
that inputting 0 for most pier overwrite items means to use the
program default value for that item.

Select one or more piers for which you want to specify over-
writes. In the overwrites form, there is a checkbox to the left of
each item. You must check this box for any item you want to
change in the overwrites. If the check box for an overwrite item
is not checked when you click the OK button to exit the over-
writes form, no changes are made to the pier overwrite item.
This is true whether you have one pier selected or multiple piers
selected.

Shear Wall Design > View/Revise Spandrel Overwrites
Command

Use the Design menu > Shear Wall Design > View/Revise
Spandrel Overwrites command to review or change the wall
spandrel overwrites. You may not need to assign any wall span-
drel overwrites; however, the option is available.
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The wall spandrel design overwrites are basic properties that ap-
ply only to the spandrels to which they are specifically assigned.
Note that inputting 0 for most spandrel overwrite items means to
use the program default value for that item.

Select one or more spandrels for which you want to specify
overwrites. In the overwrites form, there is a checkbox to the left
of each item. You must check this box for any item you want to
change in the overwrites. If the check box for an item is not
checked when you click the OK button to exit the overwrites
form, no changes are made to the item. This is true whether you
have one spandrel selected or multiple spandrels selected.

Shear Wall Design > Define General Pier Sections Com-
mand

To define a pier section with reinforcing for checking, click the
Design menu > Shear Wall Design > Define General Pier Sec-
tions command. This command allows you to define a pier sec-
tion using the Section Designer utility.

Shear Wall Design > Assign Pier Sections Type Command
Use the Design menu > Shear Wall Design > Assign Pier Sec-
tions Type command to assign a pier a section that has been de-
fined using the Section Designer utility.

Shear Wall Design > Start Design/Check of Structure Com-
mand

To run a shear wall design, click Design menu > Shear Wall
Design > Start Design/Check of Structure. This option will not
be available if you have not first run a building analysis. It will
also be unavailable if there are no piers or spandrels in the
model.

If you have selected piers and/or spandrels when you click this
command, only the selected piers and/or spandrels are designed.
If no piers and/or spandrels are selected when you click this
command, all piers and spandrels are designed.
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Shear Wall Design > Interactive Wall Design Command
Right click on a pier or spandrel while the design results are dis-
played on it to enter the interactive design mode and interac-
tively design the pier or spandrel in the Wall Design form. If you
are not currently displaying design results, click the Design
menu > Shear Wall Design > Interactive Wall Design com-
mand and then right click a pier or spandrel to enter the interac-
tive design mode for that pier or spandrel.

Shear Wall Design >  Display Design Info Command
You can review some of the results of the shear wall design di-
rectly on the program model using the Design menu > Shear
Wall Design > Display Design Info command. The types of
things you can display are reinforcing requirements, capacity ra-
tios and boundary element requirements.

Shear Wall Design > Reset All Pier/Spandrel Overwrites
The Design menu > Shear Wall Design > Reset All
Pier/Spandrel Overwrites command resets the pier and span-
drel overwrites for all pier and spandrel elements to their default
values. It is not necessary to make a selection before using the
Reset All Pier/Spandrel Overwrites command. This command
automatically applies to all pier and spandrel elements.

Shear Wall Design > Delete Wall Design Results Command
The Design menu > Shear Wall Design > Delete Wall Design
Results command deletes all of the shear wall results. It is not
necessary to make a selection before using the Delete Wall De-
sign Results command. This command automatically applies to
all pier and spandrel elements.

Deleting your shear wall results will reduce the size of your pro-
gram database (*.edb) file.
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Overwrite Frame Design Procedure Command
The Design menu > Overwrite Frame Design Procedure
command allows you to change the design postprocessor for a
frame element as follows:

 A concrete frame element can be switched between the Con-
crete Frame Design and the Null design procedures. Assign a
concrete frame element the Null (no design) design procedure
if you do not want it designed by the Concrete Frame Design
postprocessor.

 A steel frame element can be switched between the Steel
Frame Design, Composite Beam Design (if it qualifies), and
the Null design procedures. In this form, a steel frame element
qualifies for the Composite Beam Design procedure if it meets
all of the following criteria.

 The line type is Beam; that is, the line object is horizon-
tal.

 The frame element is oriented with its positive local 2-
axis in the same direction as the positive global Z-axis
(vertical upward).

 The frame element has I-section or channel section
properties.

Note that these are the same as the criteria used by the
program to determine the default design procedure, except
that the last two criteria checked when determining the de-
fault design procedure are not checked here.

Assign a steel frame element the Null (no design) design
procedure if you do not want it designed by either the Steel
Frame Design or the Composite Beam Design postproces-
sor.

When you click the Design menu > Overwrite Frame Design
Procedure command, the Overwrite Frame Design Procedure
form appears. Five options are available in this box. Depending
on the frame section assignment made to the line object, several
of the options may not be available. Following is a description of
each of the five options:

Tip:

If you do not
want a frame
element to be
designed, use
the Design
menu > Over-
write Frame
Design Proce-
dure command
to assign it a
Null (no de-
sign) design
procedure.

Tip:

Force the de-
sign procedure
to be updated
for a line object
while you are
creating your
model simply
by clicking on
the Design
menu. This
automatically
updates the
design proce-
dure for all
objects.
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 Steel Frame Design: This option is available for all line ob-
jects that have steel frame section properties. It means that the
frame section is designed using the Steel Frame Design post-
processor.

 Concrete Frame Design: This option is available for all line
objects that have concrete frame section properties. It means
that the frame section is designed using the Concrete Frame
Design postprocessor.

 Composite Beam Design: This option is available for all line
objects that have steel frame section properties and that meet
the three requirements listed earlier in this subsection for com-
posite beams (horizontal, 2-axis up, I-section or channel sec-
tion). It means that the frame section is designed using the
Composite Beam Design postprocessor.

 No Design: This option is available for all line objects. It
means that the line object is not designed by any design post-
processor. These line objects are given the Null design proce-
dure.

 Default: This option is available for all line objects. It means
that the line object is to be given the default design procedure
(postprocessor) as described in the section entitled "Default
Design Procedure Assignments" earlier in this chapter.

The design procedure for a line object is determined when the
analysis is run. It is not necessarily determined when the line
object is drawn. The design procedure is not automatically up-
dated as you modify your model. It is automatically updated
when you click on the Design menu and when you run the analy-
sis. Thus if you draw a line object and later right click on it, the
Design Procedure item in the Line Information form may be Null
or outdated. You can always update the design procedure by
clicking on the design menu.

If at any time while you are creating your model you want to
know what the current default design procedure is for a line ob-
ject, click on the Design menu then click somewhere else to
close the design menu. This automatically updates the design
procedures. Now you can see the design procedure assigned to
the line object at the current instant in time by right clicking on
the line object.
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Chapter 14

Options Menu

General
The Options menu provides you with control over some of the
basic features of this program. It also allows you to specify val-
ues for various items that, to some degree, control the look and
feel of the graphic interface as well as the behavior of the pro-
gram. This chapter describes all of the items on the Options
menu except for the Preference items related to the design post-
processors. The design postprocessors are documented sepa-
rately.

Preferences Command
The program preferences control a variety of items that affect the
look and feel of the program, the default behavior of the design
postprocessors, and how the program considers live load reduc-
tion.
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Preferences > Dimensions and Tolerances Command
The Options menu > Preferences > Dimensions/Tolerances
command brings up the Preferences form where you can specify
preferences for various dimension and tolerance items. To mod-
ify any of the preferences, enter the number desired in the edit
box next to each of these items in the Preferences form.

The following items can be specified:

 Auto Merge Tolerance: This item is used as a basic tolerance
check in the model. It is entered in length units. The program
default for this item is 0.1 inches in English units and 1 mm in
metric units. Following are some typical uses of the tolerance.

 When a point object is drawn, or generated, that is within
this distance of another point object, the drawn point ob-
ject is merged into the original point object.

 If a point object is within this distance of a line object, the
point object is assumed to be supported by the line object.
When the analysis is run, the line object is broken up at the
point object and connected to the point object. Note that
this might put a small kink in the line object if the point
object is not exactly on the line object.

 If a point object is within this distance of being in a plane,
it is assumed to be in the plane.

 Plan Fine Grid Spacing: This is the spacing of invisible grid
points that are used by the Draw menu > Snap to > Fine Grid
command and the  button. This item is entered in length

units. The program default is 48 inches in English units or 1
meter in metric units. See the subsection entitled "Snap To
Command" in Chapter 8 Draw Menu for more information.

 Plan Nudge Value: This is the distance that a nudged object
moves after you have pressed the appropriate key on the key-
board. This item is entered in length units. The program de-
fault is 48 inches in English units or 1 meter in metric units.

Note:

The auto merge
tolerance is
used internally
by the program
to determine
such things as
when two point
objects are in
the same loca-
tion or when a
point object lies
on a line object.
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See the section titled "Nudge Feature" in Chapter 5 Edit Menu
for more information.

 Screen Selection Tolerance: When clicking on an object to
select it, your mouse pointer must be within this distance of the
object to select it. This item is entered in pixels. The screen
selection tolerance has no affect on selection by windowing.
The program default is 3 pixels.

 Screen Snap To Tolerance: When using the snap features in
this program, your mouse pointer must be within this distance
of a snap location to snap to it. This item is entered in pixels.
The program default is 12 pixels.

 Screen Line Thickness: This parameter controls the thickness
of lines on the screen. All lines are affected except for the
bounding plane line. The thickness is entered in pixels. This
item has no affect on text fonts. It also does not affect the aer-
ial view. The program default is 1 pixel.

 Printer Line Thickness: This parameter controls the thickness
of lines and fonts that are output to the printer. All lines are af-
fected. The thickness is entered in pixels. The program default
is 4 pixels.

 Maximum Graphic Font Size: The default text font size used
in this program is determined based on the average story
height of your model. As you zoom into your model, the font
size becomes proportionately larger. However, the font size is
never made larger than the specified maximum graphic font
size. The maximum graphic font size is entered in points. The
program default is 12 points.

This font size does not apply to the grid line identification la-
bels; the size of the labels is determined by the specified size
of the bubble that displays the text.

 Minimum Graphic Font Size: The default text font size used
in this program is determined based on the average story
height of your model. As you zoom out of your model, the font

Note:

A pixel is the
smallest
graphic unit
(dot) that can
be displayed on
the screen. A
typical screen
resolution is
1024 pixels by
768 pixels.

Note:

In printing a
point is a unit
of type equal to
0.01384 inch or
approximately

72
1  inch.
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size becomes proportionately smaller. However, the font size
is never made smaller than the specified minimum graphic font
size. The minimum graphic font size is entered in points.  The
program default is 3 points. In some cases, you may need to
increase this minimum font size to be able to read what is on
your screen.

This font size does not apply to the grid line identification la-
bels; the size of the labels is determined by the specified size
of the bubble that displays the text.

 Pan Margin: This is the distance beyond the edge of a view
that you can pan. It is entered as a percent of the window size.
The program default is 50%. This is a recommended value.

Figure 14-1 shows an example of the pan margin. In the figure,
the window is shown shaded. Figure 14-1a shows an example
of 100% pan margin. Note that the dimension x2 is equal to
100% of x1 and similarly y2 is equal to 100% of y1. Figure
14-1b illustrates that setting the pan margin to 100% allows
you to potentially cover nine times more screen area than when
the pan margin is set to 0%. If the pan margin is set to 0%, you
cannot pan.

Note that setting the pan margin to 100% also requires nine
times more memory than when the pan margin is set to 0%,
because nine times more screen area must be saved in mem-
ory! Thus, you need to be very careful with this control or you

b) Illustration showing that a 100%
pan margin covers nine times the
area of the window

a) Illustration showing a 100% pan
margin

x1 x2

y 1
y 2

Edge of
window

Edge of pan
margin

Figure 14-1:
Example of pan
margin

Tip:

Do not make
your pan mar-
gin too large. It
will eat up all
of your com-
puter's memory.
The default
value of 50% is
normally ade-
quate.
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may use up all of your available memory and have a difficult
time getting your program model to run.

See the subsection titled "Pan Feature" in Chapter 6 View
Menu for additional information on panning.

 Auto Zoom Step: This is the size of the step used for the View
menu > Zoom In One Step command and the View menu >
Zoom Out One Step command as well as their associated
toolbar buttons. This parameter is entered in percent. The
magnification of all objects in a view is increased or decreased
by this percentage. The program default is 10%.

See the subsection entitled "Zoom Command" in Chapter 6
View Menu for additional information on the auto zoom step.

 Shrink Factor: When you shrink the objects in a view using
the Shrink Object Toggle button , all line objects are

shrunken by this specified percentage. The program default for
this item is 70%. Note that you can also shrink objects by se-
lecting the View menu > Set Building View Options com-
mand, or the  button, and checking the Object Shrink

check box in the Special Effects area of the Set Building View
Options form.

Typically, area objects are not shrunken by this percentage. In-
stead, they are shrunken by a set number of pixels that is built
into the program. In the unusual case where shrinking the area
object by the set number of pixels causes it to become an ille-
gal object (because an edge has zero length), the area object
reverts to using the percentage specified here.

The Reset to Defaults resets the entire dimension and tolerance
values to their program default values.

Preferences > Output Decimals Command
Click the Options menu > Preferences > Output Decimals
command to bring up the Output Decimals Preferences form

Note:

The shrink
factor typically
only applies to
line objects, not
area objects.
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where you can specify preferences for the number of decimal
places desired in the numeric output for various items. To mod-
ify any of the output decimal preferences, enter the number of
decimal places desired in the edit box next to each of the items in
the Preferences form.

You can control the number of decimal places for the following
types of items:

 Displacements: These are translational displacements that are
reported in the current length units (e.g., inches). The program
default for displacements is four decimal places.

 Rotations: These are output rotations that are always reported
in radians. The program default for rotations is five decimal
places.

 Forces: These are reported in the current force units (e.g.,
kips). The program default for forces is two decimal places.

 Moments: These are reported in the current force-length units
(e.g., kip-inch). The program default for moments is three
decimal places.

 Forces per length: These are reported in the current
force/length units (e.g., kip/inch). The program default for
forces per length is three decimal places.

 Moments per length: These are reported in the current force-
length/length units (e.g., kip-inch/inch). The program default
for moments per length is three decimal places.

 Stresses: These are reported in the current force/length2 units
(e.g., kip/inch2 also known as ksi). The program default for
stresses is three decimal places.

 Lengths: These are reported in the current length units (e.g.,
inches). The program default for lengths is three decimal
places.
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 Rebar Areas: These are reported in the current length2 units
(e.g., inches2). The program default for rebar areas is three
decimal places.

 Dimension Line Text: Options are available to report the di-
mensions decimal form in the current length units (e.g., inches)
or in feet and inches. If you elect to report the dimensions in
feet and inches, the further option of reporting to either the
nearest 1/8 inch or 1/16 inch also is available. The program de-
fault for dimension line text is feet and inches if your database
units are English or in decimal form in the current units to two
decimal places if your database units are Metric.

The Reset to Defaults button resets all of the output decimal
values to their program default values. It also sets the dimension
line text to decimal form, not feet and inches.

If the ETABS defaults do not work well for the units that you
typically use, set your own output decimal preferences in an .edb
file that you use for model initialization. Note that if you do this,
the Reset to Defaults button resets the values to the built-in pro-
gram defaults, not the values that were in your initialization file.
See the section entitled "New Model Command" in Chapter 4 for
more information on the initialization file.

Preferences > Steel Frame Design Command
Clicking the Options menu > Preferences > Steel Frame De-
sign command brings up the Steel Frame Design Preferences
form where you can set the preferences. Descriptions of the pref-
erences and their associated defaults are provided in the separate
Steel Frame Design Manual.

Preferences > Concrete Frame Design Command
Clicking the Options menu > Preferences > Concrete Frame
Design command brings up the Concrete Frame Design Prefer-
ences form where you can set the preferences. Descriptions of
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the preferences and their associated defaults are provided in the
separate Concrete Frame Design Manual.

Preferences > Composite Beam Design Command
Clicking the Options > Preferences > Composite Beam Design
command brings up the Composite beam Preferences where you
can specify preferences. Descriptions of the preferences and their
associated defaults are provided in the separate Composite Beam
Design Manual.

Preferences > Shear Wall Design Command
Clicking the Options > Preferences > Shear Wall Design
command brings up the Wall Pier/Spandrel Design Preferences
form where you can set your preferences. Descriptions of the
preferences and their associated defaults are provided in the
separate Shear Wall Design Manual.

Preferences > Reinforcement Bar Sizes Command
You can define the reinforcing bar (rebar) ID,  Bar Area, and Bar
Diameter in the Reinforcing Bar Sizes form. To access this form,
click the Options menu > Preferences > Reinforcement Bar
Sizes command.

The program default reinforcing bars include the following:

 ASTM standard bar sizes: #2, #3, #4, #5, #6, #7, #8, #9, #10,
#11, #14, and #18.

 ASTM metric bar sizes: 10M, 15M, 20M, 25M, 30M, 35M,
45M and 55M.

 European (metric) bar sizes: 6φ, 8φ, 10φ, 12φ, 14φ, 16φ, 20φ,
25φ, 26φ and 28φ.

You can change the bar ID, area or diameter for any of these re-
inforcing bars, and you can Add additional reinforcing bar defi-
nitions or Modify existing definitions. You can also Delete rein-
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forcing bar definitions, including the defaults, as long as they are
not being used somewhere by the program.

Reinforcing Bar Sizes Form
The following bullet items describe how to modify the bar sizes
shown in the Reinforcing Bar Sizes form.

 To add a new bar: Type the bar ID, area and diameter in the
Bar ID, Bar Area and Bar Diameter edit boxes located at the
top of the Rebar area. Be sure to enter the area and the diame-
ter in the current units. Click the Add New Bar Size button. If
desired, make other additions, changes or deletions in the
form. Click the OK button.

 To change a bar ID, area or diameter: Click on the bar ID
that you want to change in the Rebar area of the form. Note
that the data for the bar is highlighted and that it appears in the
edit boxes at the top of the Rebar area. Modify the bar ID, area
and diameter as desired in the Bar ID, Bar Area and Bar Di-
ameter edit boxes. Be sure to enter the area and the diameter in
the current units. Click the Change Bar Size button. If desired,
make other additions, changes or deletions in the form. Click
the OK button.

 To delete a bar: Click on the bar ID that you want to delete in
the Rebar area of the form. Note that the data for the bar is
highlighted and that it appears in the edit boxes at the top of
the Rebar area. Click the Delete Bar button. If desired, make
other additions, changes or deletions in the form. Click the OK
button.

The Reset to Defaults button resets all of the area and diameter
values for the program default rebar to their default values. It
also adds back in any default rebar sizes that were deleted. This
button has no affect on other user-defined rebar you may have
added.

Note:

You can define
your own rebar
sizes if desired.
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Preferences > Live Load Reduction Command
Clicking the Options menu > Preferences > Live Load Reduc-
tion command brings up the Live Load Reduction Factor form
where you can specify your live load reduction preferences. Note
that for live load to be reduced, it must be defined as a reducible
type live load. See the section entitled "Static Load Cases Com-
mand" in Chapter 7 Define Menu for more information. The
following subsections describe the four areas in this form. Do
not overlook the upcoming subsection entitled "Application Area
in the Live Load Reduction Factor Form" that contains crucial
information about the application of live load reduction in this
program.
Note:

Live load re-
duction does
not apply to
floor and ramp-
type area ob-
jects.
4 - 10 Preferences Command

Important Note: This program applies live load reduction to line
objects (frames and links) and wall-type area objects only. It
does not apply live load reduction to floor-type and ramp-type
area objects; that is, the RLLF factor described in the subsequent
subsection en titled "Live Load Reduction Formulas" is always 1
for floor-type and ramp-type area objects.

Method Area of the Live Load Reduction Factor Form
In the Method area of the Live Load Reduction Factor form,
choose the formula or method, if any, to be used for live load re-
duction. The options available in the Methods area of the form
are described in the following bullets.

 No Live Load Reduction - In this case, no live load reduction
is performed, even if you have defined static load cases as re-
ducible live load type load cases.

 Tributary Area (UBC 97) - The tributary area live load re-
duction method is based on Section 1607.5 of the 1997 UBC.
The basic formula used is shown in Equation 14-1.

RLLF = 
100

)150(08.00.1 −− A
Eqn. 14-1

where,

Tip:

You can over-
write the RLLF
factor on an
element-by-
element basis in
the design
overwrites.
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RLLF = The reduced live load factor for an element,
unitless. The RLLF is multiplied times the unre-
duced live load to get the reduced live load.

A = Tributary area for the element, ft2. If A does not
exceed 150 ft2 , then no live load reduction is used.
See the subsequent subsection entitled "Tributary
Area" for more information.

The RLLF factor can not be less than the minimum factor de-
scribed in the section below titled "Minimum Factor Area in
the Live Load Reduction Factor Form."

Note that no check is preformed to limit the RLLF based on
Equation 7-2 in Section 1607.5 of the 1997 UBC.

 Influence Area - The influence area live load reduction
method is based on Section 4.8.1 of the ASCE 7-95 Standard.
The basic formula used is shown in Equation 14-2.

RLLF = 









+

IA

15
0.25 Eqn. 14-2

where,

RLLF = The reduced live load factor for an element,
unitless. The RLLF is multiplied times the unre-
duced live load to get the reduced live load.

AI = Influence area for the element, ft2. The influence
area for a column is taken as four times the tribu-
tary area. The influence area for a beam, brace or
wall is taken as two times the tributary area. See
the subsequent subsection entitled "Tributary
Area" for more information.

The RLLF factor is limited to a minimum value as described in
the section below titled "Minimum Factor Area in the Live
Load Reduction Factor Form."
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 User-Defined Live Load Reduction - The user-defined live
load reduction method is similar to that described in Section
1607.5 of the 1997 UBC. The basic formula used is shown in
Equation 14-3.

RLLF = 
100

)150(100 −− Ar
Eqn. 14-3

where,

RLLF = The reduced live load factor for an element,
unitless. The RLLF is multiplied times the unre-
duced live load to get the reduced live load.

r = Rate of live load reduction, 1/length2. The default
value is 0.08 in 1/ft2 units.

A = Tributary area for the element or reaction, length2.
If A does not exceed Amin then no live load reduc-
tion is used. See the subsection below titled
"Tributary Area" for more information.

Amin = User specified minimum tributary area for the
element or reaction, length2. The default for this
item is 150 ft2.

The RLLF factor is limited to a minimum value as described in
the section below titled "Minimum Factor Area in the Live
Load Reduction Factor Form."

Minimum Factor Area of the Live Load Reduction Factor Form
Two minimum reduced live load factors (RLLF in the subsec-
tions above) are specified. One applies to elements receiving
load from one story level only and the other applies to elements
receiving load from more than one story level. Default values are
provided for these minimum reduced live load factors or you can
specify your own values.

The default values for the minimum reduced live load factors for
the three different live load reduction methods are:

Note:

Live loads are
not reduced for
basic analysis
output. Re-
duced live
loads are only
used for deter-
mining design
forces in the
design postpro-
cessors.
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 Tributary area method: 0.6 for elements with load from only
one story level (Single Story) and 0.4 for elements with load
from more than one story level (Multi Story).

 Influence area method: 0.5 for elements with load from only
one story level (Single Story) and 0.4 for elements with load
from more than one story level (Multi Story).

 User-defined method: 0.6 for elements with load from only
one story level (Single Story) and 0.4 for elements with load
from more than one story level (Multi Story).

Application Area of the Live Load Reduction Factor Form
Important Note: In this program, the live load is currently only
reduced for design forces that are used in the program design
postprocessors. Live loads are not reduced in the basic analysis
output, even if the live load is specified as a reducible-type live
load when the static load case is defined and live load reduction
is enabled in the preferences. Thus, when live load reduction is
enabled, it is possible that you will see different live load forces
for the exact same item in the basic analysis output and the de-
sign output because the live load is only reduced in the design
output. Again, in the analysis output, it is unreduced.

Application to Columns Area of the Live Load Reduction Factor
Form

For columns, the live load reduction can be specified to apply to
the axial load only or to all force components. By default, the
program assumes only the axial load component of columns re-
ceives the specified live load reduction. This is useful when you
want to reduce the axial live load but not the moment due to live
load in the column.

Note that live load reduction can be overwritten on an element-
by-element basis in each of the design postprocessors.

Note:

For columns,
the live load
reduction can
be specified to
apply to the
axial load only
or to all force
components.
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Colors
You can control the colors used for display of various items and
for color-coding of output stress ratio ranges by using the Op-
tions menu > Colors command. You can separately specify col-
ors to be used for screen display, color printer graphical output
and non-color printer graphical output. The following two sub-
sections describe display colors and output colors.
Note:

The color of
Null-type area
and line objects
is controlled by
the Background
item.
4 - 14 Colors

Colors > Display Command
Click the Options menu > Colors > Display command to bring
up the Assign Display Colors form where you can set the display
colors for various items in your model. The following bullet
items describe the areas in that form.

 Click to Change Color: In this area you can left click on any
of the color boxes to change the display color for the associ-
ated item. Following is a list of items for which you can
change the display color.

 Columns: These are column-type line objects.

 Beams: These are beam-type line objects.

 Braces: These are brace-type line objects.

 Links: These are the color of the link element symbol.
When a link property is assigned to a line object, the entire
line object is not shown in this color. Only the link element
symbol attached to the line object is in this color.

 Walls: These are wall-type area objects. The color applies
to the object edges and fill color.

 Floors: These are floor-type area objects. The color ap-
plies to the object edges and fill color.

 Ramps: These are wall-type area objects. The color ap-
plies to the object edges and fill color.

Note:

The color of the
bounding plane
line (cyan) is
built into the
program. You
cannot change
this. You can
however use the
View menu >
Set Building
View Options
command, or
the Set Build-
ing View Op-
tions button on
the main (top)
toolbar, to turn
off the bound-
ing plane line.
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 Openings: These are area objects that are designated as
openings. The color applies to the object edges and cross-
ing lines. Note that openings are never filled, even when
the Object Fill box is checked in the Set Building View
Options form.

 Springs: This is the color of the spring symbol. This item
also controls the color of restraints (supports).

 Text: This is the color of all of the text, including grid line
IDs. It also controls the color of dimension lines and the
global axes. In addition, it controls the color of dots used
to show point objects when in a "Shrink Object" mode,
end releases and nonlinear hinges. It also controls the color
of the thickened line showing end offsets along the length
of a frame member.

 Grid Lines: This is the default color of grid lines and grid
line bubbles. It can be overwritten on a grid line by grid
line basis using the Edit menu > Edit Grid command. See
the section entitled "Edit Grid Data Command" in Chapter
5 Edit Menu for more information.

This item also controls the color of reference planes and
reference lines.

 Background: This is the background color. This item in-
directly controls the color of null-type line objects, null-
type area objects, and diaphragm extent lines because they
are displayed in the opposite color from the background
color.

 Steel Dsgn:  This is the color assigned to members desig-
nated to be designed as steel frame  members.

 Comp Dsgn:  This is the color assigned to members des-
ignated to be designed as Composite Steel Beams.

 Conc Dsgn:  This is the color assigned to members desig-
nated to be designed as Concrete Frame members.
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 Typ Member:  This is the color assigned to members on a
level that has been designated as typical to another level.

 Device Type: Here you indicate whether the colors you are
specifying are for screen display, output to a non-color printer
or output to a color printer. Note that you can specify different
display colors for each of these three device types.

 Darkness: This item controls the variation of color (intensity
of shading) when extruded shapes are displayed. The darkness
value can range from 0 to 1. A darkness value of 0 means there
is no variation of color and the extruded shape will not really
be distinguishable. A darkness value of 1 gives the maximum
variation of color. The default value is 0.3. This value works
well in most instances.

Note that you can click the View menu > Set Building View
Options command, or the Set Building View Options 

button to access the Set Building View Options form and tog-
gle the display of extruded shapes on or off.

 Reset Defaults button: This button resets the colors to the
built-in program default colors. The Reset Defaults button not
only resets the colors for the currently chosen device type, it
resets the colors for all three device types, regardless of which
one is currently chosen.

Colors > Output Command
Click the Options menu > Colors > Output command to bring
up the Assign Output Colors form where you can set the display
colors for various output items. The following bullet items de-
scribe the areas in this form.

 Contours: In this area, you can specify ten different colors
that are used to display shell stress contours.

In addition, some of the colors in the Contours area are used to
show the hinge state (B, IO, LS, CP, C, D or E) when display-
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ing the deformed shape of a static nonlinear analysis. The color
boxes used for this are shown in the sketch to the left.

 Steel Ratios: In this area, you can specify the colors that frame
elements are displayed in when you display results from either
the Steel Frame Design or the Composite Beam Design post-
processor on the model. You also specify the range of values
to which the colors apply. Note the following about the steel
ratios:

 The five values used to define the stress ranges must al-
ways be input in increasing numerical order. The largest
value defining the range does not necessarily have to be
1.0. It can be larger or smaller.

 Any frame element that does not have its Design Proce-
dure the same as the design postprocessor that is currently
displaying the results is shown in a color that is opposite of
the background color.

 Any frame element with the correct Design Procedure that
has not yet been designed is displayed in the "Not Yet De-
signed" color.

In some cases, a frame element with the correct Design
Procedure may not have a stress ratio calculated when it is
run through the design postprocessor. One example where
this will happen is in the Steel Frame Design postprocessor
when the axial stress for the element exceeds the Euler
buckling stress. In such cases, the element is displayed in
the color associated with the highest range of stress values
(i.e., the color of the fifth box down counting from the
top).

 Diagram Fill: In this area you specify the colors used for fill-
ing force diagrams for frame elements. Three colors are speci-
fied here. They are colors for positive values, colors for nega-
tive values, and colors for ranges of values.

B
IO
LS
CP
C
D
E
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The positive and negative colors are simply based on the sign
of the output force value (axial force, shear, torsion or mo-
ment). The range color is used when plotting the results of
multi-valued load combinations. Consider the filled moment
diagrams, for a beam element in a rigid frame, that are shown
in Figure 14-2. (Note that these diagrams are plotted with
positive values on the tension side of the element.)

Figure 14-2a shows the moment diagram for a load case desig-
nated 1, which is gravity load. Figure 14-2b shows the moment
diagram for a load case designated 2 which is a lateral load.
Figure 14-2c shows the moment diagram for a load combina-
tion designated 1. This load combination is created as an add-
type load combination and it adds the results of load case 1 and
load case 2. Note how the fill colors are different for positive
and negative moment in these moment diagrams.

Figure 14-2d shows the moment diagram for a load combina-
tion designated 2. This load combination is created as an en-
velope-type load combination. The combination shows the en-
velope of load case 1 and load combination 1; that is, it shows
the range of values, from maximum to minimum, of all load
cases and load combinations that are included in the envelope-
type load combination. As shown in Figure 14-2d, this range is
displayed in a different color that you can specify.

 Device Type: Here you indicate whether the colors you are
specifying are for screen display, output to a non-color printer
or output to a color printer. Note that you can specify different
display colors for each of these three device types.
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 Reset to Defaults button: This button resets the colors to the
built-in program default colors. The Reset to Defaults button
not only resets the colors for the currently chosen device type,
it resets the colors for all three device types, regardless of
which one is currently chosen.

Other Option Menu Commands
This section describes the other option items that are available on
the Options menu.

a) Moment Diagram
for Load Case 1

b) Moment Diagram
for Load Case 2

c) Moment Diagram for
Load Combination 1
(Add-type load combination that
includes load cases 1 and 2)

d) Moment Diagram for
Load Combination 2
(Envelope-type load combination
that includes load cases 1 and load
combination 1)

Neg.

Neg.

Neg.

Neg.

Pos.

Pos.

Neg.

Pos.

Pos.
Neg. Neg.

Range

Range

Figure 14-2:
Example of diagram
fill colors where the
diagrams are plotted
with positive values
on the tension side of
the element
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Windows Command
Display your model in from one to four windows. A different
view can be displayed in each window. Use the Options menu >
Windows command at any time to specify the number of win-
dows that you want to use.

As a shortcut if you want to close a window you can click on the
X in the upper right hand corner of the window. The remaining
windows will automatically resize. You can not use this method
to close the last window.

Show Tips at Startup Command
When you first open the program, the Startup Tips may appear.
You can toggle whether these tips appear on and off using the
Options menu > Show Tips at Startup command.

Note that the option you choose for this is saved in the
ETABS.ini file in your Windows Or WinNT directory. If this file
is deleted or moved, your Tips option is lost and the program de-
faults back to showing the tips.

Important Note: When you first start the graphical interface the
Startup Tips appear. You do not have to click the OK button as-
sociated with the tip or click the "X" button in the upper right
hand corner of the tip window to continue. Simply left clicking
anywhere in the entire program window closes the Tip of the
Day window. For example, as soon as you start the graphical in-
terface, immediately click on the file menu and the Startup Tips
window will close and the File menu will appear.

Show Bounding Plane Command
You can toggle the bounding plane feature on and off using the
Options menu > Show Bounding Plane command. When this
feature is active, a cyan line appears in some views showing you
the location of a currently active plan or elevation view. For ex-
ample, if a plan view is currently active and a three-dimensional
view is also showing, then a cyan bounding plane appears in the

Tip:

You can display
your model in
from one to
four windows.
Each window
can display a
completely dif-
ferent view.
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three-dimensional view around the story level associated with
the plan view. As a second example, if an elevation (or devel-
oped elevation) view is currently active and a plan view is also
showing, a cyan line appears in the plan view showing the loca-
tion of the elevation. Table 14-1 lists the circumstances where
the bounding plane (line) appears.

Table 14-1: Circumstances where bounding plane (line)
appears

Window You Are
Working In (i.e.,
Active Window)

Another Visible
Window

Bounding Plane
or Line Visible?

Plan No

Elevation NoPlan

3D Yes

Plan Yes

Elevation NoElevation

3D Yes

Plan No

Elevation No3D

3D No

Moment Diagrams on Tension Side Command
You have the option of plotting moment diagrams for frame
elements with positive values on the tension side of the member
or on the compression side of the member. Click the Options
menu > Moment Diagrams on Tension Side command to tog-
gle this option one way or the other. See Figure 14-2 earlier in
this chapter for an example of moment diagrams plotted on the
tension side of a member.

Sound Command
Click the Options menu > Sound command to toggle the sound
produced by the program when it is displaying animation of de-
formed shapes and mode shapes on or off.
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Lock Model Command
Click the Options menu > Lock Model command or the
Lock/Unlock Model button  to toggle the model between

locked and unlocked. When the model is locked, you cannot
make any changes to it that will affect the analysis results, except
as noted below.

Exception: While the model is locked, you can run one or
more nonlinear static analyses.

When you run an analysis, the program automatically locks the
model. This feature prevents changes to the model such that your
analysis results would be invalidated. After you have run an
analysis, if you want to make changes to your model, first unlock
it. Unlocking the model deletes all of your analysis results. The
results are deleted because, after you make changes to the model,
the analysis results are no longer valid.

If you want to save analysis results and make changes to your
model, use the File menu > Save As command to save the file
with a new name after you have run the analysis but before you
make any changes (i.e., unlock the model). You can then make
changes to the file with the new name. The original file remains
with its results.

Show Aerial View Window Command
Click the Options menu > Show Aerial View Window com-
mand to toggle the aerial view window on or off. You may find
the aerial view to be a convenient tool for quickly zooming into
various areas of your model. See the section entitled "The Aerial
View" in Chapter 1 Graphical User Interface for more informa-
tion.

Show Floating Property Window Command
Click the Options menu > Show Floating Property Window
command to toggle the floating property window on or off. The

Note:

The program
automatically
locks your
model when
you run an
analysis.
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floating property window appears when you are drawing area
and/or line objects. See Chapter 8 Draw Menu for more infor-
mation.

Show Crosshairs Command
This toggle switch option controls whether crosshairs are visible
when you are drawing objects in plan and elevation views. In
plan view, the crosshairs are always oriented in the global X and
Y directions. In elevation view, the crosshairs are always ori-
ented in the horizontal and vertical directions.

Reset Toolbars Command
This option resets the default toolbars.
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